Troubleshooting Wlan 5 Ghz

  • 7 Antworten
  • Neuester Beitrag
Diskutiere Troubleshooting Wlan 5 Ghz im Anleitungen für LG Optimus 4X HD im Bereich Root / Custom-ROMs / Modding für LG Optimus 4X HD.
Status
Für weitere Antworten geschlossen.
S

stevehh

Stammgast
Hier mal eine Lösung für das Problem: 5 Ghz Wlan Netz wird angezeigt, kann aber keine Verbindung herstellen.
Nach einigen Sekunden wird das Netz außer Reichweite angezeigt für einige Sekunden , dann wiederholt sich das ganze. 2,4 Ghz Netz verbindet sich einwandfrei.

Mein Router Asus RT N66U, Mit einem Netgear Router das gleiche Problem.

Ursache: Diese Dualband Router kommen anscheinend nicht damit klar, das auf beiden Netzen die gleiche IPAdresse des Handys verwendet wird.Anscheinend wird dann das 2,4 GHz vorrangig behandelt.

Abhilfe: 1 Schritt. im Handy unter Wlan erweitere Einstellungen nur die Frequenz auswählen die man nutzen möchte 5 Ghz, auf keinen Fall auf Automatik stellen.Gespeicherte netze löschen.

2 Schritt: Den Router Hardresetten mit Taste.

Aus- Einschalten hilft nicht, Werkeinstellungen über Oberfläche anwählen hilft auch nicht, Firmwareaktualisierung hilft auch nicht, WPS hilft auch nicht, Wifi direkt auch nicht, zumindest beim ASUS Router.

Dann den Router bzw Wlan neu einrichten.

3. Schritt: Netzwerk im handy auswählen und Zugangsdaten eingeben , verbinden. Danach kann man wieder beide Netze auf Automatik stellen .Fertig

Achtung Reihenfolge unbedingt beachten.

Achtung man hat das Problem sofort wieder sobald man sich nur einmal in das 2,4 Ghz Netz einwählt. Daran sollte man denken nach Firmwareaktualisierungen, Modroms oder Resetten des Handys.

Die Schuld scheint bei den Routerherstellern zu liegen, wenn es denn nicht irgendeine Norm gibt, die dem Handyhersteller vorschreibt verschiedene IP für verschiedene Netze zu nutzen.
Warum sich dieser Fehler aber so tief in dem Router verankert, das es sich nur durch einen Hardreset lösen lässt, erschließt sich mir aber nicht.

Ergänzung: Das Problem wird wohl doch eher durch die gleiche MAC adresse ausglöst da diese ja nur einmalig sein soll, ist also wahrscheinblich ein Sicherheitsproblem.

Wie sich herausstellte hat der Router zusätzlich doch noch einen Hardwaredefekt, Wärmefehler. 5Ghz Bereich funktioniert jetzt nur noch für kurze Zeit, nach längerem Ausschalten, wird aber trotzdem im Empfänger voll und sogar als verbunden angezeigt, solange man sich nicht ausloggt, nach ausloggen wieder gleicher Effekt wie oben beschrieben. Das fiel mir vorher nicht auf, weil ich den Router nicht im Dauerbetrieb nutze sondern nur bei Bedarf einschalte.
 
Zuletzt bearbeitet:
M

mittelhessen

Lexikon
stevehh schrieb:
Ursache: Diese Dualband Router kommen anscheinend nicht damit klar, das auf beiden Netzen die gleiche IPAdresse des Handys verwendet wird.Anscheinend wird dann das 2,4 GHz vorrangig behandelt.
Glaub ich kaum! IP arbeitet doch auf der Vermittlungsschicht und hat nichts mit dem Physical Layer (2,4 GHz oder 5 GHz) zu tun.

stevehh schrieb:
Die Schuld scheint bei den Routerherstellern zu liegen, wenn es denn nicht irgendeine Norm gibt, die dem Handyhersteller vorschreibt verschiedene IP für verschiedene Netze zu nutzen.
Auch hier: die Problematik hat nichts mit IP zu tun.

stevehh schrieb:
Ergänzung: Das Problem wird wohl doch eher durch die gleiche MAC adresse ausglöst da diese ja nur einmalig sein soll, ist also wahrscheinblich ein Sicherheitsproblem.
Welche MAC-Adresse soll denn gleich sein? Normal müssten seitens des Routers sowohl das 2,4 GHz-Band als auch das 5 GHz-Band unterschiedliche MAC-Adressen haben. Immerhin handelt es sich um zwei unterschiedliche Sende-/Empfangsmodule. Wo siehst du da also das Problem?
 
S

stevehh

Stammgast
das ist ein alter thread an anderer Stelle habe ich erwähnt das ich das prob nur mit einem Handy habe, bei dem anderen kein Prob(identische Softwarebestückung), also liegt der Fehler Hardwaremäßig offensichtlich am Handy aber mit der hier angebenen Anleitung funktioniert es komischerweise für kurze Zeit.
An anderen 5Ghz Routern auch. Das Handy wurde in der Zwischenzeit mehrmals kpl platt (Formatierung vollständig)gemacht also kann es auch kein Softwareproblem des Handys sein.
Aber 2,4 hat im allgemeinen eine etwas höhere Reichweite (Die ich wegen 3 Wänden benötige)daher ist mir das inzwischen egal.
Mit dem anderen hab ich übrigens auch ein hardwareproblem bezüglich GPS Empfang.
Scheint mit der Qualität bzw Endkontrolle bei LG daher nicht so toll zu sein, da ich auch nicht der einzige mit diesen Problemen bin, aber ist eh inzwischen alt also egal.
Samsung werd ich als Nachfolger eher in Betracht ziehen, allein schon wegen höherer Verbreitung und hoffentlich besserer Qualität und noch einigen anderen Gründen.
Aber trotzdem nett das nach 9 Monaten und über 1100 Hits noch eine Antwort kommt löl.

Zu deiner Antwort: ich vermute inzwischen eher ein Kommunikationsproblem im Sicherheitsprotokoll, als logischer schluß wegen der oben angebenen Vergleichsmöglichkeiten mit anderen Handy bzw Routern und das es nach Hardreset der router kurze Zeit läuft.
 
Zuletzt bearbeitet:
M

mittelhessen

Lexikon
Ich kann deine Schlussfolgerungen leider immer wieder aufs Neue nicht ganz nachvollziehen. Es ist ja immer schön, wenn man versucht ein Problem einzugenzen, aber irgendwie kommts mir so vor als möchtest du dir gerne die Antworten alle selber geben und begründest bestimmte Sachverhalten deshalb ohne fundierte Kenntnisse. Z. B.:

stevehh schrieb:
Das Handy wurde in der Zwischenzeit mehrmals kpl platt (Formatierung vollständig)gemacht also kann es auch kein Softwareproblem des Handys sein.
Wenn es ein Bug in der Firmware ist oder an einer Einstellung liegt, die immer wieder falsch vorgenommen wird, kannst du das Handy tausens Mal platt machen und es wird trotzdem ein Softwareproblem bleiben.

stevehh schrieb:
Zu deiner Antwort: ich vermute inzwischen eher ein Kommunikationsproblem im Sicherheitsprotokoll, als logischer schluß wegen der oben angebenen Vergleichsmöglichkeiten mit anderen Handy bzw Routern und das es nach Hardreset der router kurze Zeit läuft.
Auch hier wieder: welches Sicherheitsprotokoll meinst du und was für ein Kommunikationsproblem innerhalb des Protokolls? Logisch ist daran erstmal überhaupt nichts. :-D
 
S

stevehh

Stammgast
1. Der Thread wurde Geschlossen da veraltet.
2 . Hast du andere Lösungsansätze? bisher ja nicht.
3. mehrmals Plattmachen bedeutet mit verschiedenen "Firmwaren" und verschiedenen Einstellungen wobei es bei Wlan davon nicht sehr viele gibt.
4. Habe ich wenn du es gelesen hättest 2 identische Handys, und dadurch festgestellt das es sich eindeutig um einen Hardwarefehler handelt was du anscheinend auch nicht gelesen hast und das es ein sicherheitssprotokoll fehler ist, ist eine annahme die aber völlig nebensächlich ist da es sich um einen Hardwarefehler handelt, weil es nach Hardreset(nicht Softreset!) des Routers eine zeitlang funktioniert wie oben auch schon geschrieben.

5. Das du diesen relativ komplizierten Sachverhalt nicht nachvollziehen kannst ohne diesen Fehler selbst zu haben tut mir zwar leid aber muß mich ja auch nicht weiter interessieren, da du offensichtlich eher an Kritik interessiert bist als hier evtl andere Lösungsansätze außer deinen allgemeingültigen für die Leute bereit zu stellen.

6. Habe ich dieses "Tut" hier stehen lassen weil es Leuten eventuell helfen kann den Fehler oder andere Fehler weiter einzugrenzen, da man auf eine Hardeset des Routers erstmal kommen muß.
 
Zuletzt bearbeitet:
M

mittelhessen

Lexikon
stevehh schrieb:
1. Der Thread wurde Geschlossen da veraltet.
Scheinbar ist er nicht geschlossen. Wie sonst könnte ich hier weiter antworten?

stevehh schrieb:
2 . Hast du andere Lösungsansätze? bisher ja nicht.
Ich habe genügend Rückfragen gestellt um das Problem einzugrenzen. So z. B. zu den MAC-Adressen, zu dem von dir erwähnten Sicherheitsproblem, Sicherheitsprotokoll, Kommunikationsproblem usw. Diese blieben bisher alle unbeantwortet!

stevehh schrieb:
3. mehrmals Plattmachen bedeutet mit verschiedenen "Firmwaren" und verschiedenen Einstellungen wobei es bei Wlan davon nicht sehr viele gibt.
Dass du verschiedene Firmware ausprobiert hast, hast du noch gar nicht erwähnt. Das hättest du an gleicher Stelle tun können, damit man mehr weiß. Im Prinzip kannst du dir dabei aber sehr wohl Probleme einholen, indem du z. B. ungeeignete Radios flasht. Aber das wirst du ja sicher auch wissen. :-D

stevehh schrieb:
... das es ein sicherheitssprotokoll fehler ist, ist eine annahme die aber völlig nebensächlich ist da es sich um einen Hardwarefehler handelt, ...
Was denn nun? Einmal so und einmal so? :-D Aber gerne wiederholen ich noch mal die Rückfrage: was meinst du mit Sicherheits-Protokollfehler und welches Sicherheitsprotokoll meinst du?

stevehh schrieb:
... da du offensichtlich eher an Kritik interessiert bist als hier evtl andere Lösungsansätze außer deinen allgemeingültigen für die Leute bereit zu stellen.
Bisher hast du keinen einzigen anderen Beitrag auf deinen Thread bekommen. Ich bemühe mich, dir weiterzuhelfen, auch wenn das deiner Meinung nach nur "allgemeingültig" ist. Wenn du aber nicht bereit bist, ein kleines Stück entgegen zu kommen, indem du beispielsweise die Rückfragen beantworten kannst und sowieso (scheinbar :-D) alles selber weißt und dir gerne aussuchen möchtest, wer dir antwortet, sag ich mal, dass ich dir an dieser Stelle nicht mehr weiterhelfen werde.
 
Zuletzt bearbeitet:
S

stevehh

Stammgast
Da du diesen Thread nicht verstehen willst bring ich es nochmal auf einen leicht verständlichen Punkt.
Es handelt sich hier um einen Hardwarefehler der sich aber wie ein Softwarefehler darstellt, in dem man ohne zweites Handy zum Vergleich, etliche sinnlose Stunden investieren kann, und daher wurde er nicht gelöscht um anderen Leuten mit identischen Fehler Zeit zu sparen, da in diesen speziellen Fall nur Rep bzw. Umtausch hilft.

Es gibt aber auch ein praktisch identischenes Fehlersymptom bei dem deine allgemeinen Ratschläge, die hier im Forum aber an anderer Stelle schon stehen, helfen ( Doppelthreads werden hier aber gnadenlos geahndet löl und dank an Afro). Daher kann diese Anleitung hilfreich sein diesen Unterschied fest zu stellen.

Das Hauptproblem dieses Handys (wahrscheinlich auch anderer)liegt darin, das es bei Wlanverbíndungsprobs
keine eindeutigen Fehlerrückmeldungen geben kann und nur das entsprechende Netz aus der Empfangsliste kickt und dann versucht sich neu zu verbinden.

Und nun bin ich gespannt ob du es hier auch noch schaffst Sätze aus dem Zusammenhang zu reißen.

PS:: also nochmal für alle dieses kleine Tut ist nur für die gedacht die mit den allgemeinen Standardtipps nicht weitergekommen sind und kein zweites Handy haben(welches ich bei erstellung dieses Threads auch noch nicht besaß), um festzustellen ob es sich um einen Hardwarefehler handelt.
:: 2.4 Ghz deaktivieren im Handy -> Hardreset Router-> 5Ghz Netz verbindet sich für Minuten bis Stunden-> dann gar nicht mehr bis zum erneuten Hardreset!! nicht Softreset des Routers = Hardwarefehler des Handys.
Zeitaufwand für dieses Ergebnis inklusive aller Installationen, Updates, Zerlegung Router + Handy um auf Wärmefehler zu prüfen (Kältespray) + einiges andere ca. 20 Stunden
Für Kommunikationselektronikerprofis: die Chips sind leider zu empfindlich, um eine gesicherte Aussage über einen Wärmefehler treffen zu können, da sie zu stark reagieren und im Handy zu klein ohne umliegende SMD Komponenten mit zu beeinflussen und im Netz ist leider nur ein Lageplan der Hauptbauteile für das P880 auffindbar, aber keinerlei Schaltunterlagen um weitere Messungen durchzuführen.
 
Zuletzt bearbeitet:
Afro

Afro

Ehrenmitglied
Moin, hier scheint ja alles geklärt worden zu sein, also habe ich den Thread mal in den Anleitungs-Bereich verschoben und geschlossen! :)

Bei eventuellen Wünschen, den Thread erneut zu Öffnen, kann man mich gerne per PN anschreiben... ;)
 
Status
Für weitere Antworten geschlossen.