[How-To] Fehlerbehebung bei "brick" und neu flashen

  • 190 Antworten
  • Neuester Beitrag
Diskutiere [How-To] Fehlerbehebung bei "brick" und neu flashen im Anleitungen für Motorola Milestone im Bereich Root / Hacking / Modding für Motorola Milestone.
Gregor901

Gregor901

Lexikon
-FuFu- schrieb:
Mist, der Link ist o.k., aber die Fileserver haben alle das Ding gecancelt. Wo ggf. noch?

EDIT: Also ich hab jetzt alle Register gezogen. Alle Points von -FuFu- (außer Bootloader, den finde ich nicht).

Der Flashvorgang läuft bis 100 %, dann kommt noch die Meldung, dass das Phone rebootet wird und gleichzeitig unterbricht die USB-Verbindung zu RSD, obwohl da eigentlich noch ein "Schnelldurchlauf der Prozentwerte" erfolgen müsste. "PASS" kommt auch nicht.

Das Phone rebootet zwar, aber bleibt beim M-Logo stehen.

RSD, MotoHelper mit den Treibern - alles auf neuestem Stand. Echt ätzend...
 
Zuletzt bearbeitet:
-FuFu-

-FuFu-

Ikone
wenn rsd lite die zu flashenen dateien rübergeschickt hat, schickt er den reboot befehl... dies hat auch die nebenwirkung, das die usb verbindung weg ist, deswegen erkennt rsd lite auch nie richtig, ob der reboot beendet ist...

wenn er immerwieder am m logo hängen bleibt, ist es meistens die firmware, wenn keine error meldung im bootloader kommt, sind die partitionen zumindest soweit okay (zumindest scheint die prüfsumme zu passen)

wenn ohne sd-card das selbe problem besteht, muß es eine der internen partitionen sein...

recovery sollte eigentlich auch immer gehen -.- dann könnte man dort nochmal wipen oder nen nandroid testen...

bootloader gibt es hier ;)
http://sbf.droid-developers.org/umts_sholes/BL_9078_umts_sholes_HS_Consumer_replacer.sbf.gz
oder der, falls du den älteren hast/willst
http://sbf.droid-developers.org/umts_sholes/BL_9074_umts_sholes_HS_Consumer_replacer.sbf.gz

sonst wüsste ich so auf anhieb auch nichts...

wie sieht denn mit dem Lademodus aus, geht der? also Gerät an das Ladegerät anschließen (nicht PC), gehts dann an und zeigt die nette ladeanimation?
wenn das geht, kann man wenigstens denn Akku laden und weiter testen :D und es ist nicht ganz tot...
 
Gregor901

Gregor901

Lexikon
Danke -FuFu-, ich versuchs mal weiter. Ich hab schon mit und ohne SD-Card versucht und auch verschiedene sbf-Dateien probiert. Errormeldung im Bootloader kommt nicht, sondern erst ordungsgemäß "in process" und später kommt via RSD-Fenster "phone will rebooted". Dann ist Schluss.:cursing: Und in die Recovery komme ich überhaupt gar nicht.

Als Vielflasher habe ich 3 Akkus, die ich sowieso nur in einer Ladeschale lade. Und die sind rappelvoll.

Aber erst nochmal Danke für die Hilfe. Ich sag's ja immer wieder: "-FuFu- ist Mister Milestone".:thumbsup:

EDIT: Bootloader lässt sich flashen. Firmware offenbar auch, denn wie schon mehrfach gesagt, läuft das auf 100 %. Dann kommt auf RSD die Löschmeldung, dann die Prüfsummenchecks und dann der Reboot-Befehl.

Aber es startet nicht. Nur M-Logo. Recovery geht gar nicht (Druck auf x-Taste beim 98er BL bewirkt gar nix, das Phone startet einfach gleich ins M-Logo). Wenn ich Akku rausgenommen habe und wieder einlege, kann ich das Phone mit kurzem (nicht wie üblich lang drücken) Druck auf die Powertaste einschalten. Es kommt nach 3 Sek. das M-Logo, und dann Ende.

Edit II: Jetzt weiß ich wieder, wie das passiert ist: Ich hatte ein Froyo-Nandroid aufgespielt. Das lief sehr schön. Und dann habe ich versucht, aus einem Eclair-Nandroid SELEKTIV die Daten dadrauf einzuspielen. Dann war's hinüber...

Vlt. hilft eine eclair-sbf? - Aber wo gibts die noch?
 
Zuletzt bearbeitet:
Gregor901

Gregor901

Lexikon
Gregor901 schrieb:
Jetzt weiß ich wieder, wie das passiert ist: Ich hatte ein Froyo-Nandroid aufgespielt. Das lief sehr schön. Und dann habe ich versucht, aus einem Eclair-Nandroid SELEKTIV die Daten dadrauf einzuspielen. Dann war's hinüber...

Vlt. hilft eine eclair-sbf? - Aber wo gibts die noch?
-FuFu- schrieb:
Jaaaaaaaaaaaaaaaa !:smile:

Das war es! Das Ding läuft wieder !!! DANKE -FUFU- !:thumbsup:

Erkenntnis:
Wenn man in ein Froyo-System die Datenpartition von Eclair einspielt, ist das Phone damit gebrickt.

Aber: Leider hilft kein Service- oder Full-SBF jedweder Art. Es MUSS (wahrscheinlich aufgrund der Eclair-Daten-Partition) unbedingt eine zur Datenlage passende sbf geflasht werden. Hier also ECLAIR.

Da war mein Gedanke dann ganz richtig. Und Dank Prof. Milestone (also -FuFu-) hab ich dann den entsprechenden Link bekommen. Hier die Eclair-Version (ich wusste noch 2.1-update1) als DACH-sbf raussuchen und: Voila - es geht.

Wer hätte das gedacht ?

Und: Wer hat es gewusst?

Na, wenn das mit dem Usertreffen Hamburg klappt, dann schmeiß ich aber 'ne Runde auf das Wohl von -FuFu-.:thumbup:
 
-FuFu-

-FuFu-

Ikone
^^

ich versteh nur immer noch nicht, wieso du nicht in die recovery gekommen bist -.- denn da läd er nix von der datapartition... die recovery ist ja eigentlich für so ähnliche fälle gedacht (wenn man eben reseten will)...
sehr merkwürdig das ganze... aber nu gehts ja wieder :D
 
Gregor901

Gregor901

Lexikon
K.A., aber beim 98er Bootloader muss man ja die x-taste gedrückt halten. Wo aber kommt die Tasta-Belegung her? Ist die konstant, oder wird die irgendwo mitgeladen? Vlt. lag es daran, dass die x-taste nicht reagieren konnte..
 
-FuFu-

-FuFu-

Ikone
die belegung sollte im bootloader selbst festgesetzt sein, da dieser ja prüfen sollte, was geladen werden soll(system/bootloader oder recovery), denn in den bootloader konntest du ja ;)

aber immerhin ein weiterer lösungsansatz für leute mit ähnlichen problemen ^^
 
T

t_h666

Neues Mitglied
Hallo ich hoffe ihr könnt mir helfen! Habe heute mein MS2 laut der Anleitung https://www.android-hilfe.de/forum/custom-roms-fuer-motorola-milestone-2.527/rom-cm7-10-09-2012-cm9-15-08-2012-cm10-10-09-2012-cyanogenmod.203797.html auf chillje-ICS-120318-gb upgedated. Hatte vorher die originale Motorola Installation drauf. Hat soweit alles geklappt wie beschrieben. Doch der letzte Boot zeigt nur kurz das google Logo und dann nur noch einen Blackscreen. In den Boot Loader mittels power+<Pfeile Up> komme ich noch Recovery Modus geht jedoch nicht. Flashen mit RDS-Lite scheitert mit "Flashing process faild". Habe alle Varianten versucht. Habe gelesen das es eine spezielle Lösung gibt wenn der BootLoader geht Recovery jedoch nicht. Bitte helft mir, ich bin verzweifelt.
 
T

t_h666

Neues Mitglied
Hallo Leute,
ich meinen Stein wieder zum leben erweckt. :))
Erst mal großes DANKE an alle die auf mein Problem gepostet haben!!
Letztlich habe ich die falsche ICS-Version benutzt, hätte von meinem Stock ( Moto 2.2 ) keine GB-Version benutzen dürfen. Am Ende half nur das Flashen auf Retail DE, AT, CH - MILS2_U6_2.4.24..... ,doch hat RSD-Lite bei mir erst mit der neusten Version ( 5.5 ) und den neusten 64bit Win7-Treibern gearbeitet. Nun hab ich die richtige Version ohne GB von ICS benutzt und alles arbeitet wie beschrieben. Danke nochmal tolles Forum.
Gruß t_h666
 
Y

yufi92

Neues Mitglied
Hallo Leute,
hab ein verdammt großes Problem!!
Und zwar krieg ich meinen Stein nicht mehr zum Laufen!
Sowohl Recovery als auch Bootloader sind anwählbar. Wenn ich den Stein über Rsd Lite flashen will passiert nichts, das Handy startet nicht neu oder ähnliches. Ich komme nur bis zum Motorola (M) Logo, mehr geht nicht.
Habe ne Custom Rom flashen wollen, aber dummerweise ist das Handy abgestürzt, keine Ahnung warum.
Ich hoffe ihr könnt mir helfen!!

Update:
Hab es seltsamerweise geschafft. Hab erst eine vulnerable.sbf draufgespielt. das Handy hing sich anschließend immernoch beim Logo auf. Anschließend habe ich einfach die Open Recovery 3.3 von Androidiani benutzt und ne Custom Rom geflasht. Hat alles wunderbar geklappt. Wer ähnliche Probleme hat, dem rate ich DRINGENDS von anderen Open Recoverys ab, bei mir sind die während der Installation des Roms abgestürtzt. Androidiani erwies mal wieder grandiose Leistung.
 
Zuletzt bearbeitet: