OnepLus 3 "Energiesparmodus" zeitgesteuert aktivieren

  • 18 Antworten
  • Neuester Beitrag
Diskutiere OnepLus 3 "Energiesparmodus" zeitgesteuert aktivieren im Automatisierung - Tasker im Bereich Tools.
D

dasacom

Stammgast
Hallo zusammen,

kann man mit dem Tasker den Energiesparmodus um 23 Uhr einschalten und um 7 Uhr deaktivieren?

Ich finde in den Apps den Energiesparmodus, aber leider keine Einstellung um diesen einzuschalten.

Vielleicht geht es nicht, vielleicht bin ich blind. Wenn es geht, würde ich mich über einige Hinweise freuen.

Bitte um etwas Nachsicht, da ich mein Android Gerät erst seit 3 Wochen habe und Tasker gerade eben erst installiert habe......

Habe mich etwas eingelesen und auch einige Videos geguckt, aber vermutlich suche ich hier etwas "spezielles".

DANKE

Schöne Grüße, dasacom
 
B

blackseven

Experte
Also in der Zeit verbtaicht mein OP3 mit eingeschaltetem WLAN, GPS und BT auch so nur 1-2% vom Akku. Relativ betrachtet wird ein Tasker da nichts oder nicht viel bringen.
 
D

dasacom

Stammgast
Meins leider viel! Mehr. Aber deutlich weniger mit dem aktivierten Energiesparmodus.
 
B

blackseven

Experte
Hast Du mal Bluetooth ausgeschaltet?
 
D

dasacom

Stammgast
Hallo. ja Bluetooth ist aus. Ich habe ein "Smartband" und hatte BT aktiviert. Da habe ich schon tagsüber festgestellt, dass es ordentlich Akku kostet.
Leider ist es dass nicht alleine. Der Akku reicht auch über den Tag. Aber ich ärgere mich wenn ich über Nacht 20 bis 30 % verliere. Wenn der Akku nicht halbwegs voll ist, befürchte ich dass das OP3 aus geht! Ausserdem ist der dieser Akku-Verbrauch auch nicht ok. Wenn ich den Energiesparmodus an machte abends, dann verbrauche ich etwa 5 - 6 % über Nacht. Auch etwas mehr als mit dem iphone aber absolut im Rahmen.
 
Ninette

Ninette

Fortgeschrittenes Mitglied
Mein Huawei Y 560 braucht auch gut Akku - aber mit dem Energiesparmodus deutlich weniger - den kann man auch bei mir nicht so einstellen,dass der sich deaktiviert - aber wenn man das Gerät auflädt,deaktiviert sich der Modus selber.
Allerdings sind diverse Optionen dann sowieso deaktiviert,so z.Bsp,der Vibrationsalarm.Also so ideal ist das mit dem Energiesparmodus auch nicht :crying:
 
D

dasacom

Stammgast
über Nacht ist mir das so recht. Tagsüber möchte ich diesen Energiesparmodus garnicht. da hab ich ein Auge drauf und kann auch mal kurz Laden. aber wenn der Wecker morgens nicht klingelt, das wäre schon übel
 
Ninette

Ninette

Fortgeschrittenes Mitglied
Stimmt - blöd auch,weil der Vibrationsalarm auch nicht geht...ich versuchs jetzt auch mal mit über Nacht einschalten und morgens wieder aktivieren - wenn ichs denn nicht vergesse :laugh:
 
D

dasacom

Stammgast
Hi. Bei mir wird die Stausleiste orange wenn der Modus aktiviert ist. Das sieht man dann morgens :)

Und ich habe die kostenlose App BatterySaver System Shortcut installiert. Diese erstellt ein shortcut. Dann braucht man sich nicht durchs Menu hangeln

Die Bezahlversion ermöglicht auch eine Zeitsteuerung, aber dazu muss man noch irgend etwas anpassen am Rechner und das dann übertragen etc, hörte sich mir zu kompliziert an

Gruss
 
Ninette

Ninette

Fortgeschrittenes Mitglied
Hört sich gut an,werd mal gleich danach schauen :laugh:
 
Wipphub

Wipphub

Neues Mitglied
Mal ne Frage.... von niemandem höre ich hier dass er sein OnePlus nachts ausschaltet! Ist das ist das für euch gar keine Option? Ich fahre gut damit weil das OP3 sehr schnell hochfährt und dann natürlich voll ist, weil ich es vorher voll geladen habe.
 
schmetty2

schmetty2

Stammgast
Hallo,

das ist ja auch das Tasker Forum. Bei ausgeschaltetem Gerät funzt Tasker nicht.:winki:
Schau mal im OP3 Forum da gibst bestimmt 'nen Akku Thread.

mfg
 
D

dasacom

Stammgast
@Wipphub also ich finde das hochfahren nicht sehr schnell. Und ausschalten über Nacht kommt für mich nicht in Frage. Habe und musste ich noch bei keinem Smartphone gemacht. Es gibt aber auch einige hier im OP3 Bereich die es über Nacht ausschalten oder alternativ den Flugmodus benutzen.
 
E

Erim

Erfahrenes Mitglied
Energiesparmodus ein:
settings put global low_power 1

Ausserdem vorher mittels:
settings --cm get secure performance_profile
schauen welches Profil aktiv war, output in Variable speichern.

Energiesparmodus aus:
settings put global low_power 0

Vorheriges Profil wieder aktivieren:
settings --cm put secure performance_profile %Variable

wenn du kein cm nutzt, kannst du das --cm weglassen.
Du brauchst root und die Befehle mittels run shell in Tasker ausführen.
 
Y

YamahaR6KS

Erfahrenes Mitglied
@Erim
Also erst eimal vielen Dank!

Ein- und Ausschalten des Energiesparmodus funktioniert einwandfrei. Lieder funktioniert das Zurückstellen des Modus auf Effizient nicht.

Bei der Abfrage wird 3 in der variablen gespeichert.

Hast Du nochmal einen Tipp?

 
Zuletzt bearbeitet:
Y

YamahaR6KS

Erfahrenes Mitglied
Task Energiesparmodus ein:

<TaskerData sr="" dvi="1" tv="4.9u4m">
<Task sr="task3">
<cdate>1484942826898</cdate>
<edate>1484980259123</edate>
<id>3</id>
<nme>Energiespar an</nme>
<pri>100</pri>
<Action sr="act0" ve="7">
<code>123</code>
<Str sr="arg0" ve="3">settings --cm get secure performance_profile</Str>
<Int sr="arg1" val="0"/>
<Int sr="arg2" val="1"/>
<Str sr="arg3" ve="3">%Energie</Str>
<Str sr="arg4" ve="3"/>
<Str sr="arg5" ve="3"/>
</Action>
<Action sr="act1" ve="7">
<code>123</code>
<Str sr="arg0" ve="3">settings put global low_power 1</Str>
<Int sr="arg1" val="0"/>
<Int sr="arg2" val="1"/>
<Str sr="arg3" ve="3"/>
<Str sr="arg4" ve="3"/>
<Str sr="arg5" ve="3"/>
</Action>
</Task>
</TaskerData>

 
Y

YamahaR6KS

Erfahrenes Mitglied
Task Energiesparmodus aus:

<TaskerData sr="" dvi="1" tv="4.9u4m">
<Task sr="task12">
<cdate>1484944094843</cdate>
<edate>1484980371350</edate>
<id>12</id>
<nme>Energie aus</nme>
<pri>100</pri>
<Action sr="act0" ve="7">
<code>123</code>
<Str sr="arg0" ve="3">settings put global low_power 0</Str>
<Int sr="arg1" val="0"/>
<Int sr="arg2" val="1"/>
<Str sr="arg3" ve="3"/>
<Str sr="arg4" ve="3"/>
<Str sr="arg5" ve="3"/>
</Action>
<Action sr="act1" ve="7">
<code>123</code>
<Str sr="arg0" ve="3">settings --cm put secure performance_profile %Energie</Str>
<Int sr="arg1" val="0"/>
<Int sr="arg2" val="1"/>
<Str sr="arg3" ve="3"/>
<Str sr="arg4" ve="3"/>
<Str sr="arg5" ve="3"/>
</Action>
</Task>
</TaskerData>

 
E

Erim

Erfahrenes Mitglied
bei mir funktioniert das so, dann ist bei deinem ROM irgendwas anders.
installiert mal
System Settings for Tasker – Android-Apps auf Google Play

dann sicherst du in der app deine Einstellungen, danach machst du die Energieänderungen händisch.

Dann in der App ein compare ausführen, dann solltest du sehen was sich alles geändert hat.
 
Y

YamahaR6KS

Erfahrenes Mitglied
Oh, danke
Komisch ist, dass sich manchmal zwei und manchmal nur eine Sache ändern.

Immer ändert sich:
sysui_qs_tiles

und manchmal:
performance_profile

Ich verstehe das nicht so ganz. Es macht irgendwie den Eindruck, als gäbe es bei performance_profile keinen Unterschied zwischen "Ausgeglichen" und "Effizient".

Bei sysui_qs_tiles gibt es super viele Einträge:


Ich weiß jetzt nicht so recht, ob ich Oberhaupt was einstellen kann.
 
Ähnliche Themen - OnepLus 3 "Energiesparmodus" zeitgesteuert aktivieren Antworten Datum
2
9
3