USB Debugging

  • 6 Antworten
  • Neuester Beitrag
Diskutiere USB Debugging im Automatisierung - Tasker im Bereich Tools.
thloe

thloe

Stammgast
Hallo ich steh bei folgender Aufgaben an:
Hab in meiner Firma das Problem: wenn ich mein gerootetes Tablet anstecke um via USB Daten/Medien zu verschieben kann ich das nur , wenn der USB-Debugging Modus ausgeschaltet ist. Jetzt möcht ich das nicht jedesmal in Einstellungen ein- bzw. ausschalten. Hab schon ein Firmen-Profil über Netzwerkabfrage und in dieses könnt ich noch einen Task einbauen, wenn ich wüsste wie. Hab schon gegoogelt und dahingehend leider nichts gefunden. Hoffe nun auf eure Hilfe!!!:thumbup:
DANKE!!!!
 
C

Chillmann

Stammgast
Mit dem plugin secure settings geht das glaube.


Gruß

Chillmann
 
m505

m505

Experte
wie Chillman schon schrieb: mit Secure Setting auf on, off oder toggle
 

Anhänge

Holli33

Holli33

Erfahrenes Mitglied
Hallo,

ich greife mal das Thema noch einmal auf.
Ich wollte dieses lösen mit „Secure Stettings“. Habe es soweit auch, dass es funktioniert, aber immer nur beim 2. Mal. Das heißt, beim ersten Verbinden mit dem USB bleibt USB-Debugging Modus eingeschaltet.

Ziehe ich den Stecker und verbinde es wieder wird der USB-Debugging Modus ausgeschaltet.


Mein Profil:
USB Verbunden => Secure Settings USB-Debugging Disabled.


Ich hatte auch schon den Warte Befehl mit 5 und 10 Sekunden probiert, jedoch das gleiche Resultat.



Wo steckt der Fehler bzw was kann ich noch tun?


Danke...
 
C

Chillmann

Stammgast
Vllt lässt sich der Debug Modus nicht schalten während er aktiv ist. Nehme an das Secure Settings den Befehl zwar ans System "sendet", dieser allerdings erst nach der Trennung von USB ausgeführt wird.
Falls meine Annahme zutrifft, sehe ich leider keinen sinnvollen "Workaround". Die Debug-Einstellung müsste demnach vor dem Verbinden mit USB geschaltet werden.


Gruß

Chillmann
 
Holli33

Holli33

Erfahrenes Mitglied
Danke Chillmann ;)

So habe es mal probiert mit USB Debbugging>Toggle
Scheint erstmal zu funktionieren. Ich teste weiter....
 
thloe

thloe

Stammgast
Holli33 schrieb:
Hallo,

ich greife mal das Thema noch einmal auf.
Ich wollte dieses lösen mit „Secure Stettings“. Habe es soweit auch, dass es funktioniert, aber immer nur beim 2. Mal. Das heißt, beim ersten Verbinden mit dem USB bleibt USB-Debugging Modus eingeschaltet.
Ziehe ich den Stecker und verbinde es wieder wird der USB-Debugging Modus ausgeschaltet.
Mein Profil:
USB Verbunden => Secure Settings USB-Debugging Disabled.
Ich hatte auch schon den Warte Befehl mit 5 und 10 Sekunden probiert, jedoch das gleiche Resultat.
Wo steckt der Fehler bzw was kann ich noch tun?
Danke...
Also bei mir funktionierts! Habe es folgend gelöst: Profilname Firma
Profile:
Mo. bis Fr
07:00 bis 19:00
Funkzelle
Task:
Benachrichtigung "Firma On"
Secure Settings USB Deb. Disabled
Exit Task:
Benachrichtigung "Firma Off"
Secure Settings USB Deb. Enabled

läuft perfekt