Wiederbelebung über QFIL möglich?

  • 20 Antworten
  • Neuester Beitrag
Diskutiere Wiederbelebung über QFIL möglich? im bq Aquaris X / X Pro Forum im Bereich bq Forum.
A

AndroidIAm

Neues Mitglied
Ich habe hier ein Aquaris X Pro, das kaum mehr Lebenszeichen von sich gibt.

Ohne USB-Verbindung zeigt weder die LED etwas an, noch lässt es sich einschalten (vibriert nicht, keine Anzeige).

Bei Stromversorgung über USB leuchtet die LED rot. Nach 13 Sekunden Druck auf den Einschaltknopf vibriert es und zeigt dann für eine halbe Sekunde den Logo-Screen, bevor es wieder stirbt.

Besteht zusätzlich eine Datenverbindung, erkennt QFIL das Gerät als "Qualcomm HS-USB Diagnostics 900E". Es gibt mehrere inoffizielle Tipp-Seiten, die nahelegen, dass in den Distributionen eine passende Firehose-Datei vorliegen sollte.Ich habe drei Releases heruntergeladen, aber keines davon beinhlatet eine solche Datei.

Ob ich sie dann nutzen könnte weiß ich nicht sicher, denn bei Versuchen mit .mbn-Dateien aus der Distribution meldet QFIL "Failed to Switch to Emergency Download mode". Das könnte an der falschen Datei liegen oder daran, dass das Gerät diese Umschaltung nichtmitmacht. Für andere Geräte wird in diesem Fall das kurze Herausnehmen des Akkus empfohlen, was beim X Pro keine naheliegende Option ist.

Gibt es eine Möglichkeit, das Gerät zu retten?
 
Quallenauge

Quallenauge

Erfahrenes Mitglied
Was hattest Du denn vorher mit dem Telefon gemacht dass es nicht mehr startet?
Aktuell klingt es ja schon so, dass der Akku nicht richtig funktioniert?!
 
A

AndroidIAm

Neues Mitglied
@Quallenauge wer sagt denn, dass ich etwas mit dem Gerät gemacht habe? Am Ende des Tages sollte es aber auch egal sein und man kann später herausfinden, wie es um den Akku steht. Das Gerät versteht sich mit QFIL und genau da wird die Informationslage dünn, obwohl man angeblich damit alle Qualcomm-Geräte (Software-seitig) retten können soll.
 
Quallenauge

Quallenauge

Erfahrenes Mitglied
Ok, ich wollte nur herausfinden ob vorher ein was falsches geflasht worden ist oder sich das Gerät einfach so verabschiedet hat. Im letzteren Fall wäre der Akku tatsächlich die heisseste Spur. Oder irgendein elektronisches Bauteil meldet falsche Werte.
Im ersten Fall sieht es schon schlechter aus. Der Flasher muss zum Gerät passen.
Weiterhin wird eine genaue Flash-Definition erwartet, damit der Flasher die Partitionen erstellen kann. Erstes gibt es vielleicht (die sind ja alle Digital Signiert und die muss mit der vom Telefon (in Hardware gegossen) übereinstimmen), fuers zweite habe ich auch nix fertiges gefunden... :-/ Es sieht schwierig bis schlecht für das Teil aus...
 
A

AndroidIAm

Neues Mitglied
@Quallenauge was genau ist "der Flasher" (firehose?), was sind "seine Definitionen" (content.xml?) und was davon muss signiert sein? Die Releases enthalten ja .mbn-Dateien. Kann man den Rest anhand eines funktionierenden X Pro (re-) konstruieren?
 
Quallenauge

Quallenauge

Erfahrenes Mitglied
Richtig, der Flasher ist der Firehose. Da gibt's irgendwo Beschreibungen wie das mit der digitalen Signatur funktioniert.
Ich denke, dass man sich diese Dateien von einem funktionierenden Gerät erstellen kann - ich habe das probiert, aber noch nicht getestet.
Aber nochmal, wenn der Bootloader schon erscheint, sollte zumindestens ein Fastboot möglich sein - oder?
 
A

AndroidIAm

Neues Mitglied
@Quallenauge Nein, das ist genau so wie ich schrieb. Das Gerät ist für QFIL, aber weder für fastboot noch für adb zugreifbar. Der bq-Screen erscheint auch nur kurz.

Auf das Gerät wurde wohl TWRP und ein alternatives Betriebssystem geflasht. Danach wurde möglicherweise versehentlich fastboot oem lock o.ä. ausgeführt...
 
A

AndroidIAm

Neues Mitglied
Quallenauge schrieb:
Aktuell klingt es ja schon so, dass der Akku nicht richtig funktioniert?!
  • Würde das Handy beim Start nur kurz das bq-Logo anzeigen und dann aussteigen, wenn es an USB angeschlossen ist und der Akku leer wäre?
  • Lädt das Handy nicht, wenn es auf das Anschließen an USB nur mit der LED reagiert, aber nicht mit einem Batterie-Symbol im Display?
  • Kann man über QFIL entriegeln?
  • Gäbe es noch einen Weg, dem Gerät über eine eingelegte SD-Karte Leben einzuhauchen?
  • Kommt man doch noch irgendwie zum fastboot?
  • Kann auch der bq-Service nichts mehr machen?
 
HerrDoctorPhone

HerrDoctorPhone

Inventar
Hallo,

Nach der Beschreibung hier:
AndroidIAm schrieb:
a. Würde das Handy beim Start nur kurz das bq-Logo anzeigen und dann aussteigen, wenn es an USB angeschlossen ist und der Akku leer wäre?
b. Lädt das Handy nicht, wenn es auf das Anschließen an USB nur mit der LED reagiert, aber nicht mit einem Batterie-Symbol im Display?
...scheint es das der Akku Tot ist.
Neuen besorgen, einbauen. Über USB arbeiten geht nicht bei allem was du vor hast.

VG
DOC
 
omah

omah

Inventar
Vielleicht mal die Spannung am Akku messen.
Mit Elektronik-Lehre würde ich mit einem 9V-Block den Akku ganz kurz anladen, wenn er tiefentladen scheint. Plus an Plus, Minus an Minus. Dabei den Akku und den 9V-Block in der Hand halten, alles was über handwarm ist führt dann zum Loslassen der lose angehaltenen Drahtenden. Wenn die Spannung danach leicht gestiegen ist kann das dazu führen, daß der Akku im Gerät wieder ladefähig ist und das Smartphone funktioniert. Das würde ich allerdings nur als Hinweis sehen, daß das Gerät den neuen Akku wert ist, den ich dann bestellen würde. Dem alten Akku würde ich dann ohnehin mißtrauen und ihn nur zum Test an einem schwachen Ladegerät ohne Schnelladung kurz ein wenig laden. Es kann ja auch sein, daß die Ladeschaltung im Handy defekt ist oder ein Fremdkörper (Staubfussel) in der USB-C-Buchse.
 
A

AndroidIAm

Neues Mitglied
@HerrDoctorPhone @omah

  • Ist so eine Ladeschaltung im Handy so aufgebaut, dass die Software den Ladevorgang freigeben / überwachen / ... muss, oder nicht? Anders gefargat, kann man im Normalfall erwarten, dass das Handy den Akku lädt auch wenn es Bootloader-seitig vermurkst ist, oder nicht?
  • Was wäre zu erwarten, wenn ich das Gerät an den Service schicke?
 
Zuletzt bearbeitet:
HerrDoctorPhone

HerrDoctorPhone

Inventar
Ja, die Software gibt den Ladevorgang frei, das macht die Ladeelektronik die EEin/Aus messen und kontrolliert.
Der Akku ist die Schwachstelle, da findest eine Chemische Reaktion statt.
Nicht alles was chemisch ist, reagiert sofort oder überhaupt.

Ich gehe davon aus das du schon alle Optionen berücksichtigt hast bevor du dich an das Forum gewendest hast, aber bitte sage uns einfach was geschehen ist.

Ist das Gerät neu oder gebraucht?
Wie lange lag das Handy ohne aufgeladen gewesen zu sein?
Ist der USB Port sauber, kann der Stecker dort gut stecken?
Sind Kabel, Ladegerät in Ordnung?

Vg
Doc
 
A

AndroidIAm

Neues Mitglied
@HerrDoctorPhone

Wenn die SW den Ladevorgang kontrolliert, müsste dann nicht wenigstens in einigen Situationen noch der Bildschirm mit dem Batteriesymbol angezeigt werden? Das ist aber nicht so. Ich wäre überrascht wenn die Elektronik oder der Akku das Problem wären; es wäre meiner Einschätzung nach schlicht zu teuer (und ohne Use Case) da noch ein Self Monitoring zu haben so dass die Software aufgrund dessen (kommetarlos) erst gar nicht versucht, den Ladevorgang zu beginnen.

Das Gerät war recht neu, es lag nicht ungenutzt herum bevor das Problem auftrat, und die Akkuladung lag bei über 50 % als das Problem begann. Alles macht einen guten Eindruck, der USB-C-Stecker rastet sauber ein und hat kein Spiel, und an der LED kann man sehen wann und ob Spannung erkannt wird.

Da ich mir auch nicht vorstellen kann dass man das freiwillig so konstruiert dass es bei tiefem Akku-Ladestand nicht mehr da rauszubekommen ist (das passiert nun mal im Feld), muss es meiner Ansicht nach einen anderen Grund geben, warum nach dem Einschalten der bq-Bildschirm nur sehr kurz (0,25 .. 0.5 s) erscheint und das Gerät danach nur über QFIL ansprechbar ist.

Aber ja, wahrscheinlich ist inzwischen der Akku leer durch die vielen Experimente und wurde nie wieder nachgeladen, weil die nötige SW nie zum Zug kommt.

Nur, da dürfte ein voller Akku an sich nichts dran ändern, oder treffe ich irgendwo eine falsche Annahme?
 
HerrDoctorPhone

HerrDoctorPhone

Inventar
nun,

Ja, beim Laden sollte das Ladesymbol erscheinen und die LED aufleuchten.
Dies geschieht unter Umständen nicht wenn:
a. der Akku nicht mitspielt
b. schaden am Board ist, was eigendlich auszuschließen wäre.

Es bleiben Ladegerät und Kabel übrig.

Demzufolge würde ich das Ladegerät mal wechseln, ebenso Kabel und mal 1-2 Stunden bei ausgeschalteten Gerät den Ladevorgang initiieren.

Schauen wir mal in Paar Stunden was passiert ist.

VG
 
A

AndroidIAm

Neues Mitglied
@HerrDoctorPhone Gut, mache ich.

In der Zwischenzeit: Ganz sicher, dass es keinen Fall gibt, in dem das Stück Software, das dafür zuständig ist, einfach nicht mehr aufgerufen wird?
 
HerrDoctorPhone

HerrDoctorPhone

Inventar
Schon...... das kann passieren.
Ich habe hier ein THL liegen, da ist die Software zerschossen, trotz neu Flashen ist es niemanden mehr möglich gewesen das wieder zum laufen zu bringen.

In paar Stunden weiß man mehr wenn du ein funktionierendes Ladegerät samt ladekabel hast.

Sollte nichts mehr gehen, schreinbst du ja weiter oben:
AndroidIAm schrieb:
Das Gerät war recht neu, es lag nicht ungenutzt herum bevor das Problem auftrat, und die Akkuladung lag bei über 50 % als das Problem begann.
Da könntest du deinen Händler anschreiben und Gewährleistung geltend machen.

VG
 
A

AndroidIAm

Neues Mitglied
HerrDoctorPhone schrieb:
In paar Stunden weiß man mehr wenn du ein funktionierendes Ladegerät samt ladekabel hast.
Je eine Stunde mit je einem anderen Ladegerät und je einem anderen Kabel, eines davon QC-fähig und das andere nicht, haben nichts verändert.
 
HerrDoctorPhone

HerrDoctorPhone

Inventar
Ok, dann weiß ich auch nicht weiter, Akku sollte geladen werden.

2 Möglichkeiten nun:
a. Akku defekt
b. Laderegler defekt.
......c. Software, eher unwahrscheinlich....

Du solltest deinen Händler anschreiben/aufsuchen und das klären, du hast ja 2 jahre gewährleistung.

VG
Doc
 
M

Multiple_P

Erfahrenes Mitglied
Oder USB Port defekt.
 
HerrDoctorPhone

HerrDoctorPhone

Inventar
Eher unwahrscheinlich, denn:
AndroidIAm schrieb:
Bei Stromversorgung über USB leuchtet die LED rot. Nach 13 Sekunden Druck auf den Einschaltknopf vibriert es und zeigt dann für eine halbe Sekunde den Logo-Screen, bevor es wieder stirbt.
Wäre möglich, aber den Anzeichen nach fehlt etwas.
Noch weiter Spekulieren bringt nichts solange noch Gewährleistung drauf ist, kostet nur Zeit und das teil wird eh kostenlos repariert.

Doc