CUBOT MAX 2 rooten - Fastboot klappt nicht

  • 13 Antworten
  • Neuster Beitrag
akapuma

akapuma

Fortgeschrittenes Mitglied
Threadstarter
Hallo,

ich möchte mein Cubot Max 2 rooten und zwar nach dieser Anleitung. Ich scheitere direkt am Anfang. Mit "fastboot devices" soll die Verbindung geprüft und das MAX 2 angezeigt werden. Es wird aber nichts angezeigt.

Was mache ich falsch?

Auf dem PC ist Win 10.

Gruß

akapuma
 
Wattsolls

Wattsolls

Super-Moderator & Mediator
Teammitglied
Treiber korrekt installiert? Gerät befindet sich um Fastboot Modus?
 
akapuma

akapuma

Fortgeschrittenes Mitglied
Threadstarter
Hallo Wattsolls,

"Gerät befindet sich um Fastboot Modus?" war genau der richtige Hinweis. Ich war nicht im Fastboot-Modus. Nachdem ich USB-Debugging aktiviert hatte konnte ich mit "adb reboot bootloader" in den Fastboot-Modus. An sich sieht es ja auch gut aus:

Code:
C:\max2\tools\adbplatform>adb reboot bootloader

C:\max2\tools\adbplatform>fastboot devices
E937XXBM970803D0        fastboot

C:\max2\tools\adbplatform>fastboot oem unlock
FAILED (remote: unknown command)
Finished. Total time: 0.003s

C:\max2\tools\adbplatform>fastboot flashing unlock
(bootloader) Start unlock flow

OKAY [ 20.870s]
Finished. Total time: 20.873s

C:\max2\tools\adbplatform>fastboot flash recovery recovery.img
Sending 'recovery' (32767 KB)                      OKAY [  1.940s]
Writing 'recovery'                                 OKAY [  0.451s]
Finished. Total time: 2.444s

C:\max2\tools\adbplatform>fastboot boot recovery.img
Downloading 'boot.img'                             OKAY [  1.646s]
booting                                            OKAY [  0.058s]
Finished. Total time: 1.765s
Problem: ich komme nicht ins TWRP, sondern hierhin:




Beim Starten steht übrigens auf dem Bildschirm, mein Cubot wäre nun "unlocked".

Was ist falsch gelaufen?

Gruß

akapuma
 
Wattsolls

Wattsolls

Super-Moderator & Mediator
Teammitglied
akapuma schrieb:
Beim Starten steht übrigens auf dem Bildschirm, mein Cubot wäre nun "unlocked".Was ist falsch gelaufen?
Das da unlocked steht, ist korrekt. Der Bootloader ist nun offen.
Hast Du auch nach dem flashen des TWRP-images direkt und als erstes Versucht ins Recovery zu booten?
 
akapuma

akapuma

Fortgeschrittenes Mitglied
Threadstarter
Wattsolls schrieb:
Hast Du auch nach dem flashen des TWRP-images direkt und als erstes Versucht ins Recovery zu booten?
Nein, das Cubot bootete nach einiger Zeit von selbst.

Ich hatte lediglich, wie in der Anleitung steht, "fastboot boot recovery.img" eingegeben. und gewartet.

Was mache ich denn jetzt?

Gruß

akapuma
 
Wattsolls

Wattsolls

Super-Moderator & Mediator
Teammitglied
Nochmal TWRP flashen und dann am besten per Tasten Neustart ins Recovery.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Also "Fastboot flash Recovery..." und nach der Erfolgsmeldung mit den Gerätetasten ins Recovery booten.
 
akapuma

akapuma

Fortgeschrittenes Mitglied
Threadstarter
"fastboot boot recovery.img" also nicht mehr?

Gruß

akapuma
 
Wattsolls

Wattsolls

Super-Moderator & Mediator
Teammitglied
Nein, das machst Du ja mit den Gerätetasten. Wahrscheinlich ist es Powertaste und Lauter. Also nach dem Flashen beide gleichzeitig drücken.
 
akapuma

akapuma

Fortgeschrittenes Mitglied
Threadstarter
Hallo,

"fastboot boot recovery.img" habe ich trotzdem gemacht, dann "Lauter" + "Power". TWRP startete, Sprache habe ich von RU auf EN umgestellt. Jetzt wollte ich MAGISK installieren, die ZIP hatte ich in den Download-Ordner getan. Aber: alle Ordner sind leer, und den Download-Ordner finde ich nicht mehr.

Was jetzt? Neu booten? Komme ich dann bei einem Reboot wieder ins TWRP?

Danke.

Gruß

akapuma
 
Wattsolls

Wattsolls

Super-Moderator & Mediator
Teammitglied
TWRP sollte jetzt fix sein. Also beim nächsten booten dahin auch noch vorhanden sein.
 
akapuma

akapuma

Fortgeschrittenes Mitglied
Threadstarter
Hallo,

ich habe neu gebootet, und merkwürdigerweise waren alle Ordner da, auch der mit MAGISK. Unter TWRP war ja alles leer. Also habe ich erneut versucht in's TWRP zu kommen, aber das Android Recovery (Bild in Post Nummer 3) kam wieder. Auch ein erneutes fastboot flash recovery recovery.img half nicht, entweder es startete ohne Recovery, oder es kam das Android Recovery.

Das Cubot MAX2 ist ein tolles Handy. Ich habe es erst seit gestern und will heute nicht alles tun um es kaputt zu machen (bricken). Ich werde alle Rootversuche einstellen und hoffen, daß ich mich an die massive Werbung ohne AdAway gewöhne.

Trotzdem danke für die Hilfe!

Gruß

akapuma
 
Wattsolls

Wattsolls

Super-Moderator & Mediator
Teammitglied
Hm, sehr merkwürdig.
Wenn es Dir nur um die Werbung geht, dann teste doch mal DOT/DOH. Das blockt Dir Werbung und noch mehr. Und das ohne root. ;)
 
Zuletzt bearbeitet:
h0sch180

h0sch180

Stammgast
@akapuma
Ich geh mal davon aus, daß du wie bei den neueren Handys folgendes tun musst.
Twrp flashen
TWRP booten
Im TWRP data Partition formatieren
Im TWRP den internen Speicher formatieren
Reboot ins recovery
Handy an den PC anschließen und Magisk + die verity encrypt kopieren
Magisk flashen
Verity encrypt flashen
Reboot
System neu einrichten
Fertig
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Nachtrag, wenn du beim 2ten Boot in den TWRP keinen Touch hast, ist der Kernel nicht gepatcht, dann musst du per adb den TWRP booten und statt reboot im TWRP reboot Bootloader auswählen.

Wenn der Kernel wirklich nicht gepatcht ist kannst dich gern melden, brauch dann nur von dir ein paar Infos, dann bekommst nen aktuellen TWRP mit gepatchten Kernel.
 
akapuma

akapuma

Fortgeschrittenes Mitglied
Threadstarter
Hallo Hosch180,

vielen Dank für die Hilfe.

Primär geht es mir ja darum die Werbung zu blockieren. Hier hat Watsolls mit einen Tip gegeben, wie man Werbung auch ohne Root blocken kann. Weil das vorzüglich funktioniert hat sich das mit dem Rooten erledigt.

Gruß

akapuma
 
Oben Unten