CM7 - Market-Problem mit Kompatibilität

  • 6 Antworten
  • Neuester Beitrag
Diskutiere CM7 - Market-Problem mit Kompatibilität im Custom-ROMs für Motorola Defy im Bereich Root / Hacking / Modding für Motorola Defy.
Beacon

Beacon

Erfahrenes Mitglied
Tag zusammen!

Ich hoffe, ich hab' die Lösung meines Problems jetzt nicht irgendwo überlesen aber stelle halt einfach mal die Frage, nachdem mich die SuFu nicht weitergebracht hat (hab' zwar mehrfach vom selben Problem gelesen aber keine Antworten gefunden)...

Seit dem Update auf die cm7 Stable muckert der Market häufig rum, dass irgendwelche Apps (die ich teilweise sogar schon mit Eclair auf dem Defy hatte) "mit Ihrem (also meinem) Gerät nicht kompatibel" seien und lässt sie mich dann nicht installieren.
Mit dem letzten RC hatte ich das Problem noch nicht.

Gibt's da eine Umgehungslösung, mit der man dem Market ein anderes Gerät vorgaukeln kann?

Danke schon mal!

B.
 
Gazman

Gazman

Experte
Doch, gibt es.

Das Segeln unter falscher Flagge ist mit der build.prop eines anderen ROM möglich. Bei mir hat´s die vom Defy+ getan, hab sie leider gerade nicht zur Hand, sonst würde ich sie uppen.
Ist aber hier im Forum schon verlinkt worden.

Gruß

Christoph
 
Beacon

Beacon

Erfahrenes Mitglied
Ah! Danke für den Tipp mit der build.prop!
Das ist ja zumindest schon mal ein Anhaltspunkt, von dem aus ich mich weiterhangeln kann...
 
Beacon

Beacon

Erfahrenes Mitglied
Ok, hab's hinbekommen...

Habe die build.prop aus diesem Beitrag genommen und mit meiner was die Geräteinformationen angeht zusammengeführt.
Bis auf Googleearth (das wohl anscheinend grundsätzlich nicht mit dem Defy "kompatibel" ist?) hab' ich jetzt auch zumindes die von mir gewünschten Apps finden und installieren können.... :thumbsup:
 
J

JanHimpIII

Erfahrenes Mitglied
Hab das Problem mit "Das Telefonbuch". Hab es irgendwann mal installiert unter Froyo, läuft auch. Aber Update geht jetzt nicht mehr weil angeblich nicht kompatibel.

Google Earth geht bei mir aber. (Neueste Nightlies, buildprop nicht geändert)

apropo build.prop: Welche Einträge sind denn eigentlich relevant für das "Kompatibel-Problem", also die Erkennung durch den Market?

Edit: hab schon was gefunden, hier: https://www.android-hilfe.de/forum/...ibel-mit-meinem-defy.135706.html#post-2055508
Aber das scheint nicht alles zu sein, oder?
 
Zuletzt bearbeitet:
M

maniac103

Experte
JanHimpIII schrieb:
Hab das Problem mit "Das Telefonbuch". Hab es irgendwann mal installiert unter Froyo, läuft auch. Aber Update geht jetzt nicht mehr weil angeblich nicht kompatibel.

Google Earth geht bei mir aber. (Neueste Nightlies, buildprop nicht geändert)

apropo build.prop: Welche Einträge sind denn eigentlich relevant für das "Kompatibel-Problem", also die Erkennung durch den Market?

Edit: hab schon was gefunden, hier: https://www.android-hilfe.de/forum/...ibel-mit-meinem-defy.135706.html#post-2055508
Aber das scheint nicht alles zu sein, oder?
Es ist eigentlich nur ro.build.fingerprint, evtl. noch ro.build.description.
Ab der nächsten Nightly wird der Fingerprint vom Defy+-Stock-ROM verwendet, damit sollte dann alles kompatibel sein.
 
Gazman

Gazman

Experte
Schicke Idee! Würde viele Fragen und viel Gefummel ersparen!

Gruß

Christoph