Schlagworte:
  1. JamesBott, 13.12.2018 #1
    JamesBott

    JamesBott Threadstarter Moderator Team-Mitglied

    Ich beschreibe hier was ich mit meinem Phone gemacht habe.
    JEDER ist für das was er IN seinem Phone ändert selbst verantwortlich !!!​

    Entscheidend ist dafür der Download der im Phone installierten Firmware !
    Bitte NUR aus der richtigen Firmware das "boot.img" verwenden ! (z.Z. "Elephone_A4_20180905")
    Dieses VORHER download sowie von xda/Magisk die aktuelle Magisk-Manager.app [MM]
    Die ADB-Tools müssen auf dem PC (z.B. in C:\ADB) installiert sein.
    (Hier ist z.B. "C:\ADB" der "ADB-Ordner". Eingabeaufforderung starten, "cd C:\ADB")
    (Grundkenntnisse im Umgang mit DOS-Fenster ... werden voraus gesetzt)​

    Dies ist ein Minimal-Kochbuch (Step by Step)​
    Phone starten
    - Grundeinrichtung ( Language ... alles Unwichtige überspringen)
    - Menü / System / Über das Telefon
    - Build-Nummer 7x tippen (Entwickleroptionen freischalten)
    - Menü / System / Entwickleroptionen
    - - OEM-Entsperrung zulassen : JA
    - - USB-Debugging : JA
    USB-Kabel Phone <-> PC einstecken
    Auf PC in "ADB-Ordner" wechseln​
    Befehl : adb devices
    - Antwort : ELEE3005xxxxxxxx unauthorized
    Auf Phone Meldung "...zulassen" anhaken und JA​
    Befehl : adb devices
    - Antwort : ELEE3005xxxxxxxx device (Phone ist connected)
    Befehl : adb reboot bootloader
    Phone rebootet in "FASTBOOT mode"​
    Befehl : fastboot oem unlock (musste ich 2x machen bis es reagiert hat)
    (mit Vol-Up "BL-unlock = YES" bestätigen)​
    Befehl : fastboot reboot
    (dauert ein bisschen, da Factory-Reset gemacht wird)​
    Grundeinrichtung ( Language ...)
    Von PC auf Phone (z.B. in "Download") MM
    Von PC auf Phone (z.B. in "Download") aus der Firmware das "boot.img"
    Auf Phone MM installieren und starten
    Von MM "patched_boot.img" erstellen lassen
    Von Phone in PC "patched_boot.img" kopieren (in ADB-Ordner)​
    Auf PC in "ADB-Ordner" wechseln
    Befehl : adb devices (Connection-Check)
    Befehl : adb reboot bootloader
    Befehl : fastboot devices (Connection-Check)
    Befehl : fastboot flash boot patched_boot.img
    Befehl : fastboot reboot

    Im Phone MM starten, der checkt seinen Status, evtl. Updates installieren lassen
    In MM/Einstellungen evtl. : "Dunkles Theme" ein/aus, "Prüfe nach Aktualisierungen" ein/aus,
    "Aktualisierungs-Kanal" stable, "Magisk Hide" ein/aus.
    Eine Root-App installieren (z.B. ESDatei-Explorer) und damit check "ist root verfügbar"
    Wenn das funktioniert - fertig !

    In den nächsten Tagen werde ich noch einen Test mit "RR-System.img" machen.
    Treble-Check sagt : aOnly-System.
     
    Zuletzt bearbeitet: 14.12.2018
    Wattsolls und Falsche Uhrzeit haben sich bedankt.
  2. JamesBott, 18.12.2018 #2
    JamesBott

    JamesBott Threadstarter Moderator Team-Mitglied

    Nachtrag
    Warnung

    In Domini Spiritus Sanktus. Amen !
    Wir betrauern das vorzeitige Ableben dieses Phones.
    Nach kurzen Leiden an dem "RR-System.img" ist es friedlich entschlafen !

    Im Moment empfehle ich - rooten ja - Experimente mit "aOnly-System-img" NEIN.
    Theoretisch alles richtig gemacht. Praktisch R.I.P.​

    Evtl. findet da jemand etwas das funktioniert. Es ist dermaßen "zerschossen" das noch nicht mal SP-Flash zurück auf Stock-ROM funktioniert.
     
    Falsche Uhrzeit bedankt sich.
  3. Orcaflugzeug79, 22.12.2018 #3
    Orcaflugzeug79

    Orcaflugzeug79 Neuer Benutzer

    Hallo!
    Habe soeben auch mein A4 durch einen root-Versuch zerschossen...ich kann mir beim besten willen nicht erklären wie, da niemand anderes (scheinbar) mein Problem hat.

    Wie immer, zuerst alle benötigten Treiber installiert ("SP Driver 2.0" und die USB vcom treiber für mtk-Geräte), SP Flashtool aufgemacht, scatter von der im Internet (auch auf xda und der offiziellen Website von Elephone) angebotenen Stock ROM geladen, auf "Format All + Download" gestellt (es stand so in einer Root-Anleitung auf xda) und Smartphone im ausgeschalteten Zustand eingesteckt. Lauf Flashtool lief auch alles ordnungsgemäß. Nun ja....beim nächsten booten kam dann der Schreck: Das komplette Display sieht extrem verpixelt und verfranst aus, horizontale Streifen sind übers ganze Display verteilt und die Farbdarstellung gleicht einem alten Röhrenfernseher.....
    Außerdem sieht man "alte" Bildschirmdarstellungen leicht überall, vergleichbar mit dem Effekt wenn ein Bild in ein Display einbrennt. Nur kann das ja wohl nicht über ein paar Sekunden geschehen. Das alles geht schon soweit, dass, sobald ich das Display einschalte (auch im Recovery-Modus und Fastboot-Modus, ich schemenhaft die Taskleiste, Soft-Buttons und meinen ehemaligen Homescreen sehe.

    Dabei muss auch noch die IMEI verloren gegangen sein, denn die SIM funktioniert auch nicht mehr ordnungsgemäß.

    Es hat sich herausgestellt, dass es nichts bewirkt, die angebliche "Stock-ROM" erneut mit dem Tool zu flashen. Der Fehler im Bildschirm bleibt.

    ABER: Wenn man die beiden verfügbaren OTA-Updates macht, sieht das Display wieder normal aus, bis auf den "eingebrannten" Update-Kreis in der Mitte des Displays.

    Wenn mir irgendwer zu helfen weiß, oder zumindest weiß, wo ich eine funktionsfähige ROM herbekomme, die ich flashen kann, wär ich echt dankbar.
    Oder hört es sich nach einem Hardware-defekt an? Dann wäre jedoch verwunderlich, dass der Fehler mit dem OTA fast verschwindet.

    Anbei noch zwei Bilder, in denen man das alles hoffentlich sehen kann.
     

    Anhänge:

  4. JamesBott, 22.12.2018 #4
    JamesBott

    JamesBott Threadstarter Moderator Team-Mitglied

    Meine Diagnose : wir sind beide am Grundproblem bei den China-Krachern gescheitert.
    Wir müssen darauf vertrauen das die angebotene Firmware "funktioniert".
    Bei älteren Elephone hat das "funktioniert".
    Du hast dabei noch mehr "Glück" gehabt : zumindest läuft dein Phone. Den Screen-Effect schreibe ich einem defekten Treiber in der Firmware zu.
    Deine Chance : warten auf eine neuere Firmware, flashen und hoffen, das die funktioniert.
    Bei mir "lebt" nur noch der "preloader". SP-Flash startet, beginnt download und bricht sofort ab mit "DA-Error".
    Somit hoffe ich auch auf eine neuere Firmware. (So denn überhaupt noch eine kommt !)

    Erkenntnis : Elephone A4 use out of the Box (ohne Eingriffe) = ok.

    Just for Info : ich habe mir noch ein Cubot Nova für 83€ zu gelegt : da hat alles ohne Probleme funktioniert !
    (Firmware 20180829 von www.cubot.net)
     
    Cris bedankt sich.
  5. Wattsolls, 22.12.2018 #5
    Wattsolls

    Wattsolls Super-Moderator & Mediator Team-Mitglied

    Also an der Stelle wäre ich stutzig geworden. Das macht Dir doch auch die Bereiche platt die nicht in der downloadbaren Stock ROM enthalten sind.
    Hast Du mit dem Flashtool kein Backup gemacht?
     
  6. Orcaflugzeug79, 22.12.2018 #6
    Orcaflugzeug79

    Orcaflugzeug79 Neuer Benutzer

    @Wattsolls Ich habe mich auch gefragt, warum man formatieren muss, zumal ich die vorherigen Male, als ich das Flashtool benutzt habe (bei anderen Geräten) eben "nur" downloaden musste. Ich dachte es wäre die richtige Entscheidung gewesen, dem Tutorial 1:1 zu folgen....dem war wohl doch nicht so...
    Ein Backup habe ich diesmal ausgelassen (ein Fehler und reiner Leichtsinn), da ich bis jetzt wirklich nur positive Erfahrungen mit flashen via Flashtool gemacht habe.

    @JamesBott Okay, dein Problem ist echt übel, ich wüsste echt nicht wie ich das in den Griff kriegen könnte...ist wohl der Preis den man dann doch zahlt, wenn man sparen will und somit zu den "unbekannteren" Modellen greift. :/


    Kleines Update meinerseits trotzdem: Nach ein wenig Recherche habe ich es mit "MauiMeta" geschafft, die beiden IMEI-Nummern einzutragen und siehe da - die SIM funktioniert wieder wie sie soll, somit ist die Grundfunktion des Smartphones wieder da. Zum Display: Nach besagten zwei OTA Updates ist die Schärfe wieder einigermaßen da und das Display weist nur noch leichte Geisterbilder auf. Mal sehen wie sich das entwickelt.

    Das Problem ist jedoch echt nicht leicht ausfindig zu machen. Wenn das Display gestreamt wird auf meinen PC, wird kein Fehler "mitübertragen". Scheint also doch in Richtung Treiber/Hardware zu gehen... (sobald das Display Suppe hat, werden die Geisterbilder auch angezeigt ._.)

    Hilft wohl nur abwarten. Wünsche trotzdem noch viel Glück mit weiteren Geräten :)
     
    Wattsolls bedankt sich.
  7. JamesBott, 22.12.2018 #7
    JamesBott

    JamesBott Threadstarter Moderator Team-Mitglied

    Das ist der Preis für "wissen wollen" und "Erfahrung machen". Für mich kein großes Problem. Noch ist das A4 nicht zu 100% tot.
    (R.I.P = ruhe in Frieden. Wie lange hat keiner gesagt :D-old )
    Wenn ich da eine funktionierende Firmware finde bin ich froher Hoffnung das A4 wieder zum Leben zu erwecken.
    Da du die IMEI restaurieren konntest (altes Problem) bleibt da nur noch warten auf Firmware die das Bildschirmproblem behebt.
    Wenn ich etwas an Firmware finde mache ich hier dann einen Eintrag.

    Edit :
    aktuell download Firmware ELEPHONE A4 update supported! - ROM download - Elephone Forum - Mobile - Powered by Discuz!
    "Elephone_A4_20180530.rar 906.7 MB"
    Bei www.elephonestore.com/firmware-download habe ich nichts zum A4 gefunden.
     
    Zuletzt bearbeitet: 23.12.2018
Die Seite wird geladen...
Ähnliche Themen Forum Datum
Elephone A4 Vorstellung Elephone Allgemein 13.12.2018
Elephone A8 Rooten Hilfe / Grundlagen Elephone Allgemein 16.09.2018
Elephone A4, beim Start erfolgt folgender Fehler "Service wurde beendet" Elephone Allgemein 15.09.2018
Elephone U2 Elephone Allgemein 07.09.2018
Elephone P8 Max rooten? (2017/2018) Elephone Allgemein 19.04.2018
Du betrachtest das Thema "Elephone A4 Root mit Magisk" im Forum "Elephone Allgemein",
  1. Android-Hilfe.de verwendet Cookies um Inhalte zu personalisieren und dir den bestmöglichen Service zu gewährleisten. Wenn du auf der Seite weitersurfst stimmst du der Cookie-Nutzung zu.  Ich stimme zu.