One X gebrickt?

  • 16 Antworten
  • Neuester Beitrag
Diskutiere One X gebrickt? im HTC One X Forum im Bereich Weitere HTC Geräte.
sinchris2000

sinchris2000

Fortgeschrittenes Mitglied
Mahlzeit zusammen.

Ein Arbeitskollege meines Vaters hat ihm sein One X mitgegeben, damit ich mir das mal anschauen kann.

Ich hatte das Gerät schon mal da. Da hat sein Junior gemeint, er müsse ihm eine Custom-Rom aufspielen und hat ihm dabei das Gerät komplett zerschossen. Nur der Bootloader funktionierte noch und es ließ sich noch laden.

Hab ihm dann Cyanogen und 'n Recovery draufgespielt und es lief wieder.

Jetzt aber hab ich das Ding nach drei Monaten wieder da, weil sein Junior gemeint habe, ich hätte ihm Mist aufgespielt.

Situation jetzt: Bootet nicht, startet kein Recovery, startet gar nicht, lädt nicht.

Mit ganz viel Glück komme ich nach etwas angesteckt lassen in den Bootloader rein (Relocked)

"Battery Level too low to flash" heißts da. Also quasi "Ich bin zu leer zum flashen"

Während das Gerät im Bootloader ist, blinkt die Lade-LED. Nach einer gewissen Zeit schaltet sich das Gerät aber wieder ab.

Meine Frage jetzt: Kann man da noch was tun, oder ist das Ding ein Fall für die Tonne? Der Besitzer möchte nun nur noch das ganz normale System vom One X drauf haben.
 
Schaeferreiner

Schaeferreiner

Guru
Kann man. Lade dir mal diesen Fastbootordner herunter und entpacke ihn nach C:/, kopiere eine CMD.exe hinein, um diese schnell starten zu können. Im Ordner ist eine laden.bat-Datei. Lass diese ein paar Stunden laufen; sie startet das Gerät ständig neu und lädt dabei Stück für Stück etwas auf. Nicht irritieren lassen. Anfänglich kann der Wert auch erst nach unten gehen, nach einer Weile sollte sich dann aber allmählich die Ladung erhöhen.
Danach kannst du das CWM-5.8.4.0-Recovery aus dem Ordner flashen und uns dann die Angaben, die dir die CMD bei fastboot getvar all ausgibt posten. Im Anschluss das Gerät über Power Down ausschalten und per Netzteil länger aufladen. Dann kann man dir weitere Tipps geben, kannst dich aber hier auch umsehen.
 
sinchris2000

sinchris2000

Fortgeschrittenes Mitglied
Erstmal danke :)

Ich habe mir den Ordner mal runtergeladen, aber eine Laden.bat ist leider nicht drin.

Hier mal der Ordnerinhalt:



Edit: Habe mir jetzt über Google mal eine Laden.bat besorgt. Der Inhalt dieser Datei ist der folgende:

Code:
" @echo off
:start
fastboot getvar battery-voltage

fastboot reboot-bootloader

ping /n 6 localhost >nul

goto start
"
Edit: So, habe es jetzt mal so laden lassen, bis der Hinweis "Too low to flash" verschwunden war.

Das Recovery lässt sich leider nicht flashen.

Der Vorgang wird mit folgendem Ergebnis abgebrochen:

Code:
C:\adb>fastboot flash recovery recovery-clockwork-touch-5.8.4.0-endeavoru.img
sending 'recovery' (5742 KB)...
OKAY [  0.851s]
writing 'recovery'...
FAILED (remote: not allowed)
finished. total time: 1.061s
Der Befehl "fastboot getvar all" gab folgendes aus:

Code:
C:\adb>fastboot getvar all
(bootloader) version: 0.5a
(bootloader) version-bootloader: 1.72.0000
(bootloader) version-baseband: 5.1204.167.31
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 4.18.401.2
(bootloader) serialno: SH24JW102279
(bootloader) imei: 353043055264967
(bootloader) product: endeavoru
(bootloader) platform: HBOOT-T30S
(bootloader) modelid: PJ4610000
(bootloader) cidnum: HTC__102
(bootloader) battery-status: good
(bootloader) battery-voltage: 3623mV
(bootloader) devpower: 0
(bootloader) partition-layout: None
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: None
(bootloader) hbootpreupdate: 2
(bootloader) gencheckpt: 0
all: Done!
finished. total time: 0.879s
Edit... wiedermal: Der Bootloader war gelockt. Den habe ich wieder geöffnet. Jetzt ließ sich auch das Recovery erfolgreich flashen.

Edit... der nächste ;) : Konnte mir nun hier aus dem Forum ein Nandroid-Backup für die richtige Version runterladen.
Bin dann gemäß der Anleitung vorgegangen und was soll ich sagen? Es läuft wieder :)

Ich danke ganz herzlich für den Anstoß mit der Laden.bat :)
 
Zuletzt bearbeitet:
sinchris2000

sinchris2000

Fortgeschrittenes Mitglied
Sorry für den Doppelpost.

Ich weiß nicht, ob das schon war, oder ob das jetzt meine Schuld ist, aber: Die Softkeys funktionieren nicht mehr...

Kann das mit dem Flashen zu tun haben?
 
Schaeferreiner

Schaeferreiner

Guru
Hast du das Stock Recovery und boot.img geflasht und danach fastboot erase cache eingegeben? Ggfs. kannst du das Backup nochmal drüber flashen (ohne Wipe), vielleicht ist was schiefgelaufen. Oder, wenn das nicht hilft, einen Factory Reset im Bootloader durchführen. Daten vorher sichern. Manchmal hilft auch, alle drei Buttons gleichzeitig mehrere Sekunden zu drücken, das soll sie zurücksetzen.
Wenn gar nichts hilft, kannst du mal schauen, ob du das Viperrom flashst und auf On Screen Buttons umstellst.
Les auch mal hier: http://forum.xda-developers.com/showthread.php?t=1827090&page=2

Wundert mich, dass die laden.bat nicht mehr in meinem Allround-Ordner ist, hatte sie eine ganze Weile drin. Hab sie jetzt wieder eingefügt.
 
Zuletzt bearbeitet:
sinchris2000

sinchris2000

Fortgeschrittenes Mitglied
Stock Recovery ist geflasht. Inklusive erase cache. Backup auch drübergeflasht. Factory Reset wurde auch gemacht. Alles aber ohne Besserung.
 
Schaeferreiner

Schaeferreiner

Guru
Dann ist es möglicherweise dieser Hardwarefehler, der im XDA-Thread beschrieben wurde. Dir bleibt aber noch, entweder gleich das Viperrom zu testen oder von dieser Seite das 4.18.401.3 Original-HTC-Rom, Recovery und boot.img zu laden und zu installieren. Möglicherweise wurde auch die Firmware beschädigt. Diese kannst du nach Installation des Roms von der ARHD-Seite und der passenden boot- und recovery.img im RUU-Modus drüberflashen, dazu muss dein Bootloader per fastboot oem lock gesperrt sein. Natürlich die Version 4.18.401.3 nehmen.
Anleitung
Die Firmware in deinen ADB-/Fastbootordner laden und in firmware.zip umbenennen. Alle Programme wie Virenscanner, Firewall und UAC (Benutzerkontensteuerung), die eine Installation stören könnten, ausschalten bzw. deaktivieren. Auch Samsung Kies Software!

Am One X muss das USB-Debugging in den Einstellungen/ Entwickleroptionen eingeschaltet und unter Power der Schnellstart ausgeschaltet sein, das Gerät sollte hochgefahren sein, um zu überprüfen, dass die Verbindung zum Gerät stabil ist.
Die CMD öffnen und eingeben
adb devices
es sollte nun die Seriennummer angezeigt werden
adb reboot bootloader
das Gerät müste jetzt herunterfahren und in den Fastboot-USB-Modus starten
fastboot devices
sollte jetzt auch die Seriennummer anzeigen
fastboot oem rebootRUU
ein schwarzer Bildschirm mit silbernem Logo von HTC sollte erscheinen
fastboot flash zip firmware.zip
die Installation läuft durch, am Ende erscheint der Hinweis Failed", das ist normal. Gleich noch einmal
fastboot flash zip firmware.zip
Nun sollte es etwas länger dauern und am Ende "Okay" stehen.
fastboot reboot-bootloader
beendet den RUU-Modus und im Bootloader sollte nun die neue Firmwareversion stehen.
Ich hoffe, das bringt die Lösung und es ist kein Hardwarefehler.
 
Zuletzt bearbeitet:
sinchris2000

sinchris2000

Fortgeschrittenes Mitglied
Hm. Also folgendes: Die Rom in der 4.18.401.3 hab ich installiert und ebenso Recovery und boot.img

Ich weiß aber grad nicht, was du mit Firmware.zip meinst oder wo ich die her krieg.
 
sinchris2000

sinchris2000

Fortgeschrittenes Mitglied
Danke dir :)

Ich hab jetzt alles der Reihe nach getan, aber leider ist das Problem geblieben.
Ich habe auch mal auf eigene Faust versucht, die Softkeys auf den Bildschirm zu legen. Habs aber nicht hingekriegt.
 
Schaeferreiner

Schaeferreiner

Guru
Dann bleibt dir nur das Viperrom oder ein ähnliches, welches die Umschaltung auf die On-Screen-Softkeys erlaubt. Vermutlich ist da was beschädigt, eine Reparatur lohnt aber nicht mehr.
 
sinchris2000

sinchris2000

Fortgeschrittenes Mitglied
Ich habe jetzt das Viperrom aufgespielt. Funktioniert mit den On-Screen-Tasten einwandfrei.

Ich danke dir wirklich vielmals für deine Hilfe :)
 
N

nixx

Neues Mitglied
Schaeferreiner schrieb:
Kann man. Lade dir mal diesen Fastbootordner herunter und entpacke ihn nach C:/, kopiere eine CMD.exe hinein, um diese schnell starten zu können. Im Ordner ist eine laden.bat-Datei. Lass diese ein paar Stunden laufen; sie startet das Gerät ständig neu und lädt dabei Stück für Stück etwas auf. Nicht irritieren lassen. Anfänglich kann der Wert auch erst nach unten gehen, nach einer Weile sollte sich dann aber allmählich die Ladung erhöhen.
Danach kannst du das CWM-5.8.4.0-Recovery aus dem Ordner flashen und uns dann die Angaben, die dir die CMD bei fastboot getvar all ausgibt posten. Im Anschluss das Gerät über Power Down ausschalten und per Netzteil länger aufladen. Dann kann man dir weitere Tipps geben, kannst dich aber hier auch umsehen.
Hallo, ich habe auch das problem mit dem "Battery level is too low to flash"...leider steht der ordner nicht mehr zum download zur verfügung...wäre es möglich, diesen noch mal zu uppen?

vielen dank im voraus nixx
 
Schaeferreiner

Schaeferreiner

Guru
Hier ist er. Dadurch, dass ich die zusätzliche laden.bat eingefügt habe, hat sich der Downloadlink anscheinend verändert. In meiner Signatur kann man auch alles Notwendige finden.
 
N

nixx

Neues Mitglied
Vielen Dank für deine hilfe...soweit hat es nun auch funtioniert, habe mittlerweile wieder 42% Akkuladung auf dem Handy...aber wenn ich titanum backup instaliere und sarte, sagt er mir "kein root" was mach ich den falsch oder muß man das handy speziell rooten?

gruß nixx
 
Schaeferreiner

Schaeferreiner

Guru
Ich habe keine Ahnung, was du bisher am Handy für Eingriffe unternommen hast (Unlock, Custom Recovery usw.)
Wenn du dich mit Root noch nicht auskennst, les dir die Anleitungsthreads hier im Forum erst einmal durch.
 
K

krapfen0123

Neues Mitglied
hallo ich hab ein ähnliches problem wenn ich die laden datei öffne kommt bei mir folgendes:


C:\>" @echo off
Der Befehl "" @echo off" ist entweder falsch geschrieben oder
konnte nicht gefunden werden.

C:\>fastboot getvar battery-voltage
< waiting for device >
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
und jetzt krieg ich diese meldung:

C:\>fastboot reboot-bootloader
rebooting into bootloader...
OKAY [ 0.683s]
finished. total time: 0.683s

C:\>ping /n 6 localhost 1>nul

C:\>goto start

C:\>fastboot getvar battery-voltage
< waiting for device >
heißt es dass es auflädt ?