1. Mitglieder surfen ohne Werbung auf Android-Hilfe.de! ✔ Jetzt kostenlos Mitglied in unserer Community werden.
  1. axperiense, 25.03.2013 #1
    axperiense

    axperiense Threadstarter Erfahrener Benutzer

    Hallo liebe Android-Gemeinde,

    ich verfolge das Geschehen hier im Forum schon eine Weile (eher passiv). Bei mir hat sich folgende Situation ergeben. Meine Kamera schien von jetzt auf gleich den Geist aufgegeben zu haben. Zu dem Zeitpunkt hatte ich Miui drauf, was eigentlich auch recht stabil lief. Hatte dann testeshalber ein Backup mit gerooteter Stock-Rom zurückgespielt. Die Kamera wurde leider immer noch mit dem Fehler "Leider wurde die Kamera beendet" beendet bzw. startete gar nicht erst.

    Da mein P1 erst gegen Mitte Januar gekauft worden ist und die Gewährleistung im Normalfall auch noch greifen sollte, habe ich mein Gerät an Amazon zurück gesendet. 10 Tage vergingen und mein Handy kam mit der Begründung zurück " Es könnte nicht repariert werden, da eine Software-Manipulation durch geführt wurde" :blink:

    zur Erinnerung, das Handy war lediglich gerootet!

    Meine Frage richtet sich jetzt an euch, wie bekomm ich das Ding wieder in den Auslieferungszustand. hab schon die Stock-Recovery zurück geflasht, aber das offizielle Update will einfach nicht funktionieren. Ich komm zwar in den Update-Modus rein und er beginnt auch zu updaten, bleibt dann aber mit dem Fehler "huawei sd card update fail" stehen. ich hatte bereits eine andere build.prop ins System geschoben, half aber auch nichts.

    Langsam bin ich wirklich am verzweifeln, wäre echt unschön, wenn das Handy nach 2 Monaten keine Kamera mehr hätte :crying:

    Vielen Dank im voraus für eure Hilfe

    LG
    axP
     
  2. Overwatch, 26.03.2013 #2
    Overwatch

    Overwatch Fortgeschrittenes Mitglied

    Ein eleganter, weil schneller Weg, ohne umstellen der Build.prop ist aus meiner Sicht:

    1. CWM/TWRP flashen
    2. Cyanogenmod 10 flashen
    3. Die Stock Firmware in den dload-Ordner schieben
    4. Die Stock-Recovery per fastboot über CWM/TWRP flashen
    5. Die Update.app über CM10 flashen
    6. Fertig :)

    Die Anzahl der Schritte hört sich schlimmer an, als das flashen an sich ist. An sich ist der Auslieferungszustand binnen ein paar Minuten wieder herzustellen.

    Ich würde auf Grund der Fehlermeldung vermuten, dass die Cam. nach dem flashen der update.app wieder geht.
    Das Einspielen eines Recovery-Images (incl. wipe) betrifft nicht alle Partitionen, sodass danach auch durchaus noch diese Art von Fehlern auftreten kann.
     
    Zuletzt bearbeitet: 26.03.2013
  3. axperiense, 26.03.2013 #3
    axperiense

    axperiense Threadstarter Erfahrener Benutzer

    Hallo,

    vielen Dank für deine Antwort! Habe alle Schritte druchgeführt. Beim flashen der Update.app kommt jedoch der Fehler "version list verify fail" und der Updatevorgang bricht wieder ab.

    LG
    axP
     
  4. Overwatch, 26.03.2013 #4
    Overwatch

    Overwatch Fortgeschrittenes Mitglied

    Kriegen wir schon hin :thumbup:

    Meine Vermutung ist, dass du die falsche Version des CM geflasht hast.
    Bitte versuche es doch mit dieser Version (nutze einen Downloadmanager, da der Download sehr lange dauern kann).

    Bitte führe vor dem Flashen des CM weiterhin alle wipes durch.
     
  5. axperiense, 26.03.2013 #5
    axperiense

    axperiense Threadstarter Erfahrener Benutzer

    Alles klar, werde ich heute nachmittag versuchen. Aber das Stock Update spiele ich doch ganz normal über Vol up. + vol down + powertaste ein, oder?

    LG
    axP
     
  6. Overwatch, 26.03.2013 #6
    Overwatch

    Overwatch Fortgeschrittenes Mitglied

    Ganz richtig. CM wird über TWRP eingespielt. Danach wird die Stock-Recovery geflasht und per Vol up. + vol down + powertaste die Update.app eingespielt.
     
  7. axperiense, 26.03.2013 #7
    axperiense

    axperiense Threadstarter Erfahrener Benutzer

    Hallo,

    habe alle Schritte durchgeführt. Update bleibt wieder mit der Fehlermeldung "version list verify fail" hängen :crying:

    Sonst noch irgendwelche Vorschläge?

    LG
    axP
     
  8. Overwatch, 26.03.2013 #8
    Overwatch

    Overwatch Fortgeschrittenes Mitglied

    Welche Stock-Rom möchtest du eigentlich per update.app einspielen?
     
  9. axperiense, 26.03.2013 #9
    axperiense

    axperiense Threadstarter Erfahrener Benutzer

    Hab schon mehrere probiert. Die b123, b219, b213, b226 nirgends tut sich was...
     
  10. Overwatch, 26.03.2013 #10
    Overwatch

    Overwatch Fortgeschrittenes Mitglied

    Hier kannst du die Stock 229 finden.

    Weiterhin kannst du es noch einmal mit dieser Cm10-Rom versuchen.

    Mich wundert der Verlauf schon etwas, da ich auf diese Weise schon X-Mal vorgegangen bin...:bored:
     
  11. axperiense, 26.03.2013 #11
    axperiense

    axperiense Threadstarter Erfahrener Benutzer

    Hab es geschafft die Meldung "Version list verify failed" zu übergehen indem ich diese "anzhi-p1-b113-lesong.zip" von Johnny Paranoia's Blog geflasht habe. Das Update läuft durch und bleibt dann bei "Partition BOOT update succes" mit der Fehlermedlung Huawei SD card update failed stehen.

    Hilft diese Info weiter?
     
  12. Overwatch, 26.03.2013 #12
    Overwatch

    Overwatch Fortgeschrittenes Mitglied

    Mir nicht, nein...

    Aus meiner Sicht muss es mit den geposteten Files durchaus funktionieren.
    Was du auch sicherlich noch einmal ausprobieren kannst, ist die SD-Karte zu formatieren (wipen per TWRP) bzw. diese zu ersetzen (halte ich zu Testzwecken für Sinnvoller, falls du noch eine hast).

    Mir ist mal eine SD-Karte beim flashen von 4.2 verreckt und es war mir danach erst wieder möglich das system neu aufzusetzen bzw. die Stock-Rom einzuspielen, als ich diese ersetzt hatte (auf Dauer ein teurer Spaß :thumbup:)
     
  13. axperiense, 26.03.2013 #13
    axperiense

    axperiense Threadstarter Erfahrener Benutzer

    Also an den SD-Cards dürfte es eg nicht liegen, da ich hier drei verschiedene verwende. Formatiert ist die Karte bislang allerdings nur am Pc, ich versuchs mal in TWRP...
     
  14. Overwatch, 26.03.2013 #14
    Overwatch

    Overwatch Fortgeschrittenes Mitglied

    Also wenn die SD-Karte ebenfalls auszuschließen ist und wir folgendes festhalten:
    -Du kennst dich mit dem Verändern der build.prop aus und hattest hierdurch keinen Erfolg
    -Du bist meinen Schritten gefolgt und hattest hiermit ebenfalls keinen Erfolg

    Dann bin ich persönlich etwas ratlos. Vielleicht hast du mit anderen Nutzern mehr Glück.
    Ansonsten hast du wohl bedingt dadurch, dass du das Handy schon einmal ein gesendet hast und abgelehnt wurdest ein Problem.

    Vielleicht kennst du ja Jemand, der dir beim Flashen helfen kann?

    Ansonsten... :thumbdn:

    Edit: Einen habe ich noch...
    Du könntest mal versuchen den bootloader wieder herzustellen.
    Der fastboot-command hierfür lautet: fastboot flash bootloader xyz.zip (dateinahme einsetzen)
     
    Zuletzt bearbeitet: 26.03.2013
  15. axperiense, 26.03.2013 #15
    axperiense

    axperiense Threadstarter Erfahrener Benutzer

    Wenn ich versuche die .zip über fastboot zu flashen erscheint in der Eingabeaufforderung folgendes:

    sending 'bootloader' (260 KB).
    OKAY [ 0.015s]
    writing 'bootloader'...
    FAILED (remote: image too large for partition
    finished. total time: 0.028s

    Hab langsam echt das Gefühl, dass ein Paar Partitionen defekt oder zu klein sind.

    Alles sehr kurios...

    Trotzdem vielen vielen Dank für deine Bemühungen Overwatch

    LG
    axP
     
  16. axperiense, 27.03.2013 #16
    axperiense

    axperiense Threadstarter Erfahrener Benutzer

    Aktualisierung:

    Nachdem ich ein altes Nandroid-Backup zurück gespielt und anschließend nochmals die build.prop modifiziert und ins /system geschoben habe. Funktionierte das Systemupdate auf B218.

    Die Kamera funktioniert leider immer noch nicht, aber ich hoffe das Handy wird jetzt wenigstens repariert. :rolleyes2:

    LG
    axP
     
  17. morpheus620, 28.03.2013 #17
    morpheus620

    morpheus620 Android-Guru

    Da hättest du einmal mit dem originalen Recovery wipen müssen.
    Hatte ich auch schon gehabt.
    Nach einem wipe lief es dann durch.
    Aber nun geht es ja.
     
Du betrachtest das Thema "Kamera defekt- Reperatur verweigert! Zurück auf Auslieferungszustand!" im Forum "Huawei Ascend P1 Forum",