Kopfhörer wird als Headset erkannt und aktiviert die Sprachsuche

  • 3 Antworten
  • Neuester Beitrag
Diskutiere Kopfhörer wird als Headset erkannt und aktiviert die Sprachsuche im Huawei Ascend Y300 Forum im Bereich Weitere Huawei Geräte.
A

Astfgl_

Neues Mitglied
Hallo ihr,

ich habe ein interessantes Problem mit meinen Y300 und meinen Co:caine City Beat. Während dem Musikhören springt immer wieder die Google Sprachsuche an, obwohl die Kopfhörer kein Mikrofon haben sollten. Es lässt sich jedoch ein kurzer Ausschlag verzeichnen, wenn man gegen die Ohrmuscheln schnippt oder das Kabel im Handy dreht.

Kopfhörer wurden schon einmal mit neuen ersetzt und das Problem besteht bei allen Roms (Original bis CM11) durchweg. Es handelt sich daher sicherlich um ein Hardware-Problem der Kopfhörer bzw. einer schlechten Klinke.

Da ich ansonsten allerdings relativ zufrieden mit den Dingern bin, frage ich mich, ob ich dem Y300 vielleicht auf irgendeine Art und Weise beibringen kann, jeglichen Eingang über die Klinke zu ignorieren, sodass weder Sprachsuche, Sprachwahl oder sonstige Sprachsteuerungen ständig aktiviert werden?

Liebe Grüße
Astfgl_
 
N512

N512

Neues Mitglied
Hallo und willkommen einmal bei uns im Forum!

Zu deinem Problem:
Bei meinem Huawei (Y300-0100) hatte ich vor geraumer Zeit das gleiche Problem.

An und für sich sollte es aber nicht das Gerät (Smartphone) betreffen aber es soll dir verziehen werden, dass du es im Geräteforum geschrieben hast. Der Fehler ist ja nach dem Wechsel deiner Kopfhörer immer noch da gewesen.

Mir hat das Problem keine Ruhe gelassen und so habe ich einige Lösungswege ausprobiert welche ich dir hier, jeweils getrennt von einander beschreiben werde.

1. Lösche deinen "App-Cache" vor dem Starten des Players.
Gehe dazu in die Einstellungen -> "Apps verwalten" -> dritter Reiter/Registerkarte/Tap -> "Cache löschen".

2. Lösche die die Prozesse "Google-Dienste" und "Google-Sprachsuche" aus dem "Prozess-Cache". Einstellungen -> "Apps verwalten" -> zweiter Reiter/Registerkarte/Tap -> Rechte obere Ecke "Prozesse im Cache anzeigen".

3. Entferne die Googel-Suche sowie die Google-Sprachsuche. Einstellungen -> "Apps verwalten" -> erster Reiter/Registerkarte/Tap

Alle diese Lösungswege können, müssen jedoch nicht funktionieren. Das anwenden meiner Lösungswege ist auf eigene Gefahr! Sie können die Funktionalität des Systems beeinträchtigen.

Auch das reinigen deiner Klinkensteckerbuchse durch kräftiges Pusten kann Abhilfe schaffen, sollte die Ursache kleine Staubkörner sein.

Ich habe bei mir diese beiden Google-Apps deinstallieren müssen, jedoch kann es auch sein, dass ein Miniknick im Kopfteil des Steckers (am Kopfhörer/Headset) für minimale Abbrüche oder eine Fehlerhafte Weitergabe von Signalen sorgen kann, welche vom System als eingehende Audiosignale eines (in deinem Fall nicht vorhandenen) Mikrofons, missinterpretiert werde.

Liebe Grüße N512
 
P

Poldi123

Neues Mitglied
Das scheint schon recht speziell das Y300 zu betreffen . . .

Hier habe ich das auch schon geschildert: Huawei Ascend Y300 - Probleme / Bugs / Fehler [Sammelthread] - Seite 4

Der Adapter hilft, geht aber leider schnell kaputt . . Ich habe mittlerweile die Sprachsuche und die Googlesuche deaktiviert, das hilft etwas. Trotzdem kann es passieren, dass eine Bewegung des Kopfhörers dazu führt, dass ein Lied vorgesprungen oder pausiert wird. Vielleicht kriegt man das aber noch irgendwo wegkonfiguriert.

Poldi123
 
N512

N512

Neues Mitglied
Bezüglich dem "Vorspringen" bzw. dem "Pausieren" deiner Lieder musst du dich mit deiner App auseinander setzten. Je nachdem wie intelligent der Programmierer der App war, kannst du deiner App dieses Verhalten abgewöhnen (Stichwort: Einstellungen)