Läuft mittlerweile Android Auto auf Android 8 (Oreo)

Metallik

Metallik

Neues Mitglied
Threadstarter
Moin,
wie im Betreff angegeben hat meine Frau bisher darauf verzichtet von Android 7 auf Android 8 (Oreo)
umzusteigen weil die App "Android Auto" wahrscheinlich darauf nicht mehr läuft, lt. andere threads und leider selbst erfahren müssen. Huawei kennt dasProblem lt. Kundenservice
Ich wollte deshalb fragen, ob es für ihr Smartphone P8 Lite 2017 ein Bugfixed gibt, so dass Android
Auto auf externen Geräten (Autoradios) wieder läuft.
Bei einem P10 lite hatten wir nämlich dieses Problem als wie von Nougar auf Oreo updateten.

ciao Ronny alias Metallik
 
Frankonair

Frankonair

Stammgast
@Metallik Android Auto läuft auf dem P8 lite 2017 völlig probemlos. Ich habe es seit 1,5 Jahren im Einsatz.
Wo soll es denn Probleme geben?
Habe einen Golf 7 . Entertainment System hat die Funktion App Connect. Läuft einwandfrei.
 
Metallik

Metallik

Neues Mitglied
Threadstarter
Hallo Frankonair,
ich hatte ein Huawei P10 lite (ein halbes Jahr alt) und nach dem Update von Android 7 auf Android 8 hat das Smartphone nicht mehr mit dem Kenwood 7017 DABS Radio über Android Auto connected. Ich rief daraufhin den Huawei Kundenservice an. Dort teilte man mir mit, dass der Fehler bekannt sei mit Oreo und Android Auto und das dies auch mehrere Huawei Modelle beträfe. Man arbeite an einer bugfreien Android Version. Ich hinterließ bei Huawei meinen Namen, Tel.-Nr. IMEI, man wolle sich bei mir melden so die Service-Dame. Das war vor gut 6 Monaten. Meine Frau hat ein Huawei P8 lite 2017 und da haben wir natürlich das Firmware-Update von Android 7 auf Android 8 unterlassen, damit ihr das nicht auch passiert. Ich habe mein P10 lite verkauft, weil Android Auto sehr wichtig für uns ist und habe jetzt ein Nokia 8 mit Android 8 - mittlerweile sogar Android 9 und das läuft mit dem Kenwood-Radio und Android Auto.
Deshalb wollte ich wissen, pb es schon eine fehlerfreie und 100% funktionierende Oreo-Version für Huawei Smartphones gibt. Es steht heute wie vor 6 Monaten, dass ein Update für ihr Handy bereit liegt. Aber welche? Die alte Oreo wo höchstwahrscheinlich Android Auto nicht funktioniert oder eine modifizierte fehlerfreie Version? Deshalb meine Frage. Du musst wissen, dass Android Auto einen großen Teil bei uns abdeckt. Ein Nichtfunktionieren heisst, dass das Smartphone beinahe unbrauchbar wird.
 
Frankonair

Frankonair

Stammgast
@Metallik
Seit dem Upgrade von Nougat auf Oreo ist nun wirklich schon viel Wasser den Rhein hinunter gelaufen. Wenn du jetzt installierst, wirst du natürlich die ganzen Patches und Verbesserungen(meine sogar Wifi Calling und VoLTE) mit installiert bekommen.
Ob das sich jetzt zu 100,0000 % mit deinem Kenwood Radio verträgt, kann ich natürlich nicht zusichern.
Bei Android bleibt immer ein kleines Restrisiko. Allerdings kann ich nur mein VW Entertainment System hervorheben und da funktioniert alles blendend.
Ihr habt doch auch den Bildschirm vom Auto im Einsatz?(oder Smartphonedisplay?)
Am Anfang konnte man, wenn man über die HiSuite installierte, auch danach wieder ein Downgrade zurück zu Nougat machen. Bei mir geht es nicht mehr, aber vieleicht noch bei euch, weil ja das erste Mal.
 
Metallik

Metallik

Neues Mitglied
Threadstarter
Genau. Der Bildschirm des Autoradios zeigt alles an. Mit dem P10 lite war aber der Android Auto Button deaktiviert, sprich nicht mehr aufrufbar ab Oreo.
Bluetooth FSE funktonierte. Ist natürlich blöd. Oreo auf dem P8 lite 2017 zu installieren umd dann evtl. festzustellen, dass Android Auto nicht funktioniert,
Gehts nach meiner Frau, sollte Android 7 drauf bleiben. So wichtig ist das Oreo ihr nicht.
 
Frankonair

Frankonair

Stammgast
@Metallik
Das der Andrid Auto Button deaktiviert war, halte ich für unmöglich. Es sei denn der Wechsel hat nicht richtig geklappt, was man dann halt nochmal anstossen sollte, oder aber die Android Auto app sollte man halt einfach neu installieren,was du bestimmt gemacht hast. Mit NEU(!) meine ich komplett vom Gerät löschen, den cache leeren und dann frisch downloaden.

Seufz..... ich frage mich immer warum Leute, wie du z.B.,Threads in den Foren eröffnen ? Ist jetzt nicht böse gemeint, aber wenn dir hier User ihre Erfahrungen mitteilen, aber du(oder deine Frau) sich sowieso nicht traut, ab das nächst BS zu updaten, warum willst du dann wissen, ob es bei anderen funktioniert?
Zumal dann zum Schluss die Aussage kommt, dass deiner Frau Oreo sowieso nicht wichtig ist.

Android 7 ist seit dem erscheinen von Android 9 sowieso langsam ein Stiefkind und wie lange ihr noch Sicherheitspatches, oder gar Verbesserung bekommt, steht in den Sternen.
Android Januar-Patch: Google verteilt Sicherheitsupdates

Vieleicht hättest du beim P10 lite(hat nämlich meine Frau) einfach mal den einen , oder anderen Patch abwarten sollen, bei meiner früheren Verlobten funktionert es auf jedenfall einwandfrei.
Natürlich hat Google den Wahnsinn zu verwalten, was im Grunde aber ihrer Vermarktungspolitik aus den Anfängen geschuldet ist, dass sie genau wie Microsoft Windows , auf allen denkbaren Geräten laufen müssen. Wärend Windows aber hier eingeschränkter vom Umbau, von einzelnen Hardwarehersteller ist, können solche bei Android tun und lassen was sie wollen. (zumindest früher).
Die Folge ist ein Sammelsurium von Sch..... äh Hardware, die bei vielen anderen Geräten, wie z.B. Autoradios zicken.

Wenn du das einschränken willst, dann solltest du dich aus dem Billig/Mittelklasse Segment verabschieden und zu den Flaggschiffen wechseln, was aber einen potenten Geldbeutel voraus setzt. Leider ist aber noch nicht mal hier zu 100% gewährleistet, dass es mit jedem Gerät reibungslos funktioniert.

Oder du gehst gleich zu Apfel, denn durch immer nur ein aktuelles BS , viel weniger Fragmentierung, laufen diese Smartphones am Anfang oft besser mit anderen Geräten. Wo wir aber wieder beim Preis wären.

Huawei hat hier vieles in den letzten Monaten richtig gemacht, allen voran mit ihrer inzwischen vorbildlichen, monatlichen , Patchversorgung.
 
Metallik

Metallik

Neues Mitglied
Threadstarter
@ Frankoair: Ich muss hier mal einiges klarstellen:
1. Behaupte bitte nicht, dass der Android Button auf dem Display des Kenwood Autoradio 7017 aktivieret wird, wenn es nicht so ist. Der Android Button bleibt grau und inaktiv, wenn man Huawei P10 lite mit dem Autoradio per USB verbindet, seit Oreo-Update. Wenn du das für unmöglich hältst kann ich nichts dafür. Aber es ist nun mal so. Egal ob Android Auto deinstalliert und gelöscht wurde, wie du es beschrieben hast, es half alles nicht. Eine Verbindung P10 klappt seit Oreo-Update nicht.

2. Ich hatte erklärt - vielleicht hattest du es überlesen - dass ich sogar den Support von Huawei informiert hatte. O-TON der Dame am Telefon:
Wir wissen davon, dass einige unserer Geräte mit dem neuen Oreo i.V.m. der App Android Auto Verbindungsprobleme haben. Wir arbeiten daran.
Ich musste Name, Anschrift, Geräte-Nr. IMEI und AutoRadio Hersteller, Modell und Type, hinterlassen. Ein Patch - Update sollte dann in absehbarer Zukunft kommen, Bis jetzt kam nichts. Mein Schwiegersohn hat nämlich jetzt das P10, deshalb weiß ich es..

3. Dein Seufzer in allen Ehren. Aber meine Frau oder ich sollen jetzt testen, ob evtl. ihr P8 und Oreo mit AA läuft und sich mit dem Autoradio, nur weil dein Huawei noch nie Probleme hatte mit deinem VW Radio? Nein das reicht mir nicht, Wir sind keine Versuchskanickel. Ich möchte nur wissen, ob es eine fehlerbereinigte Oreo-Version gibt.

4. Wir haben 3 Monate gewartet auf einen Patch. Nichts kam. Da Android Auto 80% unsere Anwendungen bei den Smartphones habe ich das P10 meinem Schwiegersohn gegeben. Dem ist es egal ob AA funkt. Wie lange hätte ich denn warten sollen, deiner Meinung nach in der schnelllebigen Smartphonewelt?

5. Auch die sogenannte Oberklasse Mate xx etc. hat das Problem. Noch ärgerlicher. Man kauft sich eine Kuh, um ein Glas Milch zu trinken, die dann genauso sauer schmeckt, als wenn man 1 Liter Tetra-Pak-Milch gekauft hätte?! Ich bitte dich....

6. Ich bin zu Nokia mit reinem Android und nicht rumgepfuschtem Android weil manch Hersteller seine Apps ggü. den Google-Standard-App austauscht.
Das hat nämlich Huawei gemacht. So werden ankommende Telefonate, während Android Auto läuft nicht im Display des Autoradios angezeigt. In Teltarif stand dann auch woran das liegt. Ich kann dir gerne den Artikel raussuchen, falls interessiert. Ich hatte mich nur immer gewundert, warum da
1, 2, 3 Anrufe als nicht angenommen im Display stand, wenn man Android Auto beendete.

7. Huawei hat - wenn überhaupt - Fehler behoben, die sie vorher eingebaut haben. Schön, dass du das schon super findest.

8. Nach soviel Mutmaßungen die nicht zutreffen wieder zum eigentlichen Thema. Gibt es gepatchte Oreo Version für das P8 lite? Die Android 8 Version, die anfangs vor gut einem halben Jahr raus kam ist bekanntermaßen nicht fehlerfrei.

schones WE
 
snakey41

snakey41

Ambitioniertes Mitglied
Hallo, ich hatte ja unter Android 8 mit meinem Xiaomi das Problem, das die Anzeige imDisplay um ein Drittel nach unten gerutscht war und ich nicht navigieren konnte. Jetzt ist durch irgendein Update (mittlerweile Miui Global 10.2) das Problem wohl behoben (Bild wird richtig dargestellt), allerdings friert bei "Naviagation starten" das Bild des öfteren unregelmässig ein und es erscheint die Anzeige "warten", aber es passiert nichts. Nach diverser neueingabe der Navigation funktioniert es dann wieder.
 
Frankonair

Frankonair

Stammgast
Das ist Android. Zu 100% läuft meist gar nichts. Es ist aber wesentlich besser geworden und Android Auto läuft unter Oreo auf dem P8 lite 2017 fast 100%tig. (Ab und zu, wenn man zu schnell anruft, nachdem man per USB verbunden hat, gibt es keinen Ton, bzw. hat sich bluetooth noch nicht verbunden. Das ist aber kurze Zeit später passe)
 
Metallik

Metallik

Neues Mitglied
Threadstarter
Vielleicht ist es aber auch wirklich die Gerätezusammenstellung und Oreo mit Android Auto mag diese Konstellation nicht. Bei uns Huawei Smartphone mit Oreo Verbindung mit Radio Kenwood 7017 DABS per USB. Natürlich glaubt man ja zuerst an Oreo als Fehlerquelle, weil es ja unter Android 7 Nougat lief.
Aber es hilft ja schon weiter, dass diie von mir oben genannte Zusammenstellung nicht funkt., es aber bei anderen Autoradios geht, wie bei dir mit dem VW-Radio.
 
Frankonair

Frankonair

Stammgast
Anfügen möchte ich noch, dass es allein mit dem VW Entertainmentsystem auch nicht klappt. Man muss schon einen Baustein haben , der sich App Connect nennt. Das ist eine Option, die man sich bei VW freischalten lassen , oder halt beim Neukauf als Extra auswählen muss.
 
Frankonair

Frankonair

Stammgast
Hier nochmal der Beweis, dass man über die HiSuite jederzeit wieder zu Android 7 zurückkehren kann, wenn es Probleme gibt. Das Rollback ist also noch aktiv.
 

Anhänge

Metallik

Metallik

Neues Mitglied
Threadstarter
Letztes Update behob den Bug. Android Auto connected wieder mit Radio Kenwood DX7017 DABS. Auch das P10 Lite - das Smartphone was ich verkauft hatte, weil Android Auto sich nicht verbinden ließ - läuft auch wieder.
 
snakey41

snakey41

Ambitioniertes Mitglied
@Metallik ja, bei mir läuft es (bis jetzt) seit kurzem auch wieder ohne Probleme
 
snakey41

snakey41

Ambitioniertes Mitglied
jetzt habe ich eine neue Fehlermeldung: "Ihre Internetverbindung erscheint derzeit nicht stabil" Diese meldung höre ich, wenn ich die Adresse über Mikrofon einspreche.
Gebe ich die Adresse manuell ein, startet die Navigation. Ich verzweifele langsam. Woran liegt das jetzt jedes Mal? An AA, an der Android Version oder am Smartphone???????????????
 
Frankonair

Frankonair

Stammgast
@snakey41
Vieleicht ist die Internetverbindung nicht stabil?
 
F

funkyluke

Neues Mitglied
@Metallik : Welche Version hast du jetzt ? Mein Vater hat mit seinem P10 Lite und dem Alfa Radio dasselbe Problem, aber mit WAS-LX1A 8.0.0.390 klappt es immer noch nicht (Radio wird nicht erkannt)
 
snakey41

snakey41

Ambitioniertes Mitglied
@Frankonair die ist bis jetzt immer stabil gewesen (Ruhrgebiet mit entsprechender Abdeckung) es ist einfach mal wieder eine neue Fehlermeldung nach den altbekannten
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
@funkyluke meinst du welche Android Version ? 8,1.0
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
AA Version 4.1.59044
 
Oben Unten