Falscher Anhang

  • 12 Antworten
  • Neuester Beitrag
Diskutiere Falscher Anhang im K9 / K-@ Mail / Kaiten Mail im Bereich E-Mail.
J

jagibtsdas

Fortgeschrittenes Mitglied
Hallo,
ich habe ein Tablet mit Android 5.0, sowie ein Handy mit Android 7.0.
Bei beiden nutze ich die Mail App K9.
Jetzt passiert eine komische Sache.
Ich bekam heute auf beide Geräte, die Lesebestätigung für eine von mir am 11.07. versandte Nachricht an eine Bank. Die Sachbearbeiterin hatte Urlaub.
Diese Lesebestätigung enthielt ein Foto als Anhang. Ist eigentlich unüblich. War, soweit ich weiss, noch nie dabei.
Das Foto zeigt aber meine Sachbearbeiterin meiner anderen Bank.
Auf dem Tablet ist das Foto in Klarsicht im Thumb Format.
Das Handy zeigt als Anhang nur das Android Männchen, welches ich nicht öffnen kann.
Auf dem PC nutze ich Thunderbird, da ist kein Anhang. Ebensowenig im 1u1 Webmailer.
Komisch, gell?
Danke für die Mühe
 
L

LeCardinal

Fortgeschrittenes Mitglied
Auf dem Handy ist die Nachricht offenbar noch nicht vollständig heruntergeladen. Gibt es bei der Nachricht auf dem Handy unten einen Button "Gesamte Nachricht herunterladen"?
 
J

jagibtsdas

Fortgeschrittenes Mitglied
Dieser Zusatz erscheint in Reintext in Thunderbird auf dem PC.

Final-recipient: RFC822; Xxxxxxxxxx@xxxxxxxDisposition: automatic-action/MDN-sent-automatically; displayed X-MSExch-Correlation-Key: 2hhhJ4VOAUKzVuJ6cOOTiQ== Original-Message-ID: <xxxxxxxxxxxxxxxxxxxxxxxxx> X-Display-Name: xxxxxxxxxx (Die XXXX sind von mir.)

Beim Handy und Tablet erscheint dieser Text nicht in der mail. Stattdessen ist dort ein Anhang.
Speichere ich den und öffne ihn im Dateimanager unter noname mit dem Editor, erscheint der Text, den ich oben genannt habe.
Beim Handy ist das ok. Beim Tablet auch.
Kann schon sein, dass die K9 das nicht in die mail einbindet, sondern als Anhang.

Aber da ist halt dieses Bild. Kein Bildformat wie jpg oder png, Die Datei heisst noname und ist eine reine Textdatei
Das Foto hat definitiv nix mit der mail zu tun.
Ich habe das Foto niemals runtergeladen oder gar gespeichert. Wozu auch? Vielleicht habe ich mal vor Monaten draufgeklickt um es zu vergrössern. Keine Ahnung. Irgendwie muss das ja im Cache gelandet sein.

Heute war ich im PC Laden. Der konnte sich auch keinen Reim drauf machen.
Höchstens, dass dieses Bild irgendwo im Cache schlummerte.
Wieso, weshalb, warum, das jetzt ausgerechnet in einer mail auftaucht, wusste der auch nicht.

Ich hoffe, dass ich den Sachverhalt nun etwas klarer darstellen konnte.

Yepp, die Nachricht ist vollständig heruntergeladen.
 
L

LeCardinal

Fortgeschrittenes Mitglied
Öffne in Thunderbird mal den Quelltext der Nachricht (Nachricht öfnen, Menü "Ansicht/Nachrichtenquelle") und schau ihn Dir an. Ich bin mir ziemlich sicher, dass Du da auch einen Part mit Bilddaten findest.
 
J

jagibtsdas

Fortgeschrittenes Mitglied
Den Quelltxt habe ich gefunden. Damit kann ich aber rein garnix anfangen. Sorry.
Hier reinstellen kann ich ihn aber auch nicht, denn der ist so umfangreich, dass es wahrscheinlich den Rahmen dieses Forums sprengen würde.:biggrin:
Gibt es denn bei K9 keinen Quelltext?

Ich ordne halt den Vorgang einfach unter "man muss sich nicht alles erklären können, schon garnicht im Internet" ein.
Ein Virus ist es nicht, denn wie sollte der denn wissen, wie meine Kundenberaterin ausschaut.:confused2:

Ich weiss zwar, dass man für jedes Problem einen eigenen Thread eröffnen soll, aber vielleicht gehts ja ratz fatz.

Warum ist das so? Fahre ich mit der Maus über ein Rechteck, zeigt es mir die Funktion an.
Bei anderen Foren ist es ok.
Danke schonmal.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
neue Info:
Ich habe besagte Lesebestätigung an meine 2. mail Adresse weitergeleitet. Auf dem Tablet und dem Handy erscheint die Nachricht mit dem Anhang "Noname" aber diesmal ohne Bild.
Der Anhang hat 269 kb, jetzt und in der Lesebestätigung mit Bild.
Also nochmal: Das Bild war einfach nur da, ohne irgendeine Dateigrösse.
Vielleicht kannst dir jetzt einen Reim drauf machen.
 

Anhänge

L

LeCardinal

Fortgeschrittenes Mitglied
jagibtsdas schrieb:
Den Quelltxt habe ich gefunden. Damit kann ich aber rein garnix anfangen. Sorry.
Hier reinstellen kann ich ihn aber auch nicht, denn der ist so umfangreich
Es ist eine E-Mail von Deiner Bank. Deren Quelltext solltest Du keinesfalls im Forum posten!

jagibtsdas schrieb:
Gibt es denn bei K9 keinen Quelltext?
Nicht so direkt. In der Datenbank von K9 werden die Teile einer E-Mail getrennt gespeichert. Wenn K9 einen Menüpunkt für den Quelltext hätte, wäre das schön, aber es wäre dann auch nicht der originale, wegen des Datenbankkonzeptes.

So, aber nun gib Dir doch noch einmal etwas Mühe mit dem Quelltext in Thunderbird. Eine E-Mail besteht in der Regel nach dem Header aus mehreren Teilen. Der Header interessiert hier nicht. Aber die Beschreibung der anderen Parts wäre zunächst einmal interessant.

Ein Part einer E-Mail fängt mit einer ID gefolgt von einer Zeile mit dem "Content-Type:" an.

Beispiel:
Code:
--_ID_Nr1_
Content-Type: multipart/alternative;
        boundary="_ID_Nr2_"


--_ID_Nr2_
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

... irgendein Text

--_ID_Nr2_
Content-Type: text/html; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

... HTML-Geraffel

--_ID_Nr2_--

--_ID_Nr1_
Content-Type: image/png; name="bild.png"
Content-Description: bild.png
Content-Disposition: inline; filename="bild.png"; size=1234;
        creation-date="Thu, 26 Jul 2018 13:59:59 GMT";
        modification-date="Thu, 26 Jul 2018 13:59:59 GMT"
Content-ID: <bild.png@0815.4711>
Content-Transfer-Encoding: base64

... Bilddaten

--_ID_Nr1_--
Die Struktur Deiner E-Mail könntest Du hier posten und dann sehen wir weiter.
 
J

jagibtsdas

Fortgeschrittenes Mitglied
Also jetzt muss ich was gestehen.
Die Original Mail mit der Lesebestätigung habe ich gestern gelöscht.

Der Inhalt war aber genau wie dieser da, den ich vom Tablet an TB weitergeleitet habe.

Ihre Nachricht

An: xxxxxxxx
Betreff: Konten: xxxxxxxxxxxxx
Gesendet: Mittwoch, 11. Juli 2018 10:31:27 (UTC+01:00) Amsterdam, Berlin, Bern, Rom, Stockholm, Wien

wurde am Mittwoch, 25. Juli 2018 08:48:56 (UTC+01:00) Amsterdam, Berlin, Bern, Rom, Stockholm, Wien gelesen.





Final-recipient: RFC822; xxxxxxxxx@xxxxx
Disposition: automatic-action/MDN-sent-automatically; displayed
X-MSExch-Correlation-Key: 2hhhJ4VOAUKzVuJ6cOOTiQ==
Original-Message-ID: xxxxxxxxxxxxxxx@xxxxxxxxxx
X-Display-Name:xxxxxxxxx

(Weil ich das Original in Thunderbird gelöscht habe, habe ich die Originalmail vom Tablet an meine andere Mail Adresse geschickt.)

Die Content Types aus dem Quellcode hierzu, nach bestem Wissen u. Gewissen durchsucht:
mehr Content Types stehen da definitif nicht.

Content-Type: multipart/mixed; boundary="
Content-Type: multipart/alternative; boundary=
Content-Type: text/plain;
Content-Type: text/html;
charset=utf-8
Content-Transfer-Encoding: quoted-printable

<html>
<head>
<meta http-equiv=3D"Content-Type" content=3D"text/html; charset=3Dus-ascii=
">
<meta name=3D"Generator" content=3D"Microsoft Exchange Server">

Content-Type: message/disposition-notification;
name="noname"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename="noname";
size=269


Zum besseren Verständnis habe ich von der Original Mail (Tablet) einen screenshot gemacht.

Die Dateigrösse ist 269 B, nicht wie vorher fälschlich geschrieben 269 kb .
So, natürlich ohne die blauen Balken sah die Original Mail aus
 

Anhänge

Zuletzt bearbeitet:
L

LeCardinal

Fortgeschrittenes Mitglied
jagibtsdas schrieb:
Content-Type: message/disposition-notification;
name="noname"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename="noname";
size=269
Der obige Part der Mail ist ganz offensichtlich der Übeltäter. Der Inhaltsubtyp "disposition-notification" darf eigentlich nicht als "attachement" ausgeliefert werden und vor allem sollte der Inhalt strukturierte Informationen enthalten, welche vom Mailserver oder -client automatisch verarbeitet werden können, Bilder gehören nicht dazu.

Den Inhalt des Parts könntest Du einmal dekodieren (z.B. hier: Base64 Decode and Encode - Online) und das Ergebnis als jpg- oder png-Datei speichern. Dann siehst Du wahrscheinlich das Bild Deiner Sachbearbeiterin.

Falsche Mailstrukturen findet man ab und zu und Clients gehen damit unterschiedlich um. Was mich aber stutzig macht ist, dass eine Bank überhaupt eine Lesebestätigung verschickt. Das machen Firmen und erst recht Banken normalerweise nicht.
 
J

jagibtsdas

Fortgeschrittenes Mitglied
Keine Bedenken wegen Lesebestätigung.
Auf jede meiner mails hat sie eine Bestätigung geschickt.
Das waren bestimmt 15 oder 20 mails.
Die Antwort auf meine Anfragen kam dann mehr oder weniger zeitnah.
(Ich habe das Konto meiner verstorbenen Mutter online geführt. Weil die Bank 200 km weit weg ist, war erhöhter mailkontakt)

Ich hoffe, dass ich mich mit dem decoden nicht zu blöd anstelle.
Schau bitte mal: So schauts auf dem PC aus, nachdem ich auf decoden geklickt habe.
Auf dem Tablet habe ich vorher das Ganze auch versucht, da kam bei decoden garnichts, (Result goes here) aber bei upload file kam ein Bild.
Aber das war eine Hexe auf einem Besenstiel, das ich mal mit dem Messenger (Telegramm) zum Weltfrauentag verschickt habe.
Definitiv nicht meine Sachbearbeiterin.:biggrin:

Habe ich beim Decoden was falsch gemacht?
muss ich da noch was einfügen?
Malformed input... :(

Es ist äusserst lobenswert, dass du mir so hilfst.
Ich muss schon sagen, dass dein Wissensstand enorm ist.

Danke einstweilen
 

Anhänge

L

LeCardinal

Fortgeschrittenes Mitglied
jagibtsdas schrieb:
Schau bitte mal: So schauts auf dem PC aus, nachdem ich auf decoden geklickt habe.
Nicht den Header des E-Mail-Teils decodieren, sondern dessen Inhalt. Der sieht so ähnlich aus, wie die folgenden 2 Zeilen:
Code:
IDC9AcZl54beOBJOuq2SO403Nzc3+r/76//ZNGRzLSDF3sn3usZuLT886oqX+Lci0MkOTUvTTGsq
XNHkcTS7vr18na6XWRobdUwmVEXB5geDATm1Wm5sz/f8cL1eb5JUpZos2bAtrTMqMQwvtPwJGgAp
...
 
J

jagibtsdas

Fortgeschrittenes Mitglied
Das Ergebnis war genau das Gleiche wie eingangs im Thread 3 gepostet.

Final-recipient: RFC822; xxxxxx@xxxxxxxx
Disposition: automatic-action/MDN-sent-automatically; displayed
X-MSExch-Correlation-Key: 2hhhJ4VOAUKzVuJ6cOOTiQ==
Original-Message-ID: xxxxxxxxxxxxxxxx@xxxxxxxxx
X-Display-Name: xxxxxxx
Erscheint mir logisch, da das Bild ja nur auf dem Tablet war.
Ich habe jetzt hin und her probiert, um diesen Quelltext aufs Tablet zu bringen.
Ich hab den in eine mail kopiert und in den Decoder eingegeben. Kein Bild.
:confused2:
Am einfachsten wäre ja, diesen Quelltext im Forum über den PC einzugeben. Dann erscheint er ja auch, wenn ich das Forum im Tablet öffne.
Aber ich möchte natürlich nicht, dass jeder meine Mails lesen kann.
So jetzt habe ich den Quelltext im Tablet decodiert. Das Ergebnis ist das Gleiche wie beim PC.

Final-recipient..... usw
Euer Hochwürden. ;-)

Mir war unter Anderem halt auch wichtig, dass das kein Virus oä ist.
Das kann man, denke ich ausschliessen.
Schleierhaft ist das trotzdem.
Gehen wir halt mal davon aus, dass es fehlerhafte Mailstrukturen sind und K9 ist damit anders umgegangen als TB.


Gute Nacht und nochmal vielen Dank für deine prima Hilfe.
 
Zuletzt bearbeitet:
L

LeCardinal

Fortgeschrittenes Mitglied
jagibtsdas schrieb:
Das Ergebnis war genau das Gleiche wie eingangs im Thread 3 gepostet.
Gut, diese Informationen gehören in den "Content-Type: message/disposition-notification".

Ich würde noch den HTML-Teil (Content-Type: text/html) nach einem Image-Tag durchsuchen.
HTML:
<img ... >
Dann kannst Du sicher sein, dass die E-Mail kein Bild enthält.

Wenn Du im Quelltext keine Bilddaten findest, besteht noch die Möglichkeit, dass auf dem Tablet die K9-Datenbank fehlerhaft ist.

Leider hast Du die E-Mail schon gelöscht, sonst könntest Du prüfen ob bei einer Neuinstallation von K9 auf dem Tablet das gleiche Ergebnis erscheint.
 
J

jagibtsdas

Fortgeschrittenes Mitglied
Ich würde noch den HTML-Teil (Content-Type: text/html) nach einem Image-Tag durchsuchen.
HTML:
<img ... >
Dann kannst Du sicher sein, dass die E-Mail kein Bild enthält.
Da ist im gesamten Quelltext kein [<img ... >

Leider hast Du die E-Mail schon gelöscht schrieb:
Also die Originalmail (mit dem Foto) habe ich schon noch auf dem Tablet.
Diese Originalmail habe ich an meine andere mail Addy geschickt, weil ich die TB Mail schon gelöscht hatte.
Wenn ich also K9 neu installiere, wären dann die mails nicht verschwunden, sondern in der Datenbank von K9 trotzdem noch vorhanden. Richtig?
Das mach ich jetzt mal einfach und werde anschliessend berichten.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Nach Neuinstallation: Besagte mail da, Bild weg.:thumbsup:
Dann hätten wir das geschafft.
Was heisst wir? Du!!!
Dafür meinen herzlichen Dank.
Bleibt halt immer noch die Frage, wieso weshalb warum, war dieses Bild überhaupt da?
Ich habe das niemals, zu keinem Zeitpunkt runtergeladen. Wie kann das dann überhaupt in die (fehlerhafte) Datenbank von K9 gelangen.
Aber wie schon geschrieben: Ich muss nicht alles verstehen.