Probleme mit Standort in Kitkat

  • 18 Antworten
  • Neuester Beitrag
Diskutiere Probleme mit Standort in Kitkat im LG G2 (D802) Forum im Bereich Weitere LG Geräte.
L

lasy

Neues Mitglied
Ich habe dazu noch nichts gefunden, daher schildere ich mal mein Problem.

Ich habe die 32 gb Variante und Original Kitkate drauf, immer wenn ich den Standort an mache, fragt er mich ob ich die Google Nutzungsbedingungen zur Standortnutzung zustimme. Ich kann das dann ablehnen oder auch dem ganzen zustimmen, je nachdem werden meine Arten den Standort zu finden verändert, so weit ja alles im Lot

Nur danach findet er den Standort nicht, egal bei welcher App und bei welcher Auswahl in den Nutzungsbedingungen, das Handy sagt mir immer nach einer Weile Standort nicht ermittelbar.

Dann hab ich die Standortsuche mal oben in der Leiste aus gemacht und danach wieder an und dann Fragt das Handy mich schon wieder, ob ich die Nutzungsbedingungen zu den Standortdiensten zustimme. Da fängt es ja an schon merkwürdig zu werden.

Ich kann es beliebig oft wiederholen und immer wieder fragt er mich nach der Zustimmung und das G2 findet den Standort nicht.

Jetzt wird es echt komisch: Wenn ich die Standortdienste anlasse und das Handy neustarte, bleiben das GPS natürlich beim Neustart an, dann kann ich meinen Standort auch finden. Es gibt gar kein Problem. Wenn ich die jetzt wieder aus mache und später noch mal an fragt mich das Telefon wieder nach der Zustimmung zu den Nutzungsbedingungen und natürlich findet er danach meinen Standort nicht mehr.

Falls das Problem auch jemand Anderes hat oder eine Lösung wäre ich für die Hilfe sehr dankbar.

Ps: Ich hab dem Telefon schon alle möglichen Rechte gegeben das hilft gar nichts. Das Problem besteht auch erst seit dem Update auf Kitkat.
 
Zuletzt bearbeitet von einem Moderator:
D

daddle

Lexikon
Wenn du den Standort anschaltest fragt Google immer ob du den Google Nutzungs-Bestimmungen zustimmst um anonyme Standort-Daten zu erfassen (z.B. um ortsbasierte Werbung auf deinem Display beim Browsen anzuzeigen zu können).
Dies wird bei jeder Standort-Aktivierung aus oben geschilderten Gründen erneut abgefragt, um die lukrativen Werbeeinblendungen zu ermöglichen!
Wenn du das ablehnst , kommst du zu den ( Einstellungen) > Standort, dort zuerst oben rechts den Schieber auf "An", dann den Modus auswählen:

1. Hohe Genauigkeit ( mit GSM /Mobilfunk u. GPS), oder
2. Energiesparmodus ( wie oben aber ohne GPS), oder
3. Nur Gerät ( GPS alleine).

Wenn du "Nur Gerät" auswählst, wird GPS eingeschaltet, und Maps oder GPS-Status zeigt dir dann, je nachdem wann du das letzte Mal GPS genutzt hast, deinen Standort innerhalb von 30 sek. bis zu einigen Minuten später an.
Wenn du Standort und "Nur Gerät" beim rebooten aktiviert lässt, geht die Standort-Bestimmung schneller.
Dann lädt Android schon beim Betriebssystem-Start die Konfiguration für den GPS -Chip, und fängt dann direkt an den Almanach (die Satelliten- Bahndaten) zu laden, schaltet man GPS erst nach dem Start an, dauert es also länger.
Ausserdem ist es nicht immer möglich in geschlossenen Räumen einen GPS-Fix zu bekommen, da die Satelliten-Signale sehr schwach sind, und dicke Mauern und Stahlbeton wirksame Abschirmungen für die Signale bilden! Dann kann es passieren dass kein Standort gefunden wird.

Allerdings sollte es bei Einstellung "Hohe Genauigkeit" über GSM und W-Lan schneller einen angenäherten Standort-Fix geben, der dann durch die eintrudelnden GPS-Signale präzisiert wird. Voraus gesetzt du hast W-Lan aktiviert und bist mit deinem Handy in der Nähe von zumindest zwei, besser drei Mobilfunk-Sendestationen!
 
Zuletzt bearbeitet:
Z

Zisko

Ambitioniertes Mitglied
Ich habe genau dasselbe Problem mit der Standortbestimmung. Nicht einmal Google Maps läuft mehr in geschlossenen Räumen. Vor 4.4 war das Telefon in der Lage über Funkortung, auch ohne GPS den Standort zu finden - das geht jetzt nicht mehr. Lediglich wie oben beschrieben nach einem Neustart. Sollte doch ein Bug sein, oder?
 
Zuletzt bearbeitet:
D

daddle

Lexikon
Versucht mal das letzte Maps-Update in Einstellungen > Apps > Maps zu deinstallieren. Vielleicht liegt es am letzten Maps-Update!
 
Z

Zisko

Ambitioniertes Mitglied
Ich könnte das zwar probieren, aber glaubst du wirklich, dass es daran liegt? Wie gesagt, nach einem Neustart des Geräts funktioniert alles.
 
D

daddle

Lexikon
Du hattest von Problemen gesprochen, und nicht dass alles nach Neustart funktioniert!
Aber es ist ja kein Ding Maps-Update zu deinstallieren und testen. Update wird automatisch wieder angeboten.
 
D

defoerb

Neues Mitglied
Also ich habe auch Probleme mit dem Standort und GPS! Über die Leiste oben kann ich nurnoch "Ort" ein- oder ausschalten. Dabei werden bei "Ort" drei Modi unterschieden, ein Modus mit Wifi und 3g-Orstbestimmung, ein Modus mit allen Möglichkeiten zur Ortsbestimmung und ein Modus nur mit GPS. Wenn ich jetzt "Ort" ausschalte und dann im Energiesparmodus wieder einschalte so wird mein Standort GARNICHT gefunden, auch nicht ungefähr. Nach Neustart klappt es dann bis ich Ort wieder ausschalte um Akku zu schonen und dann wieder einschalte.
Vorher war es einfacher: Der Ort wurde durch WLAN und 3G immer bestimmt, GPS konnte ich optional zuschalten.
Wenn ich nun z.B. die Wetter.com App öffne wird mein Standort meistens nicht gefunden.
Hat jemand eine Idee wie man da vorgehen kann???
 
Bluefreeman

Bluefreeman

Ambitioniertes Mitglied
Hallo.

Ich habe ebenfalls ein Problem mit der Standortbestimmung (CloudyStock 1.1). In den Einstellungen unter Ort habe ich den Modus hohe Genauigkeit ausgewählt, bekomme aber bei der Aktualisierung des LG Wetter Widgets immer folgende Fehlermeldung:
uploadfromtaptalk1395138978244.jpg
Daten und Cache löschen habe ich bereits probiert, ebenso das Widget entfernt und neu auf den Homescreen gelegt.
Jemand ne Idee wie ich den Fehler beheben könnte?
 
dupi

dupi

Stammgast
Habe auch Probleme bei der Standortbestimmung. Habe die Standortbestimmung "Akkusparfunktion" an, wechsel ich auf hohe Genauigkeit, kommt auch die Meldung "kein Standort verfügbar".
Wechsel ich wieder zurück auf "Akkusparfunktion" immer noch "kein Standort verfügbar".
Dann mach ich ein reboot und er findet den Standort über wifi/mob. Netz...
sehr suboptimal definitiv ein Bug..
 
digitdia

digitdia

Ehrenmitglied
Bluefreeman schrieb:
Hallo.

Ich habe ebenfalls ein Problem mit der Standortbestimmung (CloudyStock 1.1).
bitte beachtet, dass es hier im Thread NUR um Standort-Probleme nach dem Update auf kitkat geht...
 
D

defoerb

Neues Mitglied
Ist das Problem denn irgendwie in den Griff zu kriegen? Nervt unheimlich!
 
E

electric-sheep

Fortgeschrittenes Mitglied
Ich kann den Fehler bestätigen, eine Lösung habe ich leider noch nicht (Nexus 4, KK Stock). Eine Zeit nach dem Neustart wird der Standort im „Energiesparmodus“ gefunden, irgendwann funktioniert es dann nur noch mit eingeschaltetem GPS (Einstellung „Gerät“ oder „Hohe Genauigkeit“). In Maps erscheint die Meldung „Standort wird ermittelt …“ in den Standorteinstellungen „letzter Standort wird verwendet“.

BTW: Ich empfinde die Vielzahl an Einstellmöglichkeiten nicht gerade als besonders benutzerfreundlich. Bei einem Google-Konto und einem damit verwendeten Gerät kann man das ja noch durchschauen, ich nutze mehrere Geräte und mehrere Konten, da wird es dann schon unübersichtlich. Die möglichen Wechselwirkunken von Standortbericht und Standortverlauf auf unterschiedlichen Geräten sind mir teilweise unverständlich. Bekommen z.B. Maps oder Earth nur eine Position, wenn der Standortbericht für das gleiche Konto aktiviert ist, in dem auch Apps angemeldet sind? Was ist mit Apps, die kein Google Konto nutzen? Beim Standortverlauf handelt es sich wohl um eine globale Einstellung für das jeweilige Google Konto. Was ist, wenn nur die Daten vom Handy aufgezeichnet werden sollen, nicht aber die z.B. vom Tablet?

Beim “Herumspielen” mit den Optionen sind dann noch ein paar ganz böse Seiteneffekte aufgetreten. Ich hatte auf dem N4 zusammen mit Google Now den Standortbericht und Verlauf aktiviert, plötzlich fing mein Tablet dann an, den Akku innerhalb kürzester Zeit leer zu ziehen, ohne dass ich etwas an dessen Einstellungen geändert hätte. Bei genauerer Untersuchung handelte es sich um die gleichen Wakelocks, die auch schon von dem Bug beim 2012er N7 bekannt waren. Irgend ein dicker Wurm steckt da derzeit noch in der Standortermittlung.
 
L

lasy

Neues Mitglied
Irgendwie bin ich ja dann schon beruhigt, dass das Problem nicht nur mir auffällt. ;)

Ich muss sagen durch diesen Softwarebug oder Feature bin ich wirklich unzfrieden und überlege ob ich das Telefon zurückschicke, da ich noch in der 1-monatigen Rückgabefrist bin.
 
Hellkeeper

Hellkeeper

Erfahrenes Mitglied
Wenn ich GPS die ganze Zeit aktiviert habe, läuft alles wunderbar. Wird es deaktiviert und dann wieder aktiviert, so tritt auch das Problem auf. Es wird in keiner App der Standort ermittelt, nur nach einem Neustart wieder. Ich fühle mich irgendwie verarscht, denn es ist ja nicht so, als ob die Entwickler keine Zeit haben.
 
D

daddle

Lexikon
Man sollte das Gerät mit Ortsbestimmung "Nur Gerät" oder "Hohe Genauigkeit" starten. Dann werden die config-dateien beim Start für GPS mit geladen.
Es scheint so zu sein, dass das Zuschalten von GPS erst nach dem Systemstart diese nicht mehr lädt, war früher ein Bug bei LG, bzw. verspätet, dann muss der Gps-Chip erst die Epheremiden ( Satelliten-Bahndaten) nachladen, was dauert.

Der GPS-Sensor selber verbraucht kaum Strom, erst wenn aus den vom GPS-Chip seit Systemstart bereits empfangenen Bahndaten (der Almanac) die Berechnung für den Standort durch eine Anwendung erfolgt, verbraucht die GPS-Standort-Berechnung viel Strom.

Wenn man also mit Standort "Nur Gerät"(GPS) eingeschaltet startet und dann Maps direkt nach dem Neustart aufruft, dauert es immer ein wenig bis der Standort gefunden wird, da erst der Almanac empfangen und eingelesen werden muss. Auch bei mir kam dann der Standort in Maps verzögert, aber nicht gleich in der Karte sichtbar!

Wenn ich dann aber Navigation einschalte, für Start "Mein Standort" und irgendeinen beliebigen Zielort angebe, dann erscheint plötzlich der Standort als blauer Punkt und bleibt auch nach Verlassen der Navi-Funktion einige Zeit in der Startkarte sichtbar!
Vielleicht soll es ja dem Stromsparen dienen, dass die stromfressende Berechnung des Standortes erst bei wirklichem Bedarf, also Start der Navigation erfolgt.
Lässt man dann Maps auf dem Screen gestartet, verschwindet das blaue Standort-Symbol in der Karte wieder, aber in der rechten unteren Ecke zeigt das GPS-Symbol mit zentralem schwarzen Punkt, dass ein Standort festgelegt ist. Tippt man dieses an erscheint in der Karte der blaue Punkt wieder.

Zusätzlich kann man sich die App GPS-Status aufspielen, dort unter Einstellungen > Sensoren > `A-GPS-Daten herunterladen´ auf 1 oder 6 Std. einstellen. und unter "Sensor Filterung" > "Schwach" einstellen.
Dann 2x zurück und unter "Hintergrundverhalten" > "GPS verwenden wenn der Bildschirm aus ist" anklicken.

Wenn ich dann GPS-Status aufrufe erhalte ich einen schnellen sichtbaren Fix, und direkt im Anschluss in Maps auch! Allerdings wird damit viel Akku verbraten.

Versucht also erstmal mit dem Start der Navi-Funktion und der Fix wird schneller sichtbar (mit Standort-Einstellung "Nur Gerät" bei boot!), die beim Navi-Start aufpoppende Abfrage zur "Standort-Präzisierung" abbrechen!
 
Zuletzt bearbeitet:
L

lasy

Neues Mitglied
Was mich wirklich ärgert ist, dass das LG G2 von der Hardware her echt total rund ist. Man kann einfach über nichts meckern und dann produzieren die solchen quatsch an Software.

Ich programmiere auch viel Software, aber ich spreche immer mit den Leuten für die ich es programmiere und dadurch ist sowas noch nie vorgekommen. Dabei kostet den Kunden fragen nicht mal Geld.
 
O

overflyer

Neues Mitglied
Hi Leute,

ich nutze OmniRom 4.4.4 (dl.omnirom.org/d802) in der neuesten build. Gibt es mittlerweile eine Lösung für das Problem? Alle Standorzugriffe sind zugelassen und individuell auch für jede App die diese benötigt. Trotzdem finden einige Apps meinen Standort nicht.

Danke im Vorraus!
 
Meikel_61

Meikel_61

Experte
Die Frage stellst Du sicherlich besser im passenden Custom-Rom Forum
 
TonieZ

TonieZ

Neues Mitglied
Gleich vorweg, ich habe dieses Problem nicht. (4.4.2, Stock ROM)
Deshalb denke ich das es KEIN Software-Bug ist, denn sonst hätten wir es alle.

Ich habe GPS standardmäßig aus und schalte es nur ein wenn ich es benötige. Ich gehe jeden 2ten Tag joggen und nutze dazu "Endomondo PRO". Heißt ich nutze regelmäßig die Standortbestimmung "Ort".
Ich schalte "Ort" (Hohe Genauigkeit) ca. 3min vor Nutzung der entsprechenden App ein. Wenn ich dann unter freiem Himmel bin, starte ich die Sport-App und es dauert ca. 20-60 Sekunden bis das GPS Signal einwandfrei steht. Es ist bisher noch nie abgebrochen oder nicht gestartet.
Anhand der aufgezeichneten Strecke kann ich später auf einer Googlemap sehen wie genau das GPS gearbeitet hat. Auch hier gibt es nichts zu meckern.

Die Standortbestimmung für die meisten Wetterapps funktioniert auch sehr gut. Es gibt aber auch Apps wie Regen-Radar die nichts finden. Daraus schließe ich dann, dass die App wohl nicht gut arbeitet.

Habt ihr nach dem Update auf KitKat mal einen Factory Reset gemacht?