PowerButton/Anschalter funktioniert nicht

  • 11 Antworten
  • Neuester Beitrag
Diskutiere PowerButton/Anschalter funktioniert nicht im LG G8s ThinQ Forum im Bereich LG Forum.
N

Nerox75

Neues Mitglied
Hallo,

ich besitze seit 9 Tagen ein (beziehungsweise seit eben das zweite) LG8s ThinQ. Ich habe das Handy eben im Media Markt gegen ein Brandneues ausgetauscht und mindestens 3 Werksresets ausgeführt. Folgendes Problem trat bei beiden Geräten auf:

-AOD Display über die Einstellungen deaktivieren (Anzeige - Haken bei AOD weg)
-Handy ausschalten
-Jetzt: dunkle Umgebung (z.B. Hosentasche simulieren): Sensoren oben mit dem Finger abdecken, Handy nachts benutzen oder ganz einfach in die Tasche stecken
-Handy wieder herausholen/Licht an den Sensor lassen: In 3 von 5 Fällen ist jetzt der Power Button "tot". Ich muss oft mindestens 5 Sekunden warten, bis sich das Handy überhaupt wieder einschalten lässt. Selbst 10 maliges Drücken des PowerButtons oder die Benutzung des Fingerabdrucksensors hilft nicht - das Display bleibt einfach schwarz.

Das Problem tritt auch mit aktiviertem AOD auf, allerdings wesentlich seltener. Offenbar reagiert der Sensor nicht schnell genug oder irgendetwas an der Programmierung ist ganz schön durcheinander?

Kann mir jemand helfen? Ich verzweifel hier langsam. Ein Handy, das ich Abends "nicht mal eben schnell" noch im Bett anschalten kann, um einen Wecker zu programmieren - nur weil es dunkel um mich herum ist - ist für mich völlig nutzlos. Ich habe noch 5 Tage Rückgaberecht und würde gerne wissen, ob LG hier wirklich Müll gemacht hat und andere dieses Problem ebenfalls kennen, oder irgendjemand Abhilfe kennt?

Viele Grüße!
 
orgshooter

orgshooter

Lexikon
@Nerox75
Was hältst du von Double Tap to wake?
Funktioniert bei uns einwandfrei.
 
N

Nerox75

Neues Mitglied
Ja, habe ich schon ausprobiert. Leider ist auch das Double Tap To Wake davon betroffen. So, als würde das Gerät in den Deep Sleep gehen, sobald man das AOD ausschaltet und dann den Sensor verdeckt. Probiert es mal aus (manchmal braucht es ein paar Anläufe, bis der Bug auftritt):
AOD deaktivieren
Sensor für 5 Sekunden mit dem Finger verdecken
Finger wegnehmen
Versuchen, das Handy zu wecken (z.B. mit DoubleTap to Wake oder dem Power Button)
 
SvenAusPirna

SvenAusPirna

Experte
Meistens treten solche Softwareprobleme auf, wenn bei der Einrichtung, ein BackUp eingespielt wird.
 
N

Nerox75

Neues Mitglied
Leider hier nicht der Fall... Bei beiden Handys fabriksneue Werkseinstellungen, ohne Backup und dergleichen.
Beitrag automatisch zusammengefügt:

Update:
Wenn ich meine ADB-Debloat-Liste durchlaufen lasse (poste ich jetzt hier nicht, sonst gibt es auf den Deckel) funktioniert auch das AOD nicht mehr. Man kann dann aber den Schalter beim AOD im Menü auf "AN" lassen und das AOD Display geht nicht mehr an. Der Bug tritt dann allerdings auch nicht auf!
Sprich: Eine Deaktivierung des AOD über die Einstellungen provoziert das hier oben beschriebene Verhalten. Der Schieber muss also zwingend auf "Ein" bleiben, ansonsten hat man ein Handy, was direkt nach dem "aus der Tasche nehmen" nicht mehr funktioniert.
Wenn man das AOD nicht möchte (so wie ich), muss man über ADB die Systemapp entfernen, die das AOD erzeugt. Ich weiß nicht genau welche App das ist, schätze aber eine von denen hier:

com.lge.gallery.collagewallpaper
com.arcsoft.app.humanavatar
com.arcsoft.lg_avatar_resource
com.lge.globaltofservice
com.lge.floatingbar
 
Zuletzt bearbeitet:
Drago3110

Drago3110

Fortgeschrittenes Mitglied
Nerox75 schrieb:
AOD deaktivieren
Sensor für 5 Sekunden mit dem Finger verdecken
Finger wegnehmen
Versuchen, das Handy zu wecken (z.B. mit DoubleTap to Wake oder dem Power Button)
Ja tatsächlich 😮😮😮
Bei mir ist das auch. Mir ist das schon ab und zu aufgefallen dass ich selten 2 oder 3 mal auf den Power Button drücken muss oder double tappen muss. Aber hab mir nie weiter Gedanken darüber gemacht. Krass... 🤷🏿‍♂️😮

Ich bin sooo gespannt auf Android 10 und ob das einige der bekannten Problemen beseitigt.
 
Zuletzt bearbeitet:
A

aking007

Ambitioniertes Mitglied
Also Habs gerade getestet.... Man muss 2 mal drücken dann geht das Display an.
Allerdings sehe ich das nicht als Bug sondern eine Maßnahme gegen versehentliches an gehen des Displays in der Hosentasche...
Beim normalen verwenden... Also normale Umgebung mit Licht geht das Handy sofort an...
 
Drago3110

Drago3110

Fortgeschrittenes Mitglied
aking007 schrieb:
Also Habs gerade getestet.... Man muss 2 mal drücken dann geht das Display an.
Allerdings sehe ich das nicht als Bug sondern eine Maßnahme gegen versehentliches an gehen des Displays in der Hosentasche...
Beim normalen verwenden... Also normale Umgebung mit Licht geht das Handy sofort an...
Nach dem Motto "it's not a bug, its a feature".

Würde tatsächlich auch Sinn machen. Vermutlich im Zusammenspiel mit dem Näherungssensor (oder wahrscheinlicher passiert das nur durch den Näherungssensor).
Ich war gestern Nacht im komplett dunklem Schlafzimmer. Also überdurchschnittliche dunkel sodass der Lichtsensor nichts mehr registriert haben dürfte. Und trotzdem ging bei mir so sofort das Display an, nur wenn ich tatsächlich meinen Finger auf den Sensor gelegt habe trat das Phänomen auf. Auch wenn noch Licht an den Sensor kommt und ich den Finger knapp drüber halte.

Wahrscheinlich steht das auch in irgendeinem Papier als Feature geschrieben 😂

Nur noch die Frage warum er dann nicht sofort angeht wenn der Finger vom Sensor weg ist. Ich könnte mir vorstellen dass nur alle 2 oder 3 Sekunden oder so eine Abfrage des Näherungssensors stattfindet??

Weil wenn du den Finger auf den Sensor legst bei ausgeschaltetem Bildschirm und du dann nach ca. 1 Sekunde den Power Knopf drückst geht das Display auch noch an.

Zusammengefasst würde ich sagen:

Es ist alles normal. Dass man bei abgedecktem Näherungssensor 2 mal drücken muss ist daher ein Schutz gegen unbeabsichtigtes betätigen in der Hosentasche.
Und dass er nicht Millisekundengenau sofort umschaltet wenn man den Sensor verdeckt oder freigibt wird einfach am Akku liegen. Also da eine permanente Abfrage auch mehr Strom kosten würde.
 
Zuletzt bearbeitet:
N

Nerox75

Neues Mitglied













Ich habe den Bug jetzt einfach mal gefilmt.
Wie man sieht, ist das mit dem zwei mal Drücken normal, solange es dunkel ist oder der Sensor mit dem Finger abgedeckt ist.
Die ersten beiden Male "Finger auf den Sensor und dann wegnehmen" ist es mir nicht gelungen, den Bug zu reproduzieren.
Beim dritten Mal "Finger auf den Sensor und dann wegnehmen" sieht man, dass ich den Powerbutton für 5 Sekunden lang wie blöd drücken kann und nix passiert. Fingerabdrucksensor das gleiche Verhalten.
 
Zuletzt bearbeitet:
Drago3110

Drago3110

Fortgeschrittenes Mitglied
Nerox75 schrieb:













Ich habe den Bug jetzt einfach mal gefilmt.
Wie man sieht, ist das mit dem zwei mal Drücken normal, solange es dunkel ist oder der Sensor mit dem Finger abgedeckt ist.
Die ersten beiden Male "Finger auf den Sensor und dann wegnehmen" ist es mir nicht gelungen, den Bug zu reproduzieren.
Beim dritten Mal "Finger auf den Sensor und dann wegnehmen" sieht man, dass ich den Powerbutton für 5 Sekunden lang wie blöd drücken kann und nix passiert. Fingerabdrucksensor das gleiche Verhalten.
Ja beim letzten Versuch sieht man das gut. Ich hab es eben probiert und es ist genauso. Meine Vermutung dazu wäre dass das "Problem" das schnelle drücken ist. Wenn ich das mache dann kann ich das auch 10 Sekunden machen und das Display geht nicht an. Erst wenn man dem Ganzen mal eine Sekunde Luft gibt und dann noch mal drückt geht das an.

Keine Ahnung ob das beabsichtigt ist und wenn ja was sich die Entwickler gedacht haben. Vllt. haben sie es so einprogrammiert, dass wenn das Handy im "in der Tasche Modus" ist, nicht jeder Druck innerhalb einer gewissen Zeitspanne umgesetzt wird. Also wenn du innerhalb einer bestimmten Zeit öfter drückst, einfach nichts passiert. Meiner Meinung nach ist das was softwareseitiges. Denn wenn du den Powerknopf im "normalen Zustand so schnell drückst, reagiert er ja auch jedesmal.

Bringt uns natürlich der Antwort ob es tatsächlich ein Bug ist nicht näher.

Ich würde aber aus dem Gefühl heraus sagen es ist kein Bug 🤷🏿‍♂️
 
Zuletzt bearbeitet:
N

Nerox75

Neues Mitglied
Es ist sicher ein (softwareseitiger) Bug, da das Verhalten nicht auftritt, sobald man das AOD in den Einstellungen anschaltet. Deshalb mein Workaround oben, über ADB/fastboot die AOD App zu deinstallieren, wenn man es nicht benutzt.

Zugegeben, im Video hämmer ich etwas theatralisch auf den Button. Bei mir ist das aber unabhängig von der "Drück-Frequenz". Auch wenn ich das Handy ganz normal aus der Tasche hole, geht der Fingerabdrucksensor oft erst nach ein paar Sekunden. Das Video habe ich nur zu Demozwecken so übertrieben.
 
K

KurtKnaller

Experte
Ich kann das nicht nachvollziehen. AOD ausgeschaltet, Handy ausgemacht und mit dem Gesicht für 30 Sek. auf den Tisch gelegt. Dann umgedreht und double tap und sofort ist das Gerät da.
2. Versuch: Wie oben, nur Handy aufgenommen und Finger auf den Abdrucksensor und sofort ist das Gerät da.
Auch der Power-Knopf geht beim ersten Mal. Den benutze ich aber ohnehin nur, wenn ich das Gerät ganz ausschalten bzw. anschalten möchte.

Im Moment habe ich ja auch noch ein zweites Gerät hier. Auch da kein Problem.

Fazit: Ich sehe da keine relevante Funktionseinschränkung.
 
Zuletzt bearbeitet:
Ähnliche Themen - PowerButton/Anschalter funktioniert nicht Antworten Datum
2
0
0