Wie LineageOS installieren?

  • 41 Antworten
  • Neuester Beitrag
Diskutiere Wie LineageOS installieren? im LineageOS Forum im Bereich Root / Custom-ROMs / Modding für bq Aquaris X / X Pro.
TramJens

TramJens

Lexikon
@just-Nob
Hallo,
Zu1.1 richtig, nimm die aktuellste Nightly, ich glaube es gibt generell keine stable mehr.
1.2 ich nehme immer die pico gapps
1.3. Magisk ist auch korrekt
1.4. keine Ahnung

2.1 Installieren via zip vom internen Speicher oder MicroSD oder OTG geht auch, mach ich nur so.
2.2 Magisk würde ich erst nach dem ersten Neustart ins System machen.

3.1 unter TWRP wird der interne Speicher nicht gelöscht, eine Sicherung kann aber nicht schaden,
da der interne Speicher formatiert werden soll ist doch alles weg.
3.2-5 kann man probieren ob alles übertragbar ist mit TB
 
Zuletzt bearbeitet:
moidept

moidept

Experte
@just-Nob , mit "Titanium Backup" reise ich von einer ROM zu nächsten, mit Apps & Daten, manchmal muss ich dann im TWRP Dalvik und Cache löschen. das war es auch schon...
 
TramJens

TramJens

Lexikon
@moidept
Mach ich ebenso, TB hat mir schon oft den A**** gerettet.
 
just-Nob

just-Nob

Erfahrenes Mitglied
Hi @TramJens ,
erstmal herzlichen Dank für die ausführlichen Antworten!
Ein paar Fragen ergeben sich daraus für mich leider noch, zusammen mit einem aktuellen Problem (s.u.):

TramJens schrieb:
2.2 Magisk würde ich erst nach dem ersten Neustart ins System machen.
Wieso das?
Was ist der Nachteil, wenn ich es im TWRP gleich mit dem LOS-ROM und den GAppy mit aufspiele?

TramJens schrieb:
3.1 unter TWRP wird der interne Speicher nicht gelöscht, eine Sicherung kann aber nicht schaden,
da der interne Speicher formatiert werden soll ist doch alles weg.
moidept schrieb:
[...] manchmal muss ich dann im TWRP Dalvik und Cache löschen. das war es auch schon...
Was heißt, unter TWRP wird der interne Speicher nicht gelöscht? In der LineageOS-Installatioonsanleitung wird dieser Schritt ja unter 4. definitiv mit angegeben. Soll/kann das vonn TWRP nicht gemacht werden? Hat es keine Nachteile (z.B. störende "Rest-Datenfragmente"), wenn ich die Datenpartition nicht lösche? Soweit ich es bis jetzt verstehe, ist dieser Schritt u.a. auch notwendig, um die Verschlüsselung der /data-Partition zu entfernen.
Zur Erinnerung: Ich komme derzeit vom (gerooteten) BQ Stock ROM.
Ein Backup der relevanten Daten (vor allem Fotos & WhatsApp) habe ich natürlich vorab gemacht...

Allerdings habe ich jetzt genau mit diesem Schritt auch ein Problem:
Wenn ich den "/data-Wipe" versuche durchzuführen, erhalte ich folgende Fehlermeldung:
Code:
Failed to mount '/data' (Invalid argument)
Unable to format to remove encryption.
Updating partition details...
Failed to mount '/data' (Invalid argument)
...done
Unable to mount storage
Aus irgendwelchen Gründen kann TWRP also die /data-Partition nicht einhängen.
Hat das vielleicht mit der Verschlüsselung selbst zu tun?
Wie kann ich das Problem lösen?

TramJens schrieb:
3.2-5 kann man probieren ob alles übertragbar ist mit TB
moidept schrieb:
mit "Titanium Backup" reise ich von einer ROM zu nächsten, mit Apps & Daten,
Kann ich in Titanium Backup (keine Pro-Version!) auch ein Backup der Systemdaten fahren?
In den "normalen" Stapel-Aktionen geht das aber nicht, oder doch?
Und weiß vielleicht auch jemand, welche Systemdaten ich dann für WLAN- und Bluetooth-Settings sichern müsste?
Wie gesagt, Kontakt- und Kalenderdaten sowie Anruflisten (wobei die i.d.R. nicht allzu wichtig sind) und SMS bekommt man auch prima mit MyPhoneExplorer gesichert...
Die Anwender-Apps habe ich komplett einmal per Stapelsicherung sichern lassen - soweit ich mich erinnere, macht TB ja immer auch gleich eine Sicherung der Anwenderdaten mit?
 
TramJens

TramJens

Lexikon
@just-Nob
TWRP kann löschen und formatieren, in der Anleitung steht format data, es geht sicher um die Verschlüsselung.
Beim löschen werden die UserApps gelöscht, der interne Speicher(Downloads,Fotos usw.) bleiben unberührt.
Ich würde keine Systemdaten wiederherstellen, gibt nur Probleme.
 
just-Nob

just-Nob

Erfahrenes Mitglied
TramJens schrieb:
TWRP kann löschen und formatieren, in der Anleitung steht format data, es geht sicher um die Verschlüsselung.
Beim löschen werden die UserApps gelöscht, der interne Speicher(Downloads,Fotos usw.) bleiben unberührt.
Bist Du Dir beim internen Speicher (Downloads, Fotos etc.) sicher, dass diese Daten erhalten bleiben?
In der LineageOS-Installatioonsanleitung steht:
  • "This will remove encryption and delete all files stored in the internal storage."
Auch wenn ich in TWRP [Löschen] --> [Daten-Partition löschen] auswähle (TWRP auf "deutsch" gestellt 😉), kommt der folgende Hinweistext als Warnung:
  • "Formatieren der Daten-Partition löscht alle Apps, Sicherungen, Bilder, Videos, sowie Medien und entfernt die Verschlüsselung des internen Speichers."
Mir scheint daher, dass hier auch die Anwender-Datenpartition (="interner Speicher" bei Dateizugriffen), in der halt auch der "Download"- oder auch der "DICM"-Ordner (Fotos) liegen, gelöscht werden, was mir durchaus auch plausibel erscheint, da die Daten ja in der verschlüsselten Parrtition liegen - und das Entfernen der Verschlüsselung löscht dann wohl halt auch die verschlüsselten Daten selbst.

Mein Problem ist aber, dass ich die Formatierung nicht durchführen kann; hier nochmal die von TWRP ausgegebene Meldung in deutsch:
Code:
'/data' konnte nicht eingehängt werden (Invalid argument)
Formatierung zum Entfernen der Entschlüsselung kann nicht durchgeführt werden.
Partitions-Informationen werden aktualisiert...
'/data' konnte nicht eingehängt werden (Invalid argument)
...Fertig
Kann Speicher nicht einhängen
Also: Ich bekomme die Partition nicht formatiert und somit die aktuelle Verschlüsselung nicht beseitigt, weil die /data-partition nicht eingehängt werden kann. Die Frage ist nur:
  1. Warum lässt sich die Partition nicht einhängen?
    Liegt das eventuell an der Verschlüsselung selbst?
    Ich hätte allerdings gedacht, dass sich die Partition in jedem Fall einhängen lassen müsste und die Ver- und Entschlüsselung erst beim Schreib- bzw. Lesezugriff erfolgt (und nichts mit dem Vorgang des Einhängens zu tun hat).

  2. Was kann ich tun, um die Partition im TWRP einzuhängen bzw. für das Formatieren einhängen zu lassen?

  3. Ist eventuell die Option [Löschen] --> [Werkseinstellungen herstellen] zielführend?
    Hierdurch müssten doch vermutlich einfach alle Partitionen gnadenlos neu angelegt werden (egal, ob einzuhängen oder nicht), und eventuell noch die Daten beim Auslieferungszustand wieder von irgendwo (einer "Wiederherstellungs"-Partition im Sinne der Windoof-Recovery?) her eingespielt werden.
    TWRP dürfte doch eigentlich bestehen bleiben, da er sich ja nicht einfach selbst löschen kann, während er darauf zugreift (außer TWRP lädt sich beim Start komplett in den Arbeitsspeicher und greift dann gar nicht mehr auf die Recovery-Partition zu).
    Ich würde allerdings annehmen, dass dann auch der Bootloader wieder neu eingespielt wird und dann erst einmal wieder gesperrt ist? - Der dürfte sich ja allerdings wieder entsperren lassen; dass damit wieder alle Daten gelöscht werden wäre ja nicht schlimm, da ich ja eh schon alles platt gemacht habe und ja auch ein "sauberes" System anstrebe... - alle anderen Daten (Fotos, WhatsApp-Ordner, TB-App-Backups usw.) habe ich ja auf die intrerne SDCard oder den externen USB-Stick kopiert (oder mit dem MyPhoneExplorer gesichert).

TramJens schrieb:
Ich würde keine Systemdaten wiederherstellen, gibt nur Probleme.
Klingt einleuchtend, da man wohl nicht sichergehen kann, dass die Systemdaten dann wieder gleich organisiert sind, zumal bei einem Wechsel sowohl der Android-Major-Version (8.1 --> 9.0) als auch des OS-Herstellers (BQ --> LinageOS).
Dann werde ich wohl nicht umhin kommen, die Sachen neu einzurichten. Ein wenig blöd ist vielleicht der Verlust des eigenen Wörterbuchs...
 
juni

juni

Experte
schon probiert, im advanced wipe alles platt zu machen? beim factory reset bleibt der interne speicher unberührt.
 
Zuletzt bearbeitet:
just-Nob

just-Nob

Erfahrenes Mitglied
MachineHead schrieb:
schon probiert, im advanced wipe alles platt zu machen?
Ich bin über [Löschen] --> [Daten formatieren] gegangen.
[Löschen] --> [Erweitertes Löschen] --> ["Data" auswählen] habe ich noch nicht probiert.
Wenn ich "Data" auswähle und dann "Löschen bestätigen" wische, wird dann die gesamte Partition gelöscht, oder nur deren Inhalt?
Sollte die Partition selbst gelöscht werden, bekomme ich dann eventuell Probleme, weil die /data-Partition fehlt?
 
TramJens

TramJens

Lexikon
@just-Nob
Die Partitionen wird neu formatiert, sie ist dann für TWRP zu gebrauchen.
Wipe und format nicht verwechseln, bei wipe bleibt intern unberührt.
Adwanced wipe bringt nichts, es muß formatieren sein.
 
just-Nob

just-Nob

Erfahrenes Mitglied
TramJens schrieb:
Die Partitionen wird neu formatiert, sie ist dann für TWRP zu gebrauchen.
Ja, aber wie soll sie denn neu formatiert werden, wenn TWRP sie nicht einhängen kann...?
 
TramJens

TramJens

Lexikon
@just-Nob
Hast Du es schon probiert?
 
juni

juni

Experte
TramJens schrieb:
Die Partitionen wird neu formatiert, sie ist dann für TWRP zu gebrauchen.
weisst du zufällig, welches format die partition vor und nach dem formatieren hat?
 
TramJens

TramJens

Lexikon
@MachineHead
Leider nicht.
Beitrag automatisch zusammengefügt:

Sehr wahrscheinlich ext4
 
Zuletzt bearbeitet:
juni

juni

Experte
angenommen ext4 wäre auch vor dem formatieren das bestehende format, dann könnte man sich ja diesen vorgang sparen. wenn es nämlich nur um das freiräumen des speichers geht, würde der advanced wipe reichen. würde mich interessieren, ob die installation dann auf einen fehler hinausläuft. vielleicht hat @just-Nob bock drauf, das mal zu testen?
 
Zuletzt bearbeitet:
TramJens

TramJens

Lexikon
@MachineHead
Es geht nicht ums "freiräumen", sondern die Verschlüsselung, erst nach dem formatieren kann TWRP mit dem internen Speicher umgehen.
 
S

sonriab

Fortgeschrittenes Mitglied
just-Nob schrieb:
Wieso das?
Was ist der Nachteil, wenn ich es im TWRP gleich mit dem LOS-ROM und den GAppy mit aufspiele?
Ich habe gestern erst lineageOS installiert und habe Magisk als letzten Schritt direkt mit eingespielt. Das führte zu einer Boot Schleife. Also lieber erst lineage und GApps aufspielen, einmal ins System starten und dann Magisk einspielen.

just-Nob schrieb:
Aus irgendwelchen Gründen kann TWRP also die /data-Partition nicht einhängen.
Hat das vielleicht mit der Verschlüsselung selbst zu tun?
Wie kann ich das Problem lösen?
Welche TWRP Version hast du? Eigentlich müsste er dich beim Start ins Recovery direkt nach dem Passwort fragen. Aktuell ist die Version 3.3.1.
 
Zuletzt bearbeitet:
just-Nob

just-Nob

Erfahrenes Mitglied
So, nach den familiären Verpflichtungen wieder zurück am Rechner... 😉

TramJens schrieb:
Hast Du es schon probiert?
Was denn probiert?
Wie bereits mehrfach oben geschrieben, erhalte ich bei [Löschen] --> [Daten-Partition formatieren] --> [(Eingabe "yes" zur Bestätigung)] eine Fehlermeldung - die Formatierung wird von TWRP entsprechend erst gar nicht ausgeführt, obwohl ich die Aktion bereits bestätigt habe! 😐

MachineHead schrieb:
weisst du zufällig, welches format die partition vor und nach dem formatieren hat?
TramJens schrieb:
Sehr wahrscheinlich ext4
Ja, es ist definitiv ext4.
Wird zusammen mit einigen anderen Informationen im TWRP angezeigt, wenn man [Löschen] --> [Erweitertes Löschen] --> [("Data"-Partition auswählen)] --> [Dateisystem reparieren oder ändern] anwählt.
Wie schon von @TramJens bereits geschrieben, denke ich allerdings auch, dass das eher nix bringt, da die Verschlüsselung der Knackpunkt sein dürfte.
Interessant wäre allenfalls, ob TWRP beim "Advanced Wipe" ebenfalls Probleme bekommt, was ich fast vermute!

sonriab schrieb:
Welche TWRP Version hast du? Eigentlich müsste er dich beim Start ins Recovery direkt nach dem Passwort fragen. Aktuell ist die Version 3.3.1.
Ich habe seit geraumer Zeit die 3.3.1-0 drauf.
Ich habe immer gleich die aktuellste TWRP mit aufgespielt, wenn ich eine Systemaktualisierung von BQ eingespielt habe, da man dem Skript von BQ da dann einfach immer TWRP anstelle der Stock Recovery "untergeschoben" hat.
Eine Frage nach dem PW habe ich allerdings nie gehabt. Liegt das womöglich an der "Installationsart" von TWRP, bei dem die Dateien vom PC via Skript und adb/fastboot (im Bootloader des BQs) auf's Handy geschoben wurden?
Wann bzw. wie stellt TWRP denn fest, dass es das PW für's Dekrypten benötigt?

sonriab schrieb:
Ich habe gestern erst lineageOS installiert und habe Magisk als letzten Schritt direkt mit eingespielt. Das führte zu einer Boot Schleife. Also lieber erst lineage und GApps aufspielen, einmal ins System starten und dann Magisk einspielen.
Dann ist das bei LOS auch anders als beim BQ Stock ROM Update - da habe ich nach dem oben bereits genannten Update via adb/fastboot immer gleich sofort ins TWRP gebootet und Magisk geflasht, jeweils mit anschließendem [Cache/Dalvik löschen]...

Wie auch immer, ich wäre froh, wenn ich erst einmal an diesen Punkt käme! 😟
 
TramJens

TramJens

Lexikon
@just-Nob
Du hast sicher versucht data manuell einzuhängen.
Mich hat TWRP auch noch nie nach einem Passwort gefragt.
 
just-Nob

just-Nob

Erfahrenes Mitglied
Hallo @TramJens ,
TramJens schrieb:
Du hast sicher versucht data manuell einzuhängen.
Meinst Du via Kommandozeile?
Oder über den Punkt [Mount] im TWRP?
Beides nicht - im "Mount"-Bildschirm waren auch nur "[x] Cache" und "[x] System" angehakt, also als eingehangen gekennzeichnet. "[ ] data" ließ sich hier auch nicht anwählen/aktivieren.

TramJens schrieb:
Mich hat TWRP auch noch nie nach einem Passwort gefragt.
Danke, das ist tröstlich... - hatte gerade echt schon an mir gezweifelt! 🙃
Liegt es eventuell tatsächlich daran, ob man für die Verschlüsselung das Standardpasswort oder ein Passwort, das irgendwo wohl beim "Sicheren Start" selbst vergeben werden kann, auswählt?
Handelt es sich beim Standardpasswort womöglich tatsächlich um ein für alle Installationen gleiches PW, das dann auch TWRP entsprechend bekannt ist (womit die Verschlüsselung ohne eigenes, selbst gewähltes PW ja dann ziemlich hinfällig wäre...)?
Ich habe meiner Erinnerung nach nämlich in der Vergangenheit nirgendwo ein PW für den "Sicheren Start" eingegeben...

Allerdings habe ich eben noch ein wenig im TWRP gestöbert und festgestellt, dass in den Settings die Option "Use rm -rf instead of formatting" aktiviert war - warum auch immer (bewusst habe ich das sicherlich nicht gesetzt)!
Also die Option deaktiviert, [Wipe] --> [Format Data] ausgeführt, und siehe da, nun kommt die folgende Meldung...:
Code:
Formatting Data using make_ext4fs...
You may need to reboot recovery to be able to use /data again.
Updating partition details...
...done
Auch ohne Reboot wird nun im "Mount"-Bildschirm "[x] data" als eingehangen angezeigt; unter [Wipe] --> [Advanced Wipe] --> [Repair or Change File System] wird nun auch "Present: Yes" und "Used: 0MB" angezeigt - das Dateisystem ist übrigens nach wie vor ext4.
Im Terminal gibt der ls-Befehl nun tatsächlich die beiden Verzeichnisse lost+found sowie media aus - natürlich vorausgesetzt, man hat erst einmal mit cd /data/ in das entsprechende Verzeichnis gewechselt. Vorher war da nämlich kein einziges Verzeichnis und keine Datei zu sehen, weil es eben nicht eingehangen war - obwohl das Datenverzeichnis an sich da ja definitiv noch nicht leer/formatiert war!

Sieht also so aus, als wenn ich dieses Problem gelöst hätte - ich werde mal schauen, wie weit ich heute Abend mit dem weiteren Verlauf meines Installationsversuches noch komme - ich hoffe, es geht nun ohne weitere Stolpersteine voran! 😉

Danke an alle jedenfalls bis hierhin für die ganze Hilfe!
 
Farron

Farron

Experte
Sorry,
aber ich frage mich wie aus einem solch einfachem Vorhaben (LOS auf BQ X/Xpro) so ein Drama gemacht werden kann ?
Das BQ X/Xpro hat keine A/B Partitionen, die einem das flashen erschweren, das sichern aller Daten sollte bei einem solchen Vorhaben selbstverständlich sein.
TWRP flashen, in dieses booten, LOS flashen, Gapps flashen > Reboot > fertig.
 
Zuletzt bearbeitet:
Ähnliche Themen - Wie LineageOS installieren? Antworten Datum
2
0
7