S8311 / MT6592 (MT8392 is Fake!) / Hard bricked / SP Flash

  • 7 Antworten
  • Neuester Beitrag
Diskutiere S8311 / MT6592 (MT8392 is Fake!) / Hard bricked / SP Flash im Medion Lifetab S8311 / S8312 Forum im Bereich Medion Forum.
L

linuxlover

Neues Mitglied
Hallo Gemeinde,

folgende Historie zu meiner Frage

-> S8311 gerootet
-> Mtk_Droid_Tool_v2.5.3 meldet

Hardware : MT6592 (MT8392 is Fake!)
Model : LIFETAB_S831X

-> mit Mtk_Droid_Tool_v2.5.3 Backup angelegt (Full)
-> dieses Backup mittels "Blöcke für FlashTool vorbereiten" convertiert
-> mit Mtk_Droid_Tool_v2.5.3 Recovery CWM geflasht
-> hard bricket

Das Gerät befindet sich nun in einer Bootloop.
Nur noch das MEDION Logo erscheint cyclisch.

Beim Halten der Vol+ Taste kommt noch das kleine, mittige Auswahlmenü (Recovery Boot, Normal Boot, FastBoot Mode, UART boot). Recovery, Normal, UART funktionieren nicht mehr -> BootLoop. FastBoot Mode funktionert noch und man sich kann sich auch mit dem PC verbinden. Sämtlicher meiner Versuche
-> fastboot oem unlock
-> fasboot boot ...
-> fastboot flash ...
-> fastboot getvar ...
Funktioniert nicht - die Fehlermeldung deutet auf gesperrten bootloader hin. Alle mein bisherigen Versuche sind gescheitert.

Beim halten der Vol- Taste kam früher ein chinesisches Menü um Systemtests zu fahren, dies ist auch nicht mehr vorhanden.

Der MTK Preloader scheint zu funktionieren. Bevor das MEDION Logo erscheint, meldet der PC den Preloader der dann erwartungsgemäß nach zwei Sekunden wieder verschwindet.

Nun mein Problem: ich würde gern mit SP Flash das Mtk_Droid_Tool_v2.5.3 Backup wieder einspielen. Dazu lade ich die scatter Datei, tick als test nur Recovery an und drücke Download. Beim einstecken des USB Kabels bei ausgeschaltetem Tablet wird der Preloader erkannt der Balken fängt an sich zu bewegen - hört aber bei 100% DA auf und bekommt dann den bekannten 2004 Fehler. Ich habe folgende Version mit gleichem Ergebnis getestet (3.1216, 3.1344, 5.1352, 5.1452, 5.1628). Das Log file von SP zeigt, dass die Kommunikation aufgebaut wird, Hardwareinfos ausgelesen werden und es dann zu einem ERROR kommt.

08/05/16 14:50:14.099 BROM_DLL[1360][8396]: DEBUG: BRom_Base::Write8DataWithEcho(): =0, cmd(0xD7) (FlashToolLib/sv5/common/interface/src/brom_base.cpp:1289)
08/05/16 14:50:14.287 BROM_DLL[1360][8396]: ERROR: BRom_MT6276::BRom_WriteBuf(): Read16Data(): Status returns error (0x2001)! (FlashToolLib/sv5/common/generic/src/brom_mt6276.cpp:1153)

Nun bin ich etwas ratlos.
Hat jemand eine Idee, Vermutung, Tip wo ich weiter ansetzen kann?
 
Zuletzt bearbeitet:
Ora

Ora

Ehrenmitglied
linuxlover schrieb:
Nun mein Problem: ich würde gern mit SP Flash das Mtk_Droid_Tool_v2.5.3 Backup wieder einspielen
Ist dieses Backup auch mit dem MTK DT für das SP FT aufbereitet worden?
Poste mal den Inhalt des Backup Vetzeinisses, aus dem Du das Sacatterfile lädst.
 
L

linuxlover

Neues Mitglied
Ich habe das MKT DT Backup unter dem Reiter "Root,Backup,Recovery" mit dem Button "Blöcke für FlashTool vorbereiten" convertiert.
Die resultierenden Daten sehen wie folgt aus

Code:
LIFETAB_S831X_150817_backup\!Files_to_FlashTool>ls -al
total 2083348
d---------+ 2  None       4096 Jul  8 15:07 .
d---------+ 3  None       8192 Jul  8 15:06 ..
----------+ 1  None        512 Jul  8 15:06 EBR1
----------+ 1  None        512 Jul  8 15:06 MBR
----------+ 1  None       6997 Jul  4 15:45 MT6592_Android_scatter.txt
----------+ 1  None   10485760 Jul  8 15:06 boot.img
----------+ 1  None     393216 Jul  8 15:06 lk.bin
----------+ 1  None    8388608 Jul  8 15:07 logo.bin
----------+ 1  None     120240 Jul  8 15:06 preloader.bin
----------+ 1  None   10485760 Jul  8 15:07 recovery.img
----------+ 1  None    6291456 Jul  4 15:46 secro.img
----------+ 1  None 2097152000 Jul  4 15:58 system.img
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Noch ein paar zusätzliche Details:

-> Als DA benutze ich MTK_AllInOne_DA.bin
-> das scatterfile hab ich mal angehängt
-> ein logTrace vom kompletten Connect, Hardwareinfo retriveal, checkSum Checks etc + Error
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
1) Wenn kein SP FT läuft und ich das Tablet ans USB anschließe, macht Windows einmal MTK Preloader connect - 2 Sek Pause - disconnect.
2) Wenn SP FT im Downloadmodus läuft und ich das Tablet ans USB anschließe, macht Windows einmal MTK Preloader connect - 2 Sek Pause - disconnect (in diesem Ablauf kommt SP FT mit DA auf 100%) - UND dann direkt wieder connect - 2 Sek Pause - disconnect.

Ich interpretiere es so als ob SP FT aufgrund des Fehlers die SOC in den Reset-State fährt und das Ding daher neu bootet. Diesmal ist SP FT aber nicht mehr im Downloadmodus und daher verhält es sich so wie in Fall 1)

Ich nehme also an, das der Preloader schon funktionert, sich konnektiert und auch Daten abgefragt werden können (siehe logfile) aber bestimmte OPs die SP FT aufruft nicht verstanden werden.

Ich frage mich ob es noch andere Tools gibt, die den MTK Preloader bedienen - um sicherzustellen, dass die Kommunikation prinzipell funktionert.
 

Anhänge

  • MT6592_Android_scatter.txt
    6,8 KB Aufrufe: 204
  • ConnectLog.txt
    50,7 KB Aufrufe: 480
Ora

Ora

Ehrenmitglied
- welche Versionen des SP FT verursacht diesen Fehler?
- welche Optionen sind eingestellt (download mit Batterie mal versuchen)
- Tablett vorher sicher ausschalten
- während des Kabelsteckens mal die Lautstärke lauter Taste gedrückt lassen
- nach dem Flashen sofort ins Recovery booten und /data wipen
 
L

linuxlover

Neues Mitglied
Ora schrieb:
- welche Versionen des SP FT verursacht diesen Fehler?
Ich habe mit den SP FT Versionen 3.1216, 3.1344, 5.1352, 5.1452, 5.1628 getestet.
Das LogTrace sieht bei allen nahzu identisch aus. Nur bei der 5.1628 ist der 2004 Fehler umbenannt worden (0x7**)
Ora schrieb:
- welche Optionen sind eingestellt (download mit Batterie mal versuchen)
Ich habe alle Permutationen der Optionen mit with Battery, w/o Batter, Battery auto-detect, HighSpeed, FullSpeed getestet
Ora schrieb:
- Tablett vorher sicher ausschalten
kein Veränderung im Testergebnis
Ora schrieb:
- während des Kabelsteckens mal die Lautstärke lauter Taste gedrückt lassen
Ich habe mit gleichem Ergebnis die Kombinationen Vol+, Vol-, Vol+/Vol-, Vol+/Power, Vol-/Power, und mit den Armen meiner Frau Vol-/Vol+/Power beim Einstecken des USB Kabels getestet.

Zudem habe ich noch zwei andere PCs mit Win7 und XP getestet und 3 unterschiedliche USB Kabel.
Bei allen das gleiche Ergebnis.

- Preloader wird von Windows erkannt und Treiber geladen
- SP FT erkennt das Device
- SP FT schickt erfolgreich dast START Command (0xa0 0x0a 0x50 0x05)
- SP FT beginnt Kommunikation und fragt erfolgreich Hardwareinfos des Tablets ab
- SP FT wählt auf Grund der HardwareInfos den korrekten DA aus und schickt diesem zum Tablet (roter Balken bewegt sich)
- Tablet quittiert erhalt des DA mit status error 0x2001 und beendet den META Mode + Reboot.

Für die Akten: hier noch technische Doku

MediaTek details: Partitions and Preloader,
MediaTek details: SoC startup
 
Ora

Ora

Ehrenmitglied
Was passiert, wenn Du formatiert oder nur den Preloader der flashst?
 
R

retikulum

Erfahrenes Mitglied
Und, schon weitergekommen? Würde mich mal interessieren, ob man das Ding irgendwie neu flashen kann. Das würde Möglichkeiten eröffnen :)
 
D

derbratmaxe

Neues Mitglied
Hallo Leute,

habe genau das gleiche PRoblem mit einem S8312 - gerootet und dann mit MTK Droid Tools Custom Recovery erstellt und installiert - dummerweise wurde dabei auch ein gepatchter Kernel installiert so dass weder ein booten ins System noch ins Recovery funktioniert.

Ein Backup habe ich nicht aber ich habe das Full OTA 4 (da ist ein boot.img und ne scatter.txt drin) runtergeladen und wollte das mit SP-Flashtool installieren, was aber leider auch immer mit Fehler 2004 abbricht. So wie ich woanders gelesen habe kann dies auch mit einem gelockten Bootloader zusammen hängen.

Im Fastboot kann man zwar "fastboot oem unlock" machen und das Tablet fragt auch ob man wirklich unlocken will, aber das geht leider nicht wirklich, kommt immer ne Fehlermeldung.

Echt ärgerlich - das nicht mal SP-Flashtool funzt hatte ich noch nie erlebt bei nem MTK-basierten Gerät.

Es muss doch irgendeine Möglichkeit geben das Teil zu retten?!