Kamera- und Galerie-Problem SD-Karte

P

Pmiboe

Neues Mitglied
0
Hi!
Hab mir durch irgendwelche Blödheiten beim Neuaufsetzen des Steins im Zuge von Installation einer ext2-Partition auf der SD / swap-Einrichtung / link2sd-Einrichtung bei der Kamera- oder Galerie-App einen Verweis zerschossen. Vorweg: alle anderen installierten apps laufen mitsamt swap und link2sd richtig, die SD-Karte ist fehlerfrei und beide Partitionen (FAT32 und ext) sind gemounted. Die ursprünglichen Ordner auf der FAT-Partition für die Kamera (dcim sowie die Unterordner) sind ebenfalls vorhanden sowie alle Bilder drin, die ich gemacht habe.
Nun das Problem: die Galerie meldet beim Öffnen: "SD-Karte wurde entfernt oder ist nicht vorhanden", zeigt mir dafür Bilder aus anderen Ordnern der SD-Karte an, jedoch nicht den dcim-Ordner.
Die Kamera-App meldet beim Starten: "Legen Sie vor Verwendung der Kamera eine SD-Karte ein." und löst daher nicht aus.
Die bisherigen derartigen Probleme, die ich im Netz gefunden habe, beruhen letztendlich auf einer defekten SD, was bei mir ja nicht zutrifft (hab auch mit gparted überprüft).
Somit dürfte der Fehler darin liegen, dass eine der beiden Apps einen falschen Verweis auf das Stammverzeichnis für die Fotos hat.
Wisst ihr vielleicht, wo die diesbezüglichen Konfigurationsfiles liegen, damit ich sie manuell bearbeiten kann?

Vielen Dank im voraus!
Peter
FB_Addon_TelNo{ height:15px !important; white-space: nowrap !important; background-color: #0ff0ff;}
 
Diese Meldung aus der Galerie- und Kamera-App hatte ich vor langer Zeit auch mal - ohne defekte SD-Karte oder Experimente mit Formatierungen, einfach so.

Meiner Erinnerung nach war ich damals nicht der einzige und das Problem wurde erst beim nächsten Firmware-Update behoben. Aber sicher bin ich mir da nicht mehr, ist lange her.

Welche Firmware hast du denn? Gibt es eine neuere?
 
Hab das Cyanogen 7.2.3. Und eigentlich ist meine Lust darauf, deswegen das ganze Gerät bzw. alle apps neu zu installieren, eher begrenzt...
Oder kann ich auf ein neueres Cyanogen updaten, ohne dass die apps leiden?
 
Pmiboe schrieb:
Oder kann ich auf ein neueres Cyanogen updaten, ohne dass die apps leiden?

Ja, das geht auf jeden Fall, allerdings kenne ich mich da auch nicht so aus. Such mal nach Nandroid und Titanium Backup im Modding-Unterforum und in den FAQ.
 
beim update von 7.2.3 auf 7.2.4f sollte man schon einen wipe machen um probleme zu umgehen...
man kann es auch so versuchen, nur gibt es keine garantie, das es dann keine probleme gibt.

ansonsten kannst du versuchen unter Anwendungen -- Anwendungen Verwalten bei; Medienspeicher, Kamera und Galerie die Daten und Cache zu leeren/löschen, das kann eventuell helfen.
notfalls noch nach weiteren Apps suchen, die damit zusammen hängen könnten und dort das selbe machen, ich hab leider gerade keine CM7 drauf und kann daher nicht genauer nachschauen.

nach dem löschen der Daten/cache vom Medienspeicher, mußt du einmal rebooten und die Klingeltöne, Benachrichtigungstöne und Alarmtöne neu einstellen, da diese zurückgesetzt werden, das gleiche gilt auch oft für apps wie whatsapp oder andere apps, wo man benachrichtigungstöne einstellen kann

und ansonsten hilft eben nur ein kompletter wipe und dann auf die neuste CM7 updaten oder eine andere Firmware nutzen (z.b. mein Froyo Fast and Lite)...
per Titanium Backup kannst du deine Apps und einstellungen sichern, aber beim wieder einspielen, bitte keine Einstellungen von Systemapps nutzen, ebenso wie wlan und Konteneinstellungen nicht nutzen, da es dabei oft zu problemen kommt und man wieder wipen darf...

infos findet man wie immer auf meiner HP: http://droid-world.fufus-design.de/ oder hier im Forum verteilt
 
  • Danke
Reaktionen: Pmiboe
Hi, seltsame Sache... Hab die Sache wieder am laufen und möchte kurz berichten, was ich gemacht habe: hatte zunächst eine andere Galerieanwendung aus dem Market geladen, die mir angezeigt hat, dass ein Haufen Fotos aus dem dcim/Camera-Ordner fehlen. Daraufhin hab ich mich entsonnen, dass ich über den PC den Ordner entrümpelt hatte, um Speicherplatz freizumachen. Konklusio: irgendwo im System existiert eine Datenbank mit den Namen der Fotos, die im dcim/Camera-Ordner sein sollten, denn ich hatte dann auch alle Dateien im thumbnail-Ordner gelöscht, also gab es im dcim nirgends einen Hinweis auf Fotos, die existieren sollten, aber zwischenzeitlich gelöscht wurden.
Nun hab ich alle Fotos von meiner Sicherung (vor mienen Spielereien mit link2sd und swap) wieder in den dcim-Ordner eingespielt und siehe da - sowohl Galerie als auch Kamera laufen wieder!!!
Bei aller Hochachtung vor den tollen Programmierern: das muss einem auch erst einmal einfallen...
Also Problem gelöst, dafür hab ich mir auch gleich das Minimod gezogen - danke an FuFu für diese tolle Unterstützung - und meine sd-Karte auf 3 Partitionen erweitert mir resize. Hat ebenfalls super geklappt und nun läuft der Stein wie ewig nicht mehr. Brauche daher auch keine weiteren Versuche mit CM7.2.4 mehr zu starten.

Vielen Dank und Grüße,
Peter

Der ursprüngliche Beitrag von 16:12 Uhr wurde um 16:17 Uhr ergänzt:

kurzer Nachtrag zu der 3. Partition: das war nämlich auch ein Hund: wenn man ein Swapfile auf der Fat nutzt, kann man das Milestone nicht mehr an den PC hängen, weil swap die Fat-Partition blockiert=nicht mehr unmounted!!! Da muss man erst händisch swap stoppen, dann hat man wieder Zugriff auf die Fat vom PC aus. Das wurde hier aber auch noch nicht explizit so beschrieben, oder ich hab's einfach nicht gefunden; hatte mich nur gewundert, warum die USB-Verbindung plötzlich nicht mehr klappte.
Somit ist die eigene Swap-Partition dringendst zu empfehlen!!!
Grüße,
Peter
 
das mit der swap datei auf der fat wurd irgendwo im CM Thread mal besprochen ;)
ich persönlich hab da immer mein swapon script benutzt und dann swap auf /cache gelegt ;) da gibt es dann nur probleme, wenn man mal größere apps runterladen will.

am besten ist es entweder ne swap partition zu nutzen oder die swap datei auf die ext zu legen
 

Ähnliche Themen

T
Antworten
1
Aufrufe
2.595
motoroller
motoroller
paysano
  • paysano
Antworten
8
Aufrufe
3.418
-FuFu-
-FuFu-
T
  • Tapitap
Antworten
1
Aufrufe
1.353
DAS_Original
DAS_Original
Zurück
Oben Unten