1. Hast Du Lust, bei uns mitzuarbeiten und das AH-Team zu verstärken? Alle Details zu dieser aktuellen Herausforderung findest Du hier.
  1. cgr, 14.08.2010 #1
    cgr

    cgr Threadstarter Erfahrener Benutzer

    Hallo Leute,

    seit 2 Tagen habe ich das Problem, dass sich mein MS sofort nach dem Einschalten anfängt zu erhitzen und der Akku in kürzester Zeit leergefressen wird. Wenn ich nach den aktiven Verbrauchern schaue, dann scheinen es Medienprozesse zu sein, die das verursachen. Ich sehe aber keine Möglichkeit diese zu beenden. Bein den aktiven Anwendungen finde ich keinen Prozess, den ich stoppen könnte.

    Hat jemand für mich einen Tipp?
     
  2. Tomdroid, 14.08.2010 #2
    Tomdroid

    Tomdroid Erfahrener Benutzer

    Kann es sein, dass du vor kurzem eine grosse Menge Mediendaten (z.B. MP3) auf den Stein geladen hast?

    Ich konnte solches Verhalten wie von dir beschrieben wiederholt bei meinem Stein beobachten, nachdem ich jeweils einige neue Alben auf die Karte geladen hatte. Es scheint, der Medienspeicher (android.process.media) scant die Karte nach einer USB Verbindung und indexiert(?) die ganzen Mediendaten, wohl damit sie im Player schnell verfügbar sind. Bei mir ist es z.B. so, dass der Stein länger im Hintergrund am rackern ist, je mehr neue Daten ich auf ein Mal hinzugefügt habe (letztes Mal waren's rund 20 Alben und der Stein war etliche Stunden beschäftigt).

    Stoppen kann man das Ganze wie's scheint tatsächlich nicht. Weder (erfolglose) Versuche den Prozess abzuschiessen (er startet sofort neu), noch reboots (Prozess macht nach dem Neustart gleich weiter) helfen. Um die Batterie zu schonen hilft es, wenn mittels Übertaktung + Undervolting für 125/250 MHz + SetCPU der Stein bei Bildschirm off auf z.B. 125-250 MHz begrenzt ist. Somit rackert er im Hintergrund die Mediendaten durch, ohne dabei gleich die Batterie leer zu saugen.

    NB: Um zu sehen, welche Prozesse genau gerade wieviel CPU oder Speicher beanspruchen, gibt's diese gratis App: OS Monitor v1.1.6 Application for Android | Tools
     
    Dadof3 und cgr gefällt das.
  3. TimeTurn, 14.08.2010 #3
    TimeTurn

    TimeTurn Foren-Inventar

    Möglicherweise ist da auch eine app am saugn - sowas wie einen Torrent-client is aber nich draud oder? Dennbei UMTS wird der Stein auch sehr heiß.
     
  4. cgr, 14.08.2010 #4
    cgr

    cgr Threadstarter Erfahrener Benutzer

    yep, das wird es gewesen sein! Da mein MS zur Reparatur gehen soll, hatte ich meine ganzen Apps auf der Karte gespeichert.
     
  5. cgr, 19.08.2010 #5
    cgr

    cgr Threadstarter Erfahrener Benutzer

    Und es geht weiter :mad:! Mein Akku wird weiter durch den android.process.media gefressen. Beim Akkuverbrauchercheck liegt der Wert bei über 90%.

    An den Medienanwendungen scheint es zu hängen, aber ich kann nicht sagen woran genau. Das Abrufen der Galerie und auch des Musikplayers klappt nicht - die Anwendungen hängen sich dabei auf. Hier muss irgendwie die Ursache liegen. Kann es sein, dass sie die Karte nicht lesen können? Über den Advanced Task Manager werden die Daten zumindest auf der Karte angezeigt.

    Hat vielleicht noch jemand einen Tipp?
     
  6. TimeTurn, 19.08.2010 #6
    TimeTurn

    TimeTurn Foren-Inventar

    Hast Du schon nen Wipe versucht?
     
  7. schmarti, 19.08.2010 #7
    schmarti

    schmarti Android-Experte

    Vielleicht ists auch einfach eine einzige (defekte) Datei, an der sich die Mediensache festnuckelt. Ich würde die ganzen Mediendaten mal Stück für Stück aufspielen und jeweils beobachten.

    Grüße
     
  8. cgr, 19.08.2010 #8
    cgr

    cgr Threadstarter Erfahrener Benutzer

    Ich vermute auch, dass es an den Dateien liegen kann. Ich denke, ich formatiere mal die Karte und schau mir dann die Reaktion des MS an.

    Bei Misserfolg wird dann der Wipe wohl folgen müssen.

    Danke und Gruß
     
  9. Tomdroid, 19.08.2010 #9
    Tomdroid

    Tomdroid Erfahrener Benutzer

    Falls du's WIRKLICH wissen willst:

    Anleitung hier https://www.android-hilfe.de/forum/...-adbrecovery-und-nandroid-tutorial.16973.html befolgen.

    Achtung, neuerer USB Treiber: USB and PC Charging Drivers - Motorola Western Europe


    Dann im Stein bei Anwendungen "Entwicklung" aktivieren, mit USB an den PC hängen, die USB Einstellung auf'm Stein auf "Portal" etc. stellen, über Kommandozeile die ADB Shell starten und dann den Befehl "logcat" eingeben. Dann siehst du das Log auf'm PC.

    Eventuell siehst du jetzt schon, was er entweder vergeblich (Error) oder halt immer wieder tut.
    Sonst einfach mit dem Stein mal den Mediaplayer bzw. die Galerie öffnen und auf dem PC-Bildschirm beobachten, was da an Fehlermeldungen ausgeworfen wird (falls die Meldungen zu schnell sind kannst du das autoscrollen durch festhalten des vertikalen Fensterschiebers unterbinden).
     
    cgr gefällt das.
  10. Sonatic, 20.08.2010 #10
    Sonatic

    Sonatic Android-Hilfe.de Mitglied

    Ich tippe auf eine Videodatei, die der Stein zu indizieren versucht, die es aber nicht verarbeiten kann. Da soll er wohl etwas zickig reagieren. Versuch doch mal, alle Videodateien zu entfernen und schau dann mal, ob das Problem immer noch auftritt.
     
    TimeTurn, Milestone92 und cgr gefällt das.
  11. cgr

    cgr Threadstarter Erfahrener Benutzer

  12. Sonatic, 20.08.2010 #12
    Sonatic

    Sonatic Android-Hilfe.de Mitglied

    Ist nicht sooo viel. Ich habe vor zwei Tagen meinen Stein zum ersten mal gewurzelt und mich daher vorher in alles mit ADB und Nandroid und OpenRecovery eingelesen. Hat nur knapp eine Stunde gedauert, danach wusste ich bescheid, und dann war das rooten nur noch eine Sache von 5 minuten ;)
     
  13. Tomdroid, 20.08.2010 #13
    Tomdroid

    Tomdroid Erfahrener Benutzer

    Eigentlich ist das echt super simpel:

    1. Oben genannte / verlinkte Dateien runterladen
    2. Motorola USB Treiber installieren, danach PC rebooten
    3. Android SDK nach z.B. c:\Android-SDK entpacken
    4. Im Stein Menu->Einstellungen->Anwendungen->Entwicklung-> Haken bei USB-Debugging
    5. Stein per USB anschliessen
    6. Infoleiste beim Stein runterziehen, aus USB-Verbindung tippen und "Portal & Tools" auswählen
    7. Windows Start->ausführen->cmd eingeben
    8. cd.. wiederholen bis auf C:\, dann der Reihe nach eingeben und bestätigen:

    cd android-sdk
    cd tools
    adb shell
    logcat

    Das war's. Danach läuft der logcat output im PC Bildschirm. Wenn man am Stein nun was macht wie z.B. eine App starten, sieht man im logcat output gleich die Fehlermeldungen.

    Übrigens funktioniert das sogar bei nem reboot weiter, also wenn der Stein von sich aus neu startet.
     
  14. ins4n3h0rst, 20.08.2010 #14
    ins4n3h0rst

    ins4n3h0rst Neuer Benutzer

    Da ich das selbe Problem hab mit dem hohen Akkuverbrauch durch "Medien" und dem Aufhängen von der Mediengallerie und dem Player, hab ichs einfach mal mit logcat probiert:

    Wenn ich den Player startet, erscheint folgendes:

    Die letzte Zeile wiederholt sich jetzt andauernd...
     
  15. Dadof3, 23.08.2010 #15
    Dadof3

    Dadof3 Android-Guru

    Danke, ich hatte wiederholt dasselbe Problem, und deine Erklärung ist absolut plausibel. Da kann man sich nur merken, dass man den Stein nach dem Aufspielen von Mediendaten noch 'nen paar Stunden am Ladekabel lassen muss, bevor man ihn in die freie Wildbahn entlässt ... :-(
     
  16. ins4n3h0rst, 23.08.2010 #16
    ins4n3h0rst

    ins4n3h0rst Neuer Benutzer

    Also bei mir war ein kaputtes Bild schuld...
    Jetz läuft alles wieder super!
     
  17. Spikie, 23.08.2010 #17
    Spikie

    Spikie Android-Hilfe.de Mitglied

    ich hab das problem auch seit kurzem, hab ein paar GB mp3s auf die karte gespielt, danach ging der player nicht mehr weil nichts mehr angezeigt wurde, hab dann mal über nacht den player laufen lassen und am nächsten tag gings wieder. der akkuverbrauch ist aber trotzdem enorm. hört sich also bei mir auch nach diesem problem an ... aber jetzt sollte der stein doch schön langsam mal alles durchgescannt haben oder nicht ? gg
    hab mir jetzt diesen osmonitor installiert ... was is denn "DRM-geschützter Content Speicher" ? der steht ständig über 80% auslastung.
     
  18. segelfreund, 23.08.2010 #18
    segelfreund

    segelfreund Ehrenmitglied


    Klingt nach kopiergeschützen Sachen.
    Kann alles mögliche sein, Musik, Spiele oder sonst was.
     
  19. foxylion, 23.08.2010 #19
    foxylion

    foxylion Android-Hilfe.de Mitglied

    Aus meinen Erfahrungen zu urteilen ist es immer eine defekte Bild/Audio/Video-Datei, die das Milestone versucht in den internen Medien-Index aufzunehmen. Klappt das bei einer Datei die eigentlich lesabar sein sollte nicht probiert das der Prozess immer wieder in ner Endlosschleife und hört nich mehr auf.

    Ich spiel deswegen neue MP3s immer nur Albenweise auf und schau ob alles in Ordnung ist, und wenn ja kommt das nächste Album, usw...
     
  20. Spikie, 23.08.2010 #20
    Spikie

    Spikie Android-Hilfe.de Mitglied

    Könnt ihr was genaueres herauslesen wenn ich euch das log von osmonitor poste?
    Da stand schonmal mehr drin heute aber momentan steht nur das im log ->

    "08/23/2010 14:19:47 [VERBOSE] MediaProvider(1369) enter delete, uri: content://media/external/audio/media/300"
     
Du betrachtest das Thema "Sehr hoher Akkuverbrauch und Erhitzung Milestone" im Forum "Motorola Milestone Forum",