Update auf 5.1 nicht möglich

  • 5 Antworten
  • Neuester Beitrag
Diskutiere Update auf 5.1 nicht möglich im Motorola Moto G (LTE) (1. Generation) Forum im Bereich Weitere Motorola Geräte.
Teddy 239

Teddy 239

Fortgeschrittenes Mitglied
Hallo,
Ich melde mich mal wieder ^^
Also, mir wurde vor ein paar tagen angezeigt, dass ein Update auf 5.1 verfügbar wäre. Habe es runtergeladen und installieren lassen. beim starten in die recovery fingen die probleme schon an. Es kommt einfach ein standbild, mit einem androiden aus dessen bauch ein rotes warndreieck kommt.
Also habe ich twrp geflasht und es darüber versucht zu installieren (Datei aus /cache hinauskopiert).
Dabei gibt mir TWRP einen Error aus, der besagt, dass ich versuchen würde die reteu version auf einer retbr version zu installieren. Ich habe aber die reteu version, wie man auch in den einstellungen bei "über das Telefon" sehen kann.

Ich selbst habe stock rom und das moto g ist gerootet. Busybox habe ich auch schon für das update entfernt.
Ich hoffe ihr könnt mir helfen :)
Teddy 239
 
K

keule1035

Ambitioniertes Mitglied
Du kannst es nur über die Stock recovery installieren! Ich hatte auch TWRP drauf und musste es noch mal komplett flashen damit wieder die stock recovery drauf ist. Danach lies sich die Zip mit dem Update ohne Probleme installieren.
Übrigens wenn der Androide auf dem Rücken liegt, ist das wahrscheinlich der Punkt, wo du gleichzeitig laut und leise gedrückt halten (5 Sekunden) und einmal kurz die Power Taste drücken musst.
 
Teddy 239

Teddy 239

Fortgeschrittenes Mitglied
Leider kein erfolg. Immer noch die gleiche Fehlermeldung.
Hier ist das Log:

Install /data/media/0 ...
Finding update package...
I:Update location: /tmp/sideload/package.zip
Opening update package...
I:read key e=3 hash=20
I:1 key(s) loaded from /res/keys
Verifying update package...
I:comment is 1462 bytes; signature 1439 bytes from end
I:whole-file signature verified against key 0
I:verify_file returned 0
Installing update...
installing gptupgrade updater extensions
file_contexts path is present in /tmp/file_contexts
mount point :/system location: /dev/block/platform/msm_sdcc.1/by-name/system , file system type :ext4script aborted: Package expects build fingerprint of motorola/peregrine_reteu/peregrine:4.4.4/KXB21.14-L1.56/52:user/release-keys or motorola/peregrine_reteu/peregrine:5.1/LPB23.13-17/18:user/release-keys; this device has motorola/peregrine_reteu/peregrine:4.4.4/KXB21.14-L1.56-1/1:user/release-keys.
Package expects build fingerprint of motorola/peregrine_reteu/peregrine:4.4.4/KXB21.14-L1.56/52:user/release-keys or motorola/peregrine_reteu/peregrine:5.1/LPB23.13-17/18:user/release-keys; this device has motorola/peregrine_reteu/peregrine:4.4.4/KXB21.14
E:Error in /tmp/sideload/package.zip
(Status 7)
Installation aborted.
Rebooting...

Hmmm :(
 
Teddy 239

Teddy 239

Fortgeschrittenes Mitglied
So update hat jetzt endlich geklappt.
Zumindest das installieren. Mir fehlen alle apps die auf der sdkarte waren, diese trudeln aber innerhalb von 20 Minuten wieder ein. Ziemlich lahm.
Außerdem werden bei jedem Start alle apps optimiert. Komischerweise nur 57, wo ich doch rund 300 installiert habe. Auf internen/externen Speicher kann ich durch einen filemanager nicht mehr zugreifen, in die recovery komme ich nicht mehr und bekomme die Fehlermeldung "no Command".
Außerdem meint das Moto g alle 20 Minuten einen schwarzen Bildschirm zu bekommen wo nur noch die Hintergrundbeleuchtung und dieser Punkt aus den entwicklereinstellungem funktionieren. Einziger Ausweg für mich natürlich reboot und da wiederholt sich alles.
Ich hoffe ihr könnt mir helfen :/
 
Teddy 239

Teddy 239

Fortgeschrittenes Mitglied
Nach dem Downgrade auf 4.4.4 buggt es richtig rum. Wenn ich 1 mal GPS aktiviere lässt es sich nicht mehr ausmachen. Sonst läuft auch IMMER ein Seltsamer streifen durch das Display, jedoch ist der streifen farblos, wirkt nur so als würde er alles verziehen. Auf screenshots ist er nicht sichtbar. Er geht erst weg wenn ich das Display aus und wieder ein schalte. In der Recovery ist er auch zu sehen.
Außerdem funktioniert die ersten ~10 min die ein/aus taste nicht.
Sonst gibt es auch immer zufällige appabstürze
Ich hoffe ihr könnt mir helfen.
 
cptechnik

cptechnik

Moderator
Teammitglied
Das mit dem farblosen Streifen/wandernden Balken ist ein Produkt aus neuem bootloader (motoboot) und altem stock/Firmware.
Einmal die neue Motorboot geflasht, gibt es kein zurück ohne streifen.

Beim update wird der gesamte interne Speicher gelöscht, die intern installierten App's sind gelöscht.

Beim flashen von stock, vor allem der neueren Generationen 4.4.4 ff ist der Zugriff auf die SD immer mehr eingeschränkt worden, und IMHO dadurch oft ohne root kein Zugriff möglich.

Mit TWRP ist kein stock update möglich - einfach aus einer passenden herunter geladenen Firmware recovery.img flashen.

Wo ich mir jetzt weniger sicher bin ist ob überhaupt bei root und entsperrtem bootloader es möglich ist ein update durch zu führen.
Vielleicht meldet sich noch ein Experte nachdem ich den Thread aufgewärmt habe...

Wenn du geöffneten bootloader und TWRP hast, ist der weg zu CyanogenMod doch nicht weit...?