Custom-ROM flashen mit TWRP schlägt fehl

  • 3 Antworten
  • Neuster Beitrag
A

AriCo

Neues Mitglied
Threadstarter
Hallo,
mein Problem muss nicht unbedigt Gerätespezifisch sein, aber ich hoffe mir kann jemand helfen.
Ich habe mir den Bootloader meines Nokia 6.1 entsperren lassen. Hintergrund für mich war es, mehr Zugriff auf das System zu bekommen und etwas mit den verfügbaren Custom-ROMs zu tinkern. Soweit so gut -> Bootloader ist entsperrt.
Das ist nicht mein erstes mal mit Custom-ROMs und somit eigentlich kein Problem soweit man sich an die Anleitungen hält.

Im TWRP bekomme ich bei jeder ROM .zip folgende Ausgabe:
[...]
Installing zip file '/sdcard1/DATEINAME.zip'
Checking for Digest file...
Error installing zip file '/sdcard1/DATEINAME.zip'
Updating partition details...
[...]

TWRP boote ich via "fastboot boot 'file.img'", was auch funktioniert. Ich habe bereits verschiedene Version getestet, keine behebt für mich das Problem.
Seltsamerweise weicht die Dateistruktur jeder .zip etwas von dem ab, wie ich es im Internet recherchieren konnte. Es sind keine .img vorhanden, sondern nur eine payload.bin und der "META-INF/com/google"-Ordner fehlt. Aber da das alle soweit betrifft, gehe ich mal davon aus, dass das stimmt.

Bei der Installation halte ich mich in der Reihenfolge an die Anleitung der jeweiligen ROM-Entwickler. Sprich: format -> wipe -> flashen ...
Aber das flashen lässt TWRP ja gar nicht erst zu..

Beispielhaft nenne ich mal folgende ROM, jedoch trifft das auch auf andere zu:
[ROM][UNOFFICIAL][10.0][Plate2] Havoc-OS-v3.0 [2019/12/15]

Mein Modell ist ein TA-1043
Ich hoffe die Infos waren ausreichend und es hat jemand einen Tipp für mich.
 
Wattsolls

Wattsolls

Super-Moderator & Mediator
Teammitglied
Nur mal laut gedacht, den TWRP Installer vor der ROM flashen bringt auch nichts?
 
A

AriCo

Neues Mitglied
Threadstarter
Den soll man laut den Anleitungen nicht flashen weil das Smartphone keine gewöhliche Recovery-Partition hat. Zumindest wenn ich das richtig deute..
"See in AB devices, there is no separate recovery partition. Recovery resides in boot itself. Just fastboot boot it, do your stuff and use it. "
siehe
 
Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Stammgast
Das mit payload.bin ist normal, da manche ROMs wie ein OTA Update installiert werden und dies geschieht auch mit der payload.bin-Datei. Die Images liegen darin und können entpackt werden (s. payload_dumper). Nach solch einer Installation wechselt auch dein boot slot auf _a oder _b.

Hast du mal in den Einstellungen von TWRP die Digestüberprüfung ausgeschaltet? Da gibt es eine Option.
Beitrag automatisch zusammengefügt:

Muss mich korrigieren, die Digestüberprüfung bezieht sich in den Einstellungen nur auf die Sicherung.

Lade dir den payload dumper runter und entpacke die Images. Die kannst du ohne Probleme in TWRP installieren.
 
Zuletzt bearbeitet:
Oben Unten