Austausch von wpa_supplicant scheitert

  • 19 Antworten
  • Neuster Beitrag
burnieflash

burnieflash

Fortgeschrittenes Mitglied
Threadstarter
mit der absicht, adhoc für mein loox zu ermöglichen (hab ein nokia mit joku-hotspot) arbeite ich bereits seit 3 tagen an dem neuen ding und habe viele ratschläge umsetzen können. ich habe es gerootet, hab den superuser (allerdings mit unaktueller binary) hab den rootexplorer, und den ROM Manager.
Allein, ich komme nicht damit zurecht, diese wpa_supplicant in die system/bin zu kopieren, da ich die zugriffsrechte nicht verändern kann. Die Schaltfläche im Rootexplorer funzt da nicht.
 
burnieflash

burnieflash

Fortgeschrittenes Mitglied
Threadstarter
Horschtl schrieb:
Hallo,

habe jetzt das Looxi mit dem Fluxflux Crom geflasht aber jetzt
keine Rootrechte mehr. :cursing: Muss da nochmals nachlesen...
Auf folgender Seite steht aber, was der Adhocenabler macht:
szym.net » Ad-hoc Wifi in Android
Also nichts, wozu man die App zwingend bräuchte.
Also alles, was in diesem Thread schon steht.
Was ich auf der Seite gefunden habe und nicht weis
um was es geht ist eigentlich:

removes the [IBSS] flag from scan results,
masquerades and demasquerades ad-hoc ssid with (*) prefix
sets mode 1 (ad-hoc) if the ssid is for IBSS
permits the supplicant to select an IBSS when associating to a given ssid

Was ist den generell IBSS?

Viele Grüße

gerhard

Darf ich fragen, wie Sie Schreibzugriff für die wpa_supplicant.gz erhalten haben?

lg
Martin
 
hävksitol

hävksitol

Ehrenmitglied
Hallo burnieflash, willikommen im Forum;ich habe aus Deinen Beiträgen einen neuen Thread gemacht, da es eher ein Problem der Zugriffsrechte als ein AdHoc-Problem zu sein scheint - möglicherweise ist das Roten nicht korrekt durchgeführt worden?
 
burnieflash

burnieflash

Fortgeschrittenes Mitglied
Threadstarter
hävksitol;3022317 schrieb:
Hallo burnieflash, willikommen im Forum;ich habe aus Deinen Beiträgen einen neuen Thread gemacht, da es eher ein Problem der Zugriffsrechte als ein AdHoc-Problem zu sein scheint - möglicherweise ist das Roten nicht korrekt durchgeführt worden?
Vielen Dank für die freundliche Rückmeldung!
Ich vermute, dass das Rooten schon gut gelaufen ist, und zwar mit dem Wendal-Tool. Allerdings funzt das RKCooking nicht so wie darkwing das beschreibt. Die Rückmeldungen der RKCooking.bat kommen völlig anders. Das Cooking ist laut darkwing allerdings die Voraussetzung, um Schreibzugriff in den Systemdateien zu erhalten.
Somit steht die Sache nicht.
Aber alles andere läuft noch völlig normal. Ist ja auch schon was, oder :)
 
M

MikeBerlin

Neues Mitglied
burnieflash schrieb:
Ich vermute, dass das Rooten schon gut gelaufen ist, und zwar mit dem Wendal-Tool....
Ich vermute den Grund in dem verwendeten Dateisystem. Das "cramfs" lässt kein Schreiben zu. Ich habe, da ich das Dateisystem nicht ändern wollte, mit RKcooking die Datei in der system.img ausgetauscht und das Image neu geflasht.
 
burnieflash

burnieflash

Fortgeschrittenes Mitglied
Threadstarter
MikeBerlin schrieb:
Ich vermute den Grund in dem verwendeten Dateisystem. Das "cramfs" lässt kein Schreiben zu. Ich habe, da ich das Dateisystem nicht ändern wollte, mit RKcooking die Datei in der system.img ausgetauscht und das Image neu geflasht.
Ich hab gestern gelesen, dass unter Win7 64Bit das Wendal-Tool nicht richtig funktioniert. Normalerweise sollte man mit einem gerooteten Loox und Super-User Schreibzugriff bekommen, oder?
Ich könnte es noch einmal mit einem XP-Rechner probieren.

Jedenfalls aber ist mir das RKCooking noch ein komplett spanisches Dorf. Obwohl ich seit Tagen herumlesen, wie man es anstellen könnte, dass dieses verd.... Loox den Joikuspot akzeptiert....

Ich habe es heute laut Anleitung darkwing versucht, aber die Rückmeldungen und das Verhalten der Bat-Datei sind völlig anders als in seiner Anleitung. Na und da ich keine andere Anleitung sonst kenne, steh ich momentan an.

Kennst Du eine Anleitung, wie man das RKCooking verwenden kann?
Image flashen, was hat das auf sich und wie geht das? Ich will in Wahrheit nur eine einzige wpa_supplicant.gz Datei in die /system/bin kopieren und schauen, ob dann der Joikuspot erkannt wird.
 
hävksitol

hävksitol

Ehrenmitglied
Hallo burnieflash, muss es denn unbedingt eine selbst gerootete FW sein?
Hier gibt es doch reichlich fertig gerootete FW-Varianten für den Loox.

Vielleicht erweist sich dieser Hinweis ja als gordischer Knoten.
 
burnieflash

burnieflash

Fortgeschrittenes Mitglied
Threadstarter
wow, danke für Deine wertvolle Anteilnahme!

Verstehe ich das richtig, dass all diese images für mein loox möglich wären, und dass es nach dem rooten völlig normal aussehen und funktionieren sollte, trotz der unterschiedlichen dateiformate (ext3, ext4, cramFS)?
Das wär ja richtig abenteuerlich ...
 
burnieflash

burnieflash

Fortgeschrittenes Mitglied
Threadstarter
hävksitol;3027050 schrieb:
Hallo burnieflash, muss es denn unbedingt eine selbst gerootete FW sein?
Hier gibt es doch reichlich fertig gerootete FW-Varianten für den Loox.

Vielleicht erweist sich dieser Hinweis ja als gordischer Knoten.
extra spannend wirds ja mit den ext4-images, aber die sind mir noch zu exotisch.
faszinierend, was die jungs hier alles entwickeln!
danke nochmal für diesen blindenstock. hatte ich dringend nötig.
 
M

MikeBerlin

Neues Mitglied
burnieflash schrieb:
Ich hab gestern gelesen, dass unter Win7 64Bit das Wendal-Tool nicht richtig funktioniert
Bei mir hat alles problemlos funktioniert (Windows 7 Ultimate 64 Bit). Heute erfolgreich Verbindung mit meinem HTC-Touch-Diamand (AdHoc Netzwerk WMWifiRouter) aufgenommen.
 
M

MikeBerlin

Neues Mitglied
burnieflash schrieb:
... nur eine einzige wpa_supplicant.gz Datei in die /system/bin kopieren und schauen, ob dann der Joikuspot erkannt wird.
Noch mal drei Schritte zurück, oder hat sich Dein Problem erledigt? "nur" ist nicht so einfach!
- Eine komplette Anleitung findest Du hier https://www.android-hilfe.de/forum/root-hacking-modding-fuer-das-odys-loox.598/odys-loox-xpress-rooten-und-image-bearbeiten.159565.html. Ich habe das Teil ausgedruckt und Punkt für Punkt abgearbeitet. Mir war nirgends eine Abweichung aufgefallen.
- Du brauchst keine ROOT-Rechte? Viele Apps hätten aber gerne diese Rechte, also machst Du es gleich mit.
- Die wpa_supplicant.gz musst Du extrahieren (ist ein Linux-Kompressionsverfahren, das inzwischen auch Windows-Programme verstehen.)
- die ausgepackte Datei musst Du in den entsprechenden Ordner packen. Das geht aber nicht im LiveSystem, da Du keine Schreibrechte hast und ohne neues Filesystem auch nicht bekommst. Also machst Du das im offline-Modus auf dem Windows-Rechner.
- nach dem Flashen findet Odys-Loox auch AdHoc-Netze. (bei mir: HTC Touch Diamond mit originalen Vodafone-ROM mit WMWifiRouter 2.0 und WEP-Verschlüsselung)
Viel Erfolg.
 
burnieflash

burnieflash

Fortgeschrittenes Mitglied
Threadstarter
wow, und mit welcher umprogrammierung ist das zustande gekommen?
verwendet das htc auch joikuspot?

ich habs heute wieder einige stunden mit verschiedenen kniffen versucht, aber leider erfolglos. musste das ganze wieder und wieder neu aufsetzen.
 
N

netlars

Erfahrenes Mitglied
burnieflash schrieb:
ich habs heute wieder einige stunden mit verschiedenen kniffen versucht, aber leider erfolglos. musste das ganze wieder und wieder neu aufsetzen.
Ich verstehe das Problem nicht.
Wo kommst du nicht weiter?
Hast du nun ein fertig gerootetes Image genommen?
 
burnieflash

burnieflash

Fortgeschrittenes Mitglied
Threadstarter
netlars schrieb:
Ich verstehe das Problem nicht.
Wo kommst du nicht weiter?
Hast du nun ein fertig gerootetes Image genommen?
vorerst mal:
danke, mike, und danke netlars für eure rückmeldungen.
ich stelle fest, dass seit gestern das thema für diesen thread erledigt ist und ich mich auf eine andere ebene begeben sollte:
der austausch der wpa... funktioniert seitdem ich das jüngste ext3-image von fluxflux installiert habe.
danke thomas, das ist eine spitzen arbeit, die hier zusammengestellt wurde!

ich habe nun auf wunsch alle schreibzugriffe und daher konnte ich die wpa... von wendal - entzippt - in den \system\bin kopieren (die originale habe ich aufgehoben). nach dem neustart ging aber das wlan überhaupt nicht mehr (WLAN fehler ...). das zurückkopieren der alten wpa... hats leider nicht gebracht, wie ich nach neuerlichem neustart feststellen musste. mit der wpa... von wendal hatte ich also kein glück und musste das img neu aufspielen. das geht aber sehr easy dank thomas.

nun habe ich es mit adhoc-enabler versucht. der konnte wegen der zugriffsrechte nun auch seine arbeit tun, aber leider auch ohne erfolg. wieder WLAN fehlermeldung. lobenswerterweise konnt der adhoc-enabler seine einstellung erfolgreich zurücksetzen. somit hab ich mir die neuaufsetzung diesemal erspart.
nun steh ich aber wieder am anfang: ich will mit dem loox über joiku-spot eine netzverbindung herstellen.
und somit muss ich den thread wechseln.

mike, deine tipps sind sehr exakt, danke vielmals. ich kann aber nun direkt auf dem loox die datei tauschen. halt ohne den gewünschten erfolg.
was mich der vollständigkeit halber trotzdem interessiert hätte wäre, wie du auf dem windows-rechner die wpa... datei in die img kopieren kannst.

ich begeb mich jetzt in den bereich "Odys Loox - Ad-hoc-Netz?"
danke allen! für mich ist das thema beschlossen. der tausch der wpa... gelang, aber er bringt nichts.

martin
 
N

netlars

Erfahrenes Mitglied
burnieflash schrieb:
ich habe nun auf wunsch alle schreibzugriffe und daher konnte ich die wpa... von wendal - entzippt - in den \system\bin kopieren (die originale habe ich aufgehoben). nach dem neustart ging aber das wlan überhaupt nicht mehr (WLAN fehler ...). das zurückkopieren der alten wpa... hats leider nicht gebracht, wie ich nach neuerlichem neustart feststellen musste. mit der wpa... von wendal hatte ich also kein glück und musste das img neu aufspielen. das geht aber sehr easy dank thomas.

martin
Hast du die dateirechte nach dem ersetzen der wpa supplicant wieder gesetzt, so das die neue auch die selben rechte wie die anderen in dem verzeichnis hat?

Mfg
Netlars
 
burnieflash

burnieflash

Fortgeschrittenes Mitglied
Threadstarter
netlars schrieb:
Hast du die dateirechte nach dem ersetzen der wpa supplicant wieder gesetzt, so das die neue auch die selben rechte wie die anderen in dem verzeichnis hat?

Mfg
Netlars
Die Rechte beider Dateien sind -rw.
Muss man nach dem verschieben der Wenadl - wpa _ suppliciant ins system\bin irgendwelche Rechte, aendern?
Lg
Martin
 
F

fluxflux

Stammgast
Die Datei wpa_supplicant muss ausführbar sein, also -rwxrwxrwx ...

rw alleine reicht nicht.

Thomas.
 
burnieflash

burnieflash

Fortgeschrittenes Mitglied
Threadstarter
:scared:
Finally!
Thomas, ich muss dir nochmals danken.
Zuerst dieses Spitzenmaessige Ext3-Image und nun die Loesung fuer mein Joikuspot-Problem!
Einfach gut ihr Typen!
Habt ihr eine Bierkassa oder sowas?

Um es ganz besonders verflixt zu machen, hat sich der Joikuspot am Handy 9x nicht erfolgreich starten lassen ...:cursing:

Bin ja schon gespannt auf die ext4 ...
Dankbare Gruesse!
Martin

(Also war es doch noch eas fuer diesen thread ...)
 
F

fluxflux

Stammgast
burnieflash schrieb:
Habt ihr eine Bierkassa oder sowas?
Wenn du einen Bedürftigen am Weg sitzen siehst, dann gib es ihm, er wird es brauchen können, ich denke und danke, dass wir alles haben ...

Thomas.
 
Zuletzt bearbeitet:
burnieflash

burnieflash

Fortgeschrittenes Mitglied
Threadstarter
Wusste bisher nicht, dass mein Meister aus Nazareth auch Nachfolger unter den Hackern berufen hat (bewusst oder unbewusst).
Danke, der Beduerftige kann sich schon freuen ...
:smile:
 
Oben Unten