Root mit KatKiss-5.1_TF300T_022 funktioniert nicht

  • 7 Antworten
  • Neuester Beitrag
Diskutiere Root mit KatKiss-5.1_TF300T_022 funktioniert nicht im Root / Custom-ROMs / Modding für Asus Transformer Pad TF300 im Bereich Asus Transformer Pad TF300 Forum.
michafdl

michafdl

Neues Mitglied
Hi, Ich habe das Asus TF300T und möchte gerne mit KatKiss-5.1_TF300T_022 rooten. Da ich hier absoluter Neuling bin habe ich keinen Plan über den Ablauf. Habe gelesen das ich SuperUser brauche um Rootrechte zu bekommen. Leider meldet dieses Progi immer das es keine Binäre Datei findet und nicht installieren kann. Dann habe ich noch ein App benutzt das Geräteextras entsperren heisst. Hier wird aber immer ein unbekannter Netzwerkfehler genannt. Einen TWRP Manager habe ich mir auch schon installiert funktioniert aber wohl nicht ohne Rootrechte? Leider finde ich im Netz nur Englische Beschreibungen und werde nicht daraus schlau. Kann mir einer von Euch mitteilen welche Apps ich brauche und wie die Abläufe sind oder eine Seite nennen die dies auf Deutsch beschreibt? :sad:
Update: Habe jetzt Kingo Root installiert. Damit hat das Root geklappt.Nach dem Neustart des Pad meldet Kingo Root Erfolg. TWRP lässt sich dann auch starten. Wenn ich aber nun z.b. ein Backup erstellen will passiert ne Zeitlang nichts und dann meldet TWRP das,das App gecrasht ist. Nach einem Neustart des Pads meldet Kingo Root das,das Pad wieder nicht grootet ist. Kriegt man ja die Krise. Was läuft verkehrt???
 
Zuletzt bearbeitet:
C

c_w

Dauergast
Ich glaube, du wirfst da einige Sachen querbeet durcheinander. Und so richtig bist du hier in diesem Thread damit auch nicht aufgehoben, aber ich antworte mal drauf und bitte einen Mod, das ganze auszulagern:

Wenn du wirklich nur rooten möchtest, ist das flashen einer Custom Rom etwas überdimensioniert. Deswegen spar ich mir auch mal die Erklärung, was du alles tun müsstest, um die Rom in dem Thread hier zu installieren.

Das du mit dem TWRP Manager keinen Erfolg hast, ist auch logisch. Für die App benötigst du neben Root noch einen offenen Bootloader und das TWRP Recovery. Die App ist im Endeffekt nur eine Benutzeroberfläche für das Recovery, soweit ich weiß.

Du hast mehrere Möglichkeiten, um zu rooten. Am sichersten wäre wsl der Versuch, mit geschlossenem Bootloader. Da kann recht wenig schief gehen. Welche Android Version hast du denn installiert? Die neueste offizielle von Asus? Ich bin da nicht ganz auf dem aktuellen Stand, ob das rooten bei allen Version mit geschlossenem Bootloader möglich ist.

Ansonsten, was immer geht und auch immer gut klappt: Bootloader öffnen, ein alternatives Recovery installieren (TWRP oder Clockwork Mod) und dann rooten. Anleitungen hier:

https://www.android-hilfe.de/forum/...1-27-1-twrp-recovery-2-5-0-0-root.391627.html

und hier

https://www.android-hilfe.de/forum/...kworkmod-recovery-for-tf300t-root.246798.html
 
michafdl

michafdl

Neues Mitglied
Hi, erstmal Danke fürs verschieben ins richtige Forum und für die Antwort. Habe die Version 4.2.1 drauf. Was ich will ist von 4.2.1 loolypop auf das KatKiss 5.1 zu wechseln.
Nachdem ich mich durch etliche Anleitungen in Englisch durchgekämpft habe, meine ich nun - damit dies klappt, verstanden zu haben das ich erst Rooten muss und eine Recovery brauche. Das klappte aber alles nicht so richtig. Gerootet habe ich es jetzt bekommen aber irgendwie klappt das mit TWRP nicht. Nun werde ich mich mal durch Deinen Link morgen durchlesen. Da in Deutsch ;o) bin ich guter Dinge das ich morgen weiter komme. :thumbup:
 
michafdl

michafdl

Neues Mitglied
habe nun TWRP installiert bekommen nach dieser Anleitung. https://www.android-hilfe.de/forum/...1-27-1-twrp-recovery-2-5-0-0-root.391627.html
Hat alles geklappt bis zum Punkt 11. Dann kam Fehler. SuperSU Zip Signature failed. Jetzt startet er nur noch ins TWRP nicht mehr ins System. Habe mir die
orginal JP_epad-user-10.6.1.27.5.zip von Asus runtergeladen und versucht mit TWRP zu installieren. Immer diesselbe Fehlermeldung : No MD5 File found. Signature vertification failed. Error flashing zip.
Kann mir jemand weiterhelfen???:confused2:
Update: Habe Dank dieser Seite https://www.android-hilfe.de/forum/...tloader-error-0x00000000-bootloop.455533.html das Gerät wieder am laufen. :razz: Werde es also erneut versuchen KatKiss zum laufen zu bekommen. Versuch macht klug....falls noch einer Tipps hat....
 
Zuletzt bearbeitet:
C

c_w

Dauergast
Ok, du willst doch auf jeden Fall KatKiss installieren... hatte ich nicht so verstanden.
Welche TWRP Version hast du installiert? Die 2.5 aus dem Thread, den ich verlinkt hatte?

Lade dir hier

[ROM][LP 5.1.1_r1] [ KatKiss - Lollipop #023… | Asus Transformer TF300T | XDA Forums

aus dem ersten Posting das KatKiss Rom, die GoogleApps, SuperSU (ist nicht die aktuellste Version, kannst du aber nachher einfach updaten) und wenn du möchtest noch den Google Launcher herunter.

Dann:
1. Boote ins TWRP Recovery
2. Mache einen full wipe / factory reset
3. Flashe nacheinander: Rom, SuperSU, GApps und ggf. den Google Launcher (wichtig, alles in der reihenfolge flashen, auch wenn du SuperSU schon vorher mal geflasht hattest - nur der Google Launcher ist optional)
4. Wipe cache/dalvik
5. Reboot

Falls du aktuell ein funktionierendes System hast, kannst du die Sachen direkt aufs Tablet runterladen und später von da flashen.
Wenn nicht, dann lade die Dateien auf den PC und flashe sie per adb sideload. Oder kopiere sie per adb push auf's Tablet.

Das erste mal booten dauert dann wie üblich etwas länger.
Wenn du danach Probleme hast (System startet, zickt aber rum oder ähnliches), dann boote nochmal ins TWRP, führe dort ein format /data aus (dabei wird die komplette Datenpartition formatiert, dauert locker mal 20 min - bloß nicht zwischen drin abwürgen, weil man denkt, passiert ja nix mehr). Anschliessend dann der gleiche Installationsprozess wie oben nochmal.
 
michafdl

michafdl

Neues Mitglied
Jo, von da hatte ich meine KatKiss und SuperSu usw. Aber das Problem ist das ich die SuperSu nicht zum laufen bringe. Da meldet - wie oben beschrieben - mir TWRP immer SuperSU Zip Signature failed. So wie bei allen anderen Zip auch. Bekomme nichts installiert. Werde jetzt nochmal nach Deiner Beschreibung gehen. Mal schaun wies klappt. Schonmal Danke für die weitere Hilfe.
Nachfrage: Da ich jetzt mein System gerettet habe indem ich nur die blob von Android 4.2.1 überspielt habe.....würde das nicht auch mit der 5.1 so funktionieren? Also nur die Blob rausziehen und mit TWRP flashen? Wäre aber wohl zu einfach....wie gesagt habe keinen Plan bin noch in der Lernphase.

Update: Ich kriegs nicht hin. Beim Wipe meldet er immer unable to write. Ich hake alles an aber alles ist unable???

Update 1: Krieg die Krise. Nu hat das mit Wipe hingehauen. Lag wohl daran das TWRP zuerst ein Passwort wollte. Wipe lief also nu.
Nun wollte ich das KatKiss installieren - von SDCard - hier bekomme ich jetzt aber immer die Meldung. -
E: Zip signature verification failed:1
Error flashing zip `/external_sdcard/KatKiss-5.1_023.zip

Update 2: Krieg Hörner. Bei meinem ersten gescheiterten Versuch konnte ich ja mit Fastboot rangekommen und hab wieder alles zum laufen gebracht. Jetzt erkennt Fastboot Devices nichts mehr. Im Gerätemanager ist das Asus erkannt aber Fastboot findet nichts. ADB Shell blitzt nur kurz auf. Mit TWRP bekomme ich nicht eine ZIP installiert alles Unable. HiiiiillllfffeBittte...,..

Update 3: Mache hier den Aleinunterhalter ;o) Also nu hab ich wieder die 4.2.1 druf. Fragt mich nicht wie ich das hinbekommen habe....also tippen tu ich darauf das ich die Tastatur vom Pad abgeklemmt habe und das Pad direkt per USB verbunden habe und ne andere Fastboot Version (K.a. welche ich jetzt aktuell hab) genommen hab. Kapiere bloß nicht warum ich mit TWRP nicht KatKiss draufbekomme. ???
 
Zuletzt bearbeitet:
Captain Awesome

Captain Awesome

Dauergast
Hi,

also:
TWRP ist drauf? Welche Version?

Tab ins TWRP booten und an Pc anschließen dann USB mounten.
Das Katkiss Rom, die Gapps und SuperSu auf das Tab kopieren.
Dann per TWRP nacheinander flashen:

Rom
Supersu
Gapps

Ohne irgendeine SDCard im Tab.

So sollte es klappen.

MfG
 
michafdl

michafdl

Neues Mitglied
Moin....Leider nicht. Wenn ich das KatKiss direkt auf den Interen Speicher lege fängt er gar nicht erst an zu installieren. Es kommt gleich eine Fehlermeldung. Leider weiss ich jetzt nicht mehr wie die lautete. Nicht notiert.:sad:
TWRP Version wie in meinem neuen Beitrag "TF300T von 4.2.1 JB auf KatKiss 5.1" beschrieben 7.5.

Kann geschlossen werden.
Habs nu...Scheint die falsche TWRP Version gewesen zu sein. Mit der 2.8.0.1 hats nu geklappt.
Danke an alle.....
 
Zuletzt bearbeitet: