"Ultimate" Unbrick TF300T 4.2.1 Unrecoverable bootloader error (0x00000000) Bootloop

  • 69 Antworten
  • Neuester Beitrag
Diskutiere "Ultimate" Unbrick TF300T 4.2.1 Unrecoverable bootloader error (0x00000000) Bootloop im Asus Transformer Pad TF300 Forum im Bereich Weitere Asus Geräte.
K

KingDroid

Neues Mitglied
Hallo zusammen :)

da mir dieses Forum auch schon weitergeholfen hat, möchte ich hier eine Problemlösung als Dank hinterlassen. (Ich kann nicht sagen, ob es diese hier schon gibt.)

Alles was ich zu meinem Problem finden konnte war, dass das Gerät nicht mehr zu retten ist. Umso mehr war ich verwundert, als ich es wiederherstellen konnte.

Eines Vorweg: Ich übernehme keinerlei Haftung/Garantie, ob meine Lösung wirklich hilft bzw. das Gerät zerstört, alles auf eigene Gefahr !


Wer nichts mehr zu verlieren hat, kann das ja probieren.

Also ich konnte ein TF300T aus folgendem Zustand wiederherstellen:

- Bei Aufruf von: RCK (Recovery Kernel = Recovery mode), Wipe erscheint der Fehler: Unrecoverable bootloader error (0x00000000), bei cold Boot friert das Gerät ein.

- Funktioniert bei Rooted & nicht Rooted, aber bei mir war ansonsten alles Stock / unverändert, geschlossener Bootloader

- TF300T (NICHT UMTS / 3G Gerät, wahrscheinlich 32GB aber nicht sicher).

- Letzte Android Version vor dem Brick: 4.2.1 natürlich auch dessen Bootloader, ich weiß nicht ob meine Lösung bei anderen Versionen funktioniert.

- Wenn das Gerät mit Lautstärke unten + Power gestartet wurde, war automatisch Fastboot aktiv, es gibt kein extra USB-Symbol.


So mein Heilrezept:

1. Die Zutaten: folgendes Herunterladen

Treibers:
http://dl.dropbox.com/u/14669363/ASUS%20Android%20USB%20Drivers.zip
In einen Ordner entpacken.

Fastboot:
Nach Android SDK download googlen und aus diesem die neusten Fastboot Dateien entnehmen. Das SDK gibt es auch als Zip offiziell bei Google.

Die 4.2.1 Firmware:
trecoverytf300t4.2.rar (435,39 MB) - uploaded.net
Nur die Datei "blob" entnehmen, den Rest löschen.

Die 3 Zutaten in einem Ordner geben, ich nenne diesen "Zutaten" und direkt auf C: legen.


2. Das Gerät ausschalten.
(Ist evlt. nicht möglich, da ein Bootloop vorhanden ist und das Gerät dauerhaft am booten/laden ist und geht nach Ausschalten sofort wieder an, war bei mir so.)
Dann einfach Power Taste gedrückt halten, bis das Gerät kurz aus ist, dann sofort die Lautstärke unten Taste gedrückt halten, bis man in einem Menü ist.
Jetzt keine Taste mehr drücken. Wenn dies nicht verständlich ist bzw. nicht gelingt, einfach nach "TF300T + Fastboot" suchen.

Das Menü zeigt 3 bis 4 Symbole, ist ein USB-Symbol zu sehen ist dieses per Lautstärke runter auszuwählen und mit Lautstärke hoch zu starten. Sind 3 Symbole zu sehen, darf nichts gedrückt werden und die grüne Auswahlmarkierung muss pulsierend blinken, ist diese nicht vorhanden oder leuchtet dauerhaft, hat sich das Gerät aufgehängt, dann muss die Prozedur wiederholt werden, oder der Spaß endet hier bereits. Wie die Auswahlmarkierung bei 4 Symbolen aussieht, bzw. sich verhält weiß ich nicht!

Das Gerät sollte auf jeden Fall etwas wie: "Fastboot Download Protocoll" anzeigen.


3. jetzt TF300T per USB am PC anstecken und dann Treiber fürs TF300T per Geräte Manager manuell raussuchen, alle Verzeichnisse der entpackten Dateien ausprobieren, bis die Treiber installiert werden. Der Geräte Manager zeigt bevor der Treiber installiert wurde wahrscheinlich Fastboot Gerät o. ä. an.

4. Start -> Ausführen -> "CMD" in diesem schwarzem Fenster mit "cd .." und "cd nächster Ordner" auf C:\Zutaten navigieren. Jetzt "fastboot devices" eingeben, das Gerät muss erscheinen in etwa so: " xxxx device ".
Jetzt folgendes nacheinander eingeben (immer abwarten):

fastboot erase system
fastboot erase recovery
fastboot erase userdata
fastboot erase boot
fastboot erase misc
fastboot erase cache

Danach:

fastboot -i 0x0B05 flash system blob

Nullen, keine "O" Buchstaben eingeben.

Dies dauert etwas und zeigt am Anfang "sending ..." abwarten und danach "write ..." zusätzlich zeigt das Brett nach einiger Zeit einen Ladebalken.

Ist dieser voll, erscheint im schwarzen Fenster am PC wieder: "C:\Zutaten\>"
Jetzt "fastboot -i 0x0B05 reboot" eingeben, das Gerät startet neu, es dauert ein wenig und es müsste wieder funktionieren :)

Ich freue mich sehr, wenn ich hiermit jemanden helfen konnte und sich jemand zu meinem Guide äußert. Dank + Kritik erwünscht !

Gruß
 
Zuletzt bearbeitet:
W

[wEm]

Neues Mitglied
Hammer!, Danke!

Hatte schon einige blobs mit fastboot versucht zu flashen, aber jedesmal hat sich fastboot aufgehängt.
Mit Deiner Anleitung läuft mein TF300 wieder ohne Probleme :)

Zur Info für die anderen:
Hatte mein TF300T mit nem falschen Recovery geflashed (Danke, ASUS für den besch**** Bootloader seit 4.2), und dummerweise durch einen WIPE den "unrecoverable bootloader error" bekommen, und zwar unabhängig davon was ich im Bootmenü ausgewählt habe. Wenn Ihr auch das Problem habt, dann könnte Euch das von KingDroid evtl. weiterhelfen.
 
K

KingDroid

Neues Mitglied
das freut mich sehr soetwas zu hören :)

Gruß
 
W

[wEm]

Neues Mitglied
Was ist denn an dem von Dir gepostetem Recovery so besonders, dass Fastboot nicht den Geist beim flashen aufgibt?
 
L

leechxyz1

Ambitioniertes Mitglied
Habe die Anleitung ausprobiert und die schritte system - boot erasen konnte ich durchführen, bei den letzten beiden hat er mir immer fehler ausgegeben, beim flash system blob resultierte das ganze dann in einem Hard Brick der nicht mehr behoben werden kann ( Tablet startet kurz, man sieht das asus logo und oben links device unlocked und dann geht es wieder aus). ADB und Fastboot gehen nicht mehr, apx modus geht zwar, aber ohne Backups bringt einem das nichts(Stichwort Nvflash).

Also wie immer gilt, bloß vorsichtig sein!
 
O

Oo_Tobii_oO

Neues Mitglied
Also ich hab mir jetzt extra ein Account eingerichtet um mich bei dir zu bedanken ^^

Ich dachte echt ich bekomms nicht mehr hin aber mit deinem Tutorial hab ich mein Tab wirklich wieder hinbekommen :scared: danke danke danke :rolleyes2:
 
K

KingDroid

Neues Mitglied
Freut mich für dich :)

Glückwunsch, dass du es wieder zum Laufen gebracht hast :)

Gilt auch für alle anderen mit Erfolg !


@wEm

Ich denke, dass es an der richtigen Ausführung liegt, ich habe die Zutaten meines Rezepts im Internet zusammengesucht und dann experimentiert.

(Ich habe leider schon vergessen, was ich alles gemacht habe ^^)

Gruß
 
B

Baluu

Neues Mitglied
:thumbsup::thumbsup::thumbsup:DANKE DANKE DANKE mein TF300T war gebrickt lag ein viertel Jahr tot rum dann habe ich gestern Abend durch Zufall den Bericht gelesen sofort alle"Alle Zutaten" zusammen getragen alles nach Anleitung durchgeführt uuuuuuuunnnnd es gieng so problemlos.
ES LÄUFT PERFECT bin voll Happy.
Echt supertolle Arbeit nochmals DANKE DANKE DANKE
Viele Grüsse Baluu:thumbsup::thumbsup::thumbsup:
 
C

Cremate

Neues Mitglied
Super Anleitung, habs jetzt über viele andere Wege und Anleitungen versucht aber nur diese Anleitung hat geklappt :thumbsup::thumbsup::thumbsup::thumbsup: entlich kann ich mein Asus wieder benutzen :biggrin::biggrin::biggrin:

DANKE

lg
 
L

lürimüs

Neues Mitglied
Hi erstmal vielen Dank für deine Mühen.
Ich habe aber bei der ganzen Prozedur ein Problem, und zwar bei dem 4. Punkt hängt sich das Tablet bzw. cmd bei

"fastboot erase misc" auf.

C:\Zutaten>fastboot erase misc
erasing 'misc'...

es passiert einfach nichts mehr und wenn ich versuche diesen schritt zu überspringen und "fastboot -i 0x0B05 flash system blob" zu starten dann hängt es sich bei "WRITING" auf.

Kann mir da bitte jemand helfen?

Beste Grüße, lürimüs
 
Zuletzt bearbeitet:
Tealk

Tealk

Neues Mitglied
Also das ist ja mal ein starkes Stück:lol:. Da fragt man hier echte Freaks, googelt sich durch weltweite Foren und letztlich ist es ein Laie (nichts gegen dich KingDroid:winki:) der das ausschlaggebende Lösungsschema liefert:thumbsup::thumbsup::thumbsup: Ich bin begeistert. Ganz großes DANKESCHÖN :thumbup: an dich King. Der Fehler bei den meisten anderen Lösungsansätzen ist einfach, daß das wipen nicht Schritt für Schritt direkt vor der Installation durchgeführt wird. Geht zwar heftig zur Sache, aber was muss das muss:thumbdn: und am Ende das Resultat: das Teil läuft wieder und startet sauber im Android ohne zu meckern. Ich habe die Routine mal ohne die erase-Befehle ausgeführt. Das blob löscht dann nur das System und die Installation hängt sich auf. Mit erasen alles super! Kleiner Hinweis noch für alle nachfolgenden "Tester", gebt dem System bei jedem Schritt genügend Zeit und werdet nicht ungeduldig:laugh: Der RCK-Button muss nach jedem Schritt wieder beginnen zu blinken und der Installationsbalken nach dem Flashstart ist ein absolutes "must have". Aber auch der kommt erst nach einiger Zeit während des Schreibvorgangs...
Lösung ist definitiv zu empfehlen!!!

Gruß
Tealk

ASUS Transformer Pad TF300TL
Android JB 4.2.1
WW_epad-10.6.2.10
 
Zuletzt bearbeitet:
B

buda

Fortgeschrittenes Mitglied
KingDroid schrieb:
Hallo zusammen :)

da mir dieses Forum auch schon weitergeholfen hat, möchte ich hier eine Problemlösung als Dank hinterlassen. (Ich kann nicht sagen, ob es diese hier schon gibt.)

Alles was ich zu meinem Problem finden konnte war, dass das Gerät nicht mehr zu retten ist. Umso mehr war ich verwundert, als ich es wiederherstellen konnte.

Eines Vorweg: Ich übernehme keinerlei Haftung/Garantie, ob meine Lösung wirklich hilft bzw. das Gerät zerstört, alles auf eigene Gefahr !


Wer nichts mehr zu verlieren hat, kann das ja probieren.

Also ich konnte ein TF300T aus folgendem Zustand wiederherstellen:

- Bei Aufruf von: RCK (Recovery Kernel = Recovery mode), Wipe erscheint der Fehler: Unrecoverable bootloader error (0x00000000), bei cold Boot friert das Gerät ein.

- Funktioniert bei Rooted & nicht Rooted, aber bei mir war ansonsten alles Stock / unverändert, geschlossener Bootloader

- TF300T (NICHT UMTS / 3G Gerät, wahrscheinlich 32GB aber nicht sicher).

- Letzte Android Version vor dem Brick: 4.2.1 natürlich auch dessen Bootloader, ich weiß nicht ob meine Lösung bei anderen Versionen funktioniert.

- Wenn das Gerät mit Lautstärke unten + Power gestartet wurde, war automatisch Fastboot aktiv, es gibt kein extra USB-Symbol.


So mein Heilrezept:

1. Die Zutaten: folgendes Herunterladen

Treibers:
http://dl.dropbox.com/u/14669363/ASUS%20Android%20USB%20Drivers.zip
In einen Ordner entpacken.

Fastboot:
Nach Android SDK download googlen und aus diesem die neusten Fastboot Dateien entnehmen. Das SDK gibt es auch als Zip offiziell bei Google.

Die 4.2.1 Firmware:
trecoverytf300t4.2.rar (435,39 MB) - uploaded.net
Nur die Datei "blob" entnehmen, den Rest löschen.

Die 3 Zutaten in einem Ordner geben, ich nenne diesen "Zutaten" und direkt auf C: legen.


2. Das Gerät ausschalten.
(Ist evlt. nicht möglich, da ein Bootloop vorhanden ist und das Gerät dauerhaft am booten/laden ist und geht nach Ausschalten sofort wieder an, war bei mir so.)
Dann einfach Power Taste gedrückt halten, bis das Gerät kurz aus ist, dann sofort die Lautstärke unten Taste gedrückt halten, bis man in einem Menü ist.
Jetzt keine Taste mehr drücken. Wenn dies nicht verständlich ist bzw. nicht gelingt, einfach nach "TF300T + Fastboot" suchen.

Das Menü zeigt 3 bis 4 Symbole, ist ein USB-Symbol zu sehen ist dieses per Lautstärke runter auszuwählen und mit Lautstärke hoch zu starten. Sind 3 Symbole zu sehen, darf nichts gedrückt werden und die grüne Auswahlmarkierung muss pulsierend blinken, ist diese nicht vorhanden oder leuchtet dauerhaft, hat sich das Gerät aufgehängt, dann muss die Prozedur wiederholt werden, oder der Spaß endet hier bereits. Wie die Auswahlmarkierung bei 4 Symbolen aussieht, bzw. sich verhält weiß ich nicht!

Das Gerät sollte auf jeden Fall etwas wie: "Fastboot Download Protocoll" anzeigen.


3. jetzt TF300T per USB am PC anstecken und dann Treiber fürs TF300T per Geräte Manager manuell raussuchen, alle Verzeichnisse der entpackten Dateien ausprobieren, bis die Treiber installiert werden. Der Geräte Manager zeigt bevor der Treiber installiert wurde wahrscheinlich Fastboot Gerät o. ä. an.

4. Start -> Ausführen -> "CMD" in diesem schwarzem Fenster mit "cd .." und "cd nächster Ordner" auf C:\Zutaten navigieren. Jetzt "fastboot devices" eingeben, das Gerät muss erscheinen in etwa so: " xxxx device ".
Jetzt folgendes nacheinander eingeben (immer abwarten):

fastboot erase system
fastboot erase recovery
fastboot erase userdata
fastboot erase boot
fastboot erase misc
fastboot erase cache

Danach:

fastboot -i 0x0B05 flash system blob

Nullen, keine "O" Buchstaben eingeben.

Dies dauert etwas und zeigt am Anfang "sending ..." abwarten und danach "write ..." zusätzlich zeigt das Brett nach einiger Zeit einen Ladebalken.

Ist dieser voll, erscheint im schwarzen Fenster am PC wieder: "C:\Zutaten\>"
Jetzt "fastboot -i 0x0B05 reboot" eingeben, das Gerät startet neu, es dauert ein wenig und es müsste wieder funktionieren :)

Ich freue mich sehr, wenn ich hiermit jemanden helfen konnte und sich jemand zu meinem Guide äußert. Dank + Kritik erwünscht !

Gruß
Bei mir ist der güne Balken ersichtlich, bricht aber gleich ab mit
Failed to process command flash:system error(0x170003)


Ich habe die Befehle hier nicht gemacht, weil ich angst habe, das dann gar nichts mehr geht. Die löschen ja alles und im Momemt komme ich noch in den CMW 5.5.0.4 wie auch in den Fastboot. Nur das Gerät loopt immer gleich nach dem ASUS Signt.

fastboot erase system
fastboot erase recovery
fastboot erase userdata
fastboot erase boot
fastboot erase misc
fastboot erase cache

Gibt da nicht noch einen sicheren Weg, wenn CMW etc noch laufen und nur ein Asus Signet loop besteht?
Danke für die Hilfe.
 
Zuletzt bearbeitet:
M

Merlin46

Neues Mitglied
Hi buda,
ich hab mein TF300 schon mehrfach nach der Anleitung wieder zu Leben erweckt, wenn ich zuviel rumgespielt habe oder nichts mehr ging. Genau nach Anleitung vorgehen und alles funktioniert wieder mit einem "jungfräulichen" System. Danach einmal durchstarten lassen, dann wieder die passende Recovery flashen und dann was immer du flashen möchtest! Hast du denn in der Recovery zugriff aus die SD und kannst die Größe sehen?? Bei mir wird immer Größe 0 angegeben. Deswegen alles löschen und neu aufsetzen mit Original ROM.
VG
 
B

buda

Fortgeschrittenes Mitglied
Hallo zusammen
Ich haben nun wirklich alle Fastboot Erase Befehle gemacht und dann den den Fastboot blob geschickt.

Zuerst mit dem Asus Stock 4.2, welches aber auch mit den Erase Befehlen immer zu einem Write Error führte.
Danach habe ich die Asus DE 4.0.3 Version genommen, welche dann wirlich funktionierte.
Ob die hier erwähnte Version gegangen wäre, kann ich somit nicht sagen. Mir war ein Original einfach sicherer :)

Aber mein Tablet läuft nun wieder dank der Anleitung und nach dem ich die letzte Version ins Root Verzeichnis kopiert habe, ging auch der ASUS Update wieder, da die Original Recovery Version ja wieder darauf ist.

Vielen Dank somit auch von meiner Seite :)
 
S

SirDoba

Neues Mitglied
Hallo!
Da auch mein TF300T nen Bootloop hatte und ich nicht weiter wusste habe ich mich mal im Internet schlau gemacht was zu tun ist. Hier bin ich schließlich hängen geblieben und habe aufgrund des durchaus positiven Feedbacks die Anleitung zur Hilfe genommen.
Habe mich jetzt sogar extra registriert da ich doch ein paar Fragen hätte:
Zum einen, im Zutatenverzeichnis die fastboot.exe habe ich aus der entpackten Datei die das SDK-Programm enthält entnommen, so hatte ich die Vorgehensweise zumindest verstanden. Also: adt-bundle-windows-x86-20140321 -> sdk -> platform-tools -> fastboot.exe
Wenn ich jetzt über ausführen ->cmd -> C:\Zutaten> 'fastboot devices' eingebe, tut sich nichts, gebe ich allerdings fastboot ein, werden mir verschiedene commands angezeigt und andere Sachen bei denen ich nicht ganz dahinter komme. Wenn ich dann den ersten Befehl eingebe -> 'fastboot erase system' sagt der cmd mir <waiting for device> das steht dann auch ne ganze Weile da und es tut sich nichts, die Frage: Muss man genug Geduld haben, also ne Stunde warten z.B.? Vielleicht bin ich einfach nur zu ungeduldig. Die RCK Anzeige blinkt die ganze Zeit, also beim Tablet kommt vielleicht garnichts an?
Nächste Frage: funktioniert diese Anleitung nur bei gerooteten Geräten?
Soweit erstmal.
Ich bedanke mich auf jeden Fall schonmal für die Anleitung und auch im Vorraus für Antworten.
Bis dahin die besten Grüße!

Der ursprüngliche Beitrag von 17:02 Uhr wurde um 18:59 Uhr ergänzt:

Hallo nochmal,
bin jetzt insofern weiter gekommen alsdass ich aus dem sdk Verzeichniss alle Dateien die im Ordner der fastboot.exe in die Zutaten kopiert habe, sodass jetzt statt <waiting for device> 'erasing system' im CMD Fenster zu lesen ist, allerdings auch schon seit 2 Stunden. Ich kann mir nicht vorstellen das das im Sinne des Erfinders ist, was mache ich jetzt noch falsch?
Liebe Grüße!
 
Zuletzt bearbeitet:
B

buda

Fortgeschrittenes Mitglied
Nein braucht kein root. Das löschen geht nur Sekunden.
Kannst du nicht einfach die weiteren Befehle im cmd eingeben?
Da kommt keine fertig Meldung sondern nur ein prompt im cmd. Auf dem Tablet sollte aber der Befehl auch angezeigt werden.

Was wird dir mit fastboot device angezeigt? Sollte eine Zahl erscheinen.
 
Zuletzt bearbeitet:
S

SirDoba

Neues Mitglied
Ich hab meinen Fehler schon gefunden, ich hatte mit den Volumetasten zwischen den drei Icons die im fastboot usb control modus sind gescrolt, wobei ja ausdrücklich gesagt wurde das man nichts drücken darf, das war der Fehler.
Soweit konnte ich dann fortfahren, wobei sich der Bildschirm vom Tablet nicht verändert hat, der grüne Kasten hat geblinkt und das wars. Allerdings ging es beim letzten Befehl nicht weiter, da hat sich dann nichts mehr getan...
Habe jetzt alle Dateien die in der .rar waren in der die blob-Datei ist, zu den Zutaten kopiert und schaue ob das etwas hilft.
Die Nummer die nach dem Befehl 'fastboot devices' erscheint ist 015d2109a8540e1 und dann noch fastboot.
Dann steht die Zeile drunter wieder
C:\Zutaten
Jetzt gebe ich wie im Rezept steht die anderen Befehle ein.
 
B

buda

Fortgeschrittenes Mitglied
Wieso hast du ein bootloop?
Custom rom installiert? Ev. Hast du ja ein anderes recovery installiert dann kannst du auch einfach wieder ein neues Rom damit installieren.
 
S

SirDoba

Neues Mitglied
Nachdem ich einen Riss im Digitizer hatte, habe ich mein Tablet selber repariert und sowohl Digitizer als auch Touchscreen selber gewechselt. Danach hat es heftig reagiert, sprich war nicht zu bedienen, da es irgendwas gemacht hat (Apps geöffnet, Desktops gewechselt etc.) obwohl ich das Teil nicht berührt habe. Irgendeine Hardware neheme ich an muss Befehle gesendet oder Empfangen haben die es nicht gab. Dann hab ich gelesen das es sogar 4 verschiedene Digitizer oder Touchscreentypen gibt, womit dieses Problem dann auch seinen Ursprung zeigt. Dann nachdem ich es leer gehen lassen hab und es starten wollte, hatte es den Bootloop.
Da ich noch ein ziemlicher Grünschnabel bin was das angeht (wie man vielleicht auch merkt ;) ) muss ich fragen:
Was ist eine installierte Custom rom? Und was ist das installierte recovery?
 
B

buda

Fortgeschrittenes Mitglied
SirDoba schrieb:
Nachdem ich einen Riss im Digitizer hatte, habe ich mein Tablet selber repariert und sowohl Digitizer als auch Touchscreen selber gewechselt. Danach hat es heftig reagiert, sprich war nicht zu bedienen, da es irgendwas gemacht hat (Apps geöffnet, Desktops gewechselt etc.) obwohl ich das Teil nicht berührt habe. Irgendeine Hardware neheme ich an muss Befehle gesendet oder Empfangen haben die es nicht gab. Dann hab ich gelesen das es sogar 4 verschiedene Digitizer oder Touchscreentypen gibt, womit dieses Problem dann auch seinen Ursprung zeigt. Dann nachdem ich es leer gehen lassen hab und es starten wollte, hatte es den Bootloop.
Da ich noch ein ziemlicher Grünschnabel bin was das angeht (wie man vielleicht auch merkt ;) ) muss ich fragen:
Was ist eine installierte Custom rom? Und was ist das installierte recovery?
Uff, hat sich das gelohnt, ich habe mir für 160.- CHF ein TF300T mit Tastatur gebraucht gekauft?

Custom-Rom = angepasstes Android Betriebssystem meistens mit Root
Recovery = Notfall Startsystem im Tablet

Root / Custom-ROMs / Modding für Asus Transformer Pad TF300 auf Android-Hilfe.de

Im Moment würde es für dich aber reichen, das Tablet überhaupt wieder richtig zum laufen zu bringen.