[Root] Firmware Update trotz Root [bq Aquaris X5 Plus]

  • 157 Antworten
  • Neuester Beitrag
Diskutiere [Root] Firmware Update trotz Root [bq Aquaris X5 Plus] im Root / Custom-ROMs / Modding für bq Aquaris X5 Plus im Bereich bq Aquaris X5 Plus Forum.
K

kddh

Erfahrenes Mitglied
Habe jetzt einmal nach der Neuinstallation mit Erhalt der Daten (siehe Beitrag #12) alle Module von Xposed mit Titanium BackUp gesichert und dann entfernt. Danach habe ich Xposed installiert und das Smartphone fuhr auch hoch. Nun wollte ich die Module einzeln wiederherstellen und gleich beim ersten (GavityBox) fährt es nicht mehr hoch. Somit vermute ich, dass es entweder an meinen Einstellungen in GravityBox liegt oder am Modul selbst. Wenn jemand ebenfalls GravityBox nutzt und es zum laufen bekommt, ggf. auch ohne Einstellungen soll er/sie sich bitte melden (mir geht es hauptsächlich um die Statusleiste).

@loopiCB Die Anleitung kann gern ausgegliedert werden. Man sollte aber ggf. noch ein paar erweiterte Erläuterungen mit einbringen (wo man TWRP und Super SU her bekommt, ich verwende z.B. Super SU 2.65 und mach danach ein Update auf die aktuelle Version über den Playstore, etc.). Eine schöne Anleitung befindet sich im Unterforum zum BQ M5. Diese könnte man als Basis nehmen und um die Sache mit dem Erhalt der Daten ergänzen. Ich komme zur Zeit aber nicht dazu, eine solche Anleitung zu schreiben.Die Anleitung kann man auch irgendwo zentral im BQ-Forum ablegen, da sie meines erachtens nach für alle Modelle funktioniert. Die Unterschiede liegen aber wohl in der Version von TWRP.

Mit freundlichen Grüßen
Carsten
 
D

dlueth

Erfahrenes Mitglied
Und wo steht das etwas über flashfire? ;) Genau das möchte ich doch gerade mal (aus gegebenem Anlass) testen, möglichst ohne brick...
 
loopi

loopi

Ehrenmitglied
Ups sorry ;) Da müssen wir wohl warten.
 
D

dlueth

Erfahrenes Mitglied
Ich bin mit flashfire im Moment noch vorsichtig, benutze das zum ersten Mal...
 
E

eis0r

Fortgeschrittenes Mitglied
carlmeier schrieb:
TWRP ist nur temporär drauf. Ansonsten habe ich Magisk und phh-superuser geflasht.
hattest du vor dem OTA-Update schon magisk laufen?
wenn ja hast du wahrscheinlich vorher root deaktiviert damit das OTA sich installieren ließ, oder?
 
C

carlmeier

Neues Mitglied
Ja, vorher war Magisk und Automagisk installiert. Automagisk deaktiviert automatisch Google Play Dienste für root. Aktiv habe ich nichts deaktiviert. Ob es daran liegt??
 
C

crunchie

Ambitioniertes Mitglied
kddh schrieb:
Ich hab mein X5plus manuell mit der neuen Firmware 1.5.0 versorgt, da ich mein X5plus gerootet hab. Ich möchte aber meine Daten erhalten.

Ich bin folgendermaßen vorgegangen:

1.) Firmware von der BQ-Seite heruntergeladen und in den entsprechenden Ordner auf dem Rechner entpackt (bei mir C:\X5plus)
2.) Die Datei 8976_fastboot_all_images.bat dahingehend modifiziert, dass ich die Passage „fastboot flash userdata userdata.img“ entfernt, um meine Daten zu erhalten.
3.) Die Eingabeaufforderung als Administrator geöffnet und in den Ordner X5plus ( cd.. ; cd.. ; cd X5plus)navigiert.
4.) Smartphone im Fastboot Modus gestartet ("Vol-" und "Power" gleichzeitig drücken) und an den Rechner via USB-Kabel (verwende das Originalkabel von BQ) verbunden
5.) Die modifizierte Datei 8976_fastboot_all_images.bat gestartet
6.) Smartphone nach Abschluss hochfahren lassen. Dies dauert etwas – Geduld mitbringen.

Bis hierher können auch die User gehen, die kein Root haben, aber manuell updaten und dabei ihre Daten erhalten wollen. Die weiteren Schritte richten sich an User die Root (und Xposed) haben wollen.

7.) Nach dem Hochfahren habe ich das Smartphone wieder ausgeschaltet und erneut im Fastboot Modus gestartet.
8.) Da ich TWRP permanent auf dem Smartphone haben möchte habe ich die „fastboot flash recovery twrp-3.0.2-0-gohan.img“ eingegeben (Hatte die Datei noch auf dem Rechner im Ordner X5plus)
9.) Nach dem Flash Recovery gleich ins Recovery gestartet ("Vol+" und "Power" gleichzeitig drücken)
10.) Im Recovery habe ich dann meine auf dem Smartphone gespeicherte Super-SU.zip installiert
11.) Nach der Installation von Super-SU hochgefahren. Alles noch da und funktioniert,
12.) Smartphone wieder runter gefahren und ins Recovery gestartet um Xposed zu installieren.
13.) Smartphone versucht hochzufahren. Leider bleibt es im Startbildschirm (BQ-Logo und Android-Schriftzug) hängen..

Auf Grund des Problems mit Xposed habe ich die Schritte 4.) bis 11.) wiederholt. Werde erstmal ohne Xposed leben. Wenn jemand Xposed nach dem Update zum Laufen gebracht hat, soll er sich bitte mal melden und berichten, welche Version er verwendet und wie er es installiert hat. Hätte es gern wieder drauf, aber ohne ist es erstmal kein Beinbruch.

Ob es positive oder negative Änderungen gibt wird sich in der nächsten Zeit zeigen.

Mit freundlichen Grüßen
Carsten
Warum so kompliziert?
Firmware downloaden und mit flashfire Flashen mit den original Einstellungen.
Funktioniert super.
 
E

eis0r

Fortgeschrittenes Mitglied
bei xda liest man von Problemen mit Flashfire wenn Magisk installiert ist.
kann das jemand bestätigen?
 
J

jochenf

Erfahrenes Mitglied
OTA 1.5.0

Gerade über BQ-Updater am Handy gemacht: trotz Magisk/Root ohne Probleme durchgelaufen.

Danach wieder Magisk + Root per TWRP drauf - fertig.

Warnung: Xposed geht nicht -> bootet nicht mehr! Habe dann einfach /magisk/xposed Verzeichnis gelöscht und alles wieder ok.
 
B

BB1

Fortgeschrittenes Mitglied
Ich habe meine komplette TWRP-Sicherung zurückgeflasht (1.3.0), auch kein Gesprächspartner mehr hörbar.
Was könnte da schief gegangen sein?

Edit: Über Headset höre ich noch was!
 
Zuletzt bearbeitet:
Bearbeitet von loopiCB - Grund: in neues Thema integriert, Grüße loopiCB
B

BB1

Fortgeschrittenes Mitglied
Also, zunächst mal, ich höre meinen Gesprächspartner wieder. Musste komplett neu flashen und rooten. Seltsam, dass ein Rücksichern der 1.3.0-TWRP-Sicherung den Fehler nicht behoben hat.

Also, ich traue diesem Flashfire nicht. Nach dem Flashfire durch war, wurden meine Fingerabdrücke nicht mehr erkannt, obwohl sie noch registriert waren. Da ist wohl was schief gelaufen.
 
Braile

Braile

Stammgast
Hi,

kannst du erläutern wie du diese Datei modifiziert hast?

2.) Die Datei 8976_fastboot_all_images.bat dahingehend modifiziert, dass ich die Passage „fastboot flash userdata userdata.img“ entfernt, um meine Daten zu erhalten.
 
M

mikojan

Fortgeschrittenes Mitglied
kddh schrieb:
Ich hab mein X5plus manuell mit der neuen Firmware 1.5.0 versorgt, da ich mein X5plus gerootet hab. Ich möchte aber meine Daten erhalten.

Ich bin folgendermaßen vorgegangen:

1.) Firmware von der BQ-Seite heruntergeladen und in den entsprechenden Ordner auf dem Rechner entpackt (bei mir C:\X5plus)
2.) Die Datei 8976_fastboot_all_images.bat dahingehend modifiziert, dass ich die Passage „fastboot flash userdata userdata.img“ entfernt, um meine Daten zu erhalten.
3.) Die Eingabeaufforderung als Administrator geöffnet und in den Ordner X5plus ( cd.. ; cd.. ; cd X5plus)navigiert.
4.) Smartphone im Fastboot Modus gestartet ("Vol-" und "Power" gleichzeitig drücken) und an den Rechner via USB-Kabel (verwende das Originalkabel von BQ) verbunden
5.) Die modifizierte Datei 8976_fastboot_all_images.bat gestartet
6.) Smartphone nach Abschluss hochfahren lassen. Dies dauert etwas – Geduld mitbringen.

Bis hierher können auch die User gehen, die kein Root haben, aber manuell updaten und dabei ihre Daten erhalten wollen. Die weiteren Schritte richten sich an User die Root (und Xposed) haben wollen.

7.) Nach dem Hochfahren habe ich das Smartphone wieder ausgeschaltet und erneut im Fastboot Modus gestartet.
8.) Da ich TWRP permanent auf dem Smartphone haben möchte habe ich die „fastboot flash recovery twrp-3.0.2-0-gohan.img“ eingegeben (Hatte die Datei noch auf dem Rechner im Ordner X5plus)
9.) Nach dem Flash Recovery gleich ins Recovery gestartet ("Vol+" und "Power" gleichzeitig drücken)
10.) Im Recovery habe ich dann meine auf dem Smartphone gespeicherte Super-SU.zip installiert
11.) Nach der Installation von Super-SU hochgefahren. Alles noch da und funktioniert,
12.) Smartphone wieder runter gefahren und ins Recovery gestartet um Xposed zu installieren.
13.) Smartphone versucht hochzufahren. Leider bleibt es im Startbildschirm (BQ-Logo und Android-Schriftzug) hängen..

Auf Grund des Problems mit Xposed habe ich die Schritte 4.) bis 11.) wiederholt. Werde erstmal ohne Xposed leben. Wenn jemand Xposed nach dem Update zum Laufen gebracht hat, soll er sich bitte mal melden und berichten, welche Version er verwendet und wie er es installiert hat. Hätte es gern wieder drauf, aber ohne ist es erstmal kein Beinbruch.

Ob es positive oder negative Änderungen gibt wird sich in der nächsten Zeit zeigen.

Mit freundlichen Grüßen
Carsten
Ich habe:

- die 8976...bat per Editor verändert
- das X5+ im Fastboot-Modus gestartet
- per USB-Kabel verbunden (es macht "pling", rote LED blinkt)
- die 8976...bat als Admin gestartet

und es passiert nichts!

Was mache ich falsch? Muss der Bootloader geöffnet werden?
 
E

Elmario

Fortgeschrittenes Mitglied
Habt ihr denn funktionierende ADB und Fastboot Treiber installiert?

Wenn nicht, dann installiert erst einmal das:
[TOOL]Minimal ADB and Fastboot [10-22-16]

Und im Smartphone muss in den Entwickleroptionen USB-Debugging aktiviert sein.
Falls es dann immer noch nicht klappt, versucht einfach mal die Kommandos von Hand nacheinander in der Textkonsole einzugeben, bis ihr auf ein Problem stoßt. Dabei natürlich auch die userdata Partition auslassen!
 
Braile

Braile

Stammgast
habe das Update erfolgreich geflasht, boote ich jedoch in den bootloader steht da noch 1.3. Ist das bei euch auch der Fall?
 
J

jochenf

Erfahrenes Mitglied
Braile schrieb:
habe das Update erfolgreich geflasht, boote ich jedoch in den bootloader steht da noch 1.3
Hast du per fastboot geflasht und auch die Ausgaben davon mal angesehen? Da kam garantiert
Code:
FAILED (remote: Critical partition flashing is not allowed)
bei der entsprechenden Partition.

Für das BQ-Flashtool kannst du bei BQ eine json Unlock-Datei anfordern und darüber nochmal entsperren. Dann solltest du auch die geschützten flashen können, zumindest war es bei mir damals so. Ich habe 1.5.0 im Bootloader stehen.
 
Braile

Braile

Stammgast
ja habe über fastboot geflasht, wie fordere ich die Datei an?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
okay Datei ist angefordert, allerdings funktioniert das flash tool bei mir nicht. Es steht dort immer nur "Loading" und weiter passiert nichts! Gibt es hierfür eine Lösung?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
die Datei habe ich, aber wie flash ich diese. Das Firmware Tool funktioniert nicht. Geht das auch über ADB?
 
J

jochenf

Erfahrenes Mitglied
Nicht das ich wüsste, die wird innerhalb des BQ-Tools genutzt. Was dieses dann genau macht zum entsperren weiß ich leider nicht.
 
Braile

Braile

Stammgast
hm ja auch schon lange gegoogelt, nichts gefunden. Das Firmware Flash Tool klappt bei mir nicht, es bleibt immer bei "Loading stehen".

Der Support antwortet nicht auf dieses Problem.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
hat jemand die vorherige Version von den Flash Tool eventuell?
 
aquanout

aquanout

Neues Mitglied
Bei mir hat OTA auch geklappt. Trotz root. Ich war total überrascht.
Beim Updateeauf 1.3 ging es damals nicht.
TWRP ist nicht fest installiert. Nur SuperSu.
Gerooted habe ich, wie ursprünglich im Nachbarthread beschrieben.
Root ist erst mal weg. Werde ich bei Gelegenheit wieder aktivieren.