Google Pixel - Factory Image flashen

  • 38 Antworten
  • Neuster Beitrag
yogi911

yogi911

Fortgeschrittenes Mitglied
Threadstarter
hallo zusammen,

hat jemand hier schon probiert die factory-images auf das pixel zu bringen? ich ja und es hat NICHT hingehauen... ich habe ein telekom-modell (sailfish), bootloader liess sich sofort entsperren.
adb-umgebung korrekt installiert, richtiges image von den betr. developer-seiten geladen, alles korrekt vorbereitet. will jetzt nicht zu sehr ins detail gehen, aber die batch-abfolge meldet das sie mehrere dateien angeblich nicht findet, allen voran die system.img. diese ist aber in dem archiv enthalten...
ähnliche fehler kenne ich von früher vom nexus 5, da konnte man dann alles einzeln flashen statt mit der flashall.bat... klappt auch nicht und in der 63H ist auch kein recovery.img enthalten... mhhh, ist da doch noch irgendwas versteckt???

grüße joern
 
Zuletzt bearbeitet:
jan.lamp

jan.lamp

Fortgeschrittenes Mitglied
Habe es über das Toolkit versucht und beim flashen gab es eine Fehlermeldung. Werde es morgen nochmal über ein anderes Gerät probieren und berichten
 
yogi911

yogi911

Fortgeschrittenes Mitglied
Threadstarter
ok, ich habs eben nochmal an einem anderen rechner probiert und es ging diesmal etwas weiter.
habe es übrigens mit dem xda minimal adb and fastboot tool geflasht:

C:\Program Files (x86)\Minimal ADB and Fastboot>dir
Datenträger in Laufwerk C: ist OS
Volumeseriennummer: 9414-E1F8

Verzeichnis von C:\Program Files (x86)\Minimal ADB and Fastboot

05.11.2016 22:30 <DIR> .
05.11.2016 22:30 <DIR> ..
24.04.2016 23:51 1.474.048 adb.exe
24.04.2016 23:51 97.792 AdbWinApi.dll
24.04.2016 23:51 62.976 AdbWinUsbApi.dll
26.09.2016 11:30 33.607.680 bootloader-sailfish-8996-012001-1608281716.img
24.04.2016 23:51 802.304 fastboot.exe
26.09.2016 11:30 988 flash-all.bat
26.09.2016 11:30 859 flash-all.sh
26.09.2016 11:30 814 flash-base.sh
26.09.2016 11:30 1.832.662.566 image-sailfish-nde63h.zip
09.08.2015 14:50 29.882 MAF32.exe
26.09.2016 11:30 58.417.152 radio-sailfish-8996-012511-1609081444.img
05.11.2016 22:28 1.996 unins000.dat
05.11.2016 22:28 719.521 unins000.exe
13 Datei(en), 1.927.878.578 Bytes
2 Verzeichnis(se), 7.041.691.648 Bytes frei

C:\Program Files (x86)\Minimal ADB and Fastboot>flash-all
target reported max download size of 536870912 bytes
sending 'bootloadera' (32820 KB)...
OKAY [ 0.786s]
writing 'bootloadera'...
(bootloader) Valid bootloader version.
OKAY [ 1.048s]
finished. total time: 1.836s
rebooting into bootloader...
FAILED (command write failed (Unknown error))
finished. total time: 5.005s
target reported max download size of 536870912 bytes
sending 'radioa' (57048 KB)...
OKAY [ 1.333s]
writing 'radioa'...
OKAY [ 0.895s]
finished. total time: 2.233s
rebooting into bootloader...
OKAY [ 0.014s]
finished. total time: 0.016s
< waiting for any device >
target reported max download size of 536870912 bytes
archive does not contain 'boot.sig'
archive does not contain 'recovery.img'
archive does not contain 'system.sig'
archive does not contain 'vendor.sig'
wiping userdata...
Creating filesystem with parameters:
Size: 122633060352
Block size: 4096
Blocks per group: 32768
Inodes per group: 8192
Inode size: 256
Journal blocks: 32768
Label:
Blocks: 29939712
Block groups: 914
Reserved block group size: 1024
Created filesystem with 11/7487488 inodes and 518062/29939712 blocks
--------------------------------------------
Bootloader Version...: 8996-012001-1608281716
Baseband Version.....: 8996-012511-1609081444
Serial Number........: FA69N0311863
--------------------------------------------
checking product...
OKAY [ 0.050s]
checking version-bootloader...
OKAY [ 0.050s]
checking version-baseband...
OKAY [ 0.049s]
sending 'boota' (25069 KB)...
OKAY [ 0.590s]
writing 'boota'...
(bootloader) Flashing active slot "_a"
FAILED (remote: partition [boota] doesn't exist)
finished. total time: 1.047s
Press any key to exit...

weil mir dieser sch... keine ruhe lässt, habe ich mir mal die flash-all.bat angeschaut, da stimmt der dateiname für die image-datei auch... was für ein mist. habe jetzt keinen bock mehr und gehe pennen. morgen ist auch noch ein tag den man sich damit versauen kann ;-)
 
Zuletzt bearbeitet von einem Moderator:
storandtchris

storandtchris

Stammgast
Also ich habe die letzte Version geflasht und zwar jedes einzeln ganz nochmal so wie früher beim Nexus.
Muss aber sagen das mein Pixel aus dem Play store ist,welches allerdings denke ich kein Problem darstellen sollte.
 
r4Mp1n0

r4Mp1n0

Lexikon
Hast an dem PC, an dem es weiter ging als vorher mal versucht, alles einzeln zu flashen wie du meintest? Ich kenne es auch von den nexen mir diesem "Problem"
Hab auch n Telekom Gerät, finde aber keine Zeit, das mal zu testen
 
A

AraldoL

Fortgeschrittenes Mitglied
Die Pixel haben jetzt doch angeblich erstmalig zwei Systempartitionen, wo Updates im laufenden Betrieb in die jeweils andere Partition installiert werden und dann wird beim Booten die Partition gewechselt und die neue Version gebootet. Beim nächsten Update dann umgekehrt.

Vielleicht müssen die Flash-Anleitungen und die Scripts daher geändert werden.
 
R

Roman441

Experte
Also ich habe die 63P über flash-all.bat geflasht. Ging ohne Probleme und auch wieder zurück auf die 63H funktionierte
 
yogi911

yogi911

Fortgeschrittenes Mitglied
Threadstarter
hallo zusammen :) also das mit dem einzeln flashen probiere ich mal. was nur komisch ist, dass die recovery.img in dem flash-file nicht zu finden ist und ich habe alle drei verfügbaren mal runtergeladen...

...hat jemand das mal über eine linux-umgebung versucht, z. b. ubuntu???
 
Zuletzt bearbeitet von einem Moderator:
Klartext

Klartext

Ehrenmitglied
Habe das Thema mal ausgelagert, denn wenn der Bootloader unlock ja problemlos funktioniert hat, hat es nichts mehr im 'Bootloader unlock' Thread verloren ;)
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
[How-To] Factory Image manuell flashen

Die Anleitung sollte nach wie vor funktionieren.
 
yogi911

yogi911

Fortgeschrittenes Mitglied
Threadstarter
Nochmals besten Dank für die Hilfe.
Bin aber trotzdem schon mit meinen Nerven ziemlich am Ende, weil ich jetzt Angst habe, mein nagelsneues Pixel durch die vorherigen fehlgeschlagenen Versuche "zerflasht" zu haben. Deshalb will ich das jetzt gerne alles sauber abschliessen.
Dazu jetzt meine Frage: In dem Image fehlt jeweils die cache.img, sowie die recovery.img.
Muss die vorhandene vendor.img ebenfalls geflasht werden?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ich könnte heulen:
Bei der system.img bleibt er hängen. Ich habe kein gutes Gefühl...Neustart klappt jedoch nach dem ganzen Gewurstel problemlos...
Hier mal der Auszug:

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot flash system system.img
target reported max download size of 536870912 bytes
sending sparse 'systema' 1/3 (516971 KB)...
OKAY [ 12.846s]
writing 'systema' 1/3...
FAILED (remote: partition table doesn't exist)
finished. total time: 12.940s
 
R

raZr87

Ambitioniertes Mitglied
Also, hatte exakt das selbe vor 2 Tagen durchlebt. Die Lösung ist allerdings extremst einfach. Lade dir Android Studio runter und installiere dort die aktuellste Android SDK 25 mit nougat 7.1.1 Unterstützung.
Danach ist alles gut.
Hatte die P drauf, dann wieder zurück zu H
 
yogi911

yogi911

Fortgeschrittenes Mitglied
Threadstarter
Lieben Dank, das werde ich jetzt gleich mal probieren. Mit dieser Anwendung habe ich jedoch noch keine Erfahrung, mal schauen :)
 
R

raZr87

Ambitioniertes Mitglied
und deinstalliere vorher den "Android Unified Toolkit" - Mist, falls du den aktuell nutzt...
Das Ding funktioniert eigentlich super... allerdings hat das Pixel 2 Systempartitionen... und da kommt das Toolkit noch nicht mit klar.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
yogi911 schrieb:
Lieben Dank, das werde ich jetzt gleich mal probieren. Mit dieser Anwendung habe ich jedoch noch keine Erfahrung, mal schauen :)
Nimm dir Zeit... Installation dauert en bisschen, gerade das entpacken. Allerdings geht es danach, versprochen :D
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
wenn Frage, gerne PN...
 
yogi911

yogi911

Fortgeschrittenes Mitglied
Threadstarter
Nochmals auch an dieser Stelle herzlichen Dank an raZr87 für die tolle Hilfe :)
Mit dem Android-Studio hat jetzt alles hingehauen!

Viele liebe Grüße,
Jörg
 
R

raZr87

Ambitioniertes Mitglied
Sehr gerne ! ;D
 
Knighty

Knighty

Fortgeschrittenes Mitglied
Du hast jetzt also das originale Google Factory Image auf ein Telekom-Gerät geflasht, richtig? Mithilfe des SDK.
Ich bekomme meins erst Anfang Dezember, habe aber genau dasselbe vor. Prima, dass es offensichtlich geklappt hat :)
 
yogi911

yogi911

Fortgeschrittenes Mitglied
Threadstarter
Ja, mit freundlicher Unterstützung von raZr87 habe ich es schliesslich hinbekommen.
Sämtliche andere Methoden die man noch von den Nexus-Geräten kannte, haben absolut nicht funktioniert, ich war schon voll gefrustet.
Jetzt wirds nochmal spannend, ob die Telekomiker über die IMEI oder so nicht doch noch die OTA-Upates filtern...
 
HCD

HCD

Moderator
Teammitglied
Kann ich mir nicht vorstellen das die Telekom so ein Aufwand treibt für die Pixel! Sind wir mal ehrlich die sind keine Verkaufsschlager!
Ich denke auch das sie nicht mal ein verstecktes Branding haben.
Da werden vielleicht Deutschlandweit 2000 bis 3000 Stück von verkauft.
Also da eird nix mit der IMEI passieren........
 
Yiruma

Yiruma

Stammgast
Habe gestern noch irgendwo gelesen, dass sich die Pixel in Deutschland und der USA unerwartet gut verkaufen.
Weiß nur nicht mehr wo:smile:
2000-3000 Stück ist doch arg pessimistisch:D
 
yogi911

yogi911

Fortgeschrittenes Mitglied
Threadstarter
Na ja, in irgendeinem Forum (weiss aber nicht mehr wo) war zu lesen, dass die Telekomiker zum Marktstart die Geräte unbedingt vorrätig haben wollten und diese in der ersten Charse unverändert auf den Markt geschmissen haben. Der nächste Schwung soll wieder einen gesperrten BL haben. Weiterhin soll sich das Pixel nach "Insiderangaben" unerwarter gut verkaufen. Also ich weiss nicht was man davon halten soll, aber ich traue diesem Steinzeit-Anbieter alles zu...
 
Oben Unten