Mitglieder surfen ohne Werbung: Jetzt kostenlos registrieren!

[ROM] Viper10 ◦ Android 8 ◦ Tweaks | HUB | OTA | Sidebar

  • 1.034 Antworten
  • Neuester Beitrag
Diskutiere [ROM] Viper10 ◦ Android 8 ◦ Tweaks | HUB | OTA | Sidebar im Root / Custom-ROMs / Modding für HTC 10 im Bereich HTC 10 Forum.
Peri25

Peri25

Experte
Ja aber die sunshine App funktioniert nicht. Und ich kann das OEM entsperren nicht anwählen. Ich bin aktuell auf s-off und bootloader unlocked. Ich hab bereits die neusten Updates drauf. Danke für deine Hilfe
 
Black-FR

Black-FR

Stammgast
Wenn bei der Ausführung der Sunshine app eine Fehlermeldung kommt, musst du dich an deren Support wenden.
(Steht ja sicherlich auch in der Fehlermeldung)
Gibt da einen IRC Kanal, bzw ein Ticket System auf der Webseite.
 
Peri25

Peri25

Experte
Danke, dass muss ich noch machen, bin noch nicht dazu gekommen:)
 
Zuletzt bearbeitet:
HenkerLenker

HenkerLenker

Experte
Moin Leute, hab da mal die frage ob Xposed mit der aktuellen Viper Rom kompatiebel ist? Hat ja lange gedauert bist es Xposed für Android 7.x da ist aber jetzt würde ich die Framework gerne flashen :D

Vielen dank schonmal
 
Black-FR

Black-FR

Stammgast
Teste es und lass uns das Ergebnis wissen.
Selber, werde ich xposed nicht nutzen oder testen, da es mir keinen Mehrwert gibt.
 
HenkerLenker

HenkerLenker

Experte
Black-FR schrieb:
Teste es und lass uns das Ergebnis wissen.
Selber, werde ich xposed nicht nutzen oder testen, da es mir keinen Mehrwert gibt.
Habe ich natürlich heute gemacht und "NEIN", Xposed Framework läuft nicht auf der Viper Rom bzw. vermute ich auf allen Sense Roms. Ich habe mir nämlich auch die aktuelle LeeDroid geflasht und da versucht Xposed zu installieren und bei beiden Roms kann ich die Framework zwar flashen und es startet auch danach ohne Bootloop, bekomme aber vom Xposed Installer die Meldung: "Xposed-Framework Version 87,3(Systemless by topjohnwu) ist installiert, aber nicht aktiv. Bitte schaue in den Logs nach Deteils."
Hab mir die Log Datei zwar mal grob angeschaut aber kann da raus jetzt nicht erkennen wieso die Framework nicht aktiv ist. Aber vieleicht kann ja jemand anderer aus der Datei was erkennen und füge sie hier einfach mal ein.
Code:
11-19 05:45:48.242 I/Xposed  (  948): -----------------
11-19 05:45:48.242 I/Xposed  (  948): Starting Xposed version 87 (Xposed by PurifyOS), compiled for SDK 24
11-19 05:45:48.242 I/Xposed  (  948): Device: HTC 10 (HTC), Android version 7.0 (SDK 24)
11-19 05:45:48.242 I/Xposed  (  948): ROM: NRD90M release-keys
11-19 05:45:48.242 I/Xposed  (  948): Build fingerprint: Xiaomi/sagit/sagit:7.1.1/NMF26X/V8.2.17.0.NCACNEC:user/release-keys
11-19 05:45:48.242 I/Xposed  (  948): Platform: arm64-v8a, 64-bit binary, system server: yes
11-19 05:45:48.242 I/Xposed  (  948): SELinux enabled: yes, enforcing: yes
11-19 05:45:49.261 I/Xposed  (  948): -----------------
11-19 05:45:49.261 I/Xposed  (  948): Added Xposed (/system/framework/XposedBridge.jar) to CLASSPATH
11-19 05:45:58.337 I/Xposed  (  958): -----------------
11-19 05:45:58.337 I/Xposed  (  958): Starting Xposed version 87 (Xposed by PurifyOS), compiled for SDK 24
11-19 05:45:58.337 I/Xposed  (  958): Device: HTC 10 (HTC), Android version 7.0 (SDK 24)
11-19 05:45:58.337 I/Xposed  (  958): ROM: NRD90M release-keys
11-19 05:45:58.337 I/Xposed  (  958): Build fingerprint: Xiaomi/sagit/sagit:7.1.1/NMF26X/V8.2.17.0.NCACNEC:user/release-keys
11-19 05:45:58.337 I/Xposed  (  958): Platform: arm64-v8a, 32-bit binary, system server: no
11-19 05:45:58.337 I/Xposed  (  958): SELinux enabled: yes, enforcing: yes
11-19 05:45:58.341 I/Xposed  (  958): -----------------
11-19 05:45:58.341 I/Xposed  (  958): Added Xposed (/system/framework/XposedBridge.jar) to CLASSPATH
11-19 05:46:26.032 I/Xposed  (  948): Detected ART runtime
11-19 05:46:26.033 I/Xposed  (  948): Found Xposed class 'de/robv/android/xposed/XposedBridge', now initializing
11-19 05:46:26.763 E/Xposed  (  948): Cannot load any modules because /data/data/de.robv.android.xposed.installer/conf/modules.list was not found
11-19 05:46:37.247 I/Xposed  (  958): Detected ART runtime
11-19 05:46:37.249 I/Xposed  (  958): Found Xposed class 'de/robv/android/xposed/XposedBridge', now initializing
11-19 05:46:37.792 E/Xposed  (  958): Cannot load any modules because /data/data/de.robv.android.xposed.installer/conf/modules.list was not found
 
Hopie

Hopie

Experte
kann man den Abstand vom Dock zu den unteren Apps verringern?
 
HenkerLenker

HenkerLenker

Experte
@Hopie Soweit ich weiß geht das nur in dem du das Homescreen Layout von 4 x 4 auf 4 x 5 umstellst. Findest du unter: ViperTweaks > Home Screen > Home screen layout.
 
Peri25

Peri25

Experte
Hopie schrieb:
Das hab ich mir schon fast gedacht.
Ich arbeite im Media Markt und der Verkauf von HTC Handys wird immer schwerer, weil HTC nicht wirklich in die Gänge kommt, Samsung und Apple verkaufen sich wie blöd und noch dazu seh ich es auch an mir selbst, ich hab einfach keine Lust mehr Stunden, Tage, Monate am Handy zu verbringen mit dem flashen, dafür ist mir die Zeit zu schade geworden. Ich hab mir das U11 gekauft und kann nur sagen, ein geiles Telefon so wie die anderen es auch waren, kult natürlich das One M7.
Ich möchte auch dem Team Venom Danken, durch die bin ich auch auf HTC hängen geblieben.[emoji16] Danke und macht es gut.
Wir lesen uns bestimmt hier im Forum, da gibt es ja trotzdem noch genug Themen ohne root und flashen[emoji23][emoji16]
 
Zuletzt bearbeitet:
P

proph

Erfahrenes Mitglied
Sehr schade. Hatte gehofft, das wenigstens noch ein Viper Oreo für das 10 kommt. [emoji24]
 
Black-FR

Black-FR

Stammgast
Den Titel hier, könnte man auch Mal anpassen...
Auf xda gibt's eine Aktualisierung des ROM, mit Android 8...
 
Hopie

Hopie

Experte
Hi, bei XDA gibts ja von santod040 und LlabTooFeR jeweils ne Oreo Firmware.

Gibt es da irgend welche unterschiede? Datei grössen sind auch unterschiedlich
 
happy-drummer

happy-drummer

Ambitioniertes Mitglied
Hallo zusammen!

Nachdem ich fast 6 Jahre ein M7 und dann für ein Jahr ein M9 (länger hat Letzteres nicht gehalten, da der Akku echt eine Krücke ist/war) habe ich mir nun das HTC10 gegönnt und mich abermals in die mehr oder weniger gerätespezifische Materie des Themas Root/ViperROM eingelesen und dabei mit größtem Bedauern festgestellt, dass es TeamVenom nicht mehr gibt *heul*. Hatte mich schon gewundert, dass mit dem Hub und dem Viper Pro Key etwas nicht mehr stimmte. Nun weiß ich warum...

Ich tue mich gerade etwas schwer, die neuen Hintergründe rund um Magisk und "force encryption" zu verstehen - bin zwar PC-affin und bekomme es seit meinem ersten HTC (dem TD2) hin, die Geräte zu individualisieren und mich von den Datenkraken weitestgehend zu befreien, aber seit Android 6 hat sich bei Google scheinbar eine Menge getan und man macht es den Entwicklern offensichtlich sehr schwer, Großes zu leisten, und die ganzen neuen Tools und programmiertechnischen Hintergründe übersteigen dann doch meinen Horizont.

Was ich bisher tat:
  • Gerät beim ersten Start kurz eingerichtet
  • Entwicklereinstellungen aktiviert
  • Update von 2.41.401.4 auf 3.16.401.2 (passend zu Viper10 6.0.0) durchgeführt
  • Bootloader über HTCDev geöffnet
  • CustomRecovery geflasht
  • Viper10 6.0.0 geflasht, anschließend Cache gelöscht und Viper10 eingerichtet (die Tweaks sind ja leider nicht mehr das, was Viper mal ausmachte, aber wenn ich es richtig verstanden habe, ist einiges mit Android nicht mehr kompatibel)

Danach ging es drum, Xposed und XprivacyLua zum Laufen zu bringen. Das Thema GooglePay ist mir dabei egal, da ich es glaube nicht zu brauchen bzw. nie genutzt zu haben. Also gelesen, geflasht, probiert, nochmals probiert, wieder gelesen....und so weiter... Irgendwann lief Xprivacy Lua dann, aber ich sah, dass es gegen Xprivacy Pro (Original) echt sehr spärlich ausgestattet ist.

Zwischendurch lief alles bis auf HTC Gallery und HTC Music, wobei letzteres egal ist, da es nur temporär genutzt werden sollte.
Nun bin ich an einem Punkt angekommen, an dem alles zu klappen scheint. Auch Xprivacy. Nun wollte ich PRO kaufen. Ähm....wo genau geht das? In GooglePlay kann man es runterladen und dann InApp die Module kaufen. Geht aber nicht, die sind alle ausgegraut. Muss man Marcel erst etwas spenden um dann PRO aktivieren zu können? Erscheint mir unlogisch. Also nochmals alles von vorne. PRO-Module sind aber weiter ausgegraut. Also damit meine ich, dass ich beim Klick auf "Save" ein Drilldown mit "dieses Modul kaufen" und "alle Module kaufen" nach unten aufgeht, die zwei Punkte dann aber nicht anklickbar sind. Hat das noch jemand beobachten können?

Weiteres Phänomen: beim ersten Flash des TWRP hatte ich es mit r/w geöffnet. Dann klappte Einiges nicht wie gewünscht (Probleme beim Flashen von Viper10, Install von Xposed u.a.). Im Forum Handy-FAQ las ich dann, dass TWRP beim ersten Start zwingend schreibgeschützt zu öffnen sei. Ok, alles nochmal. Mit alles nochmal meinte ich, dass ich die RUU für 3.16.401.2 installierte. Das klappte auch immer problemlos.
Später habe ich dann TWRP schreibgeschützt gestartet. Einiges klappte so besser, aber rund lief es noch immer nicht. Mir rund meine ich, dass ich ein sauberes Viper10 mit Xposed und XprivacyLua laufen haben will, sodass ich vor dem Install jeder weiteren App ein TWRP-Backup machen kann.
In dem ganzen Kudelmuddel der mehrfachen Versuche hänge ich nun insofern fest, dass auch wenn ich ganz von vorne ab RUU und CustomRecovery starte, die Schreibschutzfrage im TWRP gar nicht mehr kommt. Auch nicht, wenn ich zuvor im OS die Displaysperre via Muster & Fingerprint aktiviert habe. Als wäre noch irgendwas von den vorherigen Installtionen auf dem Gerät geblieben.

Ich würde nun gerne ganz von vorne beginnen und die Fehler mit Schreibschutz TWRP und falsche Xposed Version und Kauf der XprivacyLua Pro vermeiden. Nach meinem Verständnis muss ich doch dann "nur"
  • RUU drüberbügeln
  • CustomRecovery flashen
  • Viper10 flashen

Genau das habe ich nun aber schon mehrfach getan, doch irgendwie werden mein HTC10 und ich nicht so warm, wie ich es vom DesireHD, von zwei M7 und vom M9 her kenne.

Wohl möglich übersehe ich nur etwas.

Übrigens war es stets egal, ob ich das FullROM flashe oder nur das MagiskROM. Jedesmal klappte irgendwas nicht sauber.
Ich hoffe, ihr könnt einem alten Nicht-Programmierer einen Tipp geben.

Sonnige Grüße