HTC M7 - Keine Verbindung zum PC / Kein OTG

  • 4 Antworten
  • Neuester Beitrag
Diskutiere HTC M7 - Keine Verbindung zum PC / Kein OTG im Root / Custom-ROMs / Modding für HTC One (M7) im Bereich HTC One (M7) Forum.
K

KWHDroid

Neues Mitglied
Hi Leute,

ich lese hier schon länger mit und habe nun selbst ein Problem dass mich jetzt schon beinahe an den Rand des Wahnsinns treibt.

Anbei meine Geschichte:

Habe vor 2 Tage mein HTC One Rund-Erneuert (Neues Display, neue Kamera, neuer Akku, neues Backcover). Hat auch alles wunderbar funktioniert. Jetzt wollte ich gestern Abend auch noch mein System von 0 aufbauen, da die SD und Android schon sehr extrem zugemüllt waren (App-Junkie..:rolleyes2:). Ab hier beginnen die Probleme, zur Einfachheit mal in kurzen Stichpunkten erklärt:

- Wipe per Recovery, Handy wollte nicht mehr ins OS booten und bringt einen Fehler mit der Sim. Habe die dann rausgenommen und hat funktioniert - nur die System UI ist immer gleich gecrasht. Habe es dann geschafft per Browser noch die aktuelle Venomrom 8.0.0 zu saugen und wollte dann neu flashen.

- Hab blöderweise die Rom fürs M8 gesaugt gehabt, das Handy hat natürlich dann mit einer Fehlermeldung abgebrochen.

- Wollte dann per MHL-Kabel neu aufspielen, aber das Recovery will meinen USB-Stick nicht mounten. Habe verschiedenste Sticks und Formatierungen probiert. Ich kann das Feld "USB-OTG" einfach nicht anklicken im TWRP. (In früheren Versionen ging es)

- Wollte dann mein Handy per ADB neu flashen, aber nun erkennt auch mein Windows das Gerät nicht mehr und schreibt nur "Unbekanntes USB-Gerät: Fehler bei der Enumeration". Habe vor ein paar Monaten den Work-Around mit den Treibern für den ntel(R)_USB_3.0_eXtensible_Host_Controller gemacht da ich Windows 8.1 habe und es hatte prima funktioniert. Jetzt geht es aber plötzlich nicht mehr??

- Habe verschiedenste Treiber und Lösungen probiert, nichts hat geholfen. Es Funktioniert auch nicht auf dem Laptop meines Bruders oder Vaters (beide Windows 7). Ich kriege immer nur "Unbekanntes Gerät".

Ich bin nun echt am Ende mit meinem Latein und hoffe sehr das ihr einen Tipp für mich habt. Irgendetwas muss ich doch übersehen??

Hier noch ein paar Eckdaten für euch:
HTC One m7 Unlocked + S-OFF
CID-02__102
HBOOT-1.44.0000
RADIO-4A.14.3250.13
OpenDSP-v26.120.274.0202
Windows 8.1
TWRP ist die 2.8.5.0
Venom Rom 8.0.0.

Ich hoffe wirklich dass ihr mir weiterhelfen könnt, ich bin am verzweifeln!

Danke euch allen und schon mal einen schönen Abend!

Grüße KWHDroid
 
ferchi

ferchi

Ehrenmitglied
Hallo KWHDroid,

hat das Handy vor dem wipe (aber nach dem reparieren) denn noch funktioniert? Wie lange?

Wenn du einfach keine Verbindung zum Pc bekommst, ist es natürlich einen Versuch wert einfach die Treiber + adb & fastboot neu zu installieren.
Falls du dann eine Verbindung schaffst, würde ich erstmal eine ältere ROM (und Recovery) empfehlen welche du installierst (Bei der alten firmware).. damit das Handy erstmal läuft.
Dann ne aktuelle firmware + ROM.

Gruß ferchi
 
K

KWHDroid

Neues Mitglied
Hi Ferchi,

danke für deinen schnellen Kommentar und danke fürs verschieben :smile:

Nach dem Wipe ist das Handy gebootet (Natürlich in das Set-Up für Sprache etc, wie nach jedem neuen Flash). Als ich da durch da kam immer wieder "Preparing Sim Card" oder so ähnlich. Danach "System UI ist abgestürzt" und ich konnte nur noch neustarten.

Ohne Sim-Karte konnte ich das Set-Up abschließen, aber die System UI ist trotzdem gecrasht. Ich konnte dann aber wie bereits gesagt trotzdem über den Browser die (leider falsche...) Rom runterladen.

Treiber für ADB und Fastboot habe ich versucht. Aber solange Windows mein Handy nicht erkennt, krieg ich auch keine ADB Verbindung hin, oder?

Wie gesagt:
Windows 8.1 (bei usb 3.0) = Fehler bei der Enumerierung
Windows 7 (egal ob 2.0 oder 3.0) = Unkown Device

Gibt es irgend eine Möglichkeit das HTC als Massenspeicher zu booten? Oder irgend eine andere Möglichkeit die Daten ohne Treiber auf das Handy zu bekommen? Ein System habe ich ja drauf - es will nur nicht booten weil es die Rom fürs M8 ist.
 
K

KWHDroid

Neues Mitglied
UPDATE
Das HTC One meiner Bekannten wird an meinem PC mit "Fastboot-USB" ganz normal erkannt. An den Treibern kann es also nicht liegen.
Mein Gerät schreibt nur "Fastboot" und bringt im Geräte-Manger "Unknown Device".

Ich habe ja geschrieben das ich, während das Handy noch lief, die Rom für das M8 geladen habe, welche sich natürlich nicht installieren lies. Die Systemstruktur von meiner alten Rom ist aber noch vorhanden (also Data, Media, Download etc.), kann es eventuell daran liegen? Normalerweise sollte es doch egal sein für die Verbindung im Fastboot..

Mir ist auch aufgefallen das mir der "Check SmartSD"-Eintrag im Bootloader fehlt?
 
Zuletzt bearbeitet:
K

KWHDroid

Neues Mitglied
Bisher hat noch keiner geantwortet, ich hau hier trotzdem mal ein weiteres Update rein..

Hab jetzt versucht über Linux-Live-USB das Gerät zu mounten. MTP-Detect scheint mein HTC nicht zu finden. Mit "Dmesg" allerdings findet er wohl irgend eine Verbindung zu meinem Smartphone und zeigt mir eine Vendor- und Product-ID an. Sieht dann wie folgt aus. Wie ich von hier allerdings weiterkommen soll weiß ich nicht..
 

Anhänge