Obere Lautstärkewippe durch Software defekt?

  • 14 Antworten
  • Neuester Beitrag
Diskutiere Obere Lautstärkewippe durch Software defekt? im Root / Custom-ROMs / Modding für HTC One (M7) im Bereich HTC One (M7) Forum.
H

HandySIIck

Fortgeschrittenes Mitglied
Meine obere Lautstärkewippe funktioniert nun schon seit 6 Monaten nicht mehr. Ich dachte an ein Hardwareproblem und hatte beschlossen damit zu leben.

Aus Intuition habe ich mir die App QuickClick installiert. Mit dieser App kann man die Laut- und Leisertasen mit neuen Funktionen belegen. Durch diese App ging meine Lauttaste kurzzeitig wieder. Nachdem ich die App mehrmals wieder neu installierte, konnte ich den Effekt reproduzieren. Somit scheidet ein Hardwarefehler aus und es müßte ein Softwareproblem sein

Nun meine Frage: Hat jdm. eine Idee, durch welche Kernel, Rom (Aktuell Viper 8 zuvor Eragon, also immer sense-custom-roms) oder App dieser Problem ausgelöst wird?

Habe auch schon versucht bei XDA etwas von diesem Phänomen zu erkunden, leider nicht erfolgreich.

Vieleicht ist ja einer von euch schon mal über dieses Problem gestolpert.
 
BanB

BanB

Lexikon
Versuch einfach mal einen anderen Kernel. Ist keine große Änderung und geht auch schneller als ne ROM zu switchen. Also einfach nach den Ausschluss verfahren.

Kernel dann ROM wenn der Kernel Wechsel nix bringt.

PS: Backup nicht vergessen zu machen. ;)
 
H

HandySIIck

Fortgeschrittenes Mitglied
Danke, habe schon verschiedene Kernel ausprobiert. Werde wohl weiter testen müssen. Dachte eigentlich nach dem Wechsel mit Full-Wipe von der Eragon zur Viper mit Kernel- Wechsel müsste es doch gehen. Aber war auch nur kurzzeitig mit dieser App. Vielleicht startet dann irgendwas und nimmt die Lautertaste wieder in Anspruch
 
BanB

BanB

Lexikon
Hast du schon einmal ein Firmware update versucht?
 
H

HandySIIck

Fortgeschrittenes Mitglied
Eine Original-Firmware? Wurde gleich am ersten Tag durch eine Customrom ersetzt. Wäre vielleicht eine Maßnahme. Ich werde es testen
 
ferchi

ferchi

Ehrenmitglied
Dazu schaust du am besten mal in diesen Bereich oben in die Anleitung;)
Die oben verlinkte firmware ist 1. nur mit S-Off flashbar und 2. könnte sie dein Handy bricken da es keine vollständige firmware ist.

Gruß ferchi
 
BanB

BanB

Lexikon
Steh ich jetzt auf dem Schlauch oder bin ich blöd [emoji15]

Er will doch gar nicht zurück zu Stock, oder etwa doch?[emoji28]
 
ferchi

ferchi

Ehrenmitglied
Ist aber mit S-On die einfachste/zuverlässigste Methode um die firmware zu updaten ;)
 
H

HandySIIck

Fortgeschrittenes Mitglied
Ich bin s-off und dachte, wenn ich sense costum roms benutze wie eragon und viper, bekomme ich auch alle Orginal- Verbesserungen der Firmware.
Würde dann eh nur Stock flashen und testen,dann wieder die viper 8. Gruß und danke für die Hilfestellungen
 
BanB

BanB

Lexikon
Die Firmware beinhaltet, meines Wissens Touchscreen Treiber etc..
 
ferchi

ferchi

Ehrenmitglied
Schau mal in mein Repository (Signatur) und nimm die volle 7er firmware (ca. 500MB groß).

Gruß ferchi
 
H

HandySIIck

Fortgeschrittenes Mitglied
Hilfe, bin gerade dabei mein One in einen Stein zu verwandeln.

Hatte die Woche zu wenig Zeit es mit einer neuen Firmware zu probieren, nachdem nun auch noch die unter Lautstärketaste nicht mehr ging, wußte ich gar nicht mehr, ob ich mich überhaupt getrauen sollte....

Heute nun die firmware 7.19. 401.2 runtergeladen und über Anleitung mit fastboot gestartet.
1. Teil funkionierte mit Fehlermeldung, dann wieder fastboot flash zip firmware.zip gestartet.

Sending “zip“ läuft nun schon seit 1h und es geht nicht mehr weiter.

Wenn ich jetzt das Handy trenne und nicht mehr mit den Lautsprecherwipen in den fastboot komme, ist es wohl aus mit dem One, oder gibt es noch eine Lösung?. Ohne Trennung nochmals fastboot oem rebootRUU eingeben? Das silberne HTC ist ja schon da... Oder nochmal fastboot flash zip firmware.zip eingeben?
 
H

HandySIIck

Fortgeschrittenes Mitglied
Nachdem ich nun abgestöpselt habe, war ich immer noch im Bootloader. Nochmals die Firmware 7.19.401.2 geflasht. Dieses Mal durchgelaufen.
Leider bringt er mir beim Booten das rote Ausrufezeichen eines fehlgeschlagenen Updates, ebenso beim Versuch ins Recovery zu kommen.

Ich würde nun die T-mobile Firmware von klein auf einspielen mit den entsprechenden Otas, oder gibt es einen schnelleren und einfacheren Weg?

Edit: konnte TWRP flashen und dann über Usb-Otg mein altes Image (Viper 8) einspielen und es läuft wieder mit kaputter oberer Lautstärke, aber der 7.19.411.20 firmware und hboot 1.61
 
Zuletzt bearbeitet:
H

HandySIIck

Fortgeschrittenes Mitglied
Mein Handy startet nur noch in den Ladebildschirm und startet immer wieder neu. Da meine Lautstärketasten nicht funktionieren, komme ich nicht mehr in den Bootloader oder Recovery. Gibt es noch eine Lösung