[Anleitung] Huawei Sonic U8650 Root

  • 75 Antworten
  • Neuester Beitrag
Diskutiere [Anleitung] Huawei Sonic U8650 Root im Root / Custom-ROMs / Modding für Huawei Sonic im Bereich Huawei Sonic (U8650) Forum.
A

aivc

Ambitioniertes Mitglied
Hier mal eine kleine Anleitung zum rooten des U8650, der etwas größere, bezüglich des Displays, Bruder des Ideos X3.

Auf HTC Mania, spanisches Forum, ist das Sonic sehr verbreitet und es gibt einige Custom Roms bisher.

Sonic vorab vorbereiten.

1. in die Einstellungen navigieren.
2. Anwendungen öffnen, dort Häkchen raus bei der Option Schnellstart.
3. Menüpunkt Entwicklung öffnen und dort USB-Debugging ein Häkchen setzen.
4. Sonic ausschalten.

Anleitung um ClockworkMod Recovery zu Flashen.

1. die Dateien auf dem örtlichen Rechner installieren
2. das Sonic in den Fastboot Modus bringen, hierzu den leiser Konpf sowie den Startknopf für ca. 10 sek halten, anschließend erscheint das Huawei Logo und sollte auch stehen bleiben und nicht booten.
3. anschließend das Sonic an den PC anschließen und die instalador.bat auf dem örtlichen PC ausführen.
4. irgendeine Taste drücken und das Programm startet zum beenden nochmals Taste drücken.
5. das Sonic bootet in CWM v4.0.1.4, ihr habt nun CWM drauf und habt das Sonic vorbereitet für Root Zugriff und zum installieren von Custom Roms.

Root für Sonic

1. ihr kopiert die Datei Su.zip auf die SD Karte ins Hauptverzeichnis.
2. das Sonic im CWM Modus starten, hierzu Powerknopf und Lautstärke+ gedrückt halten, bis CWM startet.
3. Sicherheit! ein erstes Backup erstellen.
- navigieren mit den Laustärke + und - nach oben und unten
- auswählen mit dem Powerknopf
- zu Backup and restore navigieren ~ Powerknopf
- Backup ~ Powerknopf
Es startet nun ein komplettes Backup und wird auf der SD Karte im ClockworkMod Ordner angelegt, dieses Sicherheitshalber auf dem örtlichen PC zusätzlich sichern. Meldung Backup Complete!
4. Nun naviegiert ihr zu -install zip from sdcard ~ Powerknopf
5. -choose zip from sdcard ~ Powerknopf
6. zur Su.zip navigieren *~ Powerknopf, das Root wird installiert.

Nach Complete Meldung könnt ihr das Sonic ganz normal starten und habt dann den Superuser auf dem Sonic, welcher die Root Rechte erlaubt.

Die benötigten Dateien verlinke ich mal aus dem Forum von HTC Mania.

Treiber: Multiupload.com - upload your files to multiple file hosting sites!
Flash: Multiupload.com - upload your files to multiple file hosting sites!

Bei Treiber Problemen dieses Paket: http://www.dc-unlocker.com/test/Pulse_Drivers_xp_w7_w764.zip und entsprechend der Bit Variante installieren.

Su.zip: aus dem X3 Topic verlinkt. Multiupload.com - upload your files to multiple file hosting sites!

Hinweis! die Datei " recovery.img" aus dem Flash Paket wird nicht benötigt.

Update 12.02.2012 Neue Links.

Flash: http://www.mediafire.com/?k421vgl3xy1fgpa
Treiber Win/:http://www.mediafire.com/?3bvp3p42t4iqwt2

bei Problemen folgende Treiber: http://www.mediafire.com/?20qkr711ceuna0n

Su.zip Link wird nachgereicht, oder alternativ im Ideos X3 Forum schauen, Link aus dem X3 Forum: https://rapidshare.com/#!download|765tl5|2244779298|su.zip|296|R~6AD0CDE59A825624D0B4EA592A9F8C71|0|0

Mittlerweile gibt es auch den Root nur mit einer Datei zu erlangen ohne vorher das CWM zu flashen.

Root: http://www.mediafire.com/?4f29cszyula2vx6 stammt vom XDA Forum.

oder

Update Zip: http://www.mediafire.com/?g0w2d9qz7cvox60 stammt aus dem HTCmania Forum.


- Die Datei auf SD Karte kopieren.
- Telefon ausschalten
- Batterie kurz entfernen
- dann wieder anschalten mit Powerknopf und Lautstärke + gleichzeitig.
- dann erscheint Recoverymenu
- Update von SD Karte also die Root.zip oder Update.zip Datei anwählen
- anschließend normal neu starten.

Ich empfehle eher die Update.zip aus dem HTC Mania Forum zu nehmen, da diese aktueller ist.
 
Zuletzt bearbeitet:
X

Xpisto89

Fortgeschrittenes Mitglied
Vielen lieben Dank dass du sowas für die noch sehr kleine Community erstellt hast!
 
X

Xpisto89

Fortgeschrittenes Mitglied
Vielleicht sllte man ergänzen für Leute die noch nicht so bewandert auf diesem gebiet sind, dass man bevor man in den Fastboot mittels volume up + power erstmal in den einstellungen den debug modus aktivieren muss, sonst könnt ihr lange drücken :)
 
A

aivc

Ambitioniertes Mitglied
@Xpisto89

Ergänzt, danke für den Hinweis.
 
SlimDNS

SlimDNS

Fortgeschrittenes Mitglied
Hallo liebe Huawei Gemeinde!
Ich habe versucht mir nach dieser Anleitung Root-Rechte zu verschaffen, um in einem weiteren Schritt dann die CyanogenMod 7.2 zu installieren.
Leider scheitert es bei mir bereits an der Installation des ClockworkMod Recovery.
Ich habe USB-Debugging aktiviert und Schnellstart deaktiviert und das Gerät in den Fastboot Modus versetzt. Den USB Treiber habe ich unter Win7 installiert. Wenn ich das Handy nun anschließe und die instalador.bat starte, dann erscheint "waiting for device" und das war`s dann! Dauert dieser Vorgang nur einfach irre lange oder funktioniert es bei mir einfach nicht? Alternativ ist es ja möglich das Recovery auch über die App "Rom Manager" zu installieren,- nur, daß das Sonic leider nicht in der Liste der unterstützten Geräte aufgelistet ist. Besteht vielleicht die möglichkeit ein anderes Gerät für die Installation auszuwählen?
Hat jemand Erfahrung mit dieser Prozedur und kann mit weiter helfen?

Vielen Dank schon mal!
 
S

segler11

Gast
SlimDNS schrieb:
Hallo liebe Huawei Gemeinde!
Ich habe versucht mir nach dieser Anleitung Root-Rechte zu verschaffen, um in einem weiteren Schritt dann die CyanogenMod 7.2 zu installieren.
Leider scheitert es bei mir bereits an der Installation des ClockworkMod Recovery.
Ich habe USB-Debugging aktiviert und Schnellstart deaktiviert und das Gerät in den Fastboot Modus versetzt. Den USB Treiber habe ich unter Win7 installiert. Wenn ich das Handy nun anschließe und die instalador.bat starte, dann erscheint "waiting for device" und das war`s dann! Dauert dieser Vorgang nur einfach irre lange oder funktioniert es bei mir einfach nicht? Alternativ ist es ja möglich das Recovery auch über die App "Rom Manager" zu installieren,- nur, daß das Sonic leider nicht in der Liste der unterstützten Geräte aufgelistet ist. Besteht vielleicht die möglichkeit ein anderes Gerät für die Installation auszuwählen?
Hat jemand Erfahrung mit dieser Prozedur und kann mit weiter helfen?

Vielen Dank schon mal!
edit. zum rooten probier doch mal die app z4root

Probier mal den recovery-manager Hier:[APP] Recovery Manager v0.36 [BETA] - Android @ MoDaCo

Ich kann dir aber nicht sagen ob es bei deinem Phone klappt.

lg
 
Zuletzt bearbeitet von einem Moderator:
SlimDNS

SlimDNS

Fortgeschrittenes Mitglied
Hi, vielen Dank fpr die schnelle Antwort!
Diese App lässt sich zwar installieren, stürzt dann aber nach dem Starten sofort ab.
Ist jemandem noch ein anderer Recovery Manager für das Sonic bekannt bzw. gibt es noch andere USB Treiber? Vielleicht liegt es ja auch an dem Handset USB Treiber, dass ich keine Verbindung zu dem Gerät bekomme.
 
S

segler11

Gast
SlimDNS schrieb:
Hi, vielen Dank fpr die schnelle Antwort!
Diese App lässt sich zwar installieren, stürzt dann aber nach dem Starten sofort ab.
Ist jemandem noch ein anderer Recovery Manager für das Sonic bekannt bzw. gibt es noch andere USB Treiber? Vielleicht liegt es ja auch an dem Handset USB Treiber, dass ich keine Verbindung zu dem Gerät bekomme.
Schade,

Was sagt den der gerätemanager sind die treiber richtig geladen.

Ansonsten treiber usw gibts Hier:CYANOGEN MOD 7.1 ROM Huawei U8650 Sonic - Power Your Android Phone

lg
 
SlimDNS

SlimDNS

Fortgeschrittenes Mitglied
Danke schön! Bei mir scheint Win7 das Problem zu sein! Ich habe auch mal den PulseDriver ausprobiert,- hat allerdings auch nicht funktionier. Dann habe ich mal eine WinXP Pro VMWare Session verwenden ... und siehe da, das Gerät wird nach dem Starten der Instalador.bat erkannt und der Vorgang beginnen! Leider sturzt die Session dann bereits nach einer Sekunde ab! Ich werde es später mal auf einem "richtigen" WinXP PC probieren! Danke für die Hilfe!
 
A

aivc

Ambitioniertes Mitglied
Zuletzt bearbeitet:
SlimDNS

SlimDNS

Fortgeschrittenes Mitglied
Es scheint bei mir wirklich an Windows 7 gelegen zu haben. Mit XP und dem Pulse Trieber hat es prima geklappt!
Danke noch mal für die Hilfe!
 
C

Capurgana

Neues Mitglied
Bei mir hat es auch geklappt! Mittels Windows XP und mit dem Pulse-Treiber. Vista + Original-Huawei-Treiber war erfolglos, ob's an Vista oder dem Treiber lag, kann ich leider nicht sagen.
Vielen, vielen Dank!
Noch eine Info: Bei mir lief das XP auch im VMWare Player (unter Vista), erfreulicherweise ging es bei mir. Es ist also prinzipiell möglich.
 
C

cantax

Erfahrenes Mitglied
Im 1. Post steht als letztes der Hinweis:

Hinweis! die Datei " recovery.img" aus dem Flash Paket wird nicht benötigt.
Verstehe ich nicht ganz. Die recovery.img enthält doch den CWM v4.0.1.4.
Soll das bedeuten die enthaltene recovery.img passt nicht zum Sonic und ich muss mir die von wo anders her besorgen?
 
A

aivc

Ambitioniertes Mitglied
Falsch ausgedrückt, die muss nicht ausgeführt werden.

Es sind alle Dateien für CWM und für Superuser in den Links für das Sonic enthalten.
 
Zuletzt bearbeitet:
C

cantax

Erfahrenes Mitglied
Super
Vielen Dank für deine schnelle Antwort aivc.

Hab ich mir schon gedacht. Aber wenn man irgendwas Flasht fragt man besser zweimal nach.
 
C

cantax

Erfahrenes Mitglied
Ich wollte nochmal Danke sagen.
Mein Sonic ist jetzt nach Anleitung gerootet.
Ich habe das alternative Treiberpaket benutzt weil mein XP SP2 x86 den oberen Treiber nicht nehmen wollte.
 
K

kentaz

Gast
hallo,

hab mich hier angemeldet, weil ich mich bedanken wollte!

DANKE !!!

hab jetzt mein sonic unter windows 7 - 32 bit - enterprise 90 tage testversion gerootet! Es klappt doch mit den win7 treibern.

kann jetzt endlich den facebook und twitter mist - mit titanium backup löschen.

Nochmals danke!

Liebe grüße.
 
segelfreund

segelfreund

Ehrenmitglied
Hat alles super geklappt!
 
C

cantax

Erfahrenes Mitglied
Wenn mein Sonic ausgeschaltet ist und ich es an das Ladegerät anschließe erscheint erst das Huawei Logo und dann startet es in den CWM.
Im CWM kann ich zwar "Power Off" wählen, aber nachdem es aus ist geht es sofort wieder an und bootet wieder in den CWM.
Wähle ich Reboot, dann tut es das auch und bootet ganz normal.
Schnellstart ist deaktiviert.

Kann das jemand reproduzieren? Ist das normal, ein Bug oder ein Feature?
 
A

aivc

Ambitioniertes Mitglied
Das ist normal bei cwm