LG G6 LineageOS Google Konto nach Update verschwunden

  • 14 Antworten
  • Neuester Beitrag
Diskutiere LG G6 LineageOS Google Konto nach Update verschwunden im Root / Custom-ROMs / Modding für LG G6 im Bereich LG G6 (H870) Forum.
D

Defy_user

Neues Mitglied
Ich habe das Problem, dass nach jedem Update, was über TWRP installiert wird, die Google Einstellungen verschwunden sind. Auch manche App's funktionieren danach nicht mehr. Sie stürzen einfach ab. Z.B. die Google Telefon App.
Ich habe die aktuelle TWRP installiert und nutze die aktuelle SuperSU von Chainfire.

Kennt jemand das Problem und hat vielleicht sogar eine Lösung dafür?
 
JC00P3R

JC00P3R

Senior-Moderator
Teammitglied
Ich denke du musst du GApps neu flashen nach jedem Update. War zumindest mal so.
 
D

Defy_user

Neues Mitglied
Habe ich schon gemacht. Leider sind die Einstellungen trotzdem verschwunden.
 
morrg

morrg

Fortgeschrittenes Mitglied
Hast du mal andere TWRP Versionen versucht? Es gibt da eine sogenannte "Melina" Version, die soll ein paar workarounds enthalten, mit der sich einige derartige Effekte besser handlen lassen.
 
D

Defy_user

Neues Mitglied
@morrg
Hallo, dass habe ich noch nicht ausprobiert, da ich noch nie von "Melina" Versionen gehört habe. Hört sich aber interessant an.

Ich habe das Problem mittlerweile anders gelöst. Wobei gelöst eigentlich der falsche Begriff ist. Ich starte nach jeder installierten Zip Datei, dass Smartphone neu. Natürlich nicht das System, sondern das Recovery. Dann kommt die zweite Zip Datei usw...
Die Gapps müssen wie oben beschrieben immer mit geflasht werden. Dann funktioniert es.

Bin natürlich für bessere Lösungen gerne offen.

Vielen Dank für Eure Hilfe... :thumbsup:
 
morrg

morrg

Fortgeschrittenes Mitglied
In der Lineage Downloader app, kann man das so konfigurieren, dass nach jeder verarbeiteten und geflashten neuen LOS Version direkt weitere zips hinter her geflasht werden: also zb gappps und SuperSU
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von hanspampel - Grund: Unnötiges Direktzitat entfernt - Der Bezug steht ja. - "hanspampel"
D

Defy_user

Neues Mitglied
TWRP kann das ja auch. Nur funktioniert LOS danach nicht mehr richtig. Einziger Lösungsweg ist bisher, wie ich es beschrieben habe. Alles einzeln flashen und zwischen drin TWRP immer neu starten...
Ich möchte im Augenblick nicht experimentieren, wenn nicht sicher gestellt ist, dass es 100% funktioniert. Das LG G6 ist momentan mein Hauptgerät. Wenn es nach einem Experiment nicht mehr richtig funktionieren würde, wäre das für mich nicht sehr gut. :crying:
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von hanspampel - Grund: Unnötiges Direktzitat entfernt - Der Bezug steht ja. - "hanspampel"
morrg

morrg

Fortgeschrittenes Mitglied
Jetzt hab ich diese Seuche: versehentlich nach dem Update von LOS 14.1 das Gerät durchgestartet und erst danach noch mal ins TWRP und gapps nach geflasht. Danach sind die google apps zwar im Prinzip alle da, aber der google account fehlt. Das eingetliche Problem: ich kann den google account auch nicht hinzufügen: Egal ob in den einstellungen, beim Aufruf von gmail oder anderen gapps, es erscheint zwar der Dialog für das Hinzufügen eines google Kontos, aber sobald ich Email und das korrekte Passort eingegeben habe, läuft eine Prüfung und am Ende verschwindet der Dialog ohne Felermeldung und ohne dass der google account hinzugefügt ist. Habe das jetzt schon ein paar dutzend mal getestet und auch bei allen möglichen apps den cache und alle Daten gelöscht. Nix zu machen. Irgendwie scheinen Fragmente des Google accounts noch irgendwo gespeichert zu sein, die es verhindern, dass dieser account nochmal hinzugefügt werden kann. Die Google aps sind daher alle unbenutzbar, app-updates über google play gehen auch nicht mehr und Kalender sync auch nicht. Habe jetzt also ein defakto google freies Handy.
Gibt es sowas wie eine gapss-Rückstands-Beseitigungsmethode mit der man alles googleske vom Handy entfernen kann? (also unter Beibehaltung des restlichen Setups von >300 apps mit Konfiguration und Daten)
 
D

Defy_user

Neues Mitglied
Hallo,
ich hatte das Problem jetzt, nachdem ich das Smartphone verschlüsselt habe. Das geht jetzt neuerdings auch mit dem LG G6... ;-)
Ich habe es so gelöst bekommen:

TWRP Starten
Die System Partition einbinden. Falls es nicht geht, dann einfach schreibgeschützt einbinden.
Gapps flashen
Neu starten.

Leider musste ich einige Programme danach neu installieren. Z.B. Google Telefon. alles andere ging so.
Einzig die Zugriffsberechtigungen aller Programme mussten neu erteilt werden.
 
H

Hygros

Neues Mitglied
morrg schrieb:
Jetzt hab ich diese Seuche: versehentlich nach dem Update von LOS 14.1 das Gerät durchgestartet und erst danach noch mal ins TWRP und gapps nach geflasht. Danach sind die google apps zwar im Prinzip alle da, aber der google account fehlt. Das eingetliche Problem: ich kann den google account auch nicht hinzufügen: Egal ob in den einstellungen, beim Aufruf von gmail oder anderen gapps, es erscheint zwar der Dialog für das Hinzufügen eines google Kontos, aber sobald ich Email und das korrekte Passort eingegeben habe, läuft eine Prüfung und am Ende verschwindet der Dialog ohne Felermeldung und ohne dass der google account hinzugefügt ist. Habe das jetzt schon ein paar dutzend mal getestet und auch bei allen möglichen apps den cache und alle Daten gelöscht. Nix zu machen. Irgendwie scheinen Fragmente des Google accounts noch irgendwo gespeichert zu sein, die es verhindern, dass dieser account nochmal hinzugefügt werden kann. Die Google aps sind daher alle unbenutzbar, app-updates über google play gehen auch nicht mehr und Kalender sync auch nicht. Habe jetzt also ein defakto google freies Handy.
Gibt es sowas wie eine gapss-Rückstands-Beseitigungsmethode mit der man alles googleske vom Handy entfernen kann? (also unter Beibehaltung des restlichen Setups von >300 apps mit Konfiguration und Daten)
Geht mir auch so.
Playstore stützt beim einrichten ab.
Habe das Image noch mal neu aufgespielt, vorher System und Cache gelöscht.
Hilft nix.
 
D

Defy_user

Neues Mitglied
@Hygros
Bei einer Neuinstallation, musst du das System erst einmal starten. Anschließend kannst du im TWRP erst Gapps installieren. Darauf achten, dass beim installieren der Gapps keine Fehlermeldung auftritt. Sollte das der Fall sein, im TWRP nachsehen, ob die System Partition eingebunden ist. falls nicht, über das entsprechende Menü nachholen und Gapps einfach noch mal installieren.

Bei einem Systemupdate wird nach dem Update wie im Thread #5 beschrieben verfahren.
 
H

Hygros

Neues Mitglied
Servus Defy,

habe ich auch noch mal probiert, ändert aber nichts.
Lustig das ich einen neuen Google Account anlegen kann und dann läßt sich der Playstore auch starten. Hilft mir aber nix will ja meinen Account :)
Das würde ja darauf hindeuten das da tatsächlich noch Fragmente irgendwo stecken, die man löschen müßte.
Gruß
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ich habe noch ein wenig "rumgefummelt".
Die gesuchte Einstellung oder Datei muss im User Profil versteckt sein.
Wenn ich nämlich einen neuen User anlege dann kann ich unter dem user auch den Playstore starten.
 
morrg

morrg

Fortgeschrittenes Mitglied
Nach weiterer Recherche scheint klar zu sein, dass das Problem darin besteht, dass der alte google account in einer der beiden Dateien:
/data/system_ce/0/accounts_ce.db 236 KB
/date/system_de/0/accounts_de.db 64 KB
noch zu stecken scheint. Also mutmasslich in der größeren Datei.
Vermutung: wenn ich beide Dateien lösche, müsste sich der google account auch wieder einrichten lassen, aber dann sind wohl auch alle anderen eingerichteten Accounts auf dem Gerät futsch: email, evernote, whatsapp, threema ....

Mal sehen, ob ich ein tools finde mit dem ich diese .db Dateien lesen und ggf. bearbeiten kann
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ok! Habe es gelöst bekommen.
Im Web sqlite-editor.apk gesucht, runtergeladen und installiert.
Damit dann /data/system_ce/0/accounts_ce.db geöffent und darin die Zeile mit den Daten zu meinem google account gelöscht.
Danach konnte ich diesen Account dann endlich wieder regulär hinzufügen!
 
H

Hygros

Neues Mitglied
@ morrg Danke:thumbsup:
Habe bei mir auch die Zeile mit dem Google Account gelöscht (bin beeindruckt PWD wird nicht im paintext gespeichert :) ) allerdings hat das bei mir nicht geholfen.
Habe dann aber die ganze Datei "entsorgt" nach Neustart lief alles wieder bzw. der Playstore lies sich einrichten.
 
morrg

morrg

Fortgeschrittenes Mitglied
Ja löschen der Datei, wäre auch mein nächster Schritt gewesen, dann hätte ich allerdings auch die anderen 24 accounts (mail, whatsapp, telegram, threema etc. pp.) alle wieder neu hinzufügen müssen.