WLAN zeigt keine Internet-Verbindung (wegen Firewall?)

S

starbright

Stammgast
Threadstarter
Benutze AFWall+. Vermutlich weil ich einige Google Dienste blockiert habe, meint mein Handy nun dauernd, ich hätte zwar WLAN aber keine Internet-Verbindung, und will sich dann auch nicht automatisch einloggen. Es fragt zwar dann bei manuellem Einloggen, ob es die Verbindung halten soll und man kann angeben, ob es sich das für den AP merken soll - allein es macht es nicht. Das nervt.
Andererseits muss ja Google auch nicht alles wissen, und sonst funktioniert ja alles.
Hat jemand eine Idee dafür?
 
O

ooo

Lexikon
Das ist die Captive Portal Detection, die durch AFWall+ geblockt wird (und das ist gut so).

Lösung zum Vermeiden der nervigen Fehler-Meldung/Anzeige:
  • ooo-v1-captive-portal.flashable.zip downloaden
  • TWRP Recovery starten
  • TWRP > Install > Auswahl ooo-v1-captive-portal.flashable.zip > Swipe to Flash ...
  • TWRP > Reboot > System
  • Terminal Emulator öffnen, Eingabe
    su
    cpdstatus
    cpdoff
    reboot
    (Funktioniert reboot nicht, Phone einfach neu starten.)
  • W-LAN einmal de-aktivieren, dann wieder aktivieren

Neue Befehle im Root-Terminal ("su"):
  1. cpdstatus - Zeigt den aktuellen Status der Captive Portal Detection an
  2. cpdoff - Schaltet die Captive Portal Detection aus
  3. cpdon - Schaltet die Captive Portal Detection an (ROM-Standard, für W-LANs in Hotels etc.)
(Die neuen Befehle sind in /system/xbin/ zu finden und einfache Shell-Scripte, also Text-Dateien und bearbeitbar.)

Die Datei /system/addon.d/98-ooo-files.sh sorgt dafür, dass die Befehle bei einem (OTA-)Update nicht wieder gelöscht werden.

Diese Lösung ist für CM ROMs gedacht.
___

VORHER >>> NACHHER

01.png >>> 21.png
___

02.png 03.png 04.png 05.png 06.png 07.png 08.png 09.png 10.png 11.png 12.png 13.png 14.png 15.png 16.png 17.png 18.png 19.png 20.png
___
 

Anhänge

  • ooo-v1-captive-portal.flashable.zip
    143.4 KB Aufrufe: 246
S

starbright

Stammgast
Threadstarter
Hey, ganz vielen Dank!
Ja, die Abfrage ist weg. Mal schauen, ob er die Verbinduung auch behält, bzw sich auch wieder automatisch einloggt.

Ich hab noch kurz zwei Fragen an @ooo:
Da mir die 1GB RAM und CPU langsam zu klein werden, schiele ich schon mal auf einen Nachfolger. Hast du eine Empfehlung, nicht zu groß und eins das auch ein paar Androidverserionen mit CM (und deiner Super-Unterstützung) erlebt?

Und das zweite: schon mind. seit dem letzten Update (8.11.) hab ich nach Neustart immer die Meldung das sich der Prozess "System" beendet hat.
Das klickt man weg und ich hab eigentlich keine Probleme (ausser mit dem WLAN). Hast du eine Idee was es damit auf sich haben könnte?
 
O

ooo

Lexikon
Ich kann nicht in die Zukunft sehen, aber hier meine Vorauswahl-Kriterien (subjektiv, Kamera ist mir z. B. egal, es muss CM-fähig sein):
Nur Phones mit Snapdragon (Custom ROM Support) ab 617/625 ++ (Vulkan-API-fähig), min. 2 GB (besser 3 oder 4), min. 16 GB Speicher, min. HD (720p)
Mindestens mit Marshmallow Stock-ROM, besser bereits Nougat, ein kleines Display (unter 5 Zoll) kann man sich inzwischen "abschminken", wenn man aktuelle Hardware haben möchte. - Vor dem Kauf: Ansagen zu Upgrades der Hersteller verfolgen (also die "falschen Versprechungen"-Meldungen), Hersteller Foren lesen, XDA ROM Unterstützung zu den Phones checken, bei brandneuen Devices mindestens 3 Monate warten und lesen, was Negatives aufschlägt.
Ob der Bootloader entsperrbar ist, es (einfach) zu rooten ist und es eine CM ROM gibt, weiß man nie so genau bei Erst-Erscheinen.
___

SD Card wechseln und/oder - besser - Apps von der SD Card zurück in den Phone-Speicher verschieben oder ganz weglassen hilft oft (Das Phone ist kein hyper-schneller "Kraftprotz") ...
 
O

ooo

Lexikon
System Process:
Gegentest (ohne installierte Apps): In den Safe Mode starten mit [Power] > Laaanger Touch auf Neustart > [OK], dann (länger) testen auch ein paar Mal wiederholen ...
 
S

starbright

Stammgast
Threadstarter
WLAN: Also funktioniert jetzt prima. Bin ganz happy. Nur das "WLAN: im Ruhemodus aktiviert lassen", ich glaub das geht nach wie vor nicht.
Zumindest sieht man, was WLAN-aktivieren wenn man das Mobile etwas länger in Ruhe läßt. Daran scheitert bei mir daheim (gerade unterwegs) auch die zuverlässige Nutzung als Dect-Ersatz an der Fritzbox mit deren App.

Naja, um die SD komme ich im Moment nicht herum und die Apps brauch ich fast alle. Kann aber gut sein, dass das daher kommt. Naja, nicht tragisch.
Mit einem langen Touch auf Neustart passiert bei mir aber nichts?!?
 
S

starbright

Stammgast
Threadstarter
Ok, also langer Touch auf "Ausschalten", nicht auf "Neustart" . ;)
Die Anzeige "Prozess "system" reagiert nicht" bleibt aber auch im Safe Mode erhalten
 
O

ooo

Lexikon
Wir werden das so nicht gelöst bekommen, da das Phone eine Nightly fährt (vermutlich bereits mehrfach aktualisiert), Apps auf die SD Card verschoben sind, ein Custom Recovery installiert ist und evtl. Backups alter Daten restored wurden (vllt. sogar mehrfach). - Das sind zu viele mögliche Fehlerquellen. - Ich gehe in einem solchen Fall zurück auf die jüngste Nightly (clean install, full wipe, vorher Komplett-Backup) und setze Schritt für Schritt alles neu auf (ohne Backups einzuspielen). - Es gibt dafür keine "wasserdichte" Lösung und ist sehr zeitaufwändig.
___
Der Safe Mode funktioniet bei mir mit langem Druck auf "Neustart" (CM 11 und CM 14.1, Normales Startmenü und auch Entwickleroptionen > Erweitertes Startmenü > aktiviert)
 
Zuletzt bearbeitet:
S

starbright

Stammgast
Threadstarter
Das verstehe ich. Hab auch mal danach gesucht. Da es keine großen Probleme gibt, werd ich das erst bei einem Versuch mit CM14 angehen. Da trau ich mich noch nicht ran, ist noch recht neu....

Aber hast du ne Idee zu dem "WLAN im Ruhezustand"? (Nie oder immer scheinen das gleiche zu machen. Wenn das Handy kurz aus ist, dann ist das WLAN Zeichen beim Einschalten da, sonst kommt es nach 1-2s.) Das wär mir wichtiger.
 
O

ooo

Lexikon
Android Smartphone verliert WLAN Verbindung: Eine Fehlersuche

Ich habe es auf "Immer" und verwende eine statische IP im W-LAN - auch, wenn der Router die IPs automatisch über DHCP vergibt.
Die FritzBox-App sollte von sich aus immer aktiv sein und die Verbindung über den Heartbeat-Mechanismus aufrecht erhalten, was auch das W-LAN aktiv hält. - Wenn nicht, dann kann man in den Energie-Einstellungen auch zusätzlich eine Ausnahme für die FritzBox eintragen (immer aktiv). - Wenn es nur die (Aktualisierung der) Anzeige sein sollte, die stört: da kann ich nicht helfen.
 
Zuletzt bearbeitet:
S

starbright

Stammgast
Threadstarter
Der Anleitung bin nachgegangen. WLAN Optimierung hab ich nicht gefunden. Das Rücksetzen geht derzeit (Urlaub) nicht. Die Nutzung als Tel an der Fritzbox ist eine Anwendung, Messanger eine andere. Vielleicht probier ich das ganze mal nach dem Neuaufsetzen mit nur der Messanger-App. Da hab ich nämlich auch mit der mobilen Datenverbindung oft das Problem, dass ich über eine neue Nachricht nicht gleich informiert werde sondern erst, wenn ich das Fon anmache. Ich glaub, es nimmt das mit dem Energiesparen ernst. ;)
Daher bin ich die Akku-Settings durchgegangen. Ich nehme an "Mehr Leistung" gegenüber "Ausgeglichen" bezieht sich eher auf Frequency/Powerscaling als aufs Funkmodul.
Akkuleistungs-Optimierung : alle ausser Google Play Dienste sind optimiert.Das wäre ein Ansatzpunkt. Ob man da aber die App oder eine Systemfunktionen "deoptimieren" muss?
Und dann gibt es noch App Profile aktivieren. Das geht aber nur Global.
 
O

ooo

Lexikon
starbright schrieb:
Das wäre ein Ansatzpunkt.
Fang erstmal damit an (nicht alles auf einmal und durcheinander). - Keine Services anfassen, nur von dir installierte Apps. - Wenn es das ist, "wecken" deine Apps die benötigten Services automatisch mit auf ...

(Und nicht vergessen: Es gibt immer zwei Seiten bei einer W-LAN-Verbindung - der Router kann auch sagen "Ich geh jetzt pennen, tschüüss Gemeinde!" ... oder ein Update seiner u. U. uralten Firmware vertragen ...)
 
S

starbright

Stammgast
Threadstarter
Da ich gerade beim Neueinrichten bin:
Den online Check mit google zu machen (default) ist Datensparsamkeitsmäßig doof. Ganz darauf verzichten ist aber vielleicht auch nicht schlau - oder wie bekommt man sonst bei offenen WLAN die Portalabfragen mit die vorgeschaltet sind?
Könnte man nicht auf eine nicht sammelnde IP prüfen (heise.de, ard.de) oder was man sowieso wahrscheinlich demnächst ansurft ;) ?

Wenn ich dein Paket installiert hab, dann sollte aber die FW auch für den Captive Check freigegeben werden, richtig?
 
Zuletzt bearbeitet:
O

ooo

Lexikon
Du machst bei einem offenem WLAN den Captive Portal Check wieder an (Terminal Emulator > su > cpdon).
Firewall-Freigabe musst du nicht machen, wenn du "[0] root" freigegeben hast, weil du im Terminal Emulator ja als "root" (su) unterwegs bist.
(Wenn du allerdings eine App "CaptivePortalLogin" hast, was bei neueren ROMs die Regel ist, dann musst du diese in der Firewall freigeben.)
Oder du weißt den URL der Startseite (z. B. https://offenes-wlan/startpage.html) im offenen WLAN (wobei ein "echt" offenes WLAN so etwas eigentlich nicht besitzen dürfte) und tippst diesen URL im Browser ein. Der Browser muss natürlich in deiner Firewall freigeschaltet sein.
Wenn du fertig bist mit dem offenen WLAN, dann machst du die Captive Portal Detection wieder aus (Terminal Emulator > su > cpdoff).

(Evtl. muss man das Phone jeweils neu starten; siehe cache(s) löschen)
___

Google umgehen

fake captive portal check at DuckDuckGo
 
Zuletzt bearbeitet:
S

starbright

Stammgast
Threadstarter
Verstanden. Wobei ich vielleicht doch zu faul bin zum ein/ausschalten.
Daher die Überlegung, die Systemapp CaptivePortalLogin in der Firewall zu enablen und nur den Server von einem google zu einem anderen zu ändern. (Wenn ich einen eigenen hätte würde ich den nehmen).
Also die ganze Änderung besteht dann aus:
settings put global captive_portal_server ard.de
Oder muss der captive_portal_server eine spezielle Antwort zurückgeben, die eben nur diese Google-Server bieten? Scheinbar schon, das generate_204 (siehe unten) deutet darauf.
(Captive Portal – Wikipedia
Im Fall von Android gibt es den Captive Portal Check.
).
Man müßte dann tatsächlich sein eigenes CaptivePortalLogin schreiben und die System-App ersetzen :( ?
Denn auch wenn du mit "cpdon" wieder einschaltest, bist du wieder bei google.

Also den check doch ganz weglassen?
"settings put global captive_portal_mode 0" (Android 7)

Dass man dann nicht ins Netz kommt und ein Portal vor sich hat, merkt man dann schon. Hauptsache die nervige Meldung von Android ob man die Verbindung behalten will entfällt.
Blöd nur, dass ich manchmal beobachtet habe, dass wenn man eine url eingibt, nicht auf das captive Portal umgeleitet wird. Aber das ist ein anderes Problem, oder?
Spannend!
 
O

ooo

Lexikon
Benutzung fremdes, offenes WLAN mit Zwangs-Portal-Seite (Captive Portal):
Phone sieht WLAN.
Phone schaltet von Mobile Daten auf WLAN um.
Phone verbindet sich mit WLAN.
Die ("aufgetaute") App CaptivePortalLogin versucht, einen Google-Server zu erreichen, um eine HTTP Code 204 Response zu erhalten.
Das fremde, offene WLAN lässt das nicht zu.
Die App CaptivePortalLogin interpretiert das Ausbleiben der HTTP Code 204 Response so, dass das Phone in einem WLAN ohne Internetzugang ist und stellt die Zwangs-Portal-Seite des WLANs zur Verfügung (im Browser).
Entweder man gibt dort seine (bekannten) User-Daten/Account ein oder, wenn es ohne geht, nickt man einfach die AGB (oder sonst einen Mist) ab. - Z. B. durch Anklicken eines Links/Buttons "Ich habe die AGBs gelesen & bin damit einverstanden" o. ä.
Danach kann man i. d. R. das fremde WLAN für Internet benutzen.

Während des gesamten Vorgangs kam das Phone aber nicht dazu, irgendetwas ins Internet zu pusten (Google).
Das heißt, wenn man in einem solchen WLAN eingebucht ist, dann kommt man zunächst sowieso nicht zu Google & Co.
Also kann man cpdon machen, sich verbinden und das WLAN benutzen.
(Firewall: Die App CaptivePortalLogin hat dabei keinen Zugriff auf das Internet.)
Vor der Benutzung des eigenen WLANs macht man wieder cpdoff.
___

Die Warnung "Kein Internet" und "Nicht mehr fragen, weiter aktiv benutzen" > OK/JA kommt bei mir nur einmal nach einem cpdoff, wenn überhaupt ...
Danach habe ich (Android 7, LineageOS) vollen Internet-Zugriff, aber ein "x"-Symbol in der Notification Bar bei den Schnittstellen.
Das ist aber nur unschöne Optik/Kosmetik und ich interpretiere das positiv so, dass mein Phone nicht zu Google "telefoniert" und alles in Ordnung ist (Captive Portal Detection ist deaktiviert, die App CaptivePortalLogin eingefroren - durch cpdoff = Prima!).
___

Anderer Server:
Das geht nur, wenn dieser Server die HTTP 204 Response senden kann.
Das muss man aber selbst vorbereiten, ich kenne keinen fremden Server/Service, der das macht.
Was aber nicht heißen soll, dass es keinen gibt ...
 
Oben Unten