Bootloop und CWM/TWRP lässt sich nicht starten/neu installieren

  • 1 Antworten
  • Neuester Beitrag
Diskutiere Bootloop und CWM/TWRP lässt sich nicht starten/neu installieren im Root / Custom-ROMs / Modding für Motorola Moto G im Bereich Motorola Moto G Forum.
Status
Für weitere Antworten geschlossen.
A

artna93

Neues Mitglied
Hallo

Ich habe bei meinem Moto G XT1032 den Bootloader ungelocked, das Handy gerootet, laut Anleitung:

[HOW TO] Motorola Moto G: Bootloader Unlock, Rooten und ROM Flashen. – Android Forum - AndroidPIT

Anschließend wollte ich den CWM-Recovery installlieren, hat nicht funktioniert Fehler:
flash recovery recovery.img
error: cannot load 'recovery.img'

Ich habe es nach langen hin und her doch geschafft, habe am Handy über den Play store „TWRP“ installiert.

Habe ein Backup gemacht und wollte dann den CyanogenMod auf das Handy laden, dazu musste ich das Handy neu starten!

Jetzt hängt mein Handy in einem Bootloop, komme nicht mehr in den Recovery-Modus, kann es nicht mehr starten und ich kann den TWRP nicht neu installieren!


HIIIILFE was kann ich machen

Helft mir bitte
 
email.filtering

email.filtering

Gesperrt
Dir erst einmal ein herzliches Willkommen im Forum!


Leider benötige auch ich Eure Hilfe. Nach der oben angepinnten und hier bereits genannten Anleitung habe ich den Bootloader meines Moto G (mit einer 5.0.2er drauf) entsperrt. Anschließend habe ich auch noch diesen lästigen Vorspann (aka Warnhinweis) durch das Flashen einer modifizierten logo.bin unsichtbar gemacht. So weit so gut, und wie man daran erkennen kann, sind die Gerätetreiber korrekt installiert sowie fastboot vorhanden.

ABER das Flashen eines Images in die Recovery-Partition will partout nicht klappen (oder es funktioniert zumindest das Booten ins Minibetriebssystem nicht).

Ich wollte die aktuelle Version des Minibetriebssystems des TWRP, angeblich ist das derzeit die 2.8.70 (ich hab's aber auch mit der 2.8.6.0 und der 2.8.5.0 versucht; selbstverständlich alle für mein XT1032), flashen um darüber später erst mal den Root-Account zu aktivieren bzw. wohl auch einmal ein Community-OS (vermutlich das Minimal-OS) einzuspielen.

Das Flashen sollte ja so klappen (und das hat bei mir natürlich auch bei zig verschiedenen Geräten seinen Zweck erfüllt):
fastboot flash recovery entsprechendes.img

Nun kann ich den Befehl wohl absetzen und laut Kommandozeile ist auch alles in Ordnung, bloß am Gerät gibt's zwei Sorten von Fehlermeldungen. Beliebtester ist dabei eindeutig das in violetter Schrift erscheinende "Mismatched partition size (recovery)", und das, obwohl alle Versionen kleiner als das Image aus Original aus der .4.4.4er (mit seinen 10.240 KiB = 10,0 MiB) ist. :huh:

Verwende ich statt meiner Version von fastboot diese angeblich auf die Motorola-Geräte zugeschnittene und mit der Bezeichnung mfastboot.exe im Umlauf befindliche Version (mit 521 KiB), ändert das nichts am Ergebnis. Ich sehe dann lediglich am Display des Gerätes eine zusätzliche Zeile in gelber Schrift mit dem Text "getvar:max-sparse-size" bzw. in der Konsole "target max-sparse-size: 256MB". Auch ein vorangehendes fastboot device ändert nichts am Ergebnis; das Gerät wird ja gefunden.

Wenn ich dann irgendeines der (angeblich) geflashten Images vom Bootloader aus starten will, geht das Display aus und das Gerät schalten sich ab. Manchmal geht der Abschaltung noch eine Vibration voran, aber eben nicht immer.

Ach ja, und in einer (Video)Anleitung wurde als Vorbereitung fürs Flashen sogar die Aktivierung des USB-Debuggings erwartet, die - aus meiner Sicht natürlich - nichts am Ergebnis ändert; wie auch, schließlich hat das Fastboot-Interface ja nichts mit dem ADB-Interface zu schaffen.

Was bitte mache ich da falsch? :confused:
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
"Kommando" retour! Das Flashen hat doch geklappt! :D

Dabei geht's um zwei Knackpunkte: Die Fehlermeldung "Mismatched partition size (recovery)" kann und muss ignoriert werden (wieso steht das nur in einem Thread bei XDA direkt bei der Anleitung dran?), und dann muss man natürlich wissen, dass das Bootloader-Menü bei Motorola-Geräten anders tickt als sonst üblich. Mit der 'Lautstärke runter'-Taste geht man zum gewünschten Menüpunkt (so weit der Standard), und mit der 'Lautstärke rauf"-Taste (statt der sonst üblichen Power-Taste) wird der Menüpunkt dann ausgeführt.
 
Status
Für weitere Antworten geschlossen.
Ähnliche Themen - Bootloop und CWM/TWRP lässt sich nicht starten/neu installieren Antworten Datum
0
Ähnliche Themen
Moto G läd TWRP nicht mehr