Wie Neo X rooten?

  • 150 Antworten
  • Neuester Beitrag
Diskutiere Wie Neo X rooten? im Root / Custom-ROMs / Modding für Odys Neo X im Bereich Odys Neo X Forum.
DarthRailGun

DarthRailGun

Ambitioniertes Mitglied
Du hastest ein Neo X7 oder X8 ??? - Würde mich interessieren ob es beim X8 auch funtzt.
 
Zuletzt bearbeitet:
T

Toxic1982

Neues Mitglied
DarthRailGun schrieb:
Du hastest ein Neo X7 oder X8 ??? - Würde mich interessieren ob es beim X8 auch funtzt.

Habs grad mit dem X8 getestet. Hat funktioniert.

Hatte es gestern schon versucht. Superuser.apk war zwar installiert, funktionierte aber nicht. Irgendetwas muß ich falsch gemacht haben.

Per ADB hatte ich das Device übrigens nicht gefunden weil der Droidexplorer Dienst noch lief.

Danke für die Anleitung DarthRailGun.
 
DarthRailGun

DarthRailGun

Ambitioniertes Mitglied
Toxic1982 schrieb:
Habs grad mit dem X8 getestet. Hat funktioniert.

Danke für die Anleitung DarthRailGun.
Also ist die Methode - ICS Root verdächtig, müsste auf anderen Geräten auch funtzen.

Wenn im ADB

adbd cannot run as root in production builds

ist.

LG DarthRailGun
 
W

wildwasserbahn

Fortgeschrittenes Mitglied
Ich habe einen X7

Unter Win 7 (32 & 64) hat es bei mir auch nicht funkrioniert. Unter XP ging es sofort.


Gruss
 
DarthRailGun

DarthRailGun

Ambitioniertes Mitglied
Buchinho schrieb:
Wie läuft das unter Linux?

Ich habe mir das adb-1.0.29.tar.gz aus dem Thread hier runtergeladen:
https://www.android-hilfe.de/forum/...06/odys-cosmo-rooten.193732.html#post-2609272

Jetzt habe ich versucht diese ID hinzuzufügen: "adm712hc01234567" mit ADB_AddVendor.sh

Geht nicht. Wer kann mir weiterhelfen?

Unter Windows ist es ID 0x2207

"adm712hc01234567" ist dein device vom Gerät das muss erscheinen, wenn du adb device eingibst.

Leider habe ich zur Zeit kein Linux mehr auf mein Rechner sonst hätte ich es getestet.

LG DRG
 
Buchinho

Buchinho

Ambitioniertes Mitglied
Jetzt bekomme ich das hier: List of devices attached
???????????? no permissions
 
Astralix

Astralix

Stammgast
So, aber die Anleitung mal ganz nach vorne gehievt, damit sie jeder auch schnell findet.

Gruß Astralix

Der ursprüngliche Beitrag von 23:22 Uhr wurde um 23:31 Uhr ergänzt:

Buchinho schrieb:
Jetzt bekomme ich das hier: List of devices attached
???????????? no permissions
Bitte adb mal als root ausführen, bzw. via "sudo adb".
No Permissions bedeutet möglicherweise auch, dass Du auf dem Tablet das USB Debugging nicht aktiviert hast?

Astralix
 
P

Postnix

Fortgeschrittenes Mitglied
Alle Treiber installiert.

Nach "adb devices", erhalte ich

"List of devices attached"

mehr nicht, kein Neo X8 angezeigt?
 
T

Toxic1982

Neues Mitglied
Postnix schrieb:
Alle Treiber installiert.

Nach "adb devices", erhalte ich

"List of devices attached"

mehr nicht, kein Neo X8 angezeigt?
"Android Composite ADB Interface" Im Gerätemanager installiert? Kein zusatz Tool laufen? Droidexplorer? HTC Sync?
 
P

Postnix

Fortgeschrittenes Mitglied
Zuletzt bearbeitet:
DarthRailGun

DarthRailGun

Ambitioniertes Mitglied
Postnix schrieb:
Logo.

Vielleicht liegt es an der android_winusb.inf?

Da ist es nicht eingetragen.

PS: Im Gerätemananger unter Win7 wird es angezeigt.
Das muss in die android_winusb.inf

;Odys Neo x7&8
%SingleAdbInterface% = USB_Install, USB\VID_2207&PID_0000
%CompositeAdbInterface% = USB_Install, USB\VID_2207&PID_0000&MI_01

LG DRG
 
P

Postnix

Fortgeschrittenes Mitglied
Done.

Ergebnis das gleiche.

Der ursprüngliche Beitrag von 10:13 Uhr wurde um 10:27 Uhr ergänzt:

Aber jetzt!

Mein Fehler: ADB_AddVendor.vbs übersehen.

Alter Mann, blind, und so.

Wenn jetzt einer meckert, gibt es was auf die Nase, gell?

Danke an alle, die sich gekümmert haben.

Der ursprüngliche Beitrag von 10:27 Uhr wurde um 10:56 Uhr ergänzt:

@DarthRailGun

Kann ich Dein Script auch in eine Bat oder Cmd packen und es automatisiert ausführen lassen?

Wenn ja, wie?

Das funnktioniert bei mir nämlich nicht:

adb shell
exit

Er bleibt dann bei der Shell-Eingabeaufforderung stehen: "shell@android:/ $"
 
P

Postnix

Fortgeschrittenes Mitglied
@DarthGailRun

Nach 13 sagt er mir:

"cannot stat "su": No such file or directory.

Und nun?

Habe den Fehler gefunden:

Man muss vorher die Superuser.apk und su in das "adb" Verzeichnis kopieren. Es wäre hilfreich, wenn Du das in Deiner Anleitung dazu schreiben könntest.
 
Zuletzt bearbeitet:
LR7

LR7

Ambitioniertes Mitglied
Und bei mir hängt's bei

Code:
8. shell@android:/ $ echo ro.kernel.qemu=1 >/data/local.prop
Permission denied
 
P

Postnix

Fortgeschrittenes Mitglied
Schau mal, ob Du Dich nicht vertippt hast. Das passiert schnell.

PS: Ich bin root!
 
H

hmhmhm

Neues Mitglied
Hi,

mein x7 wird nicht erkannt bzw. ich kann die Treiber nicht installieren. USB Debug ist an.
Am Netbook konnte ich die Treiber installieren, trotzdem kommt

Waiting for device ...

liegt es vielleicht an Win7 64bit?
 
LR7

LR7

Ambitioniertes Mitglied
Ein prima Progrämmchen heißt "USB-Fehlerbehebung". Damit habe ich alle alten Treiber für nicht angeschlossene Geräte im Gerätemanager entfernt, mit CCleaner irgendwo ein Häkchen gesetzt (Inf-Backup löschen, oder so, eventuell gibt es diesen Eintrag erst mit CCEnhancer, aber das nur der Vollständigkeit halber).

Beim Neuanschluß meines X8 habe ich den USB Treiber von (siehe Post hier im Thread) ausgewählt, und siehe da, Gerät wurde im ADB-Dings erkannt.

Nun kann ich lustig in der Konsole rumtippen, und es passiert sogar was ("adb reboot" und so), aber leider... siehe oben. Eine Batchdatei für Nicht-Computerfüchse wäre wirklich prima.

Bin allerdings auf XP 32.
 
T

tempora

Neues Mitglied
Juchuuh, ich bin auch Root. Neo X 8 (4Gb), PC Win XP Home.
ADB-Connection hatte ich ja schon am Wochenende (siehe weiter oben), dank DRG hat das Rooting jetzt geklappt. Wichtig ist tatsächlich auch der Hard-Reset ganz am Schluß.

Nochmal vielen Dank an alle ! :thumbup:

Der ursprüngliche Beitrag von 13:17 Uhr wurde um 13:20 Uhr ergänzt:

LR7 schrieb:
Und bei mir hängt's bei

Code:
8. shell@android:/ $ echo ro.kernel.qemu=1 >/data/local.prop
Permission denied
Das bedeutet erstmal, dass Du keine Schreibrechte auf /data hast. DRG hat das mit dem Symlink umgangen, wahrscheinlich hast Du dich da vertippt:
ln -s /data /data/local/tmp

Viele Grüße
 
DarthRailGun

DarthRailGun

Ambitioniertes Mitglied
Wenn man von irgendwo was falsch gemacht hat, kann man ruhig bei 1. Punkt wieder beginnen. Da passiert nix.

An einen einfachen Script arbeite ich. Kann aber noch etwas dauern.

Was wichtig ist. Das ihr keinen DroidExplorer auf euren Rechner habt, wenn der installiert ist. Findet ihr zu 100% den Devices nicht. Weil der immer seinen eigenen Treiber startet.

LG DRG