Probleme beim Rooten unter Linux

E

EhWurst

Fortgeschrittenes Mitglied
Ich frage mich allmählich, ob dein Tablet vielleicht irgendein Firmwareproblem hat? Vermurkste Berechtigungen? Ein Rückgabegerät... ? Es gäbe ja die Original-Firmware bei Odys zum Runterladen. Bloß ob dein Spieltrieb soweit geht, und ob man dann nicht doch noch was vermurksen kann? Bis jetzt ist ja zumindest nichts passiert.
 
W

wibra1

Fortgeschrittenes Mitglied
Hallo EhWurst,
so meinen Feierabend werde ich nun noch mit Odys verbringen
Ich habe aus Linux Intern sowie Linus Intern Extra 2 Live CD 12.04. Ich habe nun mal da getauscht und nochmal alles eingegeben. Nun steht nach dem Hinweise Warten nichts weiter, auch bei ausschalten von Odys nicht. Ich werde nun nochmal den Versuch mit deinem 2. Tipp starten obwohl ich da das Kopieren in den entsprechenden Ordner nicht geschafft habe. Wenn das auch wieder Fehl schlägt werde ich einfach mal den Werksreset ausführen und ganz neu anfangen. Wenn das alles nicht hilft fehlt mir natürlich ein Grund das Gerät zu tauschen. Root klappt nicht fällt jawohl aus, grins:blink:
mfg wibra1

Der ursprüngliche Beitrag von 23:11 Uhr wurde um 23:13 Uhr ergänzt:

@ EhWurst,
ein Nachtrag. Ich habe ehe ich das Ubuntu ausgemacht habe mal in meinen Persönlichen Ordner geschaut. Komischerweise war da adb-1.0.29 aufgeführt. Vom Superuser habe ich da keinen Eintrag bekommen. Müßte der nicht auch dasein ???:angry:
 
E

EhWurst

Fortgeschrittenes Mitglied
Ich werde nun nochmal den Versuch mit deinem 2. Tipp starten obwohl ich da das Kopieren in den entsprechenden Ordner nicht geschafft habe. :
Auf diese Seite gehen [How to] Easy Rooting Toolkit - Root fr fast alle Androiden per Klick Rechtsklick auf den Linux-Link unten und wählen "Ziel speichern unter /home/ubuntu/" dann müsste das Paket im richtigen Ordner sein.

ein Nachtrag. Ich habe ehe ich das Ubuntu ausgemacht habe mal in meinen Persönlichen Ordner geschaut. Komischerweise war da adb-1.0.29 aufgeführt. Vom Superuser habe ich da keinen Eintrag bekommen. Müßte der nicht auch dasein ???:angry:
Es ist in der entpackten Datei Superuser-3.0.7-efghi-signed.zip welche du mit dem zweiten wget-Befehl runterlädst. So ein Ordner muss also auch drin sein. Im ADB Ordner ist der ganze ADB-Kram. :)
Klick doch einfach mal auf die entpackten Ordner, gehe rein, dann kannst dich umschauen und sehen was drin ist. So kriegst auch ein Bild davon, was bei der ganzen Sache überhaupt abläuft.
 
W

wibra1

Fortgeschrittenes Mitglied
Hallo, Guten Abend EhWurst,
oh man ist das aufregend.Also ich habe die Befehle alle wie von Dir aufgeführt angewendet. Ich finde ber im Persönlichen Ordner nur adb-1.0.29 und das mit 2 verschiedenen Einträgen. Ich habe nun auch deinen Link ausgeführt mit Verison Linux und den auch im neuen Persönlichen Ordner aufgeführt. Soll ich vielleicht erst nochmal das andere Versuchen um zu sehen was ich da finde ?
 
W

wibra1

Fortgeschrittenes Mitglied
Smile, @EhWurst,
ja, leicht gesagt und doch gemacht. Okay, ich habe meinen Pcnochmal runtergefahren und starte dann das ganze nochmal. Ich werde dann mal versuchen in dem Ordner etwas zu finden.
mfg wibra1

Der ursprüngliche Beitrag 29.08.2012 von 23:58 Uhr wurde 30.08.2012 um 00:00 Uhr ergänzt:

Nachtrag @ Ehwurst,
>wget http://downloads.androidsu.com/superuser/Superuser-3.0.7-efghi-signed.zip<,
so wurde von Arneb der Link Ergänzt und ich habe ihn auch so eingegeben

Der ursprüngliche Beitrag von 00:00 Uhr wurde um 00:39 Uhr ergänzt:

@ EhWurst,
so ich habe ein Ergebniss. Aufgeführt sind im Persönlichen Ordner, Superuser .apk, Superuser-3.0.7-efghi-signed.zip, su, und auch einige andere. Ich gehe nun mal dran und versuche den anderen Link nochmal

Der ursprüngliche Beitrag von 00:39 Uhr wurde um 01:16 Uhr ergänzt:

@ EhWurst,
so den zweiten Weg bin ich nun auch gegangen mit dem Ergebniss, alle Punkte durch Enter ausgelöst und abgearbeitet. Schlußsatz:Nach Enter um alles zu machen kam Starting.....Killing the adb server to make shure that there are no problems....Waiting for Device.... Daemon not running. startingit now on port 5037..... daemon started successfully.
Ich warte nun noch etwas und traue mich an ./adb reboot mal sehen was passiert

Der ursprüngliche Beitrag von 01:16 Uhr wurde um 01:53 Uhr ergänzt:

@ EhWurst für heute morgen zum letzten:). Da sich nichts mehr getan hat habe ich den Befehl eingegeben. Keine Reaktion. Ich habe das Odys ausgeschaltet und wieder eingeschaltet, USB wieder Aktiviert und nichts passiert. Ich habe mich dann an ./adb shell errinnert, keine Reaktion.Ich habe 6 Befehle von dem Tool gelesen wo ich nur nicht sicher war was mit den Treibern los ist. Die Punkte müßen wohl alle erfüllt gewesen sein, ich glaube sonst hätte der PC ja wohl nicht weiter gemacht. Ich habe ja den letzten erforderlichen Start mit Enter noch auslösen müßen.
Nun glaube ich doch das es sinnvoll ist mal den Werksreset auszulösen. Gibt es vielleicht einen Grund warum ich dies Teil umtauschen kann ?
mfg wibra1
 
E

EhWurst

Fortgeschrittenes Mitglied
Gibt es vielleicht einen Grund warum ich dies Teil umtauschen kann ?
mfg wibra1
Wie gesagt, an sich kriegt man ja die Originalfirmware zum "selber reparieren"
ODYS Multimedia Produkte - Tablet PCs, E-Book Reader, LCD-/LED-Fernseher
weiter unten "Software":
http://www.odys.de/downloads/drivers/ODYS_NEXT_Upgrade_20120426.zip
Das "Upgrade" ist irreführend. Es ist die Originalsoftware. Die Installationserklärung (Windows) ist, glaube ich, im Paket enthalten. Ansonsten gibt´s auch im Forum Hinweise.
 
W

wibra1

Fortgeschrittenes Mitglied
HalloEhWurst,
nun habe ich den Werksreset getätigt und das wesentliche, Sprache, Uhrzeit und Datum neu gemacht. Als nächstes der Versuch mit Root und dem Ergebniss wie gehabt. Alles Okay und bei dem Satz" Copying su to /system /bin/... ist wieder Ende. Ich habe dann mal ./adb shell versucht, garkeine Reaktion.Als nächstes habe ich ./adb reboot versucht auch nichts. Nun habe ich das Odys über den Schalter ausgemacht und bekomme wieder die Error Meldung mit Superuser. Ich bin nun am Überlegen doch den Link zum Reparieren zu nutzen oder dasGerät zurück zu schicken.Irgendwas ist doch wohl offentsichtlich Faul.
Aber nochmal Danke :thumbsup:für deine Mühe.
mfg wibra1
 
wusel

wusel

Stammgast
HalloEhWurst,
nun habe ich den Werksreset getätigt und das wesentliche, Sprache, Uhrzeit und Datum neu gemacht. Als nächstes der Versuch mit Root und dem Ergebniss wie gehabt. Alles Okay und bei dem Satz" Copying su to /system /bin/... ist wieder Ende. Ich habe dann mal ./adb shell versucht, garkeine Reaktion.Als nächstes habe ich ./adb reboot versucht auch nichts.
Mach mal 'ne Pause und einen Reset bei Dir ... :D
Ich habe eine neue Version des Scripts gehackt und soweit möglich alles DAU-sicherer gemacht; ich werde das aber erstmal mit EhWurst testen bevor ich es auf die User loslasse, also habe bitte etwas Geduld bis wir getestet haben ob wirklich alles nun wasserdicht ist ... :razz:
Währenddessen kannst Du ja mal die aktuelle Knoppix-LiveCD saugen und brennen - eventuell klappt es damit ja besser ...
 
W

wibra1

Fortgeschrittenes Mitglied
Hallo Wusel,
auch Dir Danke. Ich habe nun noch etwas anderes Versucht. Ich habe hier 3 Notebooks, 1x XP Home und 2x Win 7 Home sowie 1 Desk mit Win 7 Pro zur Verfügung. Ausser auf dem Notebook mit XP kann kein anderes Win Gerät beim Versuch svwe10...... die Datei finden geschweige zu öffnen. Kann es vielleicht sein das ich meine beiden CD´s in die Tone kloppen kann. Bezüglich des Wartens!!! Ich wäre doch wohl blöd wenn ich so ein Angebot bekomme das nicht anzunehmen. Das mit dem Knoppix greife ich natürlich auf
mfg wibra1:drool:

Der ursprüngliche Beitrag von 16:35 Uhr wurde um 17:35 Uhr ergänzt:

@ Wusel,
ich wollte mir aus dem Link eine Knoppix Iso Brennen, welche von den möglichen ist denn die richtige ?:o:blink:
 
W

wibra1

Fortgeschrittenes Mitglied
Hallo @ EhWurst, Hallo @ Wusel,
ich finde das toll wie Ihr hier eure Hilfe anbietet. Ich komme mir allmählich schon komisch vor. Ich habe nun seit 4 Jahren einen PC und bisher bin ich dank Googeln mit Win leidlich zurecht gekommen. Nun kommt mit Android und natürlich nun Linux wieder neues dazu. Also da wäre ich ohne Hillfe richtig aufgeschmisssen. Die Iso nach dem Link ist schon in Arbeit
mfg wibra1
 
E

EhWurst

Fortgeschrittenes Mitglied
...und laaaangsam brennen! :)
Ich liebe Linux, weil man mit etwas Zeit, Interesse und auch Mühe, lernen kann zu begreifen, was der Rechner überhaupt macht. Man fühlt sich ihm dann auch nicht mehr hilflos ausgeliefert. Und ist vielleicht auch nicht so sehr auf die Hilfe eines Anderen angewiesen, der meint, mehr von der Materie zu verstehen. Nebstbei laufen so ziemlich die meisten Mainframes respektive erst recht so ziemlich alle Supercomputer-Cluster auch unter Linux. Zumindest die in Unis und anderen wissenschaftlichen Instituten. Man hat also einen richtigen "Mainframe" zu Hause! ;) Naja, fast halt.....;)
Wenn es dich interessiert, hier gibts Gratisliteratur.
http://download2.galileo-press.de/openbook/galileocomputing_linux.zip
 
Zuletzt bearbeitet:
wusel

wusel

Stammgast
soooo, warten ist vorbei .... :D
aber zunächst mal was grundsätzliches zu der Forum-Software hier:
wenn man Dir was schreiben will was Du eingeben musst dann benutzt man normalerweise einen Code-Block; das sieht dann zum Beispiel so aus:
Code:
echo "ich will lernen!"
das was im Code-Block steht gibst Du dann genauso ein wie es da steht!
So, das neue Archiv ist hochgeladen, auf zu neuen Taten ...
nachdem die LiveCD gebootet hat machst Du bitte zuerst wieder ein Terminal-Fenster auf - das geht entweder vom Menue aus, oder auch als Vollbild mit Tastenkombination CONTROL+ALT+F2 (hier musst Du Dich erst nochmal anmelden) ...
im Terminalfenster gibst Du dann ein (jede einzelne Zeile mit der ENTER-Taste abschließen!):
Code:
wget http://svwe10.itex.at/~android/adb-1.0.29.tar.gz
tar xzf adb-1.0.29.tar.gz
cd adb-1.0.29
./ADB_AddVendor.sh 0x2207
./devices.sh
dann machst Du ne Flasche Bier auf und postest hier mal das Ergebnis soweit ... :)
 
Zuletzt bearbeitet:
E

EhWurst

Fortgeschrittenes Mitglied
Du sagtest doch, Knoppix hat ne Root-Konsole. Dann doch besser dort reinkopieren! :)
 
wusel

wusel

Stammgast
Du sagtest doch, Knoppix hat ne Root-Konsole. Dann doch besser dort reinkopieren! :)
Brauchen wir wirklich root-Rechte für USB? Ich dachte immer das läuft auch im Userland ....
aber da sehe ich gerade ich habe den Befehl ADB_AddVendor.sh vergessen :crying:
schnell nachbessern ....
oh, sehe gerade Du hast den Link zur ADRIANE-KNOPPIX gepostet; werde ich auch mal schnelll saugen damit ich dasselbe sehe kann ...
 
Zuletzt bearbeitet:
W

wibra1

Fortgeschrittenes Mitglied
Hallo EhWurst, Hallowusel,
ich habe den Link aus der E-Mail, da ist er komplett runtergeladenb und als Datei bei mir am PC gespeichert. Ich habe nun 4DVD zerstört. Ich habe mit dem Win eigenen Brennprogramm, mit CD Burner und Ashampo Burning Studio versucht zum Ergebniss zu kommen. Ein Exemplar lies sich als Boot starten, aber dann kam der Hinweis das die Datei beschädigt sei. Das Brennen ging recht zügig, bei CD Burner habe ich auf x16 runtergedreht. Kann es sein das die Datei wircklich beschädigt ist ?
mfg wibra1

Der ursprüngliche Beitrag von 23:39 Uhr wurde um 23:40 Uhr ergänzt:

noch eine Nachfrage, ist es für mich sofort besser als root zu starten? Gibt es dann andere Befehle ?

Der ursprüngliche Beitrag 30.08.2012 von 23:40 Uhr wurde 31.08.2012 um 00:07 Uhr ergänzt:

Hallo @Ehwurst, Hallo @ wusel,
leise Hurra. Ich habe mir vor lauter Frust erst eine neue Version, die gleiche aber von Uni KL laden wollen. Dann dachte ich mir versuch doch einfach nochmal eine von den defekten DVD,s einfach mal. Und ich glaube es nicht. Mit einer bin ich soweit :
waiting for devise,
*daemon not running. starting it now on port 5037*
*daemon started successfully*
List of devices attached
0123456789ABCDEF device
Das alles in weiss geschrieben und nun wartet der PC auf eine weitere Eingabe
root@Microknoppix:/home/knoppix/adb-1.0.29#
Das lasse ich mal stehen. Vielleicht liestb dies ja eine von euch beiden und kann mir noch helfen. Wenn nicht versuche ich das morgen erneut, mit dem Hinweis was da noch erforderlich ist.
mfg wibra1

Der ursprüngliche Beitrag von 00:07 Uhr wurde um 00:10 Uhr ergänzt:

und doch ein Nachtrag. Nun kann ich keinen Mauszeiger mehr finden und es ist auch keine Eingabe mehr möglich. Nur Standbild mit den Daten die Ausgeführt wurden:confused2::sad:

Der ursprüngliche Beitrag von 00:10 Uhr wurde um 00:44 Uhr ergänzt:

so, hier hat sich nichts getan. Ich habe nun das Odys wieder über den Schalter abgemeldet und dann passierte doch etwas.
Ich habe dreimal die oben beschriebene <eingabeaufforderung und dann,
bash: .: Ein Dateiname wird als Argument benötigt.
.: Gebrauch: . Dateiname [Argumente]
und darunter wieder 2 x Eingabeaufforderung wie gehabt.
mfg wibra1
 
wusel

wusel

Stammgast

leise Hurra. Ich habe mir vor lauter Frust erst eine neue Version, die gleiche aber von Uni KL laden wollen. Dann dachte ich mir versuch doch einfach nochmal eine von den defekten DVD,s einfach mal. Und ich glaube es nicht. Mit einer bin ich soweit :
waiting for devise,
*daemon not running. starting it now on port 5037*
*daemon started successfully*
List of devices attached
0123456789ABCDEF device
Das alles in weiss geschrieben und nun wartet der PC auf eine weitere Eingabe
root@Microknoppix:/home/knoppix/adb-1.0.29#
Das lasse ich mal stehen. Vielleicht liestb dies ja eine von euch beiden und kann mir noch helfen. Wenn nicht versuche ich das morgen erneut, mit dem Hinweis was da noch erforderlich ist.
:thumbsup: *** PERFEKT *** ! :thumbsup:
OK, wenn Du das nun morgen nochmal genauso hinbekommst dann sind wir im Rennen!! Danach ist nur noch der Aufruf meines neuen Scripts mkroot.sh nötig - gib bitte nach den Schritten die Du oben ausgeführt hast ein:
Code:
./mkroot.sh
und poste bitte wieder die Ausgabe hier ...
es sollter folgendes passieren:
- Warnung dass keine Superuser.apk gefunden wurde
- automatisches Download der Superuser.apk und su
- und dann werden (hoffentlich!) endlich diese Dateien auf Dein Tablet kopieren damit es gerootet ist!

Ich Drück Dir die Daumen!

So, und nun noch DIE Frage: warum willst Du Dein Tablet rooten? Bist Du Dir sicher dass Du mit dieser Macht korrekt umgehen kannst? :)

Der ursprüngliche Beitrag von 03:14 Uhr wurde um 03:20 Uhr ergänzt:

Diese blöde Forum-Software wieder!! Das hätte nun wirklich ein neuer Post werden müssen da eine Antwort auf einen Post von anderem User! hävksitol - bitte splitten!
Nein, aber für's abschließende Rooten ja. Also am Besten gleich als Root starten. :)
Sorry, das kann ich noch nicht nachvollziehen ...
wenn ich als normaler User auf USB zu greifen kann und auch mit ADB Befehle an ein Android-Device senden kann dann brauch ich doch keine root-Rechte auf dem lokalen Rechner?? Für was denn? Was meinst Du mit 'für's abschließende Rooten' ?? Alles was dort passiert ist dass Befehle über USB an das Android-Device gesendet werden, mehr nicht; dass das letztlich im Android-Device bewirkt dass es gerootet wird ist doch eine andere Geschichte und hat mit dem Rechner der das Script ausführt überhaupt nix zu tun?
Also ich meine ich habe auch schon als normaler User mit Knoppix Dateien via ADV gesendet und empfangen ...
 
E

EhWurst

Fortgeschrittenes Mitglied
Also ich MEINE mich zu erinnern, dass ich meines nur als Root rooten konnte. :) Zumindest ist nix verhaut am Anfang ein sudo su einzugeben und evtl. irgendwelchen Problemen vorzubeugen. Auch wenn deine Argumentation plausibel ist. Roote dein Odys doch einfach nochmal! - wenn du dich traust.. :)


Habe mich unklar ausgedrückt: auf dem lokalen Rechner brauche ich logischerweise keine Rootrechte, brauchte aber - meine ich - für den abschließenden mkroot-Befehl welche. Und dann ist es einfacher gleich am Anfang Root zu werden.
 
Oben Unten