Probleme mit der Nachinstallation der gapps

  • 15 Antworten
  • Neuester Beitrag
Diskutiere Probleme mit der Nachinstallation der gapps im Root / Custom-ROMs / Modding für OnePlus 5T im Bereich OnePlus 5T Forum.
Schrangel

Schrangel

Neues Mitglied
Hallo zusammen,

nach einigen Dramen heute frage ich jetzt doch mal um Rat.
Heute habe ich ein neues Oneplus 5t gerootet und als Custom Recocery TWRP 3.1.1-0 eingerichtet.
Danach habe ich LineageOS 15 [dumpling] versucht aufzuspielen. Um nicht dirty zu flashen habe ich vorher das System gewipet - natürlich ohne ein Nandroid Backup. An dieser Stelle sei darauf hingewiesen: Blöde Idee. Immer vorher backuppen. Immer.
LineageOS brach nämlich mit dem Fehler 7 ab - falsches ROM für dieses Handy. Das habe ich mit Freedom und OxygenOS ebenfalls probiert, Freedom tat zwar so, als würde installiert, hatte danach aber kein OS auf dem Handy hinterlassen. Oxy meldete auch Fehler 7.
Praktisch: Gewipet konnte ich per USB auf das Telefon zugreifen und die ROMs hinkopieren. So konnte ich dann die Fehlerabfrage im LineageOS entfernen und es tatsächlich installieren. Juchu.
Leider ist mit Installation von LineageOS die Möglichkeit verschwunden, per USB auf das Handy zu schreiben. Und im TWRP komme ich nicht mehr auf die Ordner, auf die ich im LineageOS zugreifen kann. Sprich: ich kann die gapps nicht nachinstallieren. Also auch keinen Play Store...
Meine Frage nun: Wenn ich nun das LineageOS nochmal lösche, analog zum Anfang - kann ich dann wieder per USB auds Handy? Falls nicht, wäre ich tot.
Oder komme ich noch anders ans Handy ran, dass ich per TWRP die gapps installieren kann?

Vielen Dank im Voraus,

Schrangel
 
Kredar

Kredar

Erfahrenes Mitglied
Hast du alles gelöscht, auch die Daten Partition mit "yes"? Es muss alles weg sein, wichtig ist die Daten Partition. Sonst geht nix mit neuen Custom Rom. Freedom OS läuft einwandfrei, wie das Original Rom.

Lineare OS benötigt Gapps, das musst du extra per Zip-Datei im TWRP Flashen. Freedom OS braucht kein Gapps, da integriert.

Teste eine andere TWRP Version aus dem XDA-Forum.

mfg
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von TomTim - Grund: Direktzitat entfernt, bitte Forenregeln beachten
Schrangel

Schrangel

Neues Mitglied
Tja, wenn ich das mal hundertprozentig wüsste...
Ich wollte in der Tat twrp-3.2.1-0-dumpling testen, stelle aber gerade fest, dass ich mit "adb devices" nicht mehr das Handy finde...
Das Android-Debugging ist aktiviert. Trotzdem scheint es nicht mehr zu funktionieren. Ich habe mal versucht, die Treiber nochmal zu installieren, scheint aber nichts bewirkt zu haben.
Edit: Und gestern abend hat es noch funktioniert...
Hat das eventuell einen Zusammenhang mit der fehlenden Möglichkeit, Dateien direkt aus dem Windows Explorer auf das Handy zu kopieren?

So, muss (leider) jetzt zur Arbeit.

Danke für die Antwort,

Gruß,

Schrangel
 
Zuletzt bearbeitet:
Kredar

Kredar

Erfahrenes Mitglied
Nimm mal den Blue_Spark der hat OTG Unterstützung oder den letzten offiziellen da soll OTG auch gehen (per USB an USB-C).

Ganz korrekt laufen tut da bei dir was nicht, soviel steht fest.

mfg
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von TomTim - Grund: Direktzitat entfernt, bitte Forenregeln beachten
Schrangel

Schrangel

Neues Mitglied
Heute abend wollte ich mal twrp-3.2.1-0-dumpling testen, eventuell hole ich mir doch noch Bluspark - auf meinem OPX läuft das prima. Habe ich damals auch installiert bekommen :)
Da in der Regel das Problem eher vor der Tastatur sitzt, mal grundsätzliche Fragen:
Wenn ich im OS (LineageOS 15) das Handy in den Einstellungen auf "Werkszustand zurücksetzen" zurücksetze - sind dann die Partitionen ebenfalls wieder in Ordnung? Oder funktioniert das nicht mehr, weil zumindenst den ursprünglichen Werkszustand kann ich nach Löschen des ausgelieferten Oxy ja gar nicht mehr erreichen.
Ich frage das, weil ich eben in einem Anfall von Experimentierfreude in TWRP vorhatte, im Handy die Systempartitionen zu löschen um erneut das LineageOS (diesmal mit gapps) zu installieren. Ging aber nicht, brach mit einer Fehlermeldung ab.
Und, wenn man in den Werkszustand zurücksetzt - was ist mit dem Custom Recovery? Bleibt das wie es ist, oder ist es weg?
Dann gibt es ja auch den Punkt "Partitionen reparieren" im TWRP, daran wage ich mich aber auch erst im Notfall.

Heute morgen wollte ich Dalvik/ART Cache, System, Daten, interner Speicher löschen - dabei sollte das Custom Recovery ja nicht betroffen sein. Danach wieder LineageOS installieren, direkt mit den gapps nano - schon hat man den Play Store wieder.
Ist diese Vorgehensweise vom Ablauf her korrekt?

Und, um mein Problem mit dem nicht mehr erkannten Handy durch adb zu lösen - ich versuche es heute abend mit meinem Laptop (Win10), vielleicht mag der ja mit dem Handy reden. Wenn das auch nicht funktioniert, ist erstmal Sackgasse...

Vielen Dank erstmal,

Gruß,

Schrangel
 
Schrangel

Schrangel

Neues Mitglied
Hallo nochmal,

langsam stellt sich das wahre Problem heraus, denke ich.
twrp-3.2.1-0-dumpling.img habe ich installiert, lief problemlos. Das Verhalten des Handys ändert sich aber nicht, ich bekomme keinen Zugriff von meinem anderen Rechner auf das Telefon.
Da der Zustand so nicht tragbar ist, werde ich experimentierfreudiger. Im twrp habe ich einerseits versucht, zu löschen: "Löschen/Werkseinstellungen herstellen". Es erscheinen eine Menge Meldungen, alle im Tenor " `/data´ konnte nicht eingehängt werden". Wenn man beispielsweise beim Versuch zu backupen den Speicher wählen will, dann haben sowohl "Interner Speicher" 0MB als auch "USB". Bei "USB" macht es Sinn, ist ja nichts angeschlossen. Aber ein wenig internen Speicher erwarte ich schon :)

Rückschluss: Ich habe bei der Installation von LineageOS einen Bock geschossen. Irgendwie habe ich das Dateisystem geschrottet.
Nur welchen Fehler? Und wie komme ich wieder zurück zu einem funktionierenden OS, unabhängig davon, welches?
Aktuell bekomme ich ja keine Datei aufs Telefon, bzw. wenn ich eine Datei aus dem LineageOS herunterlade, dann komme ich im twrp ja nicht mehr an die Datei...

Hat jemand einen Tipp für mich, was ich da machen kann?

Vielen Dank im Voraus,

Schrangel
 
Kredar

Kredar

Erfahrenes Mitglied
Im TWRP einen Full-Wipe machen. Full heißt alles, auch Data-Partition "mit yes" zum Formatieren bestätigen. Danach nochmal schauen ob alle Partitionen Ext4 sind, ggf. Reparieren per TWRP. Danach neues Rom installieren.

Nach einem Full-Wipe sollte eigentlich alles weg sein, auch Einstellungen der Partition usw. Wenn kein Hardware defekt vorliegt sollte es danach wieder einwandfrei laufen. Installiere doch mal das Original OOS von Oneplus, da wird die Firmware auch neu bespielt. Das geht ja bei Custom-Roms leider nicht, evtl. ist da auch ein Fehler vorhanden. Die aktuelle Firmware ist leider nicht Oreo kompatibel (keine Verschlüsselung möglich des Smartphones, wenn ich es im XDA-Forum richtig gelesen habe), deshalb warte ich lieber bis es offiziell OOS Oreo gibt.

Nachdem du das original OOS installiert hast, musst du evtl. wieder TWRP installieren. Denn das original OOS überschreibt TWRP. Kannst direkt per ADB machen wenn du per Hardwaretaste nach dem Anschalten in den Fastboot gehst. Danach wie gehabt weitermachen (Wipe, Custom-Rom installieren, ect...).

Du hast noch lange keinen 500€ Briefbeschwerer, solange du ins TWRP kommst bzw. Fastboot da ist, ist alles noch okay.

mfg
 
Zuletzt bearbeitet:
Schrangel

Schrangel

Neues Mitglied
Hallo, hat funktioniert. Ich vermute, als ich die Datenpartition formatiert habe, hat es sich berappelt.
Jetzt als erstes: Nandroid Backup :)
Vielen Dank!

Gruß,

Schrangel
 
Kredar

Kredar

Erfahrenes Mitglied
Kein Thema, solange TWRP noch da ist kann nix kaputt sein. Bis auf eine korrupte Partition ;).

Per TWRP kannst auch das komplette Smartphone sichern, musst nur vor Sicherung das Passwörter/Fingerprint entfernen. Dann sichern. Ist quasi ein Full Image des kompletten Smartphones. Klappt auch gut. Wiederherstellen per USB-Stick, der spart echt viel Zeit und ist gut angelegt um "Experimente" zu machen ohne PC/Laptop :D.

mfg
 
Schrangel

Schrangel

Neues Mitglied
Mache ich. Normalerweise backupe ich Boot, System, und Data. Hier sind jetzt neu für mich System-Image, Modem und EFS. Ich werde mal Boot, System, System-Image und Data backupen.

Gruß, Schrangel
 
KyleRiemen

KyleRiemen

Ehrenmitglied
System Image lässt du bitte weg. Ignoriere diesen Punkt einfach.
EFS und Modem kannst du mit sichern.
 
Schrangel

Schrangel

Neues Mitglied
Werde ich mir merken, vielen Dank. Kannst Du mir hausfrauentauglich erklären, was sich in EFS und Modem befindet?
Muss aber nicht sein, ich mache es trotzdem :)

Gruß,

Schrangel
 
KyleRiemen

KyleRiemen

Ehrenmitglied
Hinter EFS verbirgt sich deine Seriennummer und deine IMEI.
Unter Modem / Baseband befindet sich die Firmware damit das Gerät Netzwerkverbindung nutzen kann.

Kurz erklärt :)
 
Schrangel

Schrangel

Neues Mitglied
Und auch für mich verständlich :biggrin:
Danke!
 
dexxter88

dexxter88

Stammgast
Hatte mal was ähnliches. Hab mir dann die Google Apps über Drive aufs habdy geladen. Also am PC runrerladen dann ins Drive packen un dann vom Handy aus im Drive das Paket laden. Installieren und fertig
 
Schrangel

Schrangel

Neues Mitglied
Ich muss gestehen, dass ich nicht mehr weiß, ob Google Drive installiert war. Aber ich konnte die gapps ja so herunterladen, nur im TWRP kam ich nicht mehr auf die Ordner, auf die ich im OS noch kam.
Aber ansonsten immer ein guter Tipp :smile:

Gruß,

Schrangel