TWRP kann nicht schreiben

  • 10 Antworten
  • Neuester Beitrag
Diskutiere TWRP kann nicht schreiben im Root / Custom-ROMs / Modding für OnePlus 5T im Bereich OnePlus 5T Forum.
H

hexagon

Fortgeschrittenes Mitglied
Hallo,
Irgendwas habe ich offensichtlich verstellt.
Seit gestern bricht TWRP jede Installation ab mit der Fehlermeldung, dass der Speicher im read only Modus geöffnet ist.
Wie kann ich das korrigieren?

Danke
 
H

hexagon

Fortgeschrittenes Mitglied
Es scheint keine Lösung zu diesem Problem zu geben.
Nachdem ich noch recherchiert habe, scheint die einzige Möglichkeit, wieder an an ein fehlerfreies Recovery zu kommen, das jeweilige ROM neu zu flashen.
Sofern sich das wie gedacht flashen lässt, könnte man das hier parallel verlinkte OOS 5.0.3 ohne Datenverlust drüber installieren? Dieses 5..3 habe ich jetzt auch schon drauf, gerootet. Nur eben mit fehlerhaftem TWRP.
 
Lunatic-

Lunatic-

Erfahrenes Mitglied
Hast du schon versucht die Recovery neu zu flashen? Per ADB / Fastboot?
 
H

hexagon

Fortgeschrittenes Mitglied
Ja, hatte ich versucht.
Der Fehler bleibt jedoch bestehen.
 
Lunatic-

Lunatic-

Erfahrenes Mitglied
Dann kann es theoretisch nicht an einer fehlerhaften Recovery liegen. Hmm keine Ahnung was da schief läuft.
 
H

hexagon

Fortgeschrittenes Mitglied
Da man den Fehler offenbar nicht wirklich lokalisieren kann, wollte ich es nochmal von einem "sauberen" System aus versuchen.
Zunächst jedoch möglichst ohne Datenverlust. TWRP kann ja leider auch kein Backup machen, da keine Schreibrechte.
Deshalb meine Frage, ob ein drüber flashen die Daten (zumindest theoretisch) erhält..
 
Lunatic-

Lunatic-

Erfahrenes Mitglied
Welches OS war denn vorher drauf?
 
H

hexagon

Fortgeschrittenes Mitglied
OOS 5.0.3, gerootet, Magisk
 
Zuletzt bearbeitet:
Lunatic-

Lunatic-

Erfahrenes Mitglied
Dann sollte es theoretisch kein Problem sein. Ich meine, viel kaputt machen kann man eh nicht mehr. Solange du "Data" und "Intern" nicht löschst (wipe) sollten deine Daten erhalten bleiben. Ich würde es versuchen, aber ist natürlich auch nur ein Schuss ins blaue. Kenne mich da auch nicht so gut mit aus :sad:.
 
H

hexagon

Fortgeschrittenes Mitglied
Ich habs jetzt einfach mal getestet.
- ROM neu geflasht > kein Datenverlust, Root und Recovery waren natürlich weg.
- TWRP per ADB/Fastboot geflasht > Funktioniert wieder wie es soll
- Magisk geflasht > alles wieder wie vorher und so wie es soll

danke fürs zulesen
 
reinold p

reinold p

Stammgast
Falls sowas nochmal auftritt, versuch zunächst mal, die Einstellungen /sdcard/TWRP/.twrps zu löschen.