Hacov OS auf dem OnePlus 6 Erfahrungen?

  • 14 Antworten
  • Neuester Beitrag
Diskutiere Hacov OS auf dem OnePlus 6 Erfahrungen? im Root / Custom-ROMs / Modding für OnePlus 6 im Bereich OnePlus 6 Forum.
T

Tante H

Neues Mitglied
Huhu, in die Runde.
Vielleicht hat jemand auf seinem OP 6 Hacov OS installiert und wissenswerte Erfahrungen gemacht die er hier teilen möchte.
Ich wäre sehr daran interessiert und dankbar.
Grüße Tante H
 
Baron1971

Baron1971

Erfahrenes Mitglied
Hi,
ich habe Havoc seit gut einem Jahr drauf. Es läuft absolut Stabil und flüssig. Mit Tonnen von zusätzlichen Funktionen. Ich bin eigentlich sehr zufrieden. Leider haben die Maintainer die letzte Zeit häufiger gewechselt, und die Updates kommen sehr schleppend. Aktuell ist 3.11 mit November Patch. Eigentlich soll noch 3.12 kommen. 4.0 (Android 11) steht aber schon in den Startlöchern. Der aktuelle Maintainer hat ein 6T, und kann nur bedingt auf Fehler des 6er eingehen. Er ist wohl auch immer sehr busy... Mal schauen was die Zukunft bringt!
 
Zuletzt bearbeitet:
T

Tante H

Neues Mitglied
Vielen Dank für deine Antwort.
Ich hätte noch eine Frage, in der Installationsanleitung auf XDA steht:
"DO NOT EVER WIPE SYSTEM OR VENDOR ON THE OP6".
und
" If you're coming from another ROM or need to perform a clean flash."

Wie hast du es gemacht?
Boot in TWRP > Daten formatieren
oder
Boot in TWRP und > Erweiters Löschen> Hacken setzen bei, Davlik/Cache, System, Cache, Data, Internal Stroage.

Ich habe im Moment noch OOS 10.3.7
TWRP 3.4.0-1 mauronofrio
Magisk 20.4

Grüße
Tante H
 
Baron1971

Baron1971

Erfahrenes Mitglied
Wie du oben schon geschrieben hast, kein Haken bei System ;) . Der Rest ist ok. Dabei wir aber dein ganzer interner Speicher gelöscht. D.h. vorher eine komplette Datensicherung machen!
 
T

Tante H

Neues Mitglied
@ Baron1971: Vielen Dank für Deine Hilfe!
 
G

Gizzmo

Stammgast
Warum darf man system eigentlich nicht wipen?
Holt sich der Installer da vorher noch irgendwelche Original Libs, ohne die es nicht läuft?
 
Baron1971

Baron1971

Erfahrenes Mitglied
Ja, soweit ich das verstanden habe, sind da noch originale Dateien vom OOS hinterlegt, die bei wipen gelöscht werden, aber von Havoc gebraucht werden.
 
Zuletzt bearbeitet:
T

Tante H

Neues Mitglied
So falls noch mal jemand hier rein schaut.
Ich habe mein OP6 mit Havoc OS 3.11 geflasht. So wie im XDA-Forum beschrieben:
Boot ins TWRP, nichts löschen.
2x OOS und TWRP flashen (jeweils reboot recovery), ROM flashen, Wipe Data + Cache, reboot recovery, flash Magisk.
(Google habe ich nicht mehr auf dem Handy, was letztlich das Ziel war.)
Dann habe ich Titanium Backup wiederhergestellt (die apk war im Speicher) und dann alle Apps. (Stapelaktion)
Danach war das Handy komplett instabil. SMS und Telefon-App funktionierten nicht. Der Bildschirm hat geflackert. Also noch mal von vorne. Gleiches Ergebnis. Nach dem dritten Mal, direkt nach dem wiederherstellen von Titanium Backup, einen Neustart gemacht. Dann gab es keine Probleme mehr. Die Apps habe ich allerdings nach und nach wiederhergestellt. Am Schluss habe ich meine Wlan-Zugangspunkte wiederhergestellt, dass war dann wieder keine gute Idee, auch im Zusammenhang mit meiner Firewall (+AFWall). Das Wlan hatte dann eingeschränkte Konnektivität.
Also noch mal von vorn.
Flashen
Titanium Backup wiederherstellen
Captive Portal deaktivieren (wegen der Firewall, sonst hat man in der Stausleiste ein x oder ! neben dem Wlan & Mobile Daten)
Apps nach und nach wiederherstellen.
Meine Wlan-Zugangspunkte habe ich nicht wiederhergestellt.
Nun läuft Havoc OS ganz ok.
Die Stock Kamera funktioniert einwandfrei. Auch die GCam.
MicroG ist auch kein Problem mit Aurora-Store.
KDE- Connect funktioniert nicht fehlerfrei.
Das Enttäuschendste ist die Akkulaufzeit, die wirklich unterirdisch ist.
Und der dunkle Displayhintergrund flackert leicht im automatischen Modus.
 
Zuletzt bearbeitet:
reinold p

reinold p

Stammgast
@Tante H: das Gewackel kann schlicht durch deine TiBu-Restores kommen. Mal abgesehen davon, dass TiBu neue Strukturen in Q und R nicht kennt, würde ich Appdaten nur innerhalb einer ROM-Familie und einer Androidversion wiederherstellen.
 
T

Tante H

Neues Mitglied
@reinold p
Danke für den Hinweis. Wusste ich nicht. Titanium Backup ist nicht mehr so gut zu gebrauchen, dass stimmt. Ich nutze parallel noch OAndBackupX, dass muss ich aber noch länger testen.
Ich habe mein Handy jetzt auf Havoc 3.12 geupdatet, damit läuft es ein bisschen besser.
 
Baron1971

Baron1971

Erfahrenes Mitglied
Ich würde mal einen clean Flash, ohne Restore machen. Ist zwar aufwändiger, aber dann sollte alles vernünftig laufen.
In der Telegram Gruppe ist das Thema Enchilada wohl noch nicht ganz vom Tisch. Es gibt aber wohl niemand, der die Test Builds auf Herz und Nieren testet!
 
T

Tante H

Neues Mitglied
@Baron1971
Haste Recht.
Das schöne war ja gerade. dass man keinen Clean Flash machen musste. Der Aufwand ist schon ganz schön groß.😛
 
Baron1971

Baron1971

Erfahrenes Mitglied
Dann wird es auch nicht langweilig....!😉
 
T

Tante H

Neues Mitglied
😂😂😂