I9505 Xposed Framework Installation nicht möglich?

  • 5 Antworten
  • Neuester Beitrag
Diskutiere Xposed Framework Installation nicht möglich? im Root / Custom-ROMs / Modding für Samsung Galaxy S4 im Bereich Samsung Galaxy S4 (I9500 / I9505) Forum.
T

Timle

Neues Mitglied
Hallo,
Ich möchte auf meinem gerootetem Galaxy s4 Xposed Framework installieren, das war bis her nicht möglich. Ich habe mir den Xposed Installer installiert. Anschließend habe mir die Versionen welche für Samsung vorgesehen sind von 79 -87.1 heruntergeladen und in twr geflasht, wobei es immer zu Fehlermeldungen kam. In der XposedInstaller_3.1.1 steht, dass es eine bekannte inkompatibilität mit Samsung touchwiz gäbe.
Ich hoffe, mir kann jemand helfen, da ich absolut ratlos bin. Dankeschön im Voraus
 
djhooker

djhooker

Erfahrenes Mitglied
Hallo,
welches Android ist bei dir installiert? Womöglich eine CR? Für Android N steht bislang noch kein xposed zur Verfügung.
Ansonsten check mal deine Rootberechtigungen. Xposed verlangt Zugriff für Apps und ADB (Einstellung zumeist zu finden bei den Entwickleroptionen). Für den Fall dass bei dir die originale Firmware installiert ist, müsstest du diese Einstellungen bei SuperSU suchen (ich gehe davon aus, dass du hiermit dein Gerät gerootet hast).
Ebenfalls für den Fall, dass bei dir die Original-Firmware läuft, wäre die Version interessant. Der Entwickler von xposed unterstützt als "Minimum" Android 5.x; unter 4.x (Jelly Bean oder KitKat) wird man xposed nicht mehr das Laufen beibringen können.

Viele Grüße,
djhooker
 
Zuletzt bearbeitet:
T

Timle

Neues Mitglied
Hallo,
ich habe die originale Firmware 5.0.1 von Touchwiz auf meinem Handy. Der Xposed Installer fragt mich nach keim zugriff. Du merkst, dass ich nicht viel Ahnung hab, sorry dafür.
Danke fürs Antworten,
Timle
 
djhooker

djhooker

Erfahrenes Mitglied
Hallo, nicht viel Ahnung zu haben ist nicht schlimm, dafür gibt es ja das Forum.
Kurze Frage:
"Anschließend habe mir die Versionen welche für Samsung vorgesehen sind von 79 -87.1 heruntergeladen und in twr geflasht" - was meinst du damit? Was kamen da für Fehlermeldungen? Ich denke, dass das Rooten schlichtweg nicht geklappt hat...

Bist du nach dieser Anleitung vorgegangen?
[Anleitung][I9505] Lollipop Stock-ROM 5.0.1. rooten mit Knox 0x0
 
Zuletzt bearbeitet:
T

Timle

Neues Mitglied

Anhänge

Tanis64

Tanis64

Ehrenmitglied
Du verwendest die Xposed Installer welche nur mit Deodexed Stock Roms funktionieren!
Die originalen Stock Roms von Samsung sind Odexed.
Es gibt Möglichkeiten die Odexed in eine Deodexed zu wandeln, aber dazu brauchst Du Zeit und Muße um dich durch die ganzen Threads hier und bei den XDAs zu arbeiten
Wanam hat welche erstellt die auch mit Odexed funktionieren alledings decken die von Wanam erstellten speziellen Samsung Versionen nur die Android SDK Versionen 22(5.1) und 23(6.0) ab.
Für das S4 gibt es keine Android Version 5.1.x sondern (nur) eine 5.0.1 und die hat die SDK Version 21.
Xposed funktioniert also z.Z. nur mit Custom Roms weche auf 5.1 oder 6.0 Android basieren.
Mit Cyanogen Mod hat es funktioniert.
Du kannst aber auch auf die 4.4.2 downgraden, da läuft Xposed mit dem Xposed Installer aus dem Repository ohne Probleme.
 
Zuletzt bearbeitet: