Jetzt kostenlos registrieren: Mitglieder surfen ohne Werbung!

TWRP Error 7

  • 20 Antworten
  • Neuester Beitrag
Diskutiere TWRP Error 7 im Root / Custom-ROMs / Modding für Samsung Galaxy S6 (Edge) im Bereich Samsung Galaxy S6 (G920F) / S6 Edge (G925F) Forum.
J

Junkstarr

Neues Mitglied
Moin,

Ich erhalte den Error 7, sobald ich eine neue FW flashen will. Ich liste jeweils das Gerät, sowie die installierte TWRP Version und die zu flashende FW auf:

Oneplus 3T - TWRP 3.1.1.0 - OxygenOS Open Beta (Oreo)
Samsung S6 - TWRP 3.1.1.0 - LineageOS 14.1/15

Der Fehler tritt auch mit TWRP Version 3.0.2-1 auf. Ich weiß nicht mehr weiter. Habt ihr eine Idee? LG
 
nik

nik

Senior-Moderator
Teammitglied
Was steht denn im Log vor der Fehlermeldung?
 
J

Junkstarr

Neues Mitglied
E: unknown command [Log]
Updater process ended with ERROR: 7
Error installing zip file blablabla
 
nik

nik

Senior-Moderator
Teammitglied
Und vor 'unknown command'?
 
Thyrion

Thyrion

Ehrenmitglied
Öhm... Du versuchst eine falsche Firmware zu flashen (IST: zeroltexx/zerolte/zerolteskt, SOLL: zeroflte)
 
J

Junkstarr

Neues Mitglied
Die Dateien sind aber auf jeden Fall für das 920F. Welche muss ich denn dann nehmen?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Muss ich vllt einen anderen Kernel flashen...?
 
J

Junkstarr

Neues Mitglied
dank dir. hab jetzt erst mal eine stock rom per odin geflasht. aktuell bootet er noch...mal sehen, ob ich danach mit deiner lineage version draufkomme.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
android 7.0 stock rom hat funktioniert, aber deine lineage version hab ich vorher auch schon mal erfolglos ausprobiert.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
finde auch nur zerolftexx twrp versionen für das s6, obwohl die versionen ohne f richtig sein sollten. die stock rom ist ohne f, aber twrp versionen mit f funktionieren trotzdem. was ist da denn los... ?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
ach mein device ist mit f...jetzt raff ich es
 
PrinzPoldi007

PrinzPoldi007

Inventar
Hier findest Du was zum passenden Recovery
[RECOVERY][G92xF] *19.05.2017* TWRP 3.1.1-0 [TeamWin Recovery Project]
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Und hier ein paar Custom ROMs fürs S6
Custom-ROMs für Samsung Galaxy S6 (G920F)
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Und: wenn mit der nun hoffentlich funktionierenden ROM auch Deine Shift-Taste wieder funktionieren würde, wäre das ein angenehmer Nebeneffekt ;)
 
J

Junkstarr

Neues Mitglied
Habs jetzt mit der richtigen Version versucht, bekomme aber trotzdem noch den Error 7.

Ich nehms so, wie die Autokorrektur es ausspuckt.
 
Wicki

Wicki

Ehrenmitglied
Und die ausführliche Fehlermeldung, vor Error 7?

Du bist herzlich dazu eingeladen, Dein Gehirn zu benutzen, anstatt Dich nur auf die Autokorrektur zu verlassen. Die unterscheidet nämlich nicht generell zwischen Groß- und Kleinschreibung.
 
J

Junkstarr

Neues Mitglied
Can't Install this package on top of incompatible data. Please try another package or run a factory reset

Wipes hab ich gemacht, OS ist nicht installiert. Denk aber, ich hab die full ROM genommen und nicht nur ein Update. Daran sollte es also nicht liegen.

Du bist herzlich dazu eingeladen, darüber hinwegzusehen. Mein Deutsch ist einwandfrei und der Text ist zu jeder Zeit verständlich. Groß- und Kleinschreibung kostet mich zu viel Zeit beim Schreiben.
 
hanspampel

hanspampel

Ehrenmitglied
Junkstarr schrieb:
Groß- und Kleinschreibung kostet mich zu viel Zeit beim Schreiben.
Nun ja, da wir kein Chat sind, sollte sich die Zeit genommen werden.;) Siehe Forenregeln. Auszug daraus:
Rechtschreibung & Schriftzeichen:
Falsch geschriebene Wörter können von anderen Benutzern nicht über die Suchfunktion gefunden werden und führen ggf. zu Missverständnissen. Bemüht euch bitte um eine korrekte deutsche Rechtschreibung und Grammatik in unserem Forum. Wenn ihr euch Mühe bei der Formulierung eurer Beiträge gebt, werdet ihr auch entsprechend qualifizierte Antworten erhalten. Unser Forum ist kein Chat, die dort üblichen Kürzel sind hier deshalb unerwünscht. Bitte verzichtet auch auf die übermäßige Nutzung von Smilies, Ausrufe- und Fragezeichen. Rechtschreibfehler lassen sich z.B. durch Korrekturlesen oder die Nutzung einer Rechtschreibprüfung verhindern. Bitte achtet besonders auf eine korrekte Groß- und Kleinschreibung. Texte in nicht-lateinischer Schrift sind zu unterlassen!
Quelle

Nun zu seinem Problem: Habe mir mal die Mühe gemacht 2 Version (S6 Unofficial + S7 Official) miteinander zu vergleichen. So wie aussieht hat der Bauer des ROMs die entsprechende Kennung/Abfrage des Gerätes in der build.prop zu hinterlegen.
In dem updater-script des ROMs heißt es:
Code:
assert(getprop("ro.product.device") == "zerofltexx" || getprop("ro.build.product") == "zerofltexx" || getprop("ro.product.device") == "zeroflte" || getprop("ro.build.product") == "zeroflte" || abort("E3004: This package is for device: zerofltexx,zeroflte; this device is " + getprop("ro.product.device") + "."););
Wenn die Kennung durch die Abfrage nicht stimmt, kommts eben zum "E3004-Fehler". Da nicht erkannt wird das es sich um ein zerofltexx handelt.
Die Abfrage erfolgt beim Installieren über
Code:
ro.product.device
ro.build.product
Beides wurde nicht in der build.prop hinterlegt - bei der S7 Version schon!! Ergo Abbruch.

Was kannste nun tun? Entweder kommentierts du die Abfrage in Zeile 1 aus. Sieht dann so aus:
Code:
#assert(getprop("ro.product.device") == "zerofltexx" || getprop("ro.build.product") == "zerofltexx" || getprop("ro.product.device") == "zeroflte" || getprop("ro.build.product") == "zeroflte" || abort("E3004: This package is for device: zerofltexx,zeroflte; this device is " + getprop("ro.product.device") + "."););
Einfach ein # davor setzen. Dann wird entsprechende Zeile nicht gelesen, oder eben einfach die erste Zeile kpl. löschen.

Da machste über nen Text-Editor wie Notepad++ oder eben auf dem Gerät selber. Oder fügst die beiden Zeilen der build.prop hinzu.
Code:
ro.build.product=zerofltexx
ro.product.device=zerofltexx
Natürlich machste das auf eigene Gefahr.:winki:

Ansonsten den Bauer des ROMs in den A*sch treten das er entsprechende Zeilen ergänzt. Die Probleme haben wohl viele gehabt.
 
J

Junkstarr

Neues Mitglied
Danke für deine Mühe!

Habe bereits versucht, die erste Zeile zu löschen, werd es aber noch mal so versuchen, wie du es beschrieben hast.
 
hanspampel

hanspampel

Ehrenmitglied
Ich hoffe auch mit dem TWRP fürs "F". Ansonsten einfach mal nen kompletten Log hier reinstellen. Nach dem Flashen/Abbruch kannste mit dem TWRP nen Log erstellen. Dazu auf Erweitert-->Log kopieren gehen. Das produzierte recovery.log dann mal hier reinstellen.
 
J

Junkstarr

Neues Mitglied
Genau das weiß ich eben nicht mehr, deswegen starte ich einen neuen Versuch. Melde mich morgen
 
J

Junkstarr

Neues Mitglied
hab jetzt die noble rom genommen. läuft
 
J

Junkstarr

Neues Mitglied
Noble war zu buggy, konnte danach aber komischerweise problemlos LOS 15 flashen. Danke euch allen trotzdem
 
CT-163

CT-163

Erfahrenes Mitglied
Hey!

habe eben das selbe Problem mit der LineageOS
habe auch schon neue Firmware aufgespielt und alles clean gemacht. immer wieder das selbe.
habe es mit den 3 aktuell letzten Nighlys vom 14.1er Lineage.

egal was ich versuche, es scheitert.

TWRP habe ich über die offizielle TWRP app bezogen.
twrp-3.2.1-0-zeroflte
Firmware: G920FXXU6ERD1_G920FDBT6ERD1_G920FXXU6ERC2_HOME

Logdatei habe ich erstellt, weis aber nicht wie ich sie hier hochlade =(
 
Zuletzt bearbeitet:
Ähnliche Themen - TWRP Error 7 Antworten Datum
4