[Erledigt] Xposed Framework - Problem

  • 3 Antworten
  • Neuester Beitrag
Diskutiere [Erledigt] Xposed Framework - Problem im Root / Custom-ROMs / Modding für Samsung Galaxy S7 Edge im Bereich Samsung Galaxy S7 Edge (G935F) Forum.
Status
Für weitere Antworten geschlossen.
P

Praxo87

Neues Mitglied
Grüßt euch,

da mir der bereits vorhandene Thread nicht wirklich helfen konnte und ich mit manchen "Begriffen" nichts anfangen kann, starte ich hier einen neuen und hoffe eure Hilfe bekommen zu können. Ich sollte vorher erwähnen das ich meine Geräte bisher nicht gerootet habe und ich mich auch nicht all zu groß mit dem Thema bis jetzt auseinandergesetzt habe, daher entschuldigt mein Unwissen schon mal im Vorfeld.

Warum ich einen "root" durchgeführt habe? Ganz einfach. Ich möchte mein Handy individuell gestallten. Das fängt schon mal mit der Statusleiste an und endet mit Modulen wie das YouTube im Hintergrund läuft.


Bereits gemacht:

  • S7-Edge erfolgreich gerootet
  • Xposed Installer installiert
  • TWRP Manager und Flashfire installiert
Da ich keine Lust hatte mein Handy komplett auf Werkseinstellung zurückzusetzen kam das mit dem TWRP Manager und FlasFire gelegen.


Damit ich Xposed nutzen kann brauche ich also das aktuelle Framework für mein Handy. Gesagt getan.

Ab zu Xda:


  • Xposed Framework für Android M 6.0/6.0.1 (ARM64) geholt ( Variante: -v86-sdk23-arm64 )
  • Xposed Framework Uninstaller geholt

Das alles dann schön auf die SD-Karte geschoben......


1.) Flashvorgang mit der App "TWRP-Manager" ausprobiert, leider erfolglos. Nach dem Reboot kam das Andorid-Ausrufezeichen ohne Fehlermeldung. Framework nicht installiert.

2.) Flashvorgang mit der App "Flashfire" lief ebenfalls genau so ab nur mit einer Ausnahme. Ich konnte lesen das keine Dateien geschrieben werden konnten.

Zu erwähnen ist das die FlashFire-App folgende Meldung bringt:

  • Samsung write protection - Current binary: Custom
  • WARNING: Write protection to protected partitions is (probably) turned on.


Ich denke dass das der Grund ist warum ich meinen Flashvorgang nicht durchführen kann.

Ich würde dennoch nicht auf das Framework verzichten wollen, da ich es für einige Apps benötige.
Kann mir da wer helfen?


Würde mich freuen!



Liebe Grüße.
 
P

pleitegeier

Guru
Du brauchst eine angepasste Version von Xposed für Samsung Geräte.
Wanam ist da der Entwickler.

Obs überhaupt mit FlashFire oder so geht weiß ich nicht..
TWRP kann auch ohne Wipe installiert werden, der Wipe ist nur nötig wenn du Nandroid Backups (komplettes System Backup) machen willst mit TWRP ;-)
 
P

Praxo87

Neues Mitglied
Danke!


Thema hat sich erledigt.

Über TWRP-Manager, TWRP installiert und dann auch die richtige Datei von wanam installiert.
 
Status
Für weitere Antworten geschlossen.