Samsung Galaxy S9: Downgrade auf Android 9

  • 24 Antworten
  • Neuester Beitrag
Diskutiere Samsung Galaxy S9: Downgrade auf Android 9 im Root / Custom-ROMs / Modding für Samsung Galaxy S9 / S9+ im Bereich Samsung Galaxy S9 / S9+ (G960F/G965F/DS) Forum.
C

Copiegeil

Neues Mitglied
Hallo,
ich versuche seit Tagen, auf mein Galaxy S9 SF-G960F ein Downgrade auf Android 9 durchzuführen. Hintergrund der Aktion ist, daß der Wechsel von LTE auf G3/G2 nicht klappt. Unterwegs mit dem Auto habe ich keine Verbindung zum Sendemasten, wo es mit dem S7 klaglos geht. Wenn man die automatische Umschaltung nur auf 3G/2G beschränkt, habe ich auch da mit dem S9 Empfang und kann telefonieren (Provider Winsim / O2 Netz) Ich habe jetzt schon viel gelesen wg. der Problematik, das kam ja scheinbar mit einem Update. Jetzt war meine Idee, ein downgrade durchzuführen um das Problem zu umgehen.
Ich habe schon einiges versucht, auch mal TWRP eingespielt um so auch mal auf LOS 16 zu kommen. Aber ich habe es nicht stabil zum laufen gebracht, irgendwie stürzte der Pixel Launcher ständig ab. LOS 17.1 ließ sich nicht einspielen, weil die Vendor nicht passte usw. Im Moment bin ich froh, wieder die Stock Android 10 vom 12.2020 drauf zu haben. Von hier aus möchte ich jetzt nochmals versuchen, weiter zu kommen. Kann mir jemand helfen oder hat eine andere Idee zu dem LTE Problem?

Viele Grüße

Copie
 
maik005

maik005

Urgestein
@Copiegeil
Auf Android 9 kommst du nicht zurück.
Auch nicht auf das alte Modem.
Es ist auch kein von dir genannten Problem bekannt.
 
C

Copiegeil

Neues Mitglied
maik005 schrieb:
@Copiegeil
Es ist auch kein von dir genannten Problem bekannt.
Ich setze jetzt mal keine Goolge Links hier rein, aber wenn man als Suchbegriffe " S9 LTE Probleme " eingibt, dann findet man einige mit diesem Problem. Ich bin da also nicht allein.
 
Zuletzt bearbeitet:
Julian23

Julian23

Moderator
Teammitglied
Copiegeil schrieb:
Hintergrund der Aktion ist, daß der Wechsel von LTE auf G3/G2 nicht klappt.
Wie darf ich mir das vorstellen? Das Gespräch geht weg und Du hast "0 Empfang" ?
 
C

Copiegeil

Neues Mitglied
genau, die Verbindung reißt einfach ab. Man kann ja manuell den Wechsel von LTE/3G/2G beschränken auf 3G/2G. Da geht dann die Telefonie auch an schwierigen Orten mit wenig Empfang, aber man hat dann eben keine LTE Datenverbindung. Das ist im Auto keine Lösung. Jetzt war mein Ansatz eben ein Downgrade, denn die ganzen Foreneinträge zeigen mir, daß das mit einer frühen Version kein Thema war und erst mit einem Update die Probleme auftreten. Scheinbar ist das bei einem Android 9 Update schon mal gewesen, das wurde dann gefixt, mit Android 10 gings wohl eine Zeit, dann nach einem Update wieder Probleme. Vermehrt scheint das O2 Simkarten zu betreffen, es gibt aber auch Berichte, daß es wohl auch mit Telekom und Vodafone Probleme gab, aber deutlich weniger. Selbst im Samsung Forum sind etliche Beiträge zu lesen.
 
T

Tommy001

Erfahrenes Mitglied
Wenn du Volte eingeschaltet hast dann schalte das mal aus. Volte braucht LTE und wenn kein LTE da ist brechen die Gespräche ab.
 
maik005

maik005

Urgestein
@Tommy001
Sollten in 3G/2G übergeben werden.
Er will ja beim telefonieren LTE Daten haben.
Daher ist das ausschalten von VoLTE nicht dauerhaft hilfreich.
 
T

Tommy001

Erfahrenes Mitglied
Ein Versuch ist es wert. Hatte vorher auch das S7 und jetzt das S9 und mit dem S7 war der Empfang bei mir auch besser.
 
Julian23

Julian23

Moderator
Teammitglied
@Copiegeil
Teste es mal ohne VoLTE wie es @Tommy001 vorschlägt. Ist natürlich keine richtige Lösung für dich, ich bin aber sicher, dass die Telefonie dann funktioniert. Ich habe hier auf dem Land auch Probleme mit VoLTE (LTE Empfang recht schwach). Deshalb habe ich auch VoLTE deaktiviert.
Der Handover funktioniert hier meistens auch nicht.
 
Zuletzt bearbeitet:
C

Copiegeil

Neues Mitglied
ich werde es mal testen, aber als Lösung sehe ich das echt nicht. Ich möchte ja, wenn ich im Auto bin, für Google Maps ja Daten bekommen, aber auch telefonisch gut erreichbar sein. Ich versteh da auch Samsung nicht. Das kann doch bei einem, wenn auch ehemaligen, Flaggschiff nicht sein, daß sich mit einem Update so ein Mist einschleicht. Die anderen Reihen, A, J, M haben das Problem scheinbar nicht und bei der S Serie gibt es so etwas. Ich bin jetzt auf der Suche nach einem anderen Smartphone Hersteller, der ein ähnlich ausgestattetes SM anbietet, aber so einfach ist das gar nicht. Entweder kein induktives Laden oder keine SDcard möglich, oder zu groß und schlechte Akku-Laufzeiten.. Apfel Geräte kamen bisher nicht in Frage, aber da scheint es keine allzu großen Probleme zu geben. Aber das wäre für mich komplettes Neuland.
 
T

Tommy001

Erfahrenes Mitglied
Kollege hat ein Apfel und auch dort läuft es nicht rund mit Volte, immer Verbindungsbrücke. Hat Volte ausgeschaltet und siehe da keine Abbrüche mehr.
 
C

Copiegeil

Neues Mitglied
Ich bin der Materie ehrlich gesagt, nicht weit genug drin. Ich bin zwar Funkamateur und kenne mich grundsätzlich zwar mit Frequenzen, Technik und Wellenausbreitung aus, aber hier von der Smartphone Technik habe ich nicht soviel Ahnung.
VoLTE heißt doch für mich: Solange LTE verfügbar ist, läuft die Telefonie über diese Übertragungstechnik bzw. Frequenzen. Wenn es mit LTE dünn wird, sollte das Smartphone in 3G oder 2G wechseln. Und da geht dann bei dem S9 was nicht. Mein S7 macht das anstandslos, ich habe da bei einer Strecke auf der Autobahn einen Punkt, da ist immer ein Umschalten zu merken. Erst ist die Verbindung gut, Sprachqualität 1+, dann komme ich mit meinen S7 an diesen Punkt, da wird die Sprachqulität (3-4) schlechter, aber Verbindung hält. Mit dem S9 reißt die Verbindung ab, obwohl, stimmt nicht ganz. Die Verbindung bleibt bestehen, die Sekunden laufen ja weiter, allerdings ist kein Gespräch mehr möglich. Das Vermittlungssystem hält also die Verbindung. Ich vermute mal, der Befehl für die Umschaltung wird nicht richtig umgesetzt.
Ich habe gestern Abend noch versucht, eine ältere Modem.bin einzuflashen, das ging soweit, aber dann wird keine Sim-Karte mehr erkannt. Ist also auch keine Lösung. Ich sag ja, ich habe mich son kreuz und quer im Netz eingelesen und einiges probiert, aber keine Lösung.
jetzt setze ich noch auf einen Versuch mit LOS 17.1. Das kann bei Samsung kein VoLTE, da Samsung das techisch scheinbar anders umsetzt als andere Hersteller. Aber mal sehen, wie sich das verhält.
 
T

Tommy001

Erfahrenes Mitglied
Mit dem S7 und Vodafone hatte ich z.B. auch keine Volte, obwohl freigeschaltet, konnte mir auch keiner erklären. Mit dem S9 und Vodafone auch nicht dann zu D1 gewechselt und siehe da es funktioniert. Das zu dem Thema Technik...
 
maik005

maik005

Urgestein
Copiegeil schrieb:
jetzt setze ich noch auf einen Versuch mit LOS 17.1. Das kann bei Samsung kein VoLTE,
Den Sinn dahinter gibt es nicht, oder?
Beitrag automatisch zusammengefügt:

@Tommy001
Kommt ggf. auch auf die aktive CSC und das Alter der SIM Karte an
Beitrag automatisch zusammengefügt:

Copiegeil schrieb:
Mein S7 macht das anstandslos
Mit der selben SIM Karte?
 
Zuletzt bearbeitet:
C

Copiegeil

Neues Mitglied
@maik005
ja, mit der gleichen SIM.
Mit der Sinnhaftigkeit ist das so eine Sache. Da ich die Technik dahin nicht durchschaue, kann ich ja nur über testen herausfinden, ob es eine Möglichkeit gibt, das irgendwie hinzu bekommen.
@Tommy001
Ich habe, wie oben schon erwähnt, daß dies wohl auch Provider abhängig ist. Mit o2 scheint es die größten Probleme zu geben.
 
maik005

maik005

Urgestein
Copiegeil schrieb:
Mit der Sinnhaftigkeit ist das so eine Sache.
Damit meinte ich, weil du ja im Original ROM VoLTE nicht abschalten wolltest.

LOS bringt dir einiges mehr an Fehlern. Das würde ich meiden (bei Samsung zumindest)
 
C

Copiegeil

Neues Mitglied
@maik005
ja, ich weiß, schlechtere Kamera, etc.
Mit der fehlenden Unterstützung von VoLTE wollte ich mal testen, wie sich das Smartphone dann verhält.Ob das jetzt gleich ist, ob VoLTE im Stock ROM abgeschaltet ist oder gar nicht erst implementiert. Dann wäre der nächste Versuch, ob ich über LOS 17.1 einen Downgrade auf LOS 16 schaffe und von da aus auf ein Android 9 Stock ROM komme. Scheinbar ist da Samsung mittlerweile schwer zu überreden, ein anderes ROM anzunehmen, als andere Hersteller. Ich muß mir jetzt erst eine andere SIM besorgen, den das flashen funktioniert ohne eingelegte SIM nicht und jedesmal aus meinen S7 entnehmen ist auch keine Lösung. jetzt brauche ich erst eine Zeit-SIM von meinem Provider....
 
Zuletzt bearbeitet:
maik005

maik005

Urgestein
Copiegeil schrieb:
einen Downgrade auf LOS 16 schaffe
vermutlich.
aber....
Copiegeil schrieb:
von da aus auf ein Android 9 Stock ROM komme.
defintitiv nicht. geht wegen niedrigerer Binary Version unmöglich.
Copiegeil schrieb:
den das flashen funktioniert ohne eingelegte SIM nicht
seit wann das denn?

Copiegeil schrieb:
Ob das jetzt gleich ist, ob VoLTE im Stock ROM abgeschaltet ist oder gar nicht erst implementiert.
ja ist identisch.
Dein Modem, was das ganze grundlegend steuert bleibt das selbe.
 
C

Copiegeil

Neues Mitglied
@maik005
Das mit der SIM ist eigenartig. Aber wenn keine drin ist, läuft der Flashvorgang (mit Odin TWRP einflashen) nicht vernünftig. ich hab schon zig Versuche hinter mir, und dachte, ich mache was falsch, bis ich drauf kam, wen die SIM drin ist, gehts, seltsam, kenne ich so auch nicht.
Aber ich sehe schon, Du bist hier wirklich kundig, dann kann ich mir den ganzen Aufwand eigentlich schenken und den Ziegelstein in die Entsorgung geben. Ich habe jetzt auch keine Lust, deswegen einen anderen Provider zu testen, Vertrag machen etc. . Dann bleib ich beim S7 und nehme die Erkenntnis mit, nie wieder Samsung.
 
maik005

maik005

Urgestein
@Copiegeil
meinst du denn, dass es die Probleme bei anderen Herstellern nicht gibt?
Kann ich mir ehrlich gesagt nicht vorstellen.