Active Rooten?

  • 297 Antworten
  • Neuster Beitrag
D

David.P

Fortgeschrittenes Mitglied
Also ich hab jetzt wieder die .42er Build von Android 2.3.4 drauf, und Root.

Es kommt jetzt immer die Meldung "die Superuser-Binärdatei muss aktualisiert werden". Hab mich schon mal kundig gemacht, dass man manuell die Datei

http://download.clockworkmod.com/superuser/superuser.zip

...runterladen und per Recovery Boot auf dem Telefon installieren soll.

Nun gelingt es mir aber nicht, in den Recovery Modus zu booten :confused2:

Gibt es da einen Trick für das Active?
 
statler

statler

Lexikon
Aktualisier superuser einfach über den play store.

Gesendet von meinem GT-P3110 mit der Android-Hilfe.de App
 
D

David.P

Fortgeschrittenes Mitglied
Danke.



"Aktualisieren" bietet mir der PlayStore für den Superuser nicht an...

Dachte daher, ich deinstalliere den Superuser und installiere ihn neu. Allerdings hängt er jetzt seit 5 Minuten im Zustand "Wird deinstalliert..."

Ist das normal?

Und nimmt man dann den Superuser von Clockworkmod, oder einen anderen...?
 
G

girouno

Gast
nimm einen Reboot-Manager um ins Recovery zu booten. Wenn das CWM über x-parts installiert wurde, dann kannst Du in x-parts auch "reboot to recovery" auswählen und gut ist's.
 
D

David.P

Fortgeschrittenes Mitglied
Danke. Einen Reboot-Manager hab ich schon versucht, der rebootete aber immer nur normal und nicht ins Recovery.

x-parts hab ich nicht verwendet, sondern beim ersten mal Eroot_V1.3.4.exe bzw. dann Flashtool.

Was nun, wie komm ich ins Recovery...?
 
G

girouno

Gast
Wenn ich Dich richtig verstehe hast Du aber wieder eine Stock-ROM drauf? Hattest Du überhaupt wieder ein CWM/Recovery installiert? Nur vom Rooten kommt sowas nicht aufs Phone und von Werk aus (also mit Sony-ROM) ist kein Recovery installiert. Und wenn nichts da ist, kann man auch nicht hineinkommen.

Ich hab das immer über x-parts erledigt (auf dem St15i, was aber technisch ziemlich ähnlich ist, nur halt nicht wasserdicht). Stock, rooten, x-parts, über x-parts dann CWM nachinstallieren und dann über x-parts ins Recovery booten. x-parts erfordert jedoch root-Rechte, so dass irgendeine funktionierende SU apk schon noch vorhanden sein muss.
 
D

David.P

Fortgeschrittenes Mitglied
Ojeh... mal sehen ob ich das verstehe.

Also ja, ich hab wieder das Stock Rom drauf (.42er Build von Android 2.3.4) und Root via Flashtool, incl. SU von CWM.

Also mach ich jetzt x-parts drauf, dann CWM (ClockWorkMod-Recovery, richtig?), dann ins Recovery booten, dann dort mein SU update via Zip-Datei installieren, richtig?

Oder sollte ich einen anderen Superuser als den von CWM über den PlayStore installieren, gibt dort ja mehrere?
 
D

David.P

Fortgeschrittenes Mitglied
OK danke werde ich probieren

Der ursprüngliche Beitrag von 10:36 Uhr wurde um 10:40 Uhr ergänzt:

OK SuperSU hab ich jetz drauf!

Soll ich jetzt erst das OTA Update machen (Root und SU bleiben erhalten), und dann x-parts und CWM draufmachen und Blähware mit RootAppDelete löschen, oder eine andere Reihenfolge?
 
G

girouno

Gast
ja, in der Reihenfolge würde ich's machen.
 
D

David.P

Fortgeschrittenes Mitglied
Ach ist das herrlich, ein Phone ohne Müll-Apps :)

Und Android 2.3.4 rennt wie verrückt! Oder bilde ich mir das bloß ein, im Vergleich mit Android 4 (bezogen auf das kleine Active)?
 
G

girouno

Gast
Schätze mal, dass die Active-Nutzer ihre Geräte längst gerootet haben oder es nie tun werden. Gab ja schließlich auch vor TowelRoot genug Möglichkeiten dazu.
 
statler

statler

Lexikon
wird wahrscheinlich nicht funktionieren.
Towelroot geht wahrscheinlich nur mit dem momentanen Linux Kernel der
im Android Firmware (4.3/4.4) verankert ist.
 
Zuletzt bearbeitet:
O

Oldie56

Erfahrenes Mitglied
Das jedenfalls behauptet der Autor

root for at&t and verizon s5
but in seriousness
should support all phones < jun 3 2014
In der Diskussion zum Heise-Forum berichten allerdings viele, dass es bei ihrem Model nicht geht. Habe jetzt aber nicht nachgesehen, ob das Active dabei ist (weil meins schon lange anders gerootet ist).
 
R

RobertMitchum

Ambitioniertes Mitglied
Meins noch nicht, wollte "mal eben" Root mitnehmen und die Bloatware rauswerfen, so üppig ist der Speicher schließich nicht. Das Active geht nicht mit diesem Exploit. Übrigens genau wie mein Samsung Tab3 8.0.
 
G

girouno

Gast
Mit Eroot geht's aber.
 
R

RobertMitchum

Ambitioniertes Mitglied
Nicht bei mir. Habs gerade noch mal versucht - Treiber sind da, USB Debugging an, Mass Modus in den Experia Settings, ERoot 1.3.4. Hab das aktuelle 4.0.4 von Sony laufen (neueste version).

Mal sehen, ob ein Rückflashen auf die .42 plus Doomlord geht. Richtig Bock drauf hab ich noch nicht wirklich, der Leidensdruck ist nicht wirklich groß.
 
Zuletzt bearbeitet:
G

girouno

Gast
kann ich nicht nachvollziehen. Ich habe mehrere Xperia Minis (als Actives ohne die wasserfeste Verpackung) mit eroot gerootet - 4.0.4 in den Firmwareversionen .431 und .587; vollkommen problemlos. Angeschlossen im MTP-Modus.

Das Gerät muss von ERoot erkannt werden (Modellbezeichnung wird angezeigt), sonst sind nicht die für das Rooten erforderlichen Treiber installiert. Ggf. würde ich halt das Flashtool runterladen um zu prüfen, ob die Kommunikation zwischen PC und Smartphone wirklich funktioniert.

Andererseits hätte ich (im Hinblick auf einen potentiellen Brick) überhaupt keine Bedenken, Towelroot auszuprobieren: entweder das Tool schafft es, Schreibzugriffe auf die System-Partition zu kriegen und rootet damit oder kriegt eben keinen Zugriff aufs System und ist dann wirkungslos.
 
R

RobertMitchum

Ambitioniertes Mitglied
Ich kann deinen Erfolg auch nicht nachvollziehen. .587 Firmware (404) ... Laut https://www.android-hilfe.de/forum/anleitungen-fuer-sony-geraete.1659/how-to-root-rechte-fuer-alle-bekannten-sony-android-handys-mit-fast-allen-firmwares.415804.html alles sauber eingestellt, ERoot 1.3.4, 1.2 mag ebenfalls nicht. Sowohl im MPT als auch MSC Modus scheitert es. ST17i wird erkannt, drei grüne Haken kommen sehr schnell, der unterste aber nicht und die nächste Seite hat drei rote Boxen. Das rooten selbst scheitert, hab zur Sicherheit einen Root-Checker installiert. Sowohl SUS als auch PC Compagnion installiert, keiner der beiden steht im Autostart bzw. ist aktiv. Das ERoot Verzeichnis in den APPDATA hab ich auch mal gekillt, keine Änderung.

Towelroot geht halt nicht, es passiert schlicht nichts.

Edit: SUS und Compagnion deinstalliert, USB Driver Cleanup gemacht, Aktuelle ADBTreiber als Standlone Package installiert,reboot und das ganze nochmal versucht: kein Unterschied. Tippe auf Treiberproblem, aber keine Ahnung was ich noch versuchen soll.

Edit2: Die Treiber funktionieren nun definitiv, in Anwendungsdaten/Eroot ist eine Log Datei.
Edit3: Keine Auffälligkeiten in der Logdatei, die Verbindung im ADB Modus ist definitiv da, das war vorher nicht der Fall.
 

Anhänge

  • run.log.txt
    39 KB Aufrufe: 517
Zuletzt bearbeitet:
Ähnliche Themen - Active Rooten? Antworten Datum
0
Oben Unten