Jetzt kostenlos registrieren: Mitglieder surfen ohne Werbung!

Recovery & Root für's XA2 (pioneer)

  • 68 Antworten
  • Neuester Beitrag
Diskutiere Recovery & Root für's XA2 (pioneer) im Root / Custom-ROMs / Modding für Sony Xperia XA2 / XA2 Ultra im Bereich Sony Xperia XA2 / XA2 Ultra Forum.
MysticEnforcer

MysticEnforcer

Experte
Um das XA2 (Pioneer) zu rooten braucht Ihr:
alle Treiber, falls was beim Installieren schief gehen sollte (z.B. ein Treiber nicht installiert wird) nehmt diese:
Xperia XZ2, Xperia XZ2 Premium and Xperia XZ2 Compact driver - Sony Developer World
Ich weiß die sind für's XZ2 aber mit dem XA2 funktionieren die auch,
hab's nicht anders gemacht.

Dieses .img & diese .zip:
Recovery Image zum Booten:
Download twrp-3.2.2-0-pioneer.img

Recovery zum Flashen:
Download twrp-installer-pioneer-3.2.2-0.zip

Magisk zum Rooten:
siehe Anhang

Fastboot:
siehe Anhang

Alle benötigten Dateien runterladen,
alle Treiber installieren,
Bootloader öffnen,
twrp.zip & magisk.zip in den Hauptordner auf deiner externe SD Karte kopieren,
fastboot.zip auf'm Desktop entpacken,
twrp-installer-pioneer-3.2.2-0.zip in den fastboot Ordner kopieren



Jetzt fängt der Spass an :D

Schalte dein XA2 jetzt aus,
verbinde es mit Vol+ gedrückt mit dem USB-Kabel & deinem Rechner,
die LED leuchtet jetzt blau.

Jetzt gehst auf eine freie Stelle im Ordner fastboot,
drückt die Umschalt-Taste + rechte Maustaste &
wählt dann Eingabeaufforderung hier öffnen aus
Sieht dann so aus:



Es geht jetzt ein Fenster der Windows Konsole auf,
dort gibst du das ein:
Code:
fastboot boot twrp-3.2.2-0-pioneer.img


bestätigt mit Enter.

Es dauert nur wenige Sekunden,
dann bekommst du das zu sehen:



Euer XA2 bootet jetzt ins Recovery,
jetzt tippt Ihr auf Installieren,
jetzt navigiert zu sdcard1,
wählt dann twrp-installer-pioneer-3.2.2-0.zip,
dann die 3 weißen Pfeile von links nach rechts wischen und die Installation bestätigen.
Wenn die Installation fertig ist tippt Ihr unten links auf den Pfeil für zurück,
Ihr landet jetzt wieder in sdcard1,
jetzt macht Ihr das selbe mit der Magisk-v16.7.zip,
ist die Installation jetzt fertig könnt Ihr auf System neustarten tippen,
Euer XA2 ist jetzt gerootet :thumbsup:
 

Anhänge

  • Magisk-v16.7.zip
    4,1 MB Aufrufe: 263
  • fastboot.zip
    553 KB Aufrufe: 242
Zuletzt bearbeitet:
O

oldie67

Neues Mitglied
Hallo und guten Tag,
ich benötige nach jahrelanger Nutzung eines gerooteten Samsung Smartphones und jetzigem Umstieg auf ein Sony XA2 Hilfe. Wie erwähnt bin ich nicht ganz unerfahren aber nicht der ausgewiesene Kommandozeilen König. Nach einigem suchen im Netz bin ich auf euch gestoßen und habe mit der Anleitung die von euch erstellt wurde, versucht mein Smartphone zu rooten. Warum? Weil es mir mit eurer Anleitung ganz easy erschien. Aber scheinbar liegt der Teufel im Detail. Mein Problem: Bis zum Aufruf der Kommandozeile wirklich easy. Nach Eingabe:

fastboot boot twrp-3.2.2-0-pioneer.img


bekomme ich nachfolgende
Fehleranzeige
PS C:\Users\schorsch2\Desktop\fastboot> fastboot boot twrp-3.2.2-0-pioneer.img
fastboot : Die Benennung "fastboot" wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei oder eines
ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern
enthalten), und wiederholen Sie den Vorgang.
In Zeile:1 Zeichen:1
+ fastboot boot twrp-3.2.2-0-pioneer.img
+ ~~~~~~~~
+ CategoryInfo : ObjectNotFound: (fastboot:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException
Suggestion [3,General]: Der Befehl fastboot wurde nicht gefunden. Er ist jedoch am aktuellen Ort vorhanden. Windows PowerShell lädt Befehle nicht standardmäßig vom aktuellen Ort. Wenn Sie diesem Befehl vertrauen, geben Sie stattdessen ".\fastboot" ein. Weitere Informationen erhalten Sie unter "get-help about_Command_Precedence".
PS C:\Users\schorsch2\Desktop\fastboot>


In den Entwickler Optionen ist OEM-Entsperrung und USB Debugging aktiviert.
(schlecht oder gut?) Die neuesten Google USB Treiber sind auch installiert.
"Was tun sprach Zeus, die Götter sind besoffen". Ich bin sicher ihr könnt mir helfen.
 
reraiseace

reraiseace

Ehrenmitglied
oldie67 schrieb:
Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist
Schau mal bitte, wo die fastboot.exe liegt und wechsel dann mit "cd PFADANGABE" in das Verzeichnis. Zur Sicherheit würde ich den Befehl nicht in PowerShell, sondern in der klassichen Eingabeaufforderung ausführen.
 
O

oldie67

Neues Mitglied
Hallo und guten Abend,
herzlichen Dank für ihre schnelle Reaktion. Natürlich habe ich ihre Tipp´s sofort ausprobiert::
Einstieg über cmd. Über cd Pfadangaben erneuert und den fastboot Befehl neu eingetippt. Ergebnis:

Fehler: waiting for devices

Microsoft Windows [Version 10.0.17134.345]
(c) 2018 Microsoft Corporation. Alle Rechte vorbehalten.

C:\WINDOWS\system32>cd
C:\WINDOWS\system32

C:\WINDOWS\system32>cd C:\Users\schorsch2\Desktop\fastboot

C:\Users\schorsch2\Desktop\fastboot>fastboot boot twrp-3.2.2-0-pioneer.img
< waiting for device >

Fehler 2
Microsoft Windows [Version 10.0.17134.345]
(c) 2018 Microsoft Corporation. Alle Rechte vorbehalten.

Dann habe ich den Ordner fastboot in das Verzeichnis C: kopiert, Verzeichnis neu eingestellt und den Befehl wieder eingetippt

C:\Users\schorsch2>cd C:\fastboot

C:\fastboot>fastboot boot twrp-3.2.2-0-pioneer.img
< waiting for device >

Ich habe in beiden Fällen ca. 15 min "gewaitet" leider ohne Erfolg
 
MysticEnforcer

MysticEnforcer

Experte
Alle Treiber installiert bzw. wird dein Gerät richtig im Geräte-Manager/Flashtool erkannt?
Du hast dein Gerät auch mit VOL+ gedrückt & mit dem PC verbunden?
LED leuchtet blau?

Geräte-Manager
Androi_Device.PNG

Flashtool Gerät An
flashtool.PNG

Flashtool Gerät im fastboot
flashtool2.PNG
 
O

oldie67

Neues Mitglied
Hallo und guten Abend,
ich darf mich nochmals herzlichst für ihre Hinweise bedanken. Die einzelnen Schritte der Anleitung habe ich befolgt. Die Blaue Lampe ist auch an.

Den Hinweis auf die Installation der Treiber habe ich überprüft und musste feststellen, dass diese nicht installiert bzw. fehlerhaft sind (gelb gemarkert), warum auch immer. Ich stehe derzeit etwas unter Zeitdruck und werde mich wahrscheinlich am Wochenende wieder damit beschäftigen.

Eine Sache habe ich quasi im vorbeigehen gesehen: Es hängt noch irgendwo ein Samsung ADB-Treiber herum.
Vielen Dank und eine gute Nacht.
 
MysticEnforcer

MysticEnforcer

Experte
Hi,
nimm die Treiber vom XZ2 (erster Post) funktionieren auch mit dem XA2.

Der Samsung Treiber sollte nicht stören
 
Zuletzt bearbeitet:
O

olivermak

Neues Mitglied
hallo
ich bekomme immer diser fehler
C:\Users\oa\Desktop\fastboot>fastboot boot twrp-3.2.2-0-pioneer.img
downloading 'boot.img'...
OKAY [ 1.239s]
booting...
FAILED (remote: Command not allowed)
finished. total time: 1.251s

C:\Users\oa\Desktop\fastboot>
 
MysticEnforcer

MysticEnforcer

Experte
Bootloader noch zu
 
O

oldie67

Neues Mitglied
Guten Abend,
nach dem Wochenende wollte ich mich nochmal melden. Ich bin derzeit dabei zu überlegen das Handy an die Wand zu klatschen. Irgendetwas ist da faul oder vielleicht bin ich mittlerweile zu alt um eine Handy zu rooten. Ich habe gefühlt ca 500 Seiten Internet hinter mir. Auf den Herstellerseiten Sony und Microsoft und auch auf dem "Hinterhof" mit obskuren "Tools". Ich habe den Eindruck, dass diverse Internetseiten mindestens so viel Ahnung haben wie ich, nämlich kaum. Aber nun mal kurz zum Thema. Ich habe alle Schritte ca. 20 mal durchgeführt, auch mit verschiedenen Treibern (Microsoft, Sony, Android also Google SDK). Kein Erfolg. Die Installation des ADB Interfaces wurde zwar durchgeführt, aber am Ende kam bei allen Versuchen das Gleiche heraus. "Treiber wird möglicherweise nicht funktionieren Fehlercode 10". Und über diesen Fehlercode 10 gibt es den meisten Schrott, auch bei Microsoft. Was dort vorgeschlagen wird endet in gleichen Sackgasse. Wenn Dir noch etwas einfallen sollte, bitte teile es mir bitte mit. Ich vergaß zu erwähnen, dass ich das ganze auch auf einem Laptop und an einem anderen PC probiert habe. Alles mit Win 10.
 
MysticEnforcer

MysticEnforcer

Experte
Mir fällt nichts ein, hab kein Win10.
Nen anderen Rechner mit Win7 haste nicht zufällig?
TuneUp Utilities haste nicht installiert?
 
O

oldie67

Neues Mitglied
Hallo und guten Morgen,
ich möchte mich nochmals für deine Hilfe bedanken. An WIN 7 habe ich auch schon gedacht. Im Moment habe ich nur noch XP auf einer HDD. WIN 7 müsste ich neu installieren. Vielen Dank für deine Bemühungen.
 
MysticEnforcer

MysticEnforcer

Experte
Mit WinXP sollten die Treiber auch funktionieren & die benötigten Tools sind ja auch in WinXP zu finden :D
 
O

oldie67

Neues Mitglied
Guten Morgen,
und vielen Dank für den Hinweis. Es wird ein wenig dauern bis ich dem Hinweis nachgehen kann. Jedenfalls werde ich mich wieder melden.
 
H

hkkp

Ambitioniertes Mitglied
schöne anleitung, aber wenn ich einen offenen bootloader habe, dann verliere ich meine drm-keys. wäre durchaus sinnvoll dies in die anleitung mit aufzunehmen bzw. wie ich sie vorher sichern kann, ohne offenen bootloader!
 
MysticEnforcer

MysticEnforcer

Experte
Da es hier nicht um den Bootloader unlock ging, habe ich es weggelassen,
ausserdem steht es auf der Seite von Sony.

Sichern kann man die Keys leider nicht.
Wenn man aber ein paar Euro investieren will,
kann man das Tool von Storm kaufen.
Das simuliert die notwendigen Dateien.
 
Zuletzt bearbeitet:
H

hkkp

Ambitioniertes Mitglied
okay, hab mir auch gerade xpiri gekauft... momentan habe ich nur das problem, dass ich keinen funktionierende treiber für das xa2 für win 10 finde... die oben funktinieren nicht bei mir...
 
MysticEnforcer

MysticEnforcer

Experte
Nimm die Treiber vom/für's XZ2 &
Treibersignaturprüfung deaktivieren
 
H

hkkp

Ambitioniertes Mitglied
was ist eigentlich, wenn ich keine externe sd habe?