XA2 lässt sich nicht Flashen

  • 85 Antworten
  • Neuster Beitrag
exciter

exciter

Ambitioniertes Mitglied
Threadstarter
Hallo liebe Gemeinde,

Ich habe mir ein XA2 geleistet und wollt das natürlich wie alle meine Xperias Z1, Z5 mit Lineage versorgen. Also erstmal XA2 angemacht und bissel geschaut und gespielt. Dann kam das Softwareupdate 9.0 denk ich mal, hab ich mir nicht so genau angekuckt. Ich bin dann in die Entwickler-Optionen und hab OEM Unlook zugelassen. Mittels *#*#73usw. ins Menü und nach dem Eintrag für den Bootloader geschaut, stand auf YES. War also erlaubt.
Handy ausgemacht, rann an den Lap und Bootloader entsperrt. Alles gut, keine Probleme.
nun wollt ich das TWRP drauf machen, und dann das!

C:\fastboot>fastboot devices
CQ300163NA fastboot

C:\fastboot>fastboot flash recovery twrp.img
target reported max download size of 536870912 bytes
sending 'recovery' (60380 KB)...
OKAY [ 2.013s]
writing 'recovery'...
FAILED (remote: No such partition.)
finished. total time: 2.026s

OK, dann habe ich folgendes versucht.

C:\fastboot>fastboot boot twrp.img
downloading 'boot.img'...
OKAY [ 1.333s]
booting...
OKAY [ 5.279s]
finished. total time: 6.626s

Darafhin wird das XA2 kurz hell und das wars. Kein boot ins Recovery.

Nun hab ich folgendes versucht.

fastboot getvar current-slot
this will return your <letter>

then do
fastboot flash boot_<letter> <filename>.img

Das Ganze habe ich 2 mal grmacht, einmal Slot_a und einmal Slot_b.

Das ende vom Lied, ich komme nicht ins Recovery um Lineage zu flashen.
Jetzt startet es garnicht mehr, ich komm noch in den Download und Flash-Mode, das wars.

Jetzt wollt ich mit dem Flashtool die orginal Firmware flashen, geht aber auch nicht, weil folgender Fehler kommt.

Hier das Log:
Code:
release : 50.2.A.0.379_R1B. Customization : Sony
03/007/2019 12:07:21 - INFO  - Preparing files for flashing
03/007/2019 12:07:21 - INFO  - Please connect your device into flashmode.
03/007/2019 12:07:59 - INFO  - Using Gordon gate drivers version 3.2.0.0
03/008/2019 12:08:00 - INFO  - USB buffer size set to 512K
03/008/2019 12:08:00 - INFO  - Opening device for R/W
03/008/2019 12:08:00 - INFO  - Device ready for R/W.
03/008/2019 12:08:00 - INFO  - Reading device information
03/008/2019 12:08:00 - INFO  - Reading phone properties
03/008/2019 12:08:00 - INFO  - Sending getvar:max-download-size
03/008/2019 12:08:00 - INFO  -    getvar status : OKAY
03/008/2019 12:08:00 - INFO  - Sending getvar:version
03/008/2019 12:08:00 - INFO  -    getvar status : OKAY
03/008/2019 12:08:00 - INFO  - Sending getvar:version-bootloader
03/008/2019 12:08:00 - INFO  -    getvar status : OKAY
03/008/2019 12:08:00 - INFO  - Sending getvar:version-baseband
03/008/2019 12:08:00 - INFO  -    getvar status : OKAY
03/008/2019 12:08:00 - INFO  - Sending getvar:product
03/008/2019 12:08:00 - INFO  -    getvar status : OKAY
03/008/2019 12:08:00 - INFO  - Sending getvar:serialno
03/008/2019 12:08:00 - INFO  -    getvar status : OKAY
03/008/2019 12:08:00 - INFO  - Sending getvar:secure
03/008/2019 12:08:00 - INFO  -    getvar status : OKAY
03/008/2019 12:08:00 - INFO  - Sending getvar:Sector-size
03/008/2019 12:08:00 - INFO  -    getvar status : OKAY
03/008/2019 12:08:00 - INFO  - Sending getvar:Version-sony
03/008/2019 12:08:00 - INFO  -    getvar status : OKAY
03/008/2019 12:08:00 - INFO  - Sending getvar:USB-version
03/008/2019 12:08:00 - INFO  -    getvar status : OKAY
03/008/2019 12:08:00 - INFO  - Sending getvar:max-download-size
03/008/2019 12:08:00 - INFO  -    getvar status : OKAY
03/008/2019 12:08:00 - INFO  - Sending getvar:Loader-version
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:phone-id
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:Device-id
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:Rooting-status
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:Sector-size
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:Ufs-info
03/008/2019 12:08:01 - INFO  -    getvar status : FAIL
03/008/2019 12:08:01 - WARN  -    Ufs-info not supported
03/008/2019 12:08:01 - INFO  - Sending getvar:Emmc-info
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:Default-security
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:platform-id
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:Keystore-counter
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:Security-state
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:S1-root
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:Sake-root
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:Battery
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:Frp-partition
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:Stored-security-state
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending getvar:Keystore-xcs
03/008/2019 12:08:01 - INFO  -    getvar status : OKAY
03/008/2019 12:08:01 - INFO  - Sending Get-root-key-hash
03/008/2019 12:08:01 - INFO  -    Get-root-key-hash status : OKAY
03/008/2019 12:08:01 - INFO  - Sending Read-TA:2:2202
03/008/2019 12:08:01 - INFO  -    Read-TA status : OKAY
03/008/2019 12:08:01 - INFO  - Sending Read-TA:2:2205
03/008/2019 12:08:01 - INFO  -    Read-TA status : OKAY
03/008/2019 12:08:01 - INFO  - Sending Read-TA:2:2210
03/008/2019 12:08:01 - INFO  -    Read-TA status : OKAY
03/008/2019 12:08:01 - INFO  - Sending Read-TA:2:4900
03/008/2019 12:08:01 - INFO  -    Read-TA status : OKAY
03/008/2019 12:08:01 - INFO  - Sending Read-TA:2:10021
03/008/2019 12:08:01 - INFO  -    Read-TA status : FAIL
03/008/2019 12:08:01 - WARN  -    Unable to read TA unit 10021, error=-22 ( Hex unit value 00002725 )
03/008/2019 12:08:01 - INFO  - Connected device : H3113 / SW release 1311-2845_50.2.A.0.352 / Customization 1312-2606_R1B
03/008/2019 12:08:01 - INFO  - Last flash date : null
03/008/2019 12:08:01 - INFO  - Phone ready for flashmode operations.
03/008/2019 12:08:01 - INFO  - Start Flashing
03/008/2019 12:08:01 - INFO  - No boot delivery into the bundle
03/008/2019 12:08:14 - ERROR - No flash script found. Flash script is mandatory
03/008/2019 12:08:14 - INFO  - Sending Sync
03/008/2019 12:08:14 - INFO  -    Sync status : OKAY
03/008/2019 12:08:14 - INFO  - Sending powerdown
03/008/2019 12:08:14 - INFO  -    powerdown status : OKAY
03/008/2019 12:08:18 - INFO  - Device disconnected
03/008/2019 12:08:19 - INFO  - Device connected in flash mode

Hab ich jetzt einen formschönen Briefbeschwerer oder was mach ich da falsch.
Bitte um Hilfestellung.

Tausend Dank
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von reraiseace - Grund: Log in Code- und Spoiler-Tag gepackt, um Lesbarkeit zu verbessern /VG reraiseace
skycamefalling

skycamefalling

Erfahrenes Mitglied
Ich würde jetzt mal mit dem Xperia PC Companion eine Softwarereparatur durchführen. Dabei wird das originale ROM wieder vollständig geflasht und du bist wieder am Ausgangszustand.

Zum Problem mit Lineage OS kann ich dir leider nicht helfen, tut mir Leid.
 
exciter

exciter

Ambitioniertes Mitglied
Threadstarter
ok, versuche ich mal.... melde mich dannn nochmal was raus kam.

Vielen Dank erstmal.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Hm, Das hat nicht geklappt. Die Software sagt, es kann die original Software nicht herstellen, weil der Bootloader entsperrt ist. Da ist ein Link, den folge ich mal, und belese mich.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Supie, alles englisch... Da komme ich nicht weiter. Was kann ich noch tun, das FlashTool braucht ein script? Aber woher nehmen?
 
exciter

exciter

Ambitioniertes Mitglied
Threadstarter
Hm, das lief zwar sauber durch..... aber booten tut das XA2 immer noch nicht. Wie bekomme ich den den Bootloader wieder gesperrt, dass ich mit Sony nochmal versuchen kann die Software zu reparieren?
 
exciter

exciter

Ambitioniertes Mitglied
Threadstarter
Update....
IST
Ich habe mir mal das Emma Geladen und es damit versucht. Auch hier läuft alles sauber durch. Das Handy wird am USB erkannt in Flash-Mode und er schreibt auch die Daten drauf. wenn ich das XA2 dann einschalte kommen in er Mitte (von oben nach unten) einpaar graue Streifen, dann wird es dunkel. die Hintergrundbeleuchtung ist noch an. es dauert ein paar Sekunden dann beginnt das Display grün, dann blau dann weis aufzuleuchten. wird schwarz und wieder die drei Farben....

was nun liebe Gemeinde? ich weiß nicht weiter----
 
reraiseace

reraiseace

Senior-Moderator
Teammitglied
exciter

exciter

Ambitioniertes Mitglied
Threadstarter
Hallo reraiseace,

vielen dank für die Antwort. Ich habe das H3113 (Single-SIM). Über diesen Beitrag bin ich gestern auch gestolpert, hab ich aber bei Seite gelegt, weil ich mir dachte ich will ja erstmal wieder das es mit original FW geht. Ich mach mich aber gleich mal dran und berichte dann.
 
exciter

exciter

Ambitioniertes Mitglied
Threadstarter
Sodale, ich bin schon fast am Verzweifeln. Ich habe jetz nochmal mit flashtool eine 50.1 Firmware installiert, geht auch wieder alles durch....dennoch startet das XA2 nicht. Emma sagt auch alles ok beim flashen.
newflasher sagt, alles ok beim flashen...... nur starten will es nicht.

Kann es sein, das der botloader nicht geht oder so?
was kann ich den noch machen um dem XA2 wieder leben einzuhauchen?

Ich habe gerade mal versucht, den Bootloader wieder zu sperren.....Flashtool sagt folgende:

04/047/2019 22:47:21 - INFO - Connected device : H3113 / SW release 1311-2845_50.1.A.5.59 / Customization 1314-0000_R1A
04/047/2019 22:47:21 - INFO - Last flash date : 2019-06-04 02:00:08
04/047/2019 22:47:21 - INFO - Phone ready for flashmode operations.
04/047/2019 22:47:21 - INFO - Sending Read-TA:2:2226
04/047/2019 22:47:21 - INFO - Read-TA status : FAIL
04/047/2019 22:47:21 - WARN - Unable to read TA unit 2226, error=-22 ( Hex unit value 000008B2 )
04/047/2019 22:47:24 - INFO - Sending Sync
04/047/2019 22:47:24 - INFO - Sync status : OKAY
04/047/2019 22:47:24 - INFO - Sending powerdown
04/047/2019 22:47:24 - INFO - powerdown status : OKAY
04/047/2019 22:47:24 - WARN - Your device cannot be relocked
04/047/2019 22:47:26 - INFO - Device connected in flash mode
 
Zuletzt bearbeitet:
S

Solo2502

Neues Mitglied
Hallo exciter,

lustigerweise schlage ich mich z. Zt. mit genau demselben Problem rum.
Ich habe fast genau dieselben Versuche wie du unternommen und komme auch zu keine befriedigenden Ergebnis.
Hast du schon mal Xperifix probiert?

Gruß,
Manu
 
H

hkkp

Ambitioniertes Mitglied
die zip-Datei Partition gibt es nicht bei 50.2. Jemand eine Idee?
 
S

Solo2502

Neues Mitglied
Es gibt aber eine entpackte Datei partition-image_X-flash-all-18ae.sin (zumindest in meiner 50.2.A.0.379_R1B).
Die hab ich den partition-Ordner kopiert und probier's gleich damit.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Hat nicht funktioniert... :1f641:
 
D

Danny_Wilde

Experte
Geh mal in den Ordner C:\benutzer\xxxxxxx\.flashtool\devices

Dann kopierst du den Ordner H41xx in den Ordner "my devices" und benennst das flashscript von 50.1 auf 50.2 um.

Versuche dann nochmal mit dem flashtool die Stock-Firmware zu flashen.
 
exciter

exciter

Ambitioniertes Mitglied
Threadstarter
xperiafix sagt mir nichts, ich google mal und versuche heute Abend.

@Danny_Wilde
Welchen Ordner meinst du, den mit der geladenen Firmware. Ich denke die 50.2 Firmware geht nicht mit Flashtool.
Hast du nicht eine Anleitung... ich hab schon so viele gelesen, das ich bunte Knete im Kopf habe. ;)
Ist ja auch nicht so, das ich das erste Xperia flashe.... das Teil will ums verrecken nicht booten.
Das bootet ja nicht mal mit fastboot boot recoverXYZ.img. Aber warum. Übertragung aufs Handy hegt, fastboot sagt es bootet....
nur Helle wirs es nicht mit TWRP.
 
D

Danny_Wilde

Experte
Ich hab doch genau geschrieben, welche Ordner.
Im Ordner .flashtool findest du die Ordner "devices" und "my devices"
Ob das ganze funktioniert weiß ich nicht.
Bei 2 meiner Geräte hat es funktioniert.

Erklär mal genauer was daran unklar ist.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Alternativ kannst du dir hier die Customized CE Android 8 runtergeladen und flashen.
Vielleicht kommst du damit weiter.

StackPath
 
exciter

exciter

Ambitioniertes Mitglied
Threadstarter
Ich habe doch aber kein DUAL... sondern das XA2 h3113
hast du da auch was dafür..?
 
D

Danny_Wilde

Experte
Oh sorry. Dachte du hättest H4113.
 
D

Danny_Wilde

Experte
Hier H3113 :

StackPath


Hab mal den Flash mit dem umbenannten flashscript simuliert, das ging ohne Probleme.

In deinem Fall heißt der Ordner dann H31xx.
 
Zuletzt bearbeitet:
exciter

exciter

Ambitioniertes Mitglied
Threadstarter
Vielen Dank....
Das werde ich heute Abend mal flashen. Mir stellt sich ja die Frage, warum zum Geier sich das TWRP nicht Flashen lässt.

Nachdem ich den bootloader aufgemacht habe, und "fastboot boot twrp.img" getippt habe, hat das Teil gebootet und es war kurz ein Schloss zu sehen. Es ging aber zu schnell weg, dass ich hätte reagieren können. Ins Recovery hat es da aber schon nicht gebootet, obwohl laut cmd alles OK war.

Warum ging das nicht, wieso kann ich mit fastboot nicht ins recovery booten????

....macht mich nachdenklich...,
 
D

Danny_Wilde

Experte
Dazu kann ich nichts sagen, da ich es nicht selbst gesehen hab.


Mal ne andere Frage: Welches Recovery hast du denn geflasht und woher hast du es?
 
Zuletzt bearbeitet:
Oben Unten