Wiko Rainbow - Keine SU-Binary installiert???

  • 13 Antworten
  • Neuster Beitrag
Status
Für weitere Antworten geschlossen.
F

fizher

Gast
Ich habe mein Handy (WIKO RAINBOW) mit Framaroot gerootet. Hat auch gleich alles geklappt, nur jetzt einige Zeit später zeigt mir SuperSU folgende Meldung an:
"Es ist kein SU-Binary installiert und SuperSu kann sie nicht installieren. Das ist ein Problem!"

Habs wieder ungerootet und deinstalliert und wieder alles neu drauf gespielt, kommt aber immer die selbe Meldung.

kann mir da jemand Helfen.
 
Zuletzt bearbeitet von einem Moderator:
G

ginvalid

Neues Mitglied
Bei mir gleiches Problem, nachdem ich das (WIKO-)Update vom 14.04.2014 installiert habe.
Nach mehrmaligen Versuchen hat es dann mit der "alten" Framaroot Version geklappt (1.9.1, statt 1.9.2).
Dann SuperSu aus dem Playstore installiert und hab root-Rechte wieder.
 
F

fizher

Gast
Ich hab immer noch das Problem.
Auch der Tipp von Ginvalid hat nicht funktioniert.

Kommt immer die selbe Meldung: "Es ist kein SU-Binary installiert und SuperSu kann sie nicht installieren. Das ist ein Problem!"

Hat noch jemand eine andere Möglichkeit.
Danke im Voraus!
 
Keks66

Keks66

Ehrenmitglied
Hm, hier ist es seinerzeit anstandslos mit framaroot gelaufen... Das installiert ja SuperSu gleich mit, man muß da nicht extra in den Store (das verwirrt mich etwas bei Ginvalid)
wie auch immer, vielleicht mal mit Towelroot versuchen? Wenn das Erfolg meldet, muß man allerdings aus dem Playstore noch SuperSu nachinstallieren.
 
F

fizher

Gast
Also mit Towelroot funktioniert es auch nicht, trotzdem Danke.

Also wenn ich Frameroot deinstalliere bleibt trotzdem das SuperSu erhalten.
Ich kann SuperSu nicht deinstallieren.
 
Verpeilter Neuling

Verpeilter Neuling

Super-Moderator & Mediator
Teammitglied
Towelroot funktioniert mit MediaTeks wohl grundsätzlich nicht.
 
Keks66

Keks66

Ehrenmitglied
Danke, Neuling, das hatte ich so noch nicht gelesen.
fizher schrieb:
Also wenn ich Frameroot deinstalliere bleibt trotzdem das SuperSu erhalten.
Das ist klar. Wie hast du seinerzeit überhaupt das unroot durchgeführt? Normalerweise geht es am einfachsten und sichersten aus der App Supersu heraus - über die Einstellungen in der App "vollständiges unroot" auswählen. Es deinstalliert sich dann selbst.

Btw, es schien ja anfangs mit root zu laufen, wenn ich recht verstehe. Was hast du dann in der Zwischenzeit mit den Rootrechten "angestellt"? Irgendwelche Systemapps gelöscht etc.?
 
F

fizher

Gast
Also noch mal zum Ablauf:
- Ich hatte ganz am Anfang über Frameroot das Handy gerootet wie es auch hier im Forum beschrieben wird.
- Hat alles bestens funktioniert, bis es ein Systemupdate von Wiko gab.
- Danach hatte ich keine Rootrechte mehr, und ich bekam immer diese Meldung (Es ist kein SU-Binary installiert und SuperSu kann sie nicht installieren. Das ist ein Problem!) als ich auf SuperSu kickte.
- Danach hab ich verschiedene Möglichkeiten durchgespielt:
- unrooten über Frameroot und neu-rooten, deinstallieren und wieder neu installieren von Frameroot, andere Versionen von Frameroot. Ich bekam immer die obrige Meldung wenn ich auch SUPERSU klickte.
- Zudem komm ich nicht ins Menu bei SuperSu um dieses zu deinstallieren.


Ist ein zurücksetzten auf Werkseinstellung der letzte Ausweg oder gibt es noch ein alternativen Tipp?
 
Zuletzt bearbeitet von einem Moderator:
Keks66

Keks66

Ehrenmitglied
Ich bin mir nicht mal sicher, daß ein Werksreset helfen würde. Liegt die superuser.apk noch in /system/app - ich glaube, dort kannst du gucken mit einem Dateimanager?
Wenn ja, bleibt die auch beim Reset dort liegen. Und dann wäre ich nicht überrascht, wenn dasselbe Spiel passiert :rolleyes2:
 
Verpeilter Neuling

Verpeilter Neuling

Super-Moderator & Mediator
Teammitglied
Einen Werksreset mag die Datei dort überleben - das Neuflashen mit der Wiko-Software aber definitiv nicht. Mehr dazu hier: Wiko Rainbow - Stock-ROM flashen

Eine deutsche Seite ist mittlerweile auch im Aufbau - da fehlt es aber noch an eigentlich allem - ist für's Rainbow eingestellt. Modellsuche funktioniert aber z.B. nicht. Wählt man ein Modell, so meldet es, dass kein Update gefunden wurde. Die deutsche Seite erreicht man im Moment nur durch Anpassen des französischen Links: Update Wiko. (Ausnahme: Das Highway wegen des 4.4 Updates - da funktioniert schon alles.)
 
F

fizher

Gast
Also irgendwie hat es nun funktionier, hab jetzt auch wieder meine Rootrechte :laugh:

Wollt mich nochmal hier bei allen bedanken, die versucht haben mir zu helfen.
 
seeraeuber

seeraeuber

Ambitioniertes Mitglied
fizher schrieb:
Also irgendwie hat es nun funktionier, hab jetzt auch wieder meine Rootrechte :laugh:

Wollt mich nochmal hier bei allen bedanken, die versucht haben mir zu helfen.
Kannst Du das bitte genauer erklären - wie "irgendwie" - das reRoot funktioniert hat? Danke, würde mir helfen, mein Darkmoon hat plötzlich die SD-Card verweigert und alle apk´s waren auch weg ..... (Aufforderung die SD zu formatieren folgte zuvor)
 
stoeppy

stoeppy

Erfahrenes Mitglied
Habe zwar kein Wiko, aber hat schon mal jemand versucht CWM oder TWRP zu installieren und darüber die Superuser.apk zu installieren?
Falls es hier die "keine SU-Binary"-Fehlermeldung geben sollte dann die SuperSU-Update.zip von der XDA-Seite drüber flashen. So hat es zumindest bei Samsung Geräten funktioniert.
 
Verpeilter Neuling

Verpeilter Neuling

Super-Moderator & Mediator
Teammitglied
Da hier offensichtlich ein altes Thema hochgeholt wurde (vorher ca. 10 Monate kein Post mehr), verweise ich auf die beiden Themen zu Root auf dem Rainbow (abhängig von der Androidversion):

Root unter KitKat bzw. Wiko - Rainbow rooten (Android 4.2)

Bitte diese beiden Themen nutzen. Hier schließe ich dann mal ab.
 
Status
Für weitere Antworten geschlossen.
Oben Unten