erster Versuch mit Custom-ROM gescheitert. Wer kann mir helfen?

  • 20 Antworten
  • Neuester Beitrag
Diskutiere erster Versuch mit Custom-ROM gescheitert. Wer kann mir helfen? im Root / Custom-ROMs / Modding für Xiaomi Mi 11 Pro im Bereich Xiaomi Mi 11 Pro Forum.
T

thefasteddy

Neues Mitglied
Hallo,
ich habe mir ein neues Xiaomi 11 pro bei Trading Shenzhen gekauft. Das Aufsetzen des Custom-ROMs habe ich mir selbst zugetraut, bin jetzt allerdings kläglich gescheitert und weiß nicht mehr weiter.

Ich habe das Handy unlocked, den debugging-Modus aktiviert und über die ADB das TRWP installiert, in TRWP habe ich TRWP dann dauherhaft installiert. Anschließend habe ich einen wipe durchgeführt und das xiaomi.eu ROM in den download-Ordner des Handys übertragen. Dann habe ich mit der Installieren-Funktion das ROM ausgewählt und die Installation lief ganz normal bis zum Ende durch. Soweit lief alles gut.

Beim Neustart des handys wurde dann jedoch nicht das Custom-ROM gestartet, sondern TRWP. In TRWP wurde mir dann "OS not installed" angezeigt. Da auch der interne Speicher nicht mehr angezeigt wurde kam ich auf die gloreiche Idee die Custom-ROM-Datei auf einen USB-Stick zu packen und von dort nochmals zu installieren. In TRWP habe ich dazu die mount-Funktion benutzt und der USB-Stick wurde offenbar auch gemountet. Jetzt hatte ich allerdings das Problem, dass ich aus diesem Fenster nicht mehr zurück ins Hauptmenü von TRWP wechslen konnte (zurück-Pfeil wurde nicht angezeigt). Nach einem Neustart des Handys geht dieses jetzt immer in den fastboot-Modus, TRWP ist nicht mehr erreichbar. Das Handy lässt sich auch nicht mehr ausschalten (schaltet sich nach einiger Zeit dann selbst ab).

Bin für jede Hilfe dankbar!
 
Zuletzt bearbeitet:
Empfohlene Antwort(en)
T

thefasteddy

Neues Mitglied
Es lag wirklich an TWRP 3.6.0 !!! Mit der Version 3.5.1 hat jetzt endlich auch bei mir funktioniert. Nach "format data" war jetzt in Windows kein undefinierter Speicher zu sehen, sondern ein definierter in dem die Ordner "0" und "twrp" lagen. Ich habe die Custom-ROM-Datei dazukopiert und konnte sie dann auf dem Handy in data/media finden und installieren.

Nochmal danke an alle für die Hilfe!
 
Alle Antworten (20)
T

thefasteddy

Neues Mitglied
Hallo und danke schon mal für die Antwort.

Format data habe ich nicht gemacht. Nach der Anleitung sollte ich nur einen normalen wipe durchführen (Werkseinstellungen herstellen)

Mit dem XiaomiTool geht es leider auch nicht weiter. Es kommt der Fehler info_retrieve_failed (failed to get a fastboot image for this device: star_android)
 
Zuletzt bearbeitet:
A

Abramovic

Guru
Welche Anleitung hast du verwendet?
 
T

thefasteddy

Neues Mitglied
die Anleitung von chinahandys.net
 
T

thefasteddy

Neues Mitglied
das Flash Tool will zuerst Treiber installieren, wenn ich auf installieren klicke erhalte ich jedoch eine Fehlermeldung, dass ein Pfad nicht gefunden wird. Kann ich das ignorieren?

Und dann habe ich das Fastboot-ROM für mein Mi10pro nicht gefunden. Kann ich das vom Mi10ultra nehmen? Die haben ja die gleiche Basis.
 
rene3006

rene3006

Inventar
Was hast du nun für ein Modell?
Mi 10 Pro oder Mi 11 Pro?
 
Zuletzt bearbeitet:
T

thefasteddy

Neues Mitglied
Sorry, mein Fehler! Ich habe natürlich das Mi11pro.

Bezieht sich dein NEIN auf meine zweite Frage? Benötige ich eine spezielle TGZ-Version für das Mi11pro?
 
Zuletzt bearbeitet:
rene3006

rene3006

Inventar
@thefasteddy
Schau mal hier
Achte auf Region und Fastboot.
Und das du nicht unter der Jetzigen Version liegst
Beitrag automatisch zusammengefügt:

Xiaomi Firmware Updater
 
Zuletzt bearbeitet:
medion1113

medion1113

Lexikon
Du musst die Fastboot ( TGZ ) Rom auswählen.
Mi 11 Pro / Ultra – MIUI Download Xiaomi Official ROM
Die Rom's für das Mi 11 Pro und Ultra sind gleich.
Achtung :
Im Mi Flash Tool ist clean all and lock voreingestellt.
Diese Einstellung darfst du nur bei der China Rom verwenden !
Für alle anderen Rom's muss zwingend nur clean all eingestellt werden.
Andernfalls wird der Bootloader wieder geschlossen und es gibt einen Brick.
 
Zuletzt bearbeitet:
T

thefasteddy

Neues Mitglied
Ich werde das später probieren, muss mich jetzt erstmal um Weihnachten kümmern 🎅
 
T

thefasteddy

Neues Mitglied
ERFOLG!!!
Dank eurer Hilfe habe ich das originale China-ROM wieder drauf bekommen. Jetzt kann ich den zweiten Versuch mit dem Custom-ROM in Angriff nehmen...

Bei der Prozedur hatte ich zwei Probleme, die ich jedoch selbst lösen konnte:
- Das Xiaomi Flash Tool (Version vom 15.11.2018) hat auf meinem Rechner (aktuelles Win10, zu alt für Win11) bei der Installation der Treiber eine Fehlermeldung ausgespuckt und hat dann nicht funktioniert. Nach der manuellen Installation des Android-Bootloader-Treibers über Win-Update wurde zwar im Gerätemanager kein Fehler mehr angezeigt, das flash tool hat aber weiterhin mit Fehlermeldung nicht funktioniert. Auf der Seite der Xiaomi Community habe ich dann eine neuere Version des Flash Tools vom 14.03.2020 gefunden, die bei mir funktionierte (Treiber haben sich ohne Fehlermeldung installieren lassen).
- Beim Versuch das handy zu flashen erhielt ich im flash tool die Fehlermeldung "antirollback check error". Auf youtube habe ich ein indisches Video dazu gefunden. Ich habe zwar nichts verstanden, konnte mir anhand der Bilder aber zusammenreimen, dass es entweder an einem zu langen Dateipfad und/oder einem Leerzeichen im Dateipfad hängt. Also den Ordner mit dem entpackten Original-ROM ganz nach oben geholt und Leerzeichen entfernt. Dann lief das Flashen problemlos durch.

Nochmals vielen, vielen Dank für eure schnelle Hilfe hier und ich wünsche euch noch einen schönen 2. Weihnachtstag!
Beitrag automatisch zusammengefügt:

Ich benötige doch nochmal Hilfe, ich stell mich anscheinend irgendwie blöd dran...

Ich möchte das xiaomi.eu-ROM installieren. TWRP ist bereits fest installiert und nach der Anleitung soll ich dann ein "format data" machen. Nach einem reboot ins TWRP kann ich jedoch keine Datei vom Rechner auf das Handy übertragen weil die Ordnerstrukur nach dem "format data" nicht mehr vorhanden ist (das Mi11pro wird in Windows als "internal storage" ohne Größenangabe angezeigt). Was mache ich hier falsch?
 
Zuletzt bearbeitet:
medion1113

medion1113

Lexikon
Welche Xiaomi.eu Rom soll installiert werden ?
Beta oder Stable .
 
rene3006

rene3006

Inventar
@thefasteddy
Usb Stick
 
T

thefasteddy

Neues Mitglied
@medion1113
ich möchte die Stable installieren.

@rene3006
Genau an dieser Stelle bin ich ja bei meinem ersten Versuch gescheitert. Ich habe den USB-Stick im TWRP gemountet, bin dann aber nicht mehr aus dem mount-Menü zurück ins Hauptmenü gekommen. Dort gab es keinen Zurück-Button mehr. Ist das ein Fehler in der TWRP Version 3.6.0? Oder wie kommt man da zurück? Ich möchte einen erneuten brick vermeiden.

Aber wieso funktioniert bei mir die allgemeine Anleitung nicht? Da steht doch eindeutig, dass man nach "format data" einen reboot ins TWRP machen und dann die Custom-ROM-Datei mit Hilfe des Windows-Explorers aufs Handy übertragen soll, am besten in den Download-Ordner. MTP funktioniert auch, aber bei mir gibt es halt keine Ordner mehr, es wird nur noch ein undefinierter Speicher angezeigt.
 
Anz

Anz

Stammgast
thefasteddy schrieb:
Da steht doch eindeutig, dass man nach "format data" einen reboot ins TWRP machen und dann die Custom-ROM-Datei mit Hilfe des Windows-Explorers aufs Handy übertragen soll
Ist auch so und hat bei mir problemlos funktioniert.
Allerdings gab es da keinen Download Ordner mehr, also hab ich es ins Hauptverzeichnis kopiert und bin dann im TWRP dort hin navigiert und habe die Rom von dort installiert.
 
T

thefasteddy

Neues Mitglied
ich habe jetzt eine Test-Datei (Text-Format) übertragen, aber der Windows-Explorer zeigt mir die Datei auf dem Handy nicht an. Wenn ich dann versuche die selbe Datei noch einmal zu übertragen, meckert Windows, dass die Datei schon vorhanden wäre. Ich habe in TWRP an einigen Stellen nach dieser Datei gesucht, aber nicht gefunden. Weist du noch wo du in TWRP hinnavigiert hast?
 
Anz

Anz

Stammgast
Ich weiß nur noch das ich im TWRP das Ultra mit dem PC verbunden hatte und konnte dann auf dessen komplette Ordnerstuktur zugreifen. Dort hab ich dann einfach in das Hauptverzeichnis kopiert und so auch gleich wieder gefunden.
Das sollte sich ja vom Pro in der Hinsicht nicht unterscheiden.
 
Zuletzt bearbeitet:
T

thefasteddy

Neues Mitglied
das ist halt genau mein Problem: nach dem "format data" ist bei mir die normale Ordnerstruktur verschwunden. Ich habe jetzt aus Versehen ins originale ROM gebootet. Dabei wird die gesamte Ordnerstruktur wieder hergestellt. Also habe ich es noch einmal versucht und nach dem Booten des originalen ROM's die Custom-ROM-Datei in den download-Ordner und in TWRP installiert. Danach wird immer TWRP gebootet weil gar kein OS mehr vorhanden ist, also wieder genau mein Problem wie beim ersten Versuch. Wieder keine Ordnerstruktur mehr vorhanden UND kein originales ROM mehr auf dem Handy.

Ich vermute, dass da irgend eine Einstellung falsch gesetzt ist. Aber welche?
Beitrag automatisch zusammengefügt:

Mit welcher Version von TWRP hast du die Installation durchgeführt? Vielleicht liegt es an der 3.6.0. Ich werde jetzt wohl alles wieder mit dem Flash-tool auf das originale ROM zurücksetzen und dann mal die 3.5.1 versuchen.
 
Zuletzt bearbeitet:
Ähnliche Themen - erster Versuch mit Custom-ROM gescheitert. Wer kann mir helfen? Antworten Datum
29