Firmware Update, Brick?

  • 12 Antworten
  • Neuester Beitrag
Diskutiere Firmware Update, Brick? im Root / Custom-ROMs / Modding für Xiaomi Redmi Note 5 im Bereich Xiaomi Redmi Note 5 Forum.
I

InsaneLiquid

Ambitioniertes Mitglied
Hallo zusammen,

ich hatte aktuell immer Pixel Experience laufen. Allerdings konnte ich die neusten Updates nicht installieren, weil die Firmware V10.3.1.0.PEIMIXM gefehlt habe. Hab mich also gestern Abend hingesetzt und etwas bei XDA gesucht und dann auch gefunden:
Xiaomi Firmware Updater
Hier auch die aktuelle Stable runtergeladen, dann mit TWRP geflashed. Danach wollte er mir ein Password haben um die Systempartition zu entschlüsseln. Hatte ich allerdings nicht. Daraufhin den Storage gewiped und einmal booten lassen. Wollte per USB das TWRP Backup einspielen, allerdings erkennt er mir das Smartphone nicht mehr. Lautpsrecher und Helligkeitssensor gehen auch nicht mehr. Übers Netzwerk das Backup wieder aufs Smartphone gespielt und anschließend im TWRP eingespielt. Daraufhin meldete er, dass er Probleme mit der Systempartition hatte und diese gecleaned werden muss. Hab allerdings erstmal Reboot gemacht und wollte schauen obs zumindest startet. Bootloop. Dann bin ich ins Recovery gewechselt, allerdings komme ich nur zum TWRP Loading Screen und dann crashed er und bootet wieder. Genauso Bootloop wie beim ROM. Fastboot komme ich rein ohne Bootloop, aber nachdem mir kein Notebook mehr das Smartphone mehr erkennt, bringt mir das nichts.
Jetzt bin ich aktuell am Verzweifeln. Mir fällt gerade nichts ein, was ich machen kann und wo mein Fehler lag :/

Ich bräuchte bitte dringend Hilfe!!

Danke!!
 
B

brianmolko1981

Dauergast
Welche Firmware (die im Backup) war denn vor der V10.3.1.0.PEIMIXM drauf?
 
I

InsaneLiquid

Ambitioniertes Mitglied
Kann ich ehrlich gesagt nicht sagen. Hab nur geschaut, was er braucht, aber nicht was davor drauf war. Ich weiß allerdings nicht wie ich das nachschauen kann. Dachte immer Firmware ist bei Modem, Radio etc.. immer mit dabei und braucht nicht extra...
 
G

geff5

Neues Mitglied
Hast Du TWRP nach dem fw-flash neu geflasht? Das müsste vollzogen werden - zumindest geht das aus den Anleitungen hervor, die ich mir für den Zweck zusammengesucht habe. Auf die TWRP-Version muß auch geachtet werden, da Pie-Support notwendig ist.
Die Vorgehensweise beim FW-Wechsel von Oreo auf Pie-Firmware scheint zu sein:
- boot ins recovery
- pie-fw flashen
(- evtl. reboot ins recovery)
- pie-taugliches recovery flashen
(- evtl reboot ins recovery)
- pie custom rom flashen
(- erneut ins recovery booten, falls man von stock rom kommt, um zu formattieren / wipen
- boot ins System
Der Pixel Experience thread bei XDA ist voll mit Problemen und möglichen Lösungen. Oben erwähnte hilfreiche posts, die ich mir notiert habe:

[zitat]
Copy two version of TWRP (see bellow), new FW and the new ROM to the PixelExperience-Updates folder in your phone.

1. Boot to the Recovery [VolumeUP]+[Power]
2. Install image TWRP 3.3.1-0 to the Recovery partition (Safer way, if you have old TWRP or FW 8.1. This TWRP works with FW 9.0 without support of USB-OTG.)
3. Reboot to the TWRP
4. Install ZIP - new firmware 9.0 - fw_whyred_miui_HMNote5Global_V10.3.1.0.PEIMIXM_d4d 2c9f2aa_9.0.zip
5. Reboot to the TWRP
6. Install image TWRP 3.3.1-1 to the Recovery partition (Install only if you already have installed FW 9.0.)
7. Reboot to the TWRP
8. Install ZIP - new ROM
9. Reboot phone to the system
[/zitat]
Quelle: [ROM][9.0][whyred] Pixel Experience [AOSP][r44][2019/07/22]

[zitat]
Step 1 : Go in fastboot mode and connect ur phone to pc
STEP 2: Type fastboot boot <latest_recovery_image_name> (without brackets)
STEP 3 : Transfer all the files(new_recovery,rom,firmware)
Step 4: Wipe everything except internal storage
Step 5 : Install firmware. -> recovery -> rom and boot again in recovery
Step 6 : Format data if ur coming from miui or if not just boot in system now.
Step 7: If everything works give a thumbs up otherwise mention again.
[/zitat]
Quelle: [ROM][9.0][whyred] Pixel Experience [AOSP][r44][2019/07/22]

[zitat]
Here's what you and others who failed to update need to do -
1. Keep patience, listen and read carefully.
2. Download Orange Fox Recovery MIUI Pie version.
3. Download Pie firmware MIUI V10.3.1.0.PEIMIXM.
4. Download Pixel experience ROM.
Copy all files to internal storage
Now read carefully
5. In the recovery flash Pie firmware MIUI V10.3.1.0.PEIMIXM first and hit reboot to recovery.
6. Now flash Orange Fox Recovery and again hit reboot to recovery. If you are not able to flash the recovery extract the image from zip file and flash through fastboot.
7. Go to wipe select Advanced Wipe -> Wipe data, cache, dalvik cache, system, vendor. Select the Pixel Experience ROM zip. Do not check internal storage or choose the red colour format data option, unless you want it as it would format your phone storage.
Flash and enjoy!
[/zitat]
Quelle: [ROM][9.0][whyred] Pixel Experience [AOSP][r44][2019/07/22] - Post #9534
 
I

InsaneLiquid

Ambitioniertes Mitglied
Danke für die vielen Posts die du gesucht hast. Aber ich komme nichts ins Recovery. Er lädt mir aktuell nur den TWRP Screen und fängt dann an zum Rebooten. Ich schaffe es nichts auszuwählen.
Einzigen Modus den er mir lädt ist aktuell fastboot. Aber nachdem keines meiner Notebooks in der Lage ist im fastboot eine Verbindung mit dem Smartphone aufzubauen, hilft mir das auch nicht viel. :/
Als ich das Firmware Update eingespielt habe, ging nach dem Reboot die USB Schnittstelle nicht mehr. Auch nicht im fastboot oder ähnliches, darum habe ich ja das Backup eingespielt, in der Hoffnung es geht etwas.
 
Andy

Andy

Ehrenmitglied
Gibt's denn irgendeine Art der Reaktion am
PC - sprich Sound beim an- oder abstecken, Gerätemanager usw.?
 
I

InsaneLiquid

Ambitioniertes Mitglied
Reaktion nicht, aber wenn ich im Fastboot bin bringt er mir immer folgenden Fehler in der Konsole:
FAILED (command write failed (Too many links))
Also ich schieße befehl ab, es passiert gar nichts. Ich ziehe das Kabel am Handy raus, Konsole gibt folgendes wieder:
fastboot flash recovery twrp-3.3.1-1-whyred.img
target didn't report max-download-size
sending 'recovery' (41592 KB)...
FAILED (command write failed (Too many links))
finished. total time: 0.017s
Edit:
Mit den neusten ADB und Fastboot :
fastboot flash recovery twrp-3.3.1-1-whyred.img
Sending 'recovery' (41592 KB) FAILED (Write to device failed (Unknown error))
fastboot: error: Command failed

Edit 2: Bei fastboot devices bringt er mir folgendes
???????????? fastboot

Für mich heißt das, das Handy reagiert nicht. Wobei einmal hat es reagiert und die recovery aus dem OrangeFox genommen, aber die konnte er auch nicht starten
 
Zuletzt bearbeitet:
Andy

Andy

Ehrenmitglied
"too many links" ist ja ein bekannter Fehler.
Versuche einfach verschiedene USB-Kabel, anderen USB-Port, anderen PC.

Falls das alles nicht klappt, kann man zum Schluss immer noch überlegen, ob man im EDL-Modus per QFIL ne komplette Firmware flasht.
 
I

InsaneLiquid

Ambitioniertes Mitglied
Okay, also über Umwege dann noch geklappt. Danke für den EDL-Modus, den kannte ich noch gar nicht.

Aktueller Stand: TWRP 3.3.1-1 funktioniert mit der neusten PixelexperienceRom. USB am PC wird erkannt, nur kein Ladegerät mehr. Somit lade ich zwar aktuell am PC, aber an der Wanddose sollte es auch gehen. Habe jetzt 3 Ladegeräte getestet. Bei allen startet er mit langsames Laden und bricht dann im ms takt ab und versucht es erneut eine Ladeverbindung aufzubauen. Schaut mir so aus, als könnte das Gerät die Ladeparameter nicht mehr richtig aushandeln.

Jemand Ideen woher das nun herkommt?
 
Andy

Andy

Ehrenmitglied
Hast du denn jetzt die Firmware aus deinem ersten Post noch geflasht? Wenn nein, evtl. ist ja die alte Firmware mit der Pie ROM inkompatibel.
 
I

InsaneLiquid

Ambitioniertes Mitglied
Also die Firmware musste drauf, sonst kann ich das neuste Pie Rom nicht installieren. Somit ja die ist drauf. Aber laden funktioniert immer noch nicht ordentlich. Also am PC gehts, aber sobald er QC machen will, hat er Probleme
 
B

brianmolko1981

Dauergast
Hast du noch das Originalladegerät ohne QC?
 
I

InsaneLiquid

Ambitioniertes Mitglied
Also es ist komisch. QC 2.0 Lader funktionieren nicht, aber die normalen bzw. 3.0 Lader.
Hab jetzt 3 verschiedene QC 2.0 Lader getestet, keiner ging. Aber beide 3.0 Lader und der Original Lader.

Ich mein ich kann damit jetzt wieder ganz gut arbeiten, aber seltsam ist es schon.