Android 11 - EvolutionX 5.1: Magisk addon.d failed

  • 12 Antworten
  • Neuester Beitrag
Diskutiere Android 11 - EvolutionX 5.1: Magisk addon.d failed im Root / Custom-ROMs / Modding für Xiaomi Redmi Note 7 im Bereich Xiaomi Redmi Note 7 Forum.
L

linuxnutzer

Lexikon
Unmounting System.
Detecting Current Package
- Detected Standard Package
Target: Xiaomi/evolution_lavender/lavender 11/RP1A. 201105.002/sap1k11201819+ userdebug/release-keys

Android version: 11
Build id: RP1A.201105.002
Build date: 20201120-1722
Security patch: 2020-11-05
Device: lavender

Patching system image unconditionally...
Patching vendor image unconditionally...

***********************

Magisk addon.d failed

***********************

Cannot find Magisk binaries was data wiped or not decrypted?
Reflash OTA from decrypted recovery or reflash Magisk Patching device-tree and verity images.


script succeeded: result was [1.000000]
Unmounting System. .. - Patching AVB 2.0 .. - Boot partition: /dev/block/by-name/boot
AVB 2.0 has been patched
Updating partition details.. done Updating partition details...
Vermutlich habe ich beim Wechsel vom Stock-ROM zum Custom-ROM irgendeinen Blödsinn gemacht, jedenfalls habe ich data formatiert.

Kann mir das bitte wer verständlich klar machen, was ich jetzt tun soll.

Cannot find Magisk binaries was data wiped or not decrypted?
Bin mir nicht sicher, aber ich würde meinen beides. Data wurde formatiert und ich habe solange alles gelöscht bis keine Fehlermeldungen mehr kamen, dh ich hatte kein Password um die Partition zu mounten.

Die Installation an sich funktioniert, doch sobald ich Magisk-v21.0.zip flashe ist das System kaputt und ich lande beim Einschalten beim Fastboot, kann aber in das Orange Recovery.

Was muss ich tun um Magix zu installieren?
 
L

linuxnutzer

Lexikon
Es scheint so, dass sich Magisk-v21.0.zip mit EvolutionX 5.1 nicht verträgt. Vermutlich ist Magisk 20.3 notwendig, denn das will Evolution flashen.

EvolutionX 5.1 mit twrp-3.4.0-0-lavender.img flashen funktioniert, aber wenn man dann Magisk-v21.0 installiert, startet man mit Fastboot.

Installiert man orangefox-r11.0-stable-lavender.zip mit twrp und dann mit Orange EvolutionX 5.1, dann muss man bei der Auswahl der zips sofort auch Magisk hinzufügen (Auswahl direkt neben zip hinzufügen), dann läuft die Installation mit Magisk durch, die Warnung "Cannot find Magisk binaries was data wiped or not decrypted?" kommt zwar trotzdem, aber es wird magisk 20.3 installiert.

Leider endete das in einer Boot-Loop und ich schaffe es nie mehr, dass mir die Magisk-Installation direkt neben der ROM-Installation vorgeschlagen wurde.

Ich konnte dann nur mehr mehrere zips hintereinander flashen, also Evolution und danach v21.0, lief auch fehlerfrei durch, aber das Handy startete mit Fastboot. Installation ohne Magix war immer ok, aber sobald ich Magisk probierte war die Installation kaputt und ich landete im Fastboot.
 
Zuletzt bearbeitet:
L

linuxnutzer

Lexikon
Es scheint zu sein, dass man wie sonst üblich data nicht formatieren oder wipen darf. Jedenfalls hängt es nach der Installation, man kommt in einen Bootloop oder es wird fastboot gestartet.
 
Andy

Andy

Ehrenmitglied
Zuletzt bearbeitet:
L

linuxnutzer

Lexikon
Also ich habe es aufgegeben, es läuft jetzt Lineage zur Zufriedenheit. Ich verstehe aber nicht was mit MagiskCU gemeint ist. Die ROM hat ja Magisk integriert, das nicht funktioniert., ein magisk-v21.0.zip auch nicht. Was ist denn jetzt dieses CU? Ich finde dazu nichts. Falss damit gemeint, dass ich zuerst die App installieren soll und danach die zip flahsen, das hat auch nicht geholfen.

Mich interessiert das nur, umflashen werde ich das Lineage nicht, ich mag die Gestensteuerung noch nicht so, da muss ich mich erst gewöhnen.
 
L

linuxnutzer

Lexikon
Danke, darauf muss man aber erst kommen bei Samsung zu suchen. Na ja, das RN7 läuft jetzt mit Lineage und ich muss jetzt warten bis ich das nächste alte Handy entsperren kann. Dazwischen wartet aber ein noch nicht ausgepacktes 9s zum Kennlerrnen ;-) Das soll das neue Standard-Telefonierhandy werden.
 
Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Guru
@linuxnutzer Ich hab bei XDA oder Google den Link zu github.com gefunden. Aber eine detaillierte Erklärung fehlt immer noch...
 
Zuletzt bearbeitet:
L

linuxnutzer

Lexikon
Aber eine detaillierte Erklärung fehlt immer noch...
Ich weiß jetzt nicht worauf du genau hinaus willst, das Problem hat sich ja wie geschrieben für mich erledigt, da ich mit Evolution nicht mehr rumprobieren werde, zumindest in den nächsten Monaten. LineageOS läuft mit Android 10 so wie es soll, was will ich mehr. Android 11 hat mich noch nicht begeistert, nur darauf tippen geht schneller als ziehen. Keine Ahnung was man bei 11 machen kann, um die Bedienung wie früher zu erreichen. Lineage steht beim RN7 bei Android 10 und liefert aktuelle Sicherheitsupdates, während man bei den anderen für aktuelle Sicherheitsupdates auf Android 11 umsteigen muss. Ein paar Kleinigkeiten vermisse ich bei Lineage gegenüber Havoc, aber das ist verschmerzbar.
 
BOotnoOB

BOotnoOB

Guru
linuxnutzer schrieb:
Ich weiß jetzt nicht worauf du genau hinaus willst
Seit ein paar Tagen gibt es diese CU Version, aber keiner scheint den Ursprung zu kennen oder was jetzt der Unterschied zur normalen Version ist. Hat irgendwas mit Canary zu tun und irgendwie hilft die Version bei bestimmten Problemen...
 
L

linuxnutzer

Lexikon
Ok, ich dachte schon, ich hätte was wichtiges nicht beantwortet. Danke für den Link, ja genau diese CU-Version hat mich eben gerettet, weil ...

Also Lineage 17.1 mit dem RN7 hat super funktioniert, alles super eingerichtet und dann kam ich auf die Idee ein OTA-Update auszuprobieren und danach landete ich immer wieder im Recovery. Nun darf gerätselt werden warum. Vielleicht liegt es an dieser magisk-v21.0.zip, die aber an und für sich funktioniert hat, vielleicht an den installierten Magisk-Plugins.

Das von mir installierte LineageOS war ja Android 10 und die Probleme hatte ich davor immer mit Android 11.

Da ich sowieso neu installieren musste, wollte ich mit der CU-Version rumspielen und das war dann die Lösung. EvolutionX ist mir zu verspielt, würde ich aber notfalls ertragen. Ich habe mir also revengeos-4.0-r-official-lavender-20201122-1107.zip angesehen, mit magisk-v21.0.zip gab es das bekannte fastboot-Problem, aber mit der cu-Version sieht es aus, als ob es passt. Konnte noch nicht viel probieren, da der Akku leer wurde. Die Installation bei Revenge ist ziemlich geradlinig und überspringt Wifi-Konfiguratio und Google-Anmeldung, muss man daher nacharbeiten, aber passt dann.

Solltest du dich zufällig mit Revenge auskennen bzw. ähnlichen ROMs, dann hätte ich eine kurze Frage. Ich habe auf 3-Button Navigation unter Android 11 umgestellt und suche nun eine Möglichkeit die beiden äußeren Buttons zu tauschen.

Ansonsten noch, die crdroid-Installation mit Android 11 beim RN7 blieb hängen, ich kann da aber nicht warten bis es vielleicht eine Lösung gibt, ich brauche nun das Tel dringend.
 
Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Guru
L

linuxnutzer

Lexikon
Wüsste jetzt nicht, wo man das einstellt.
Bei Lineage ist es bei System, genauso was passiert, wenn man lange drückt.

Noch ein paar Infos, vielleicht kann ja wer davon profitieren.

Wie schon geschrieben, ich habe mir Lineage beim Update kaputt gemacht und habe eine Vermutung warum. Davor habe ich aber noch Android 11 mit dem EvolutionX probiert, Magisk in der CU-Variante hat das Handy gebootet. Beider 11er-ROMs waren aber nicht in der Lage funktionierend mit Magisk-Plugins umzugehen. Also wieder zurück zu Lineage.

Mit TWRP Lineage geflasht und danach das normale Magisk, keine Probleme. Update installiert und es wurde nur mehr das Recovery gebootet. Mit OrangeFox als Recovery klappte es dann, aber ich glaube das war nicht der Grund.

Ich gebe einen Schutz (PIN) immer erst dann ein, wenn fertig installiert und konfiguriert ist. Irgendwann zwang mich Google eine Stimmprobe abzugeben, ich lehnte ab und landete wieder beim PIN, mit der Stimmprobe lief die Installation sofort durch. Leider erinnere ich mich nicht wie man die Stimmprobe wieder löschen kann und vermutlich wird sie das auch gar nicht, sondern nur deaktiviert.

Ich hatte also nun bei der 1. Installation meines ROM-Downloads nun einen PIN eingegeben und machte danach ein Update, Orange wollte nun einen PIN zum Entschlüsseln, den gab es aber davor nicht, da ich ja gar keinen PIN bei der Installation angegeben hatte und daher war mir auch kein PIN für die Werkseinstellungen bekannt. Also hatte ich alle Partitionen mehrmals gelöscht und neu installiert. Zufälligerweise hatte nun das Update via Orange einen PIN davor bei der Installation erhalten.

Meine Vermtung, bei keinem PIN steigt TWRP aus und Orange fragt, auch wenn man keinen vergeben hat.

Jedenfalls bin ich wieder zurück bei Lineage mit Android 10, wo alles funktioniert und ich hoffe auch, dass das nächste Update durchläuft. Flashen dauert ja nicht lange, aber das Handy konfigurieren dauert Stunden.
 
Zuletzt bearbeitet: