CM10 Alpha

  • 162 Antworten
  • Neuester Beitrag
Diskutiere CM10 Alpha im Root / Hacking / Modding für das Odys Xelio im Bereich Odys Xelio Forum.
H

humorvoll

Neues Mitglied
Mit der neusten CM10 mache ich bisher gute Erfahrungen - installiert auf dem Odys Xelio - läuft flüssiger und das beste ist Bluetooth geht problemlos - Rotation klappt auch ohne Fehler! Habe da ich den hohen Stromverbrauch ebenfalls bestätigen kann die build.prop angepasst und der Akku entlädt sich im standby wesentlich weniger - wichtig war der Hinweis die Original-Rom Mai 2012 zu nehmen - bei mir ist es bei der neuen ROM ebenfalls hängengeblieben.

Super Arbeit hier im Forum - herzlichen Dank dafür!!
 
H

Hansi Hinterseer

Erfahrenes Mitglied
Wie sieht es denn mit der Videowiedergabe aus?

Bei mir stürzt Youtube ab und die Tagesschau App bleibt schwarz, es kommt nur der Ton.
 
H

humorvoll

Neues Mitglied
Richtig ist das bei der Tagesschau App beim Livestream nur der Ton geht - auf der Webseite der Tagesschau selber kann ich alles aber problemlos mit dem flashplayer abspielen - betrifft auch die Videoinhalte. Mit Youtube habe ich keine Probleme lasse das allerdings über Twonky Beamer abspielen.
 
H

Hansi Hinterseer

Erfahrenes Mitglied
Soooo....


Nach einigem Testen hab ich das Problem finden könnne:

Scheinbar verbaut Odys einen anderen oder eine neue Version des Rotationssensors.

Mit dem Tool "Android Hardware Info" wird mir dieser nur in der neuesten Version des Stock Roms angezeigt, bei allen CM10 Versionen und dem Stock Rom vom Mai ist dort nichts eingetragen.

Ich tippe also darauf, dass die Compatibility.zip angepasst werden muss.

Hier die Infos aus der App:
BMA250 3-axis Accelerometer
Vendor: Bosch
Range: 39.24
Resolution: 0.038320314
Power: 0.2 mA
 
M

mhasenberg

Neues Mitglied
Hansi Hinterseer: Scheinbar verbaut Odys einen anderen oder eine neue Version des Rotationssensors.
Ah, das würde erklären, warum bei mir sowohl CM10 als auch Funrom mit genau diesem Fehler laufen.

In beiden Fällen drehte sich das Display nämlich nicht mit, wenn ich das Xelio gekippt habe.

Bin jetzt wieder auf das Stockrom zurück und warte ab, was sich so tut...

Dann frohes Fest und guten Rutsch!
 
D

Deniz70

Neues Mitglied
humorvoll schrieb:
Mit der neusten CM10 mache ich bisher gute Erfahrungen - installiert auf dem Odys Xelio - läuft flüssiger und das beste ist Bluetooth geht problemlos - Rotation klappt auch ohne Fehler! Habe da ich den hohen Stromverbrauch ebenfalls bestätigen kann die build.prop angepasst und der Akku entlädt sich im standby wesentlich weniger - wichtig war der Hinweis die Original-Rom Mai 2012 zu nehmen - bei mir ist es bei der neuen ROM ebenfalls hängengeblieben.

Super Arbeit hier im Forum - herzlichen Dank dafür!!
Könntest du mir bitte erklären, wie du das genau gemacht hast? Möchte mein Xelio auch flashen. Habe aber überhaupt keine Ahnung davon. Wäre für jede Hilfe dankbar.
 
joe_sixpack

joe_sixpack

Stammgast
Hi!
wishmasterf schrieb:
Testing Download by Shaun2029
Download Build 2012-12-08
MD5: 38f0fb0a33734d71af3e8d25990ee6ea...
Ziehe ich mir gerade runter - mal testen. Allerdings lege ich mir diesmal ein komplettes Backup mit CWM an, damit ich nicht wieder ewig basteln muss (wenn's nicht vernünftig funzt).
Zur Autorotation: Bei mir funktioniert sie in den gesamten "alten" CM10-Versionen, allerdings habe ich sie zumeist komplett deaktiviert, weil sie beim Tablet ablegen immer gern die Ausrichtung verändert und ich beim Weiterlesen warten darf/muss, bis die Darstellung wieder passt. Ich mache aber fast alles im Quer-Modus, auch mein Startscreen vom Launcher ist dementsprechend angeordnet...

Viele Grüße
 
joe_sixpack

joe_sixpack

Stammgast
Hi!
wishmasterf schrieb:
So - mal schnell installiert. Hier meine erste Einschätzung:
- Installation über bestehendes CM10 ohne Full-Wipe möglich
- G-Apps und Compatibility-Pack müssen installiert werden
- Auto-Rotation funktioniert anstandslos in allen Positionen (alter Sensor)

Was man auf jeden Fall machen sollte, ist die Veränderung der build.prop mit den Erweiterungen für Energie-Management versehen, der "Ruhestromverbrauch" ist tödlich - von 100% auf 87% innerhalb von 90 Minuten im Standby mit aktivem WLAN.
Dazu folgende Eintragungen:
ro.ril.power_collapse=1
pm.sleep_mode=1

Das System an sich rennt - keine sinnlosen Wartezeiten. Ich bin sehr beeindruckt. Abstürze oder ähnliches sind bisher nicht aufgetreten. WLAN-Reaktivierung auch super, findet das Netz schnell und verbindet sofort wieder.
Zur Auto-Rotation: Ich arbeite zu 99% im Quer-Modus (Lesen, Videos schauen) und habe auch das Launcher-Bild dafür eingerichtet bzw. angeordnet. Mich stört es, dass sich beim Ablegen gern mal die Ausrichtung ändert und ich beim "Weiterlesen" erst warten muss, bis die Bildschirmdarstellung wieder stimmt.

Viele Grüße
 
Schwarze13

Schwarze13

Erfahrenes Mitglied
Das werde ich gleich mal in die Build eintragen.
Bei mir geht das Xelio auch einfach so mal an oder bzw. nicht in den Standby.
Bei mir ist allerdings dann noch die Wlan Verbindung schlechter geworden, mit dem Fun v3
verbindet es sich schnell mit der CM10 dauert das schon um einiges länger und mit meinem S3 Mini geht es ruck zuck. Aber ansonsten Super Rom.:thumbsup:
 
joe_sixpack

joe_sixpack

Stammgast
Hi!
wishmasterf schrieb:
So, selbst mit den Anpassungen in der build.prop ist das ROM ein Akku-Töter. Innerhalb von 5 Stunden von 100% auf 76% runter, ohne WLAN, nur Launcher aktiv. Ganz schön heftig:cursing:
Ich hab jetzt erst mal CPU Spy drauf angesetzt - vielleicht geht der Prozessor nicht in den Schlafmodus (oder irgendetwas weckt ihn immer wieder auf). Daher schalte ich das Teil jetzt ganz aus, bis ich mit der Analyse weiter bin...
Schade, ansonsten geiles ROM:sad:

Viele Grüße
 
H

Hansi Hinterseer

Erfahrenes Mitglied
joe_sixpack schrieb:
Hi!

So, selbst mit den Anpassungen in der build.prop ist das ROM ein Akku-Töter. Innerhalb von 5 Stunden von 100% auf 76% runter, ohne WLAN, nur Launcher aktiv. Ganz schön heftig:cursing:
Ich hab jetzt erst mal CPU Spy drauf angesetzt - vielleicht geht der Prozessor nicht in den Schlafmodus (oder irgendetwas weckt ihn immer wieder auf). Daher schalte ich das Teil jetzt ganz aus, bis ich mit der Analyse weiter bin...
Schade, ansonsten geiles ROM:sad:

Viele Grüße
Ich kann dir GSAM Battery Monitor empfehlen, der zeigt genau an welche Prozesse das Tablet wach halten inkl. Wakelocks.

Bei mir ist es genauso, selbst mit den Anpassungen zieht das Ding immer noch gut am Akku. Ich schalte es immer komplett aus und gut ist.


Wer erstellt das Compatibility.zip? Könnte dieser jmd. das anpassen?

Hier noch meine build.prop mit einigen anderen Tweaks...könnt ihr ja mal testen.
 
Zuletzt bearbeitet:
joe_sixpack

joe_sixpack

Stammgast
Hi!
joe_sixpack schrieb:
So, selbst mit den Anpassungen in der build.prop ist das ROM ein Akku-Töter. Innerhalb von 5 Stunden von 100% auf 76% runter, ohne WLAN, nur Launcher aktiv. Ganz schön heftig...
So - etwas ganz eigenartiges: Android scheint einen Neustart anders zu behandeln als ein Aus- und Wiedereinschalten?! Jedenfalls jetzt (nach einmal Aus und am nächsten Morgen wieder Ein) ist der Stromverbrauch im Ruhezustand durchaus akzeptabel, ich komme über 6 Stunden mit ungefähr 5% Verbrauch. Laut CPU Spy pennt der Prozessor fast ständig im Deep Sleep, der Rest ist gemischt, aber insgesamt wenig Last.
Gut - da war eigentlich auch nichts anderes zu erwarten, beim Lesen ist der Hauptverbraucher halt das Display...

Viele Grüße
 
Android-freak 12

Android-freak 12

Fortgeschrittenes Mitglied
Hi, hab ne Frage, möchte Cyanbook installieren. Wie geht das?
 
J

JeremyB

Neues Mitglied
man sollte meinen, jemand mit über 70 Beiträgen in einem Forum, weiß wie dieses zu bedienen ist und das Prinzip des "suchen & finden" kennt.

Grundsätzlich unterscheiden sich die verschiedenen custom Roms nicht in der Installation.
Hier, hier, hier, hier, oder auch hier solltest du genügend Infos finden.
 
W

wishmasterf

Erfahrenes Mitglied
Neue Version von Shaun2029 :

Testing Download (For best results perform a factory reset before installation.)

Download Build 2013-03-28
MD5: cdfd72ddb9729fe3e40cad8eb1da1168

* Patched framework to prevent sleep of death. Thank you Aquous.
* Included Aquous's patch to the theme chooser that works around the theme incompatibility issue.
* Updated kernel to hopefully prevent sleep of death.
* Updated CM10 sources

Habe derzeit kaum Zeit zu testen. Bitte Erfahrungen mit dieser Version posten nicht vergessen!
 
joe_sixpack

joe_sixpack

Stammgast
Hi!
wishmasterf schrieb:
Neue Version von Shaun2029 :

Testing Download (For best results perform a factory reset before installation.)

Download Build 2013-03-28
...
Werde ich mir gerne mal aufs Pad ziehen, ich war schon mit der Vorgängerversion sehr zufrieden - die läuft bei mir im Wirkbetrieb und ist nicht kaputt zu kriegen:flapper:
Nee, mal im Ernst: bisher keine unerwarteten Neustarts, System läuft flüssig, WLAN lässt sich ohne Neustart regelmäßig ab- und auch wieder anschalten. Der einzige Wermutstropfen: App-Updates über WLAN brauchen recht lange (im Vergleich zu meinem Galaxy S2), lassen sich aber störungsfrei über den Play-Store updaten.

Viele Grüße
 
joe_sixpack

joe_sixpack

Stammgast
Hi!
wishmasterf schrieb:
Neue Version von Shaun2029 :

Testing Download (For best results perform a factory reset before installation.)

Download Build 2013-03-28
MD5: cdfd72ddb9729fe3e40cad8eb1da1168
Erster Test - Vernichtend!
Installation mit vollständigem Wipe (inkl. Dalvik-Cache), dann G-Apps & abschließend das Compat.-Pack...
Anschließend noch einmal Full-Wipe und dann sollte es losgehen: Start ohne Auffälligkeiten, Sprache auf Deutsch umgestellt, Anmeldung am WLAN - was ist dass denn?:confused2: Keine Anmeldung möglich, denn es wird keine Tastatur eingeblendet. Irgendeine Meldung blitzt ganz kurz auf - keinc Chance zum Lesen:mad2:
Noch mal von Anfang anfangen, diemal lasse ich die Sprache auf Englisch stehen, Anmeldung am WLAN geht wieder nicht, nur 'ne aufblitzende Meldung. Nachdem ich in die Settings gewandert bin, um die Tastatur-Einstellungen zu prüfen, wird alles klar. Die AOKP-Tastatur (Standart) crasht:cursing:
Glücklicherweise habe ich meinen App-Backup-Ordner auf der SD-Karte, also schnell mal Swype installiert (damit überhaupt 'ne Tastatur verfügbar ist). Damit klappt die Anmeldung im WLAN und die Anmeldung bei Google teilweise. Play Store wird sofort geschlossen (immer wieder), dadurch keine Software-Installation möglich...
An der Stelle habe ich aufgegeben, das Backup der alten Version wieder hergestellt und diese Version gelöscht.

Viele Grüße
 
G

glotzi

Neues Mitglied
joe_sixpack schrieb:
Hi!
Erster Test - Vernichtend!
Installation mit vollständigem Wipe (inkl. Dalvik-Cache), dann G-Apps & abschließend das Compat.-Pack...
Anschließend noch einmal Full-Wipe und dann sollte es losgehen ...
Kann ich so nicht bestätigen, bei mir funzt es bisher ohne Auffälligkeiten. Vorgehensweise war die gleiche.
 
joe_sixpack

joe_sixpack

Stammgast
Hi!

Ich werd's eventuell übers Wochenende noch mal versuchen, allerdings ist mein Xelio im Wirkbetrieb, daher will ich den nicht dauernd platt machen & nue installieren. Meine Frau läßt sich leider nicht dazu überreden, ihren mal als Versuchsobjekt zur Verfügung zu stellen (der läuft mit Original-OS, allerdings mehr schlecht als Recht)...

Viele Grüße

Heute Abend noch mal versucht - Ergebnis identisch. No Way:mad:. Wieder keine funktionierende Tastatur. Ich versuch gerade mal CyanBook...

Viele Grüße
 
Zuletzt bearbeitet:
W

wishmasterf

Erfahrenes Mitglied
@joe sixback:
Und hattest du schon Zeit für einen neuen Versuch?